]> git.pld-linux.org Git - packages/ntp.git/blob - ntp.spec
- added using %%{__make} macro.
[packages/ntp.git] / ntp.spec
1 Summary:        Network Time Protocol utilities
2 Summary(pl):    Narzêdzia do synchronizacji czasu (Network Time Protocol)
3 Name:           xntp3
4 Version:        5.93
5 Release:        5
6 Copyright:      distributable
7 Group:          Daemons
8 Group(pl):      Serwery
9 Source0:        ftp://ftp.udel.edu/pub/ntp/%{name}-%{version}.tar.gz
10 Source1:        ntp.conf
11 Source2:        ntp.keys
12 Source3:        xntpd.rc
13 Source4:        xntpd.sysconfig
14 Patch:          %{name}-config.patch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sysconfdir     /etc/ntp
18 %define         _bindir         %{_sbindir}
19
20 %description
21 This package contains utilities and daemons to help synchronize your
22 computer's time to UTC standard time. It includes ntpdate, a program
23 similar to rdate, and xntpd, a daemon which adjusts the system time
24 continuously.
25
26 %description -l pl
27 Pakiet zawiera narzêdzia i demony s³u¿±ce do dok³adnego synchronizowania
28 czasu Twojego komputera: ntpdate, program podobny do rdatei xntpd, 
29 demon aktualizuj±cy czas w sposób ci±g³y.
30
31 %prep 
32 %setup -q
33 %patch -p1 
34
35 %build
36 LDFLAGS="-s"; export LDFLAGS
37 %configure
38
39 %{__make} 
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT/etc/{ntp,rc.d/init.d,sysconfig}
44
45 %{__make} install DESTDIR=$RPM_BUILD_ROOT
46
47 install %{SOURCE1} $RPM_BUILD_ROOT/etc/ntp/ntp.conf
48 install %{SOURCE2} $RPM_BUILD_ROOT/etc/ntp/keys
49 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/xntpd
50 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/xntpd
51
52 gzip -9fn NEWS TODO conf/*.conf
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 /sbin/chkconfig --add xntpd
59
60 if [ -f /var/lock/subsystem/xntpd ]; then
61         /etc/rc.d/init.d/xntpd restart >&2
62 else
63         echo "Run \"/etc/rc.d/init.d/xntpd start\" to start xntpd daemon."
64 fi
65     
66 %preun
67 if [ $1 = 0 ]; then
68         /sbin/chkconfig --del xntpd
69         /etc/rc.d/init.d/xntpd stop >&2
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc conf/*.gz *.gz
75
76 %attr(750,root,root) %dir /etc/ntp
77 %attr(640,root,root) %config(noreplace) %verify(not size md5 mtime) /etc/ntp/*
78 %attr(640,root,root) %config %verify(not size md5 mtime) /etc/sysconfig/*
79 %attr(755,root,root) %{_sbindir}/*
80 %attr(754,root,root) /etc/rc.d/init.d/xntpd
This page took 0.045619 seconds and 4 git commands to generate.