]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
- release 2.snap*: rebuild against readline 4.2.
[packages/ntop.git] / ntop.spec
1 %define snap    01-03-26
2 Summary:        Network monitoring tool
3 Summary(pl):    Narzêdzie do monitorowania sieci
4 Name:           ntop
5 Version:        1.3.2
6 Release:        1.%(echo %{snap} | sed -e "s/-//g")
7 License:        GPL
8 Group:          Networking
9 Group(de):      Netzwerkwesen
10 Group(pl):      Sieciowe
11 Source0:        http://snapshot.ntop.org/tgz/%{name}-%{snap}.tgz
12 Patch0:         %{name}-configure.patch
13 Patch1:         %{name}-externallib.patch
14 Patch2:         %{name}-perl.patch
15 URL:            http://www.ntop.org/
16 BuildRequires:  libpcap-devel
17 BuildRequires:  libwrap-devel
18 BuildRequires:  ncurses-devel >= 5.2
19 BuildRequires:  readline-devel >= 4.2
20 BuildRequires:  openssl-devel
21 BuildRequires:  ucd-snmp-devel
22 BuildRequires:  gd-devel >= 1.8.2
23 BuildRequires:  gdbm-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  zlib-devel
26 BuildRequires:  libtool
27 BuildRequires:  automake
28 BuildRequires:  autoconf
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ntop is a tool that shows the network usage, similar to what the
33 popular top Unix command does.
34
35 %description -l pl
36 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
37 robi to popularna Unixowa komenda top.
38
39 %prep
40 %setup -q -n %{name}-current
41 cd %{name}*
42 rm -f missing ltconfig
43 %patch0 -p1
44 %patch2 -p1
45 cd ../gdchart*
46 %patch1 -p1
47
48 %build
49 cd gdchart*
50 rm -rf gd-* zlib-*
51 %configure
52 %{__make}
53
54 cd ../%{name}*
55 libtoolize --copy --force
56 automake -a -c -i
57 autoheader
58 aclocal
59 autoconf
60 %configure \
61         --with-gdchart-root=../gdchart0.94c \
62         --with-ossl-root=%{_prefix} \
63         --enable-tcpwrap \
64         --with-gnu-ld \
65         --localstatedir=%{_var}/%{ntop}
66         
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 cd %{name}*
72 install -d      $RPM_BUILD_ROOT%{_var}/%{name}
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76         
77 mv $RPM_BUILD_ROOT%{_bindir}/*.pem      $RPM_BUILD_ROOT%{_datadir}/%{name}
78
79 gzip -9nf AUTHORS NEWS README THANKS
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc */*.gz
90 %dir %{_var}/%{name}
91 %attr(755,root,root) %{_bindir}/*
92 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
93 %attr(755,root,root) %{_libdir}/lib*.la
94 %dir %{_libdir}/%{name}
95 %dir %{_libdir}/%{name}/plugins
96 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so*
97 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.la
98 %{_datadir}/%{name}
99 %{_mandir}/man*/*
This page took 0.048749 seconds and 4 git commands to generate.