]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
- use new %doc and some minor changes.
[packages/ntop.git] / ntop.spec
1 %define snap    02-04-04
2 Summary:        Network monitoring tool
3 Summary(pl):    Narzêdzie do monitorowania sieci
4 Name:           ntop
5 Version:        2.0
6 Release:        0.1.%(echo %{snap} | sed -e "s/-//g")
7 License:        GPL
8 Group:          Networking
9 Source0:        http://snapshot.ntop.org/tgz/%{name}-%{snap}.tgz
10 #Patch0:        %{name}-configure.patch
11 Patch1:         %{name}-externallib.patch
12 Patch2:         %{name}-perl.patch
13 Patch3:         %{name}-am.patch
14 Patch4:         %{name}-plugins-Makefile.patch
15 Patch5:         %{name}-pep-Makefile.patch
16 Patch6:         %{name}-Makefile.patch
17 URL:            http://www.ntop.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gd-devel >= 2.0.1
21 BuildRequires:  gdbm-devel
22 BuildRequires:  libpcap-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libwrap-devel
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel >= 5.2
27 BuildRequires:  openssl-devel >= 0.9.6a
28 BuildRequires:  readline-devel >= 4.2
29 BuildRequires:  ucd-snmp-devel
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ntop is a tool that shows the network usage, similar to what the
35 popular top Unix command does.
36
37 %description -l pl
38 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
39 robi to popularna Unixowa komenda top.
40
41 %prep
42 %setup -q -n %{name}-current
43 cd %{name}*
44 rm -f missing ltconfig
45 #%patch0 -p1
46 %patch2 -p1
47 %patch3 -p1
48 cd ../gdchart*
49 %patch1 -p1
50 cd ../%{name}*
51 %patch6 -p0
52
53 cd plugins
54
55 %patch4 -p0
56 cd pep
57 %patch5 -p0
58
59 %build
60 cd gdchart*
61 rm -rf gd-* zlib-*
62 %{__libtoolize}
63 aclocal
64 %{__autoconf}
65 %configure
66 %{__make}
67
68 cd ../%{name}*
69 mv -f acinclude.m4.in acinclude.m4
70 rm -f missing
71 #libtoolize --copy --force
72 aclocal
73 %{__autoconf}
74 %{__automake}
75 %configure \
76         --with-gdchart-root=../gdchart0.94c \
77         --with-ossl-root=%{_prefix} \
78         --enable-tcpwrap \
79         --with-gnu-ld \
80         --localstatedir=%{_var}/%{ntop}
81         
82
83 %{__make}
84 cd plugins
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 cd %{name}*
90 install -d      $RPM_BUILD_ROOT%{_var}/%{name}
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 mv $RPM_BUILD_ROOT%{_bindir}/*.pem $RPM_BUILD_ROOT%{_datadir}/%{name}
96
97 %clean
98 #rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS NEWS README THANKS
106 %dir %{_var}/%{name}
107 %attr(755,root,root) %{_bindir}/*
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %attr(755,root,root) %{_libdir}/lib*.la
110 #%dir %{_libdir}/%{name}
111 #%dir %{_libdir}/%{name}/plugins
112 #%attr(755,root,root) %{_libdir}/%{name}/plugins/
113 #%{_datadir}/%{name}
114 %{_mandir}/man*/*
This page took 0.058198 seconds and 4 git commands to generate.