]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
f88e267c86cfbc639f2fab23d84f329754fb2972
[packages/ntop.git] / ntop.spec
1 %define snap    03-02-13
2 Summary:        Network monitoring tool
3 Summary(pl):    Narzêdzie do monitorowania sieci
4 Name:           ntop
5 Version:        2.1
6 Release:        0.7.%(echo %{snap} | sed -e "s/-//g")
7 License:        GPL
8 Group:          Networking
9 Source0:        http://snapshot.ntop.org/tgz/%{name}-%{snap}.tgz
10 Patch0:         %{name}-acam.patch
11 Patch1:         %{name}-externallib.patch
12 Patch2:         %{name}-perl.patch
13 URL:            http://www.ntop.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gd-devel >= 2.0.1
17 BuildRequires:  gdbm-devel
18 BuildRequires:  libpcap-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libwrap-devel
21 BuildRequires:  libtool
22 BuildRequires:  ncurses-devel >= 5.2
23 BuildRequires:  openssl-devel >= 0.9.7
24 BuildRequires:  readline-devel >= 4.2
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 ntop is a tool that shows the network usage, similar to what the
30 popular top Unix command does.
31
32 %description -l pl
33 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
34 robi to popularna Unixowa komenda top.
35
36 %prep
37 %setup -q -n %{name}-current
38 #%%patch0 -p1
39 cd %{name}*
40 %patch2 -p1
41 cd ../gdchart*
42 %patch1 -p1
43
44 %build
45 cd gdchart*
46 rm -rf gd-* zlib-*
47 %{__libtoolize}
48 %{__aclocal}
49 %{__autoconf}
50 %configure
51 %{__make}
52
53 cd ../%{name}*
54 #mv -f acinclude.m4.in acinclude.m4
55 #rm -f missing
56 #%%{__libtoolize}
57 %{__aclocal}
58 %{__autoconf}
59 %{__automake}
60 %configure \
61         --with-ossl-root=%{_prefix} \
62         --with-gdchart-root=`pwd`/../gdchart0.94c \
63         --enable-tcpwrap \
64         --with-gnu-ld \
65         --localstatedir=%{_var}/lib/%{name} || true
66
67 %configure \
68         --with-ossl-root=%{_prefix} \
69         --with-gdchart-root=`pwd`/../gdchart0.94c \
70         --enable-tcpwrap \
71         --with-gnu-ld \
72         --localstatedir=%{_var}/lib/%{name}
73
74
75 %{__make}
76 cd plugins
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 cd %{name}*
82 install -d      $RPM_BUILD_ROOT%{_var}/lib/%{name}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 #mv $RPM_BUILD_ROOT%{_bindir}/*.pem $RPM_BUILD_ROOT%{_datadir}/%{name}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc ntop/AUTHORS ntop/NEWS ntop/README ntop/THANKS
98 %dir %{_var}/lib/%{name}
99 %attr(755,root,root) %{_bindir}/*
100 %attr(755,root,root) %{_libdir}/lib*
101 #%attr(755,root,root) /usr/share/ntop/*
102 %attr(755,root,root) %{_datadir}/%{name}
103 #%%{_libdir}/lib*.la
104 #%dir %{_libdir}/%{name}
105 #%dir %{_libdir}/%{name}/plugins
106 %attr(755,root,root) %{_libdir}/%{name}/plugins
107 %{_mandir}/man*/*
This page took 0.0725 seconds and 3 git commands to generate.