]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
ae25f45325cb73d6860594791dce1de776a13fed
[packages/ntop.git] / ntop.spec
1 %define snap    02-03-24
2 Summary:        Network monitoring tool
3 Summary(pl):    Narzêdzie do monitorowania sieci
4 Name:           ntop
5 Version:        2.0
6 Release:        0.1.%(echo %{snap} | sed -e "s/-//g")
7 License:        GPL
8 Group:          Networking
9 Source0:        http://snapshot.ntop.org/tgz/%{name}-%{snap}.tgz
10 #Patch0:                %{name}-configure.patch
11 Patch1:         %{name}-externallib.patch
12 Patch2:         %{name}-perl.patch
13 Patch3:         %{name}-am.patch
14 Patch4:         %{name}-plugins-Makefile.patch
15 Patch5:         %{name}-pep-Makefile.patch
16 Patch6:         %{name}-Makefile.patch
17 URL:            http://www.ntop.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gd-devel >= 2.0.1
21 BuildRequires:  gdbm-devel
22 BuildRequires:  libpcap-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libwrap-devel
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel >= 5.2
27 BuildRequires:  openssl-devel >= 0.9.6a
28 BuildRequires:  readline-devel >= 4.2
29 BuildRequires:  ucd-snmp-devel
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ntop is a tool that shows the network usage, similar to what the
35 popular top Unix command does.
36
37 %description -l pl
38 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
39 robi to popularna Unixowa komenda top.
40
41 %prep
42 %setup -q -n %{name}-current
43 cd %{name}*
44 rm -f missing ltconfig
45 #%patch0 -p1
46 %patch2 -p1
47 %patch3 -p1
48 cd ../gdchart*
49 %patch1 -p1
50 cd ../%{name}*
51 %patch6 -p0
52
53 cd plugins
54 %#patch4 -p0
55 cd pep
56 %patch5 -p0
57
58 %build
59 cd gdchart*
60 rm -rf gd-* zlib-*
61 libtoolize --copy --force
62 aclocal
63 autoconf
64 %configure
65 %{__make}
66
67 cd ../%{name}*
68 mv -f acinclude.m4.in acinclude.m4
69 rm -f missing
70 libtoolize --copy --force
71 aclocal
72 autoconf
73 automake -a -c -f 
74 %configure \
75         --with-gdchart-root=../gdchart0.94c \
76         --with-ossl-root=%{_prefix} \
77         --enable-tcpwrap \
78         --with-gnu-ld \
79         --localstatedir=%{_var}/%{ntop}
80         
81
82 %{__make}
83 cd plugins
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 cd %{name}*
89 install -d      $RPM_BUILD_ROOT%{_var}/%{name}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 mv $RPM_BUILD_ROOT%{_bindir}/*.pem $RPM_BUILD_ROOT%{_datadir}/%{name}
95
96 gzip -9nf AUTHORS NEWS README THANKS
97
98 %clean
99 #rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc */*.gz
107 %dir %{_var}/%{name}
108 %attr(755,root,root) %{_bindir}/*
109 %attr(755,root,root) %{_libdir}/lib*.so
110 %attr(755,root,root) %{_libdir}/lib*.la
111 #%dir %{_libdir}/%{name}
112 #%dir %{_libdir}/%{name}/plugins
113 #%attr(755,root,root) %{_libdir}/%{name}/plugins/
114 #%{_datadir}/%{name}
115 %{_mandir}/man*/*
This page took 0.058107 seconds and 3 git commands to generate.