]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
94af00c2c76a986c312202e69f71930151036c2f
[packages/ntop.git] / ntop.spec
1 %define snap    01-03-26
2 Summary:        Network monitoring tool
3 Summary(pl):    Narzêdzie do monitorowania sieci
4 Name:           ntop
5 Version:        1.3.2
6 Release:        2.%(echo %{snap} | sed -e "s/-//g")
7 License:        GPL
8 Group:          Networking
9 Group(de):      Netzwerkwesen
10 Group(pl):      Sieciowe
11 Source0:        http://snapshot.ntop.org/tgz/%{name}-%{snap}.tgz
12 Patch0:         %{name}-configure.patch
13 Patch1:         %{name}-externallib.patch
14 Patch2:         %{name}-perl.patch
15 URL:            http://www.ntop.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gd-devel >= 1.8.2
19 BuildRequires:  gdbm-devel
20 BuildRequires:  libpcap-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libwrap-devel
23 BuildRequires:  libtool
24 BuildRequires:  ncurses-devel >= 5.2
25 BuildRequires:  openssl-devel >= 0.9.6a
26 BuildRequires:  readline-devel >= 4.2
27 BuildRequires:  ucd-snmp-devel
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ntop is a tool that shows the network usage, similar to what the
33 popular top Unix command does.
34
35 %description -l pl
36 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
37 robi to popularna Unixowa komenda top.
38
39 %prep
40 %setup -q -n %{name}-current
41 cd %{name}*
42 rm -f missing ltconfig
43 %patch0 -p1
44 %patch2 -p1
45 cd ../gdchart*
46 %patch1 -p1
47
48 %build
49 cd gdchart*
50 rm -rf gd-* zlib-*
51 libtoolize --copy --force
52 aclocal
53 autoconf
54 %configure
55 %{__make}
56
57 cd ../%{name}*
58 mv -f acinclude.m4.in acinclude.m4
59 libtoolize --copy --force
60 aclocal
61 autoconf
62 automake -a -c -i
63 %configure \
64         --with-gdchart-root=../gdchart0.94c \
65         --with-ossl-root=%{_prefix} \
66         --enable-tcpwrap \
67         --with-gnu-ld \
68         --localstatedir=%{_var}/%{ntop}
69         
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 cd %{name}*
75 install -d      $RPM_BUILD_ROOT%{_var}/%{name}
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79         
80 mv $RPM_BUILD_ROOT%{_bindir}/*.pem      $RPM_BUILD_ROOT%{_datadir}/%{name}
81
82 gzip -9nf AUTHORS NEWS README THANKS
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc */*.gz
93 %dir %{_var}/%{name}
94 %attr(755,root,root) %{_bindir}/*
95 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
96 %attr(755,root,root) %{_libdir}/lib*.la
97 %dir %{_libdir}/%{name}
98 %dir %{_libdir}/%{name}/plugins
99 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so*
100 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.la
101 %{_datadir}/%{name}
102 %{_mandir}/man*/*
This page took 0.040682 seconds and 3 git commands to generate.