]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
40a0ca2ada7ad36de214e8eba6077b625e48ed8a
[packages/ntop.git] / ntop.spec
1 %define snap    02-10-03
2 Summary:        Network monitoring tool
3 Summary(pl):    Narzêdzie do monitorowania sieci
4 Name:           ntop
5 Version:        2.1
6 Release:        0.2.%(echo %{snap} | sed -e "s/-//g")
7 License:        GPL
8 Group:          Networking
9 Source0:        http://snapshot.ntop.org/tgz/%{name}-%{snap}.tgz
10 #Patch0:        %{name}-configure.patch
11 Patch1:         %{name}-externallib.patch
12 Patch2:         %{name}-perl.patch
13 Patch3:         %{name}-am.patch
14 #Patch4:                %{name}-plugins-Makefile.patch
15 Patch5:         %{name}-pep-Makefile.patch
16 Patch6:         %{name}-Makefile.patch
17 URL:            http://www.ntop.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gd-devel >= 2.0.1
21 BuildRequires:  gdbm-devel
22 BuildRequires:  libpcap-devel
23 BuildRequires:  libpcap-static
24 BuildRequires:  libpng-devel
25 BuildRequires:  libwrap-devel
26 BuildRequires:  libtool
27 BuildRequires:  ncurses-devel >= 5.2
28 BuildRequires:  openssl-devel >= 0.9.6a
29 BuildRequires:  readline-devel >= 4.2
30 BuildRequires:  ucd-snmp-devel
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 ntop is a tool that shows the network usage, similar to what the
36 popular top Unix command does.
37
38 %description -l pl
39 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
40 robi to popularna Unixowa komenda top.
41
42 %prep
43 %setup -q -n %{name}-current
44 cd %{name}*
45 #rm -f missing ltconfig
46 #%patch0 -p1
47 %patch2 -p1
48 %patch3 -p1
49 cd ../gdchart*
50 %patch1 -p1
51 cd ../%{name}*
52 %patch6 -p0
53
54 cd plugins
55 #%patch4 -p0
56 cd pep
57 %patch5 -p0
58
59 %build
60 cd gdchart*
61 rm -rf gd-* zlib-*
62 %{__libtoolize}
63 aclocal
64 %{__autoconf}
65 %configure
66 %{__make}
67
68 cd ../%{name}*
69 #mv -f acinclude.m4.in acinclude.m4
70 #rm -f missing
71 #%{__libtoolize}
72 aclocal
73 %{__autoconf}
74 %{__automake}
75 %configure \
76         --with-gdchart-root=../gdchart0.94c \
77         --with-ossl-root=%{_prefix} \
78         --enable-tcpwrap \
79         --with-gnu-ld \
80         --localstatedir=%{_var}/lib/%{name}
81         
82
83 %{__make}
84 cd plugins
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 cd %{name}*
89 install -d      $RPM_BUILD_ROOT%{_var}/lib/%{name}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 mv $RPM_BUILD_ROOT%{_bindir}/*.pem $RPM_BUILD_ROOT%{_datadir}/%{name}
95
96 %clean
97 #rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc ntop/AUTHORS ntop/NEWS ntop/README ntop/THANKS
105 %dir %{_var}/lib/%{name}
106 %attr(755,root,root) %{_bindir}/*
107 %attr(755,root,root) %{_libdir}/lib*.so
108 %attr(755,root,root) %{_libdir}/lib*.la
109 #%dir %{_libdir}/%{name}
110 #%dir %{_libdir}/%{name}/plugins
111 #%attr(755,root,root) %{_libdir}/%{name}/plugins/
112 #%{_datadir}/%{name}
113 %{_mandir}/man*/*
This page took 0.069965 seconds and 3 git commands to generate.