]> git.pld-linux.org Git - packages/nodejs.git/blob - nodejs.spec
99c005090b8368f80de52c82a6c930a0d733741d
[packages/nodejs.git] / nodejs.spec
1 # TODO:
2 # - use system waf
3
4 # For the 1.2 branch, we use 0s here
5 # For 1.3+, we use the three digit versions
6 %define         somajor 2
7 %define         sominor 1
8 %define         sobuild 2
9 %define         sover %{somajor}.%{sominor}.%{sobuild}
10
11 Summary:        Asynchronous JavaScript Engine
12 Name:           nodejs
13 Version:        0.1.96
14 Release:        0
15 License:        BSD
16 Group:          Libraries
17 URL:            http://nodejs.org/
18 Source0:        http://nodejs.org/dist/node-v%{version}.tar.gz
19 # Source0-md5:  5e83341afe2b5edf0595e92f96ceed09
20 Source1:        http://www.crockford.com/javascript/jsmin.py.txt
21 # Source1-md5:  0521ddcf3e52457223c6e0d602486a89
22 BuildRequires:  gcc >= 5:4.0
23 BuildRequires:  libeio-devel
24 BuildRequires:  libev-devel >= 3.90
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  python
27 BuildRequires:  rpm >= 4.4.9-56
28 BuildRequires:  udns-devel
29 BuildRequires:  c-ares-devel >= 1.7.1-0.20100523.0
30 BuildRequires:  v8-devel >= 2.2.8
31 ExclusiveArch:  %{ix86} %{x8664} arm
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Node's goal is to provide an easy way to build scalable network
36 programs. In the above example, the two second delay does not prevent
37 the server from handling new requests. Node tells the operating system
38 (through epoll, kqueue, /dev/poll, or select) that it should be
39 notified when the 2 seconds are up or if a new connection is made --
40 then it goes to sleep. If someone new connects, then it executes the
41 callback, if the timeout expires, it executes the inner callback. Each
42 connection is only a small heap allocation.
43
44 %package devel
45 Summary:        Development headers for nodejs
46 Group:          Development/Libraries
47
48 %description devel
49 Development headers for nodejs.
50
51 %prep
52 %setup -q -n node-v%{version}
53
54 %build
55 # build library
56
57 CFLAGS="%{rpmcflags}"
58 CXXFLAGS="%{rpmcxxflags}"
59 LDFLAGS="%{rpmcflags}"
60 %if "%{pld_release}" == "ac"
61 CC=%{__cc}4
62 CXX=%{__cxx}4
63 %else
64 CC=%{__cc}
65 CXX=%{__cxx}
66 %endif
67 export CFLAGS LDFLAGS CXXFLAGS CC CXX
68
69 tools/waf-light configure \
70         --system \
71         --prefix=%{_prefix}
72
73 tools/waf-light build
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}/node/libraries}
78
79 tools/waf-light install \
80         --destdir=$RPM_BUILD_ROOT
81
82 install lib/*.js $RPM_BUILD_ROOT%{_libdir}/node/libraries/
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS ChangeLog LICENSE
90 %attr(755,root,root) %{_bindir}/node
91 %attr(755,root,root) %{_bindir}/node-repl
92 %dir %{_libdir}/node
93 %dir %{_libdir}/node/libraries
94 %{_libdir}/node/libraries/*.js
95 %{_mandir}/man1/node.1*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %dir %{_includedir}/node
100 %{_includedir}/node/*.h
101 %attr(755,root,root) %{_bindir}/node-waf
102 %{_libdir}/node/wafadmin/
This page took 0.057529 seconds and 2 git commands to generate.