]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
- added "Provides" section
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - more bconds (??)
3 # - subpackage with error pages
4 # Conditional build for nginx:
5 %bcond_with     stub_status             # stats module
6 %bcond_with     rtsig
7 %bcond_with     select
8 %bcond_with     poll
9 %bcond_with     ssl                     # ssl support
10 %bcond_with     imap                    # imap proxy
11 %bcond_without  http_browser            # parse header "User-agent"
12 #
13 Summary:        High perfomance HTTP and reverse proxy server
14 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
15 Name:           nginx
16 Version:        0.5.31
17 Release:        3
18 License:        BSD-like
19 Group:          Networking/Daemons
20 Source0:        http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
21 # Source0-md5:  d84ef8e624b8953faf9cee2b5da535c1
22 Source1:        %{name}.init
23 Source2:        %{name}-mime.types.sh
24 Source3:        http://www.nginx.eu/favicon.ico
25 # Source3-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
26 Source4:        http://www.nginx.eu/download/proxy.conf
27 # Source4-md5:  f5263ae01c2edb18f46d5d1df2d3a5cd
28 Source5:        http://www.nginx.eu/download/%{name}.monitrc
29 # Source5-md5:  1d3f5eedfd34fe95213f9e0fc19daa88
30 Source6:        http://www.nginx.eu/download/%{name}.conf
31 # Source6-md5:  1c112d6f03d0f365e4acc98c1d96261a
32 Source7:        %{name}.logrotate
33 Patch0:         %{name}-config.patch
34 URL:            http://nginx.net/
35 BuildRequires:  mailcap
36 BuildRequires:  openssl-devel
37 BuildRequires:  pcre-devel
38 BuildRequires:  rpmbuild(macros) >= 1.268
39 BuildRequires:  zlib-devel
40 Requires(post,preun):   /sbin/chkconfig
41 Requires(postun):       /usr/sbin/groupdel
42 Requires(postun):       /usr/sbin/userdel
43 Requires(pre):  /bin/id
44 Requires(pre):  /usr/bin/getgid
45 Requires(pre):  /usr/sbin/groupadd
46 Requires(pre):  /usr/sbin/useradd
47 Requires:       rc-scripts
48 Provides:       group(http)
49 Provides:       group(nginx)
50 Provides:       user(nginx)
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _sysconfdir     /etc/%{name}
54 %define         _nginxdir       /home/services/%{name}
55
56 %description
57 Nginx ("engine x") is a high-performance HTTP server and reverse
58 proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
59 Sysoev for Rambler.ru, Russia's second-most visited website, where it
60 has been running in production for over two and a half years. Igor has
61 released the source code under a BSD-like license. Although still in
62 beta, Nginx is known for its stability, rich feature set, simple
63 configuration, and low resource consumption.
64
65 %description -l pl.UTF-8
66 Serwer HTTP i odwrotne proxy o wysokiej wydajności.
67
68
69 %package -n monit-rc-nginx
70 Summary:        Nginx  support for monit
71 Summary(pl.UTF-8):      Wsparcie nginx dla monit
72 Group:          Applications/System
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       monit
75
76 %description -n monit-rc-nginx
77 monitrc file for monitoring nginx webserver server.
78
79 %description -n monit-rc-nginx -l pl.UTF-8
80 Plik monitrc do monitorowania serwera www nging.
81
82
83 %prep
84 %setup -q
85 %patch0 -p0
86
87 # build mime.types.conf
88 sh %{SOURCE2} /etc/mime.types
89
90 %build
91 # NB: not autoconf generated configure
92 ./configure \
93         --prefix=%{_prefix} \
94         --sbin-path=%{_sbindir}/%{name} \
95         --conf-path=%{_sysconfdir}/%{name}.conf \
96         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
97         --pid-path=%{_localstatedir}/run/%{name}.pid \
98         --user=nginx \
99         --group=nginx \
100         %{?with_stub_status:--with-http_stub_status_module} \
101         %{?with_rtsig:--with-rtsig_module} \
102         %{?with_select:--with-select_module} \
103         %{?with_poll:--with-poll_module} \
104         %{?with_ssl:--with-http_ssl_module} \
105         %{?with_imap:--with-imap} \
106         %{?with_http_browser:--without-http_browser_module} \
107         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
108         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
109         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
110         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
111         --with-cc="%{__cc}" \
112         --with-cc-opt="%{rpmcflags}" \
113         --with-ld-opt="%{rpmldflags}" \
114         %{?debug:--with-debug}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
121         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
122         $RPM_BUILD_ROOT{%{_localstatedir}/log/{%{name},archive/%{name}},%{_localstatedir}/cache/%{name}} \
123         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}} \
124         $RPM_BUILD_ROOT/etc/{logrotate.d,monit}
125
126 install conf/* $RPM_BUILD_ROOT%{_sysconfdir}
127 install mime.types $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
128 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
129 install %{SOURCE3} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
130 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
131 install %{SOURCE5} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
132 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
133 install %{SOURCE7} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
134
135 install objs/%{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
136
137 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/*.default
138 rm -rf $RPM_BUILD_ROOT%{_prefix}/html
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %pre
144 %groupadd -r -g 213 %{name}
145 %groupadd -g 51 http
146 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
147 %addusertogroup %{name} http
148
149 %post
150 for a in access.log error.log; do
151         if [ ! -f /var/log/%{name}/$a ]; then
152                 touch /var/log/%{name}/$a
153                 chown nginx:nginx /var/log/%{name}/$a
154                 chmod 644 /var/log/%{name}/$a
155         fi
156 done
157 /sbin/chkconfig --add %{name}
158 %service %{name} restart
159
160 %preun
161 if [ "$1" = "0" ]; then
162         %service -q %{name} stop
163         /sbin/chkconfig --del %{name}
164 fi
165
166 %postun
167 if [ "$1" = "0" ]; then
168         %userremove %{name}
169         %groupremove %{name}
170 fi
171
172 %files
173 %defattr(644,root,root,755)
174 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
175 %doc %lang(ru) CHANGES.ru
176 %attr(754,root,root) /etc/rc.d/init.d/%{name}
177 %dir %attr(754,root,root) %{_sysconfdir}
178 %dir %{_nginxdir}
179 %dir %{_nginxdir}/cgi-bin
180 %dir %{_nginxdir}/html
181 %dir %{_nginxdir}/errors
182 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
183 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
184 %attr(640,root,root) %{_sysconfdir}/*[_-]*
185 %attr(640,root,root) %{_sysconfdir}/proxy.conf
186 %attr(640,root,root) %{_sysconfdir}/mime.types
187 %attr(755,root,root) %{_sbindir}/%{name}
188 %attr(770,root,%{name}) /var/cache/%{name}
189 %attr(750,%{name},logs) /var/log/%{name}
190 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
191
192 %files -n monit-rc-nginx
193 %defattr(644,root,root,755)
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 2.771024 seconds and 4 git commands to generate.