]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
Add njs packaging TODO
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 # - add njs: https://nginx.org/en/docs/njs/
5 #
6 # Conditional build for nginx:
7 # Features
8 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
9 %bcond_without  threads         # thread pool support
10 # Modules
11 %bcond_without  addition        # http addition module
12 %bcond_without  auth_request    # auth_request module
13 %bcond_without  dav             # WebDAV
14 %bcond_without  flv             # http FLV module
15 %bcond_without  gd              # without http image filter module
16 %bcond_without  geoip           # without http geoip module and stream geoip module
17 %bcond_without  http2           # HTTP/2 module
18 %bcond_without  mail            # don't build imap/mail proxy
19 %bcond_without  perl            # don't build with perl module
20 %bcond_without  poll            # poll module
21 %bcond_without  realip          # real ip (behind proxy)
22 %bcond_without  select          # select module
23 %bcond_without  ssl             # ssl support and http ssl module
24 %bcond_without  stream          # TCP/UDP proxy module
25 %bcond_without  stub_status     # http stub status module
26 %bcond_without  sub             # ngx_http_sub_module
27 %bcond_without  xslt            # without http xslt module
28 %bcond_with     http_browser    # http browser module (header "User-agent" parser)
29 %bcond_with     modsecurity     # modsecurity module
30 %bcond_with     rtmp            # rtmp support
31 %bcond_without  vts             # virtual host traffic status module
32
33 %ifarch x32
34 %undefine       with_rtsig
35 %endif
36
37 %define         ssl_version     1.0.2
38 %define         rtmp_version    1.2.1
39 %define         vts_version     0.1.18
40 %define         modsecurity_version     2.9.3
41 Summary:        High perfomance HTTP and reverse proxy server
42 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
43 # nginx lines:
44 # - stable: production quality with stable API
45 # - mainline: production quality but API can change
46 Name:           nginx
47 Version:        1.16.1
48 Release:        3
49 License:        BSD-like
50 Group:          Networking/Daemons/HTTP
51 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
52 # Source0-md5:  45a80f75336c980d240987badc3dcf60
53 Source1:        http://nginx.net/favicon.ico
54 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
55 Source2:        proxy.conf
56 Source3:        %{name}.logrotate
57 Source4:        %{name}.mime
58 Source6:        %{name}.monitrc
59 Source7:        %{name}.init
60 Source14:       %{name}.conf
61 Source17:       %{name}-mime.types.sh
62 Source18:       %{name}.service
63 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
64 # Source22-md5: 215a96d679a5b0fadcf13b5d09b35422
65 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
66 # Source101-md5:        639ac2b78103adaccbcfe484a92acf44
67 Source102:      https://github.com/vozlt/nginx-module-vts/archive/v%{vts_version}.tar.gz
68 # Source102-md5:        409a10dbd85e0b807cc77eecec29a3b5
69 Patch0:         %{name}-no-Werror.patch
70 Patch1:         %{name}-modsecurity-xheaders.patch
71 URL:            http://nginx.org/
72 BuildRequires:  mailcap
73 BuildRequires:  pcre-devel
74 BuildRequires:  rpmbuild(macros) >= 1.644
75 BuildRequires:  zlib-devel
76 %if %{with geoip}
77 BuildRequires:  GeoIP-devel
78 %endif
79 %if %{with gd}
80 BuildRequires:  gd-devel
81 %endif
82 %if %{with modsecurity}
83 BuildRequires:  lua-devel
84 %endif
85 %if %{with perl}
86 BuildRequires:  perl-CGI
87 BuildRequires:  perl-devel
88 BuildRequires:  python
89 BuildRequires:  rpm-perlprov
90 %endif
91 %if %{with ssl}
92 BuildRequires:  openssl-devel >= %{ssl_version}
93 Requires:       openssl >= %{ssl_version}
94 %endif
95 %if %{with xslt}
96 BuildRequires:  libxslt-devel
97 %endif
98 Provides:       group(http)
99 Provides:       group(nginx)
100 Provides:       user(nginx)
101 Provides:       webserver
102 Provides:       webserver(access)
103 Provides:       webserver(alias)
104 Provides:       webserver(auth)
105 Provides:       webserver(expires)
106 Provides:       webserver(headers)
107 Provides:       webserver(indexfile)
108 Provides:       webserver(log)
109 Provides:       webserver(mime)
110 Provides:       webserver(reqtimeout)
111 Provides:       webserver(rewrite)
112 Provides:       webserver(setenv)
113 Conflicts:      logrotate < 3.8.0
114 Requires(post,preun):   /sbin/chkconfig
115 Requires(post,preun,postun):    systemd-units >= 38
116 Requires(postun):       /usr/sbin/groupdel
117 Requires(postun):       /usr/sbin/userdel
118 Requires(pre):  /bin/id
119 Requires(pre):  /usr/bin/getgid
120 Requires(pre):  /usr/sbin/groupadd
121 Requires(pre):  /usr/sbin/useradd
122 Requires:       rc-scripts >= 0.2.0
123 Requires:       systemd-units >= 38
124 Suggests:       vim-syntax-nginx
125 Obsoletes:      nginx-common < 1.13.3
126 Obsoletes:      nginx-light < 1.13.3
127 Obsoletes:      nginx-standard < 1.13.3
128 Conflicts:      rpm < 4.4.2-0.2
129 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
130
131 %define         _sysconfdir     /etc/%{name}
132 %define         _nginxdir       /home/services/%{name}
133
134 # minimizing restarts logics. we restart webserver:
135 #
136 # 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
137 # 2. first install of module (post: $1 = 1)
138 # 2. uninstall of module (postun: $1 == 0)
139 #
140 # the strict internal deps between modules and
141 # main package are very important for all this to work.
142
143 # restart webserver at the end of transaction
144
145 %define restart_webserver \
146         %systemd_post %{name}.service \
147         %service %{name} force-reload \
148         %{nil}
149
150 # macro called at module post scriptlet
151 %define module_post \
152 if [ "$1" = "1" ]; then \
153         %restart_webserver \
154 fi
155
156 # macro called at module postun scriptlet
157 %define module_postun \
158 if [ "$1" = "0" ]; then \
159         %restart_webserver \
160 fi
161
162 # it's sooo annoying to write them
163 %define module_scripts() \
164 %post %1 \
165 %module_post \
166 \
167 %postun %1 \
168 %module_postun
169
170 %description
171 nginx ("engine x") is a high-performance HTTP server and reverse
172 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
173 Sysoev for Rambler.ru, Russia's second-most visited website, where it
174 has been running in production for over two and a half years. Igor has
175 released the source code under a BSD-like license. Although still in
176 beta, nginx is known for its stability, rich feature set, simple
177 configuration, and low resource consumption.
178
179 %description -l pl.UTF-8
180 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
181 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
182 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
183 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
184 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
185 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
186 prostej konfiguracji oraz małej "zasobożerności".
187
188 %package mod_http_geoip
189 Summary:        Nginx HTTP geoip module
190 Group:          Daemons
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       GeoIP
193
194 %description mod_http_geoip
195 Nginx HTTP geoip module.
196
197 %package mod_stream_geoip
198 Summary:        Nginx stream geoip module
199 Group:          Daemons
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       %{name}-mod_stream = %{version}-%{release}
202 Requires:       GeoIP
203
204 %description mod_stream_geoip
205 Nginx stream geoip module.
206
207 %package mod_http_image_filter
208 Summary:        Nginx HTTP image filter module
209 Group:          Daemons
210 Requires:       %{name} = %{version}-%{release}
211
212 %description mod_http_image_filter
213 Nginx HTTP image filter module.
214
215 %package mod_http_perl
216 Summary:        Nginx HTTP Perl module
217 Group:          Networking/Daemons/HTTP
218 Requires:       %{name} = %{version}-%{release}
219
220 %description mod_http_perl
221 Nginx HTTP Perl module.
222
223 %package mod_http_xslt_filter
224 Summary:        Nginx XSLT module
225 Group:          Daemons
226 Requires:       %{name} = %{version}-%{release}
227
228 %description mod_http_xslt_filter
229 Nginx XSLT module.
230
231 %package mod_mail
232 Summary:        Nginx mail module
233 Group:          Networking/Daemons/HTTP
234 Requires:       %{name} = %{version}-%{release}
235
236 %description mod_mail
237 Nginx mail module.
238
239 %package mod_vts
240 Summary:        Nginx virtual host traffic status module
241 Group:          Networking/Daemons/HTTP
242 Requires:       %{name} = %{version}-%{release}
243
244 %description mod_vts
245 Nginx virtual host traffic status module.
246
247 %package mod_stream
248 Summary:        Nginx stream modules
249 Group:          Daemons
250 Requires:       %{name} = %{version}-%{release}
251
252 %description mod_stream
253 Nginx stream modules.
254
255 %package -n monit-rc-nginx
256 Summary:        nginx support for monit
257 Summary(pl.UTF-8):      Wsparcie nginx dla monit
258 Group:          Applications/System
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       monit
261
262 %description -n monit-rc-nginx
263 monitrc file for monitoring nginx webserver.
264
265 %description -n monit-rc-nginx -l pl.UTF-8
266 Plik monitrc do monitorowania serwera WWW nginx.
267
268 %prep
269 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22} %{?with_vts:-a102}
270 %patch0 -p0
271 %{?with_modsecurity:%patch1 -p0}
272
273 %if %{with rtmp}
274 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
275 %endif
276
277 %if %{with vts}
278 mv nginx-module-vts-%{vts_version} nginx-vts-module
279 %endif
280
281 # build mime.types.conf
282 #sh %{SOURCE17} /etc/mime.types
283
284 %build
285 # NB: not autoconf generated configure
286 cp -f configure auto/
287
288 ./configure \
289         --prefix=%{_prefix} \
290         --modules-path=%{_libdir}/%{name}/modules \
291         --sbin-path=%{_sbindir}/%{name} \
292         --conf-path=%{_sysconfdir}/%{name}.conf \
293         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
294         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
295         --pid-path=%{_localstatedir}/run/%{name}.pid \
296         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
297         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
298         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
299         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
300         --http-uwsgi-temp-path=%{_localstatedir}/cache/%{name}/uwsgi_temp \
301         --http-scgi-temp-path=%{_localstatedir}/cache/%{name}/scgi_temp \
302         --user=nginx \
303         --group=nginx \
304         %{?with_select:--with-select_module} \
305         %{?with_poll:--with-poll_module} \
306         %{?with_rtsig:--with-rtsig_module} \
307         %{?with_perl:--with-http_perl_module=dynamic} \
308         %{?with_gd:--with-http_image_filter_module=dynamic} \
309         %{?with_xslt:--with-http_xslt_module=dynamic} \
310         %{?with_geoip:--with-http_geoip_module=dynamic} \
311         %{?with_geoip:--with-stream_geoip_module=dynamic} \
312 %if %{with mail}
313         --with-mail=dynamic \
314         --with-mail_ssl_module \
315 %endif
316 %if %{with stream}
317         --with-stream=dynamic \
318         --with-stream_ssl_module \
319 %endif
320         --with-cc="%{__cc}" \
321         --with-cc-opt="%{rpmcflags}" \
322         --with-ld-opt="%{rpmldflags}" \
323         %{?with_debug:--with-debug} \
324         %{?with_addition:--with-http_addition_module} \
325         %{?with_dav:--with-http_dav_module} \
326         %{?with_flv:--with-http_flv_module} \
327         %{?with_sub:--with-http_sub_module} \
328         %{?with_realip:--with-http_realip_module} \
329         %{?with_stub_status:--with-http_stub_status_module} \
330         %{?with_ssl:--with-http_ssl_module} \
331         %{!?with_http_browser:--without-http_browser_module} \
332         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
333         %{?with_vts:--add-dynamic-module=./nginx-vts-module} \
334         %{?with_auth_request:--with-http_auth_request_module} \
335         %{?with_threads:--with-threads} \
336         %{?with_http2:--with-http_v2_module} \
337         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
338         --with-http_secure_link_module \
339         %{nil}
340
341 %{__make}
342
343 %if %{with modsecurity}
344 cd modsecurity-%{modsecurity_version}
345 ./autogen.sh
346 %configure \
347         --enable-standalone-module \
348         --disable-mlogc \
349         --enable-alp2 \
350         --with-lua=/usr
351 %{__make}
352 cd ..
353 %endif
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
358         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
359         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
360         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
361         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
362         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{conf,modules,vhosts,webapps}.d} \
363         $RPM_BUILD_ROOT%{_sysconfdir}/snippets \
364         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
365         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
366
367 %{__make} install \
368         INSTALLDIRS=vendor \
369         DESTDIR=$RPM_BUILD_ROOT
370
371 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
372
373 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
374 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
375 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
376 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
377
378 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
379 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
380 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
381 rm -r $RPM_BUILD_ROOT%{_prefix}/html
382 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
383 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
384 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
385
386 load_module() {
387         local module=ngx_${1}_module.so conffile=mod_$1.conf
388         printf 'load_module "%{_libdir}/%{name}/modules/%s";' "$module" \
389                 > $RPM_BUILD_ROOT%{_sysconfdir}/modules.d/$conffile
390 }
391
392 %if %{with perl}
393 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
394 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
395 load_module http_perl
396 %endif
397
398 %if %{with geoip}
399 load_module http_geoip
400 load_module stream_geoip
401 %endif
402 %if %{with gd}
403 load_module http_image_filter
404 %endif
405 %if %{with xslt}
406 load_module http_xslt_filter
407 %endif
408 %if %{with mail}
409 load_module mail
410 %endif
411 %{?with_vts:load_module http_vhost_traffic_status}
412 %if %{with stream}
413 load_module stream
414 %endif
415
416 %clean
417 rm -rf $RPM_BUILD_ROOT
418
419 %pre
420 %groupadd -r -g 213 %{name}
421 %groupadd -g 51 http
422 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
423 %addusertogroup %{name} http
424
425 %post
426 for a in access.log error.log; do
427         if [ ! -f /var/log/%{name}/$a ]; then
428                 umask 022
429                 touch /var/log/%{name}/$a
430                 chown nginx:nginx /var/log/%{name}/$a
431                 chmod 644 /var/log/%{name}/$a
432         fi
433 done
434 /sbin/chkconfig --add %{name}
435
436 %posttrans
437 %restart_webserver
438
439 %preun
440 if [ "$1" = "0" ];then
441         %service %{name} stop
442         /sbin/chkconfig --del %{name}
443 fi
444 %systemd_preun %{name}.service
445
446 %postun
447 if [ "$1" = "0" ]; then
448         %userremove %{name}
449         %groupremove %{name}
450 fi
451 %systemd_reload
452
453 %module_scripts mod_http_geoip
454 %module_scripts mod_http_image_filter
455 %module_scripts mod_http_perl
456 %module_scripts mod_http_xslt_filter
457 %module_scripts mod_mail
458 %module_scripts mod_vts
459 %module_scripts mod_stream
460 %module_scripts mod_stream_geoip
461
462 %files
463 %defattr(644,root,root,755)
464 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
465 %doc %lang(ru) CHANGES.ru
466 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
467 %attr(754,root,root) /etc/rc.d/init.d/%{name}
468 %dir %attr(750,root,nginx) %{_sysconfdir}
469 %dir %{_sysconfdir}/conf.d
470 %dir %{_sysconfdir}/modules.d
471 %dir %{_sysconfdir}/snippets
472 %dir %{_sysconfdir}/vhosts.d
473 %dir %{_sysconfdir}/webapps.d
474 %attr(640,root,root) %{_sysconfdir}/mime.types
475 %attr(640,root,root) %{_sysconfdir}/koi-utf
476 %attr(640,root,root) %{_sysconfdir}/koi-win
477 %attr(640,root,root) %{_sysconfdir}/win-utf
478 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi.conf
479 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
480 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
481 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
482 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
483 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
484 %attr(755,root,root) %{_sbindir}/%{name}
485 %dir %{_libdir}/%{name}
486 %dir %{_libdir}/%{name}/modules
487 %{systemdunitdir}/%{name}.service
488
489 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
490 %attr(750,nginx,logs) /var/log/%{name}
491 %attr(770,root,nginx) /var/cache/%{name}
492
493 %dir %{_nginxdir}
494 %dir %{_nginxdir}/cgi-bin
495 %dir %{_nginxdir}/html
496 %dir %{_nginxdir}/errors
497 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
498 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
499
500 %if %{with geoip}
501 %files mod_http_geoip
502 %defattr(644,root,root,755)
503 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_geoip.conf
504 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
505
506 %files mod_stream_geoip
507 %defattr(644,root,root,755)
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream_geoip.conf
509 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
510 %endif
511
512 %if %{with gd}
513 %files mod_http_image_filter
514 %defattr(644,root,root,755)
515 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_image_filter.conf
516 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
517 %endif
518
519 %if %{with perl}
520 %files mod_http_perl
521 %defattr(644,root,root,755)
522 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_perl.conf
523 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
524 %dir %{perl_vendorarch}/auto/%{name}
525 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
526 %{perl_vendorarch}/%{name}.pm
527 %{_mandir}/man3/nginx.3pm*
528 %endif
529
530 %if %{with xslt}
531 %files mod_http_xslt_filter
532 %defattr(644,root,root,755)
533 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_xslt_filter.conf
534 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
535 %endif
536
537 %if %{with mail}
538 %files mod_mail
539 %defattr(644,root,root,755)
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_mail.conf
541 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
542 %endif
543
544 %if %{with vts}
545 %files mod_vts
546 %defattr(644,root,root,755)
547 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_http_vhost_traffic_status.conf
548 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_vhost_traffic_status_module.so
549 %endif
550
551 %if %{with stream}
552 %files mod_stream
553 %defattr(644,root,root,755)
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/modules.d/mod_stream.conf
555 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
556 %endif
557
558 %files -n monit-rc-nginx
559 %defattr(644,root,root,755)
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.104808 seconds and 4 git commands to generate.