]> git.pld-linux.org Git - packages/nghttp2.git/blob - nghttp2.spec
- new
[packages/nghttp2.git] / nghttp2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform "make check"
4 %bcond_without  static_libs     # don't build static library
5
6 Summary:        HTTP/2.0 C library
7 Summary(pl.UTF-8):      Biblioteka C HTTP/2.0
8 Name:           nghttp2
9 Version:        0.1.0
10 %define snap    20131016
11 Release:        0.%{snap}.1
12 License:        MIT
13 Group:          Libraries
14 Source0:        https://github.com/tatsuhiro-t/nghttp2/archive/master/%{name}-%{snap}.tar.gz
15 # Source0-md5:  95b817bc5fb09c75c66853fb44ce7f86
16 Patch0:         %{name}-test.patch
17 URL:            https://github.com/tatsuhiro-t/nghttp2
18 %{?with_tests:BuildRequires:    CUnit >= 2.1}
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake
21 BuildRequires:  libevent-devel >= 2.0.8
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxml2-devel >= 1:2.7.7
25 BuildRequires:  openssl-devel >= 1.0.1
26 BuildRequires:  pkgconfig >= 1:0.20
27 BuildRequires:  python >= 1:2.6
28 BuildRequires:  spdylay-devel >= 1.0.0
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRequires:  zlib-devel >= 1.2.3
32 Requires:       libevent >= 2.0.8
33 Requires:       libxml2 >= 1:2.7.7
34 Requires:       openssl >= 1.0.1
35 Requires:       spdylay >= 1.0.0
36 Requires:       zlib >= 1.2.3
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This is an experimental implementation of Hypertext Transfer Protocol
41 version 2.0.
42
43 %description -l pl.UTF-8
44 Ta biblioteka jest eksperymentalną implementacją protokołu HTTP
45 (Hypertext Transfer Protocol) w wersji 2.0.
46
47 %package devel
48 Summary:        Files needed for developing with libnghttp2
49 Summary(pl.UTF-8):      Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       zlib-devel >= 1.2.3
53
54 %description devel
55 Files needed for building applications with libnghttp2.
56
57 %description devel -l pl.UTF-8
58 Pliki niezbędne do tworzenia aplikacji z użyciem libnghttp2.
59
60 %package static
61 Summary:        Static libnghttp2 library
62 Summary(pl.UTF-8):      Statyczna biblioteka libnghttp2
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static libnghttp2 library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka libnghttp2.
71
72 %prep
73 %setup -q -n %{name}-master
74 %patch0 -p1
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         %{!?with_static_libs:--disable-static}
84
85 %{__make}
86
87 %if %{with tests}
88 %{__make} check
89 %endif
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # obsoleted by pkg-config
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnghttp2.la
99 # packaged as %doc
100 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/nghttp2
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING README.rst
111 %attr(755,root,root) %{_bindir}/nghttp
112 %attr(755,root,root) %{_bindir}/nghttpd
113 %attr(755,root,root) %{_bindir}/nghttpx
114 %attr(755,root,root) %{_libdir}/libnghttp2.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libnghttp2.so.0
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libnghttp2.so
120 %{_includedir}/nghttp2
121 %{_pkgconfigdir}/libnghttp2.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libnghttp2.a
127 %endif
This page took 0.050476 seconds and 4 git commands to generate.