]> git.pld-linux.org Git - packages/netsurf.git/blob - netsurf.spec
- up to 3.0
[packages/netsurf.git] / netsurf.spec
1 Summary:        Light www browser
2 Name:           netsurf
3 Version:        3.0
4 Release:        1
5 License:        GPL v2
6 Group:          Applications/Networking
7 Source0:        http://download.netsurf-browser.org/netsurf/releases/source-full/%{name}-%{version}-full-src.tar.gz
8 # Source0-md5:  51b13676d5f012409e0aefc6404938f6
9 Source1:        %{name}.desktop
10 Patch0:         enable-nsfb.patch
11 Patch1:         libnsfb-xcb-fix.patch
12 Patch2:         nsfb-F10-exit.patch
13 URL:            http://netsurf-browser.org/
14 BuildRequires:  SDL-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  freetype-devel
17 BuildRequires:  libCSS-devel
18 BuildRequires:  libdom-devel
19 BuildRequires:  libglade2-devel
20 BuildRequires:  libhubbub-devel
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libmng-devel
23 BuildRequires:  libnsbmp-devel
24 BuildRequires:  libnsgif-devel
25 BuildRequires:  libparserutils-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  librsvg-devel
28 BuildRequires:  libsvgtiny-devel
29 BuildRequires:  libwapcaplet-devel
30 BuildRequires:  netsurf-buildsystem
31 BuildRequires:  nsgenbind
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Small web browser with CSS support. NetSurf is a multi-platform
38 lightweight web browser. Its aim is to provide comprehensive rendering
39 of HTML 5 with CSS 2 in a small resource footprint while remaining
40 fast.
41
42 %package common
43 Summary:        netsurf - common files
44 Summary(pl.UTF-8):      netsurf - pliki wspólne
45 License:        GPL v2
46 Group:          Applications/Networking
47
48 %description common
49 netsurf - common files.
50
51 %description common -l pl.UTF-8
52 netsurf - wspólne pliki.
53
54 %package gtk
55 Summary:        netsurf browser gtk version
56 Summary(pl.UTF-8):      Wersja gtk netsurfa
57 License:        GPL v2
58 Group:          Applications/Networking
59 Requires:       %{name}-common = %{version}-%{release}
60
61 %description gtk
62 Small web browser with CSS support. NetSurf is a multi-platform
63 lightweight web browser. Its aim is to provide comprehensive rendering
64 of HTML 5 with CSS 2 in a small resource footprint while remaining
65 fast.
66
67 This is gtk version.
68
69 %package sdl
70 Summary:        netsurf browser SDL version
71 Summary(pl.UTF-8):      Wersja SDL netsurfa
72 License:        GPL v2
73 Group:          Applications/Networking
74 Requires:       %{name}-common = %{version}-%{release}
75
76 %description sdl
77 Small web browser with CSS support. NetSurf is a multi-platform
78 lightweight web browser. Its aim is to provide comprehensive rendering
79 of HTML 5 with CSS 2 in a small resource footprint while remaining
80 fast.
81
82 This is SDL version.
83
84 %prep
85 %setup -q -n netsurf-full-%{version}
86 #%patch0 -p1
87 #%patch1 -p1
88 %patch2 -p1
89
90 cat << EOF > src/netsurf-3.0/Makefile.config
91 NETSURF_FB_FONTLIB := freetype
92 NETSURF_FB_FONTPATH := %{_datadir}/fonts/TTF
93 EOF
94
95 %build
96 cd src/netsurf-%{version}
97 export CC="%{__cc}"
98 # while cxx not needed, somewhy it helps race condition on carme build
99 export CXX="%{__cxx}"
100 # silence -Werror:
101 #src/surface/vnc.c: In function 'vnc_input':
102 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
103 export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable"
104 export LDFLAGS="%{rpmldflags}"
105
106 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
107
108 %{__make} -j1 \
109         PREFIX=%{_prefix} \
110         Q='' \
111         TARGET=gtk
112
113 %{__make} -j1 \
114         PREFIX=%{_prefix} \
115         Q='' \
116         TARGET=framebuffer
117
118 %install
119 cd src/netsurf-%{version}
120 rm -rf $RPM_BUILD_ROOT
121 %{__make} install \
122         Q='' \
123         PREFIX=%{_prefix} \
124         TARGET=gtk \
125         DESTDIR=$RPM_BUILD_ROOT
126
127
128 %{__make} install \
129         Q='' \
130         PREFIX=%{_prefix} \
131         TARGET=framebuffer \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 # this is binary from last "make install", we install more specific binary ourself
135 %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/netsurf
136
137 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
138 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
139 install nsfb $RPM_BUILD_ROOT/%{_bindir}
140 install nsgtk $RPM_BUILD_ROOT/%{_bindir}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files common
146 %defattr(644,root,root,755)
147 %doc src/netsurf-%{version}/README
148 %dir %{_datadir}/%{name}
149 %{_datadir}/%{name}/*
150
151 %files gtk
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/nsgtk
154 %{_desktopdir}/netsurf.desktop
155
156 %files sdl
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/nsfb
This page took 0.068057 seconds and 3 git commands to generate.