]> git.pld-linux.org Git - packages/netsniff-ng.git/blob - netsniff-ng.spec
- pl, release 2 (rebuild due to libsodium and urcu)
[packages/netsniff-ng.git] / netsniff-ng.spec
1 Summary:        A Swiss army knife for network plumbing
2 Summary(pl.UTF-8):      "Szwajcarski scyzoryk" do napraw sieci
3 Name:           netsniff-ng
4 Version:        0.6.3
5 Release:        2
6 License:        GPL v2
7 Group:          Networking/Utilities
8 Source0:        http://pub.netsniff-ng.org/netsniff-ng/%{name}-%{version}.tar.xz
9 # Source0-md5:  e892a7f2e025fba07d0f0a330e9917df
10 URL:            http://netsniff-ng.org/
11 BuildRequires:  GeoIP-devel >= 1.4.8
12 BuildRequires:  bison
13 BuildRequires:  flex
14 BuildRequires:  libcli-devel
15 BuildRequires:  libnet-devel
16 BuildRequires:  libnetfilter_conntrack-devel
17 BuildRequires:  libnl-devel >= 3.2
18 BuildRequires:  libpcap-devel
19 BuildRequires:  libsodium-devel
20 BuildRequires:  ncurses-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.719
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  userspace-rcu-devel
25 BuildRequires:  zlib-devel
26 Requires:       GeoIP-libs >= 1.4.8
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 * netsniff-ng, a fast zero-copy analyzer, pcap capturing and replaying
31   tool
32 * trafgen, a multithreaded low-level zero-copy network packet
33   generator
34 * mausezahn, high-level packet generator for HW/SW appliances with
35   Cisco-CLI
36 * bpfc, a Berkeley Packet Filter compiler, Linux BPF JIT disassembler
37 * ifpps, a top-like kernel networking statistics tool
38 * flowtop, a top-like netfilter connection tracking tool
39 * curvetun, a lightweight curve25519-based IP tunnel
40 * astraceroute, an autonomous system (AS) trace route utility
41
42 %description -l pl.UTF-8
43 * netsniff-ng - szybkie, niekopiujące narzędzie do analizy,
44   przechwytywania pakietów przez pcap i odtwarzania
45 * trafgen - wielowątkowy, niskopoziomowy, niekopiujący generator
46   pakietów sieciowych
47 * mausezahn - wysokopoziomowy generator pakietów do zastosowań HW/SW z
48   interfejsem linii poleceń w stylu Cisco
49 * bpfc - kompilator filtrów BPF (Berkeley Packet Filter), disasembler
50   JIT linuksowego BPF
51 * ifpps - narzędzie do statystyk sieciowych jądra w stylu programu top
52 * flowtop - narzędzie do śledzenia połączeń netfiltra w stylu topa
53 * curvetun - lekki tunel IP oparty na curve25519
54 * astraceroute - narzędzie autonomicznego systemu (AS) do śledzenia
55   tras
56
57 %prep
58 %setup -q
59
60 %{__sed} -e '43i#include <stdint.h>' -i staging/mz.h
61
62 %build
63 NACL_INC_DIR=$(pkg-config --variable=includedir libsodium)/sodium \
64 NACL_LIB=sodium \
65 ./configure \
66         --sysconfdir="%{_sysconfdir}" \
67         --prefix="%{_prefix}"
68 %{__make} \
69         %{?debug:DEBUG=1} \
70         Q=
71 #       %{!?debug:HARDENING=1 CPPFLAGS="%{rpmcflags}"} \
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_sbindir},%{zsh_compdir}}
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 for i in *.zsh; do
81         install -p "$i" $RPM_BUILD_ROOT%{zsh_compdir}/_"${i%.zsh}"
82 done
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS README REPORTING-BUGS bpf_jit_disasm.c bpf.vim
90 %dir %{_sysconfdir}/%{name}
91 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
92 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/stddef.h
93 %attr(755,root,root) %{_sbindir}/astraceroute
94 %attr(755,root,root) %{_sbindir}/bpfc
95 %attr(755,root,root) %{_sbindir}/curvetun
96 %attr(755,root,root) %{_sbindir}/flowtop
97 %attr(755,root,root) %{_sbindir}/ifpps
98 %attr(755,root,root) %{_sbindir}/mausezahn
99 %attr(755,root,root) %{_sbindir}/netsniff-ng
100 %attr(755,root,root) %{_sbindir}/trafgen
101 %{zsh_compdir}/_astraceroute
102 %{zsh_compdir}/_bpfc
103 %{zsh_compdir}/_curvetun
104 %{zsh_compdir}/_flowtop
105 %{zsh_compdir}/_ifpps
106 %{zsh_compdir}/_mausezahn
107 %{zsh_compdir}/_netsniff-ng
108 %{zsh_compdir}/_trafgen
109 %{_mandir}/man8/astraceroute.8*
110 %{_mandir}/man8/bpfc.8*
111 %{_mandir}/man8/curvetun.8*
112 %{_mandir}/man8/flowtop.8*
113 %{_mandir}/man8/ifpps.8*
114 %{_mandir}/man8/mausezahn.8*
115 %{_mandir}/man8/netsniff-ng.8*
116 %{_mandir}/man8/trafgen.8*
This page took 0.050219 seconds and 3 git commands to generate.