]> git.pld-linux.org Git - packages/netsniff-ng.git/blob - netsniff-ng.spec
for syntax fixed
[packages/netsniff-ng.git] / netsniff-ng.spec
1 Summary:        A Swiss army knife for network plumbing
2 Name:           netsniff-ng
3 Version:        0.6.3
4 Release:        1
5 License:        GPL v2
6 Group:          Networking/Utilities
7 Source0:        http://pub.netsniff-ng.org/netsniff-ng/%{name}-%{version}.tar.xz
8 # Source0-md5:  e892a7f2e025fba07d0f0a330e9917df
9 URL:            http://netsniff-ng.org/
10 BuildRequires:  GeoIP-devel
11 BuildRequires:  bison
12 BuildRequires:  flex
13 BuildRequires:  libcli-devel
14 BuildRequires:  libnet-devel
15 BuildRequires:  libnetfilter_conntrack-devel
16 BuildRequires:  libnl-devel
17 BuildRequires:  libpcap-devel
18 BuildRequires:  libsodium-devel
19 BuildRequires:  ncurses-devel
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.719
22 BuildRequires:  userspace-rcu-devel
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 * netsniff-ng, a fast zero-copy analyzer, pcap capturing and replaying tool
28 * trafgen, a multithreaded low-level zero-copy network packet generator
29 * mausezahn, high-level packet generator for HW/SW appliances with Cisco-CLI
30 * bpfc, a Berkeley Packet Filter compiler, Linux BPF JIT disassembler
31 * ifpps, a top-like kernel networking statistics tool
32 * flowtop, a top-like netfilter connection tracking tool
33 * curvetun, a lightweight curve25519-based IP tunnel
34 * astraceroute, an autonomous system (AS) trace route utility
35
36 %prep
37 %setup -q
38 %{__sed} -e '43i#include <stdint.h>' -i staging/mz.h
39
40 %build
41 NACL_INC_DIR=$(pkg-config --variable=includedir libsodium )/sodium \
42 NACL_LIB=sodium \
43 ./configure \
44         --sysconfdir="%{_sysconfdir}" \
45         --prefix="%{_prefix}"
46 %{__make} \
47         %{?debug:DEBUG=1} \
48         Q=
49 #       %{!?debug:HARDENING=1 CPPFLAGS="%{rpmcflags}"} \
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sbindir},%{zsh_compdir}}
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 for i in *.zsh; do
59         install -p "$i" $RPM_BUILD_ROOT%{zsh_compdir}/_"${i%.zsh}"
60 done
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc AUTHORS README REPORTING-BUGS bpf_jit_disasm bpf.vim
68 %dir %{_sysconfdir}/%{name}
69 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
70 %attr(755,root,root) %{_sbindir}/*
71 %{zsh_compdir}/_*
72 %{_mandir}/man8/*.8*
This page took 0.052256 seconds and 3 git commands to generate.