]> git.pld-linux.org Git - packages/netpbm.git/blob - netpbm.spec
- separated librle.a to rle-static
[packages/netpbm.git] / netpbm.spec
1 Summary:        A library for handling different graphics file formats
2 Summary(pl):    Biblioteki do obs³ugi ró¿nych formatów graficznych
3 Name:           netpbm
4 Version:        9.23
5 Release:        2
6 License:        Freeware
7 Group:          Libraries
8 Source0:        ftp://download.sourceforge.net/pub/sourceforge/netpbm/%{name}-%{version}.tgz
9 Source1:        %{name}-non-english-man-pages.tar.bz2
10 Patch0:         %{name}-install.patch
11 Patch1:         %{name}-system-jbig.patch
12 Patch2:         %{name}-Makefile.common.patch
13 BuildRequires:  libjpeg-devel
14 BuildRequires:  libpng-devel
15 BuildRequires:  libtiff-devel
16 BuildRequires:  jbigkit-devel
17 BuildRequires:  perl
18 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      libgr
20
21 %description
22 The netpbm package contains a library of functions which support
23 programs for handling various graphics file formats, including .pbm
24 (portable bitmaps), .pgm (portable graymaps), .pnm (portable anymaps),
25 .ppm (portable pixmaps) and others.
26
27 %description -l pl
28 Pakiet netpbm zawiera biblioteki funkcji obs³uguj±cych ró¿ne formaty
29 graficzne, w tym .pbm, .pgm, .pnm, .ppm.
30
31 %package devel
32 Summary:        Development tools for programs which will use the netpbm libraries
33 Summary(pl):    Biblioteka netpbm - czê¶æ dla programistów
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}
36 Obsoletes:      libgr-devel
37
38 %description devel
39 The netpbm-devel package contains the header files and programmer's
40 documentation for developing programs which can handle the various
41 graphics file formats supported by the netpbm libraries.
42
43 Install netpbm-devel if you want to develop programs for handling the
44 graphics file formats supported by the netpbm libraries. You'll also
45 need to have the netpbm package installed.
46
47 %description devel -l pl
48 Pakiet netpbm-devel zawiera pliki nag³ówkowe i dokumentacjê dla
49 programistów do tworzenia programów obs³uguj±cych formaty graficzne
50 wspierane przez netpbm.
51
52 %package static
53 Summary:        Static netpbm libraries
54 Summary(pl):    Statyczne biblioteki netpbm
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}
57 Obsoletes:      libgr-static
58
59 %description static
60 Static netpbm libraries.
61
62 %description static -l pl
63 Statyczne biblioteki netpbm.
64
65 %package rle-static
66 Summary:        Limited rle library
67 Summary(pl):    Okrojona biblioteka rle
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}
70 Obsoletes:      urt-static
71
72 %description rle-static
73 Limited version of rle library from netpbm.
74
75 %description rle-static -l pl
76 Okrojona wersja biblioteki rle z netpbm.
77
78 %package progs
79 Summary:        Tools for manipulating graphics files in netpbm supported formats
80 Summary(pl):    Narzêdzia do konwersji plików graficznych
81 Group:          Applications/Graphics
82 Requires:       %{name} = %{version}
83 Obsoletes:      libgr-progs
84
85 %description progs
86 The netpbm-progs package contains a group of scripts for manipulating
87 the graphics files in formats which are supported by the netpbm
88 libraries. For example, netpbm-progs includes the rasttopnm script,
89 which will convert a Sun rasterfile into a portable anymap.
90 Netpbm-progs contains many other scripts for converting from one
91 graphics file format to another.
92
93 If you need to use these conversion scripts, you should install
94 netpbm-progs. You'll also need to install the netpbm package.
95
96 %description progs -l pl
97 Pakiet netpbm-progs zawiera programy konwertuj±ce pliki graficzne do
98 oraz z formatów obs³ugiwanych przez biblioteki netpbm.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105
106 %build
107 %{__make} \
108         CC=%{__cc} \
109         CFLAGS="%{rpmcflags} -fPIC" \
110         JPEGINC_DIR=%{_includedir} \
111         PNGINC_DIR=%{_includedir} \
112         TIFFINC_DIR=%{_includedir} \
113         JPEGLIB_DIR=%{_libdir} \
114         PNGLIB_DIR=%{_libdir} \
115         TIFFLIB_DIR=%{_libdir} << EOF
116 gnu
117 %{_prefix}
118 regular
119 shared
120 yes
121 EOF
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
126 PATH="`pwd`:${PATH}" make install \
127         JPEGINC_DIR=$RPM_BUILD_ROOT%{_includedir} \
128         PNGINC_DIR=$RPM_BUILD_ROOT%{_includedir} \
129         TIFFINC_DIR=$RPM_BUILD_ROOT%{_includedir} \
130         JPEGLIB_DIR=%{_libdir} \
131         PNGLIB_DIR=%{_libdir} \
132         TIFFLIB_DIR=%{_libdir} \
133         INSTALL_PREFIX=$RPM_BUILD_ROOT%{_prefix} \
134         INSTALLBINARIES=$RPM_BUILD_ROOT%{_bindir} \
135         INSTALLHDRS=$RPM_BUILD_ROOT%{_includedir} \
136         INSTALLLIBS=$RPM_BUILD_ROOT%{_libdir} \
137         INSTALLMANUALS1=$RPM_BUILD_ROOT%{_mandir}/man1 \
138         INSTALLMANUALS3=$RPM_BUILD_ROOT%{_mandir}/man3 \
139         INSTALLMANUALS5=$RPM_BUILD_ROOT%{_mandir}/man5
140
141 # Install header files.
142 install -d $RPM_BUILD_ROOT%{_includedir}
143 install pbm/pbm.h $RPM_BUILD_ROOT/%{_includedir}
144 install pbm/pm.h $RPM_BUILD_ROOT/%{_includedir}
145 install pm_config.h $RPM_BUILD_ROOT/%{_includedir}
146 install pgm/pgm.h $RPM_BUILD_ROOT/%{_includedir}
147 install pnm/pnm.h $RPM_BUILD_ROOT/%{_includedir}
148 install ppm/ppm.h $RPM_BUILD_ROOT/%{_includedir}
149 install shhopt/shhopt.h $RPM_BUILD_ROOT/%{_includedir}
150
151 # Install the static-only librle.a
152 install urt/{rle,rle_config}.h $RPM_BUILD_ROOT/%{_includedir}/
153 install urt/librle.a $RPM_BUILD_ROOT%{_libdir}/
154
155 # Fixup symlinks.
156 ln -sf gemtopnm $RPM_BUILD_ROOT%{_bindir}/gemtopbm
157 ln -sf pnmtoplainpnm $RPM_BUILD_ROOT%{_bindir}/pnmnoraw
158
159 # Fixup perl paths in the two scripts that require it.
160 perl -pi -e 's^/bin/perl^%{__perl}^' \
161         $RPM_BUILD_ROOT%{_bindir}/{ppmfade,ppmshadow}
162
163 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
164
165 gzip -9nf COPYRIGHT.PATENT HISTORY README
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/lib*.so.*.*
176
177 %files devel
178 %defattr(644,root,root,755)
179 %doc *.gz
180 %{_includedir}/*.h
181 %attr(755,root,root) %{_libdir}/lib*.so
182 %{_mandir}/man3/*
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libp*.a
187
188 %files rle-static
189 %defattr(644,root,root,755)
190 %{_libdir}/librle.a
191
192 %files progs
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/*
195 %{_mandir}/man[15]/*
196 %lang(fi) %{_mandir}/fi/man[15]/*
197 %lang(pl) %{_mandir}/pl/man[15]/*
This page took 0.044192 seconds and 4 git commands to generate.