]> git.pld-linux.org Git - packages/neon.git/blob - neon.spec
- updated to 0.32.2
[packages/neon.git] / neon.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_with     gnutls          # GnuTLS instead of OpenSSL for SSL
6 %bcond_without  kerberos5       # Kerberos V support
7 %bcond_without  libproxy        # libproxy support
8 %bcond_without  pakchois        # pakchois-based PKCS#11 support
9
10 Summary:        An HTTP and WebDAV client library
11 Summary(pl.UTF-8):      Biblioteka kliencka HTTP i WebDAV
12 Name:           neon
13 Version:        0.32.2
14 Release:        1
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        https://notroj.github.io/neon/%{name}-%{version}.tar.gz
18 # Source0-md5:  09dd5c5e2cf4a0e01b20dd62767a1df7
19 URL:            https://notroj.github.io/neon/
20 BuildRequires:  autoconf >= 2.58
21 BuildRequires:  automake
22 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3}
23 %{?with_kerberos5:BuildRequires:        heimdal-devel}
24 %{?with_libproxy:BuildRequires: libproxy-devel}
25 BuildRequires:  libtool
26 BuildRequires:  libxml2-devel
27 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
28 %{?with_pakchois:BuildRequires: pakchois-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.752
31 BuildRequires:  zlib-devel
32 %if %{without gnutls}
33 %requires_ge_to openssl openssl-devel
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 neon is an HTTP and WebDAV client library, with a C interface.
39 Featuring:
40  - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD
41    etc).
42  - Low-level interface to HTTP request handling, to allow implementing
43    new methods easily.
44  - HTTP/1.1 and HTTP/1.0 persistent connections.
45  - RFC2617 basic and digest authentication (including auth-int,
46    md5-sess).
47  - Proxy support (including basic/digest authentication).
48  - Generic WebDAV 207 XML response handling mechanism.
49  - XML parsing using the expat or libxml parsers.
50  - Easy generation of error messages from 207 error responses.
51  - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
52  - WebDAV metadata support: set and remove properties, query any set of
53    properties (PROPPATCH/PROPFIND).
54
55 %description -l pl.UTF-8
56 neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
57 Możliwości:
58  - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET,
59    HEAD...),
60  - niskopoziomowy interfejs do obsługi żądań HTTP pozwalający łatwo
61    implementować nowe metody,
62  - stałe połączenia HTTP/1.1 i HTTP/1.0,
63  - uwierzytelnianie podstawowe (basic) i skrótem RFC-2617 (auth-int,
64    md5-sess...),
65  - obsługa proxy (w tym uwierzytelnianie podstawowe i skrótem),
66  - mechanizm obsługi odpowiedzi WebDAV 207 XML,
67  - analiza składniowa XML przy pomocy expat lub libxml,
68  - proste generowanie komunikatów błędów dla odpowiedzi 207,
69  - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
70  - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
71    sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
72
73 %package devel
74 Summary:        Header files for neon
75 Summary(pl.UTF-8):      Pliki nagłówkowe neon
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 %{?with_gnutls:Requires:        gnutls-devel >= 3}
79 %{?with_kerberos5:Requires: heimdal-devel}
80 %{?with_libproxy:Requires: libproxy-devel}
81 Requires:       libxml2-devel
82 %{!?with_gnutls:Requires:       openssl-devel >= 0.9.7c}
83 %{?with_pakchois:Requires: pakchois-devel}
84
85 %description devel
86 C header files for the neon library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe dla biblioteki neon.
90
91 %package static
92 Summary:        Static libraries for neon
93 Summary(pl.UTF-8):      Biblioteki statyczne neon
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static neon libraries.
99
100 %description static -l pl.UTF-8
101 Statyczne biblioteki neon.
102
103 %package apidocs
104 Summary:        neon API documentation
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki neon
106 Group:          Documentation
107 BuildArch:      noarch
108
109 %description apidocs
110 API and internal documentation for neon library.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API biblioteki neon.
114
115 %prep
116 %setup -q
117
118 %build
119 %{__libtoolize}
120 %{__aclocal} -I macros
121 %{__autoconf}
122 %configure \
123         --enable-threadsafe-ssl=posix \
124         --enable-shared \
125         %{!?with_static_libs:--disable-static} \
126         --with-ca-bundle=/etc/certs/ca-certificates.crt \
127         %{!?with_kerberos5:--without-gssapi} \
128         %{!?with_libproxy:--without-libproxy} \
129         --with-libxml2 \
130         --with-pakchois%{!?with_pakchois:=no} \
131         --with-ssl=%{?with_gnutls:gnutls}%{!?with_gnutls:openssl}
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS BUGS ChangeLog NEWS README.md THANKS TODO
155 %attr(755,root,root) %{_libdir}/libneon.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libneon.so.27
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc doc/*.txt
161 %attr(755,root,root) %{_bindir}/neon-config
162 %attr(755,root,root) %{_libdir}/libneon.so
163 %{_includedir}/neon
164 %{_pkgconfigdir}/neon.pc
165 %{_mandir}/man1/neon-config.1*
166 %{_mandir}/man3/ne_*.3*
167 %{_mandir}/man3/neon.3*
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libneon.a
173 %endif
174
175 %if %{with apidocs}
176 %files apidocs
177 %defattr(644,root,root,755)
178 %doc doc/html/*
179 %endif
This page took 0.119066 seconds and 3 git commands to generate.