]> git.pld-linux.org Git - packages/neon.git/blob - neon.spec
- more verbose files, ghost soname symlink
[packages/neon.git] / neon.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  kerberos5       # don't build Kerberos V support
5 #
6 Summary:        An HTTP and WebDAV client library
7 Summary(pl.UTF-8):      Biblioteka kliencka HTTP i WebDAV
8 Name:           neon
9 Version:        0.28.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://www.webdav.org/neon/%{name}-%{version}.tar.gz
14 # Source0-md5:  9d938e1e46003cae11d9e6f596da8c95
15 URL:            http://www.webdav.org/neon/
16 BuildRequires:  autoconf >= 2.58
17 BuildRequires:  automake
18 %{?with_kerberos5:BuildRequires:        krb5-devel}
19 BuildRequires:  libtool
20 BuildRequires:  libxml2-devel
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 neon is an HTTP and WebDAV client library, with a C interface.
27 Featuring:
28  - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
29  - Low-level interface to HTTP request handling, to allow implementing
30    new methods easily.
31  - HTTP/1.1 and HTTP/1.0 persistent connections.
32  - RFC2617 basic and digest authentication (including auth-int,
33    md5-sess).
34  - Proxy support (including basic/digest authentication).
35  - Generic WebDAV 207 XML response handling mechanism.
36  - XML parsing using the expat or libxml parsers.
37  - Easy generation of error messages from 207 error responses.
38  - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
39  - WebDAV metadata support: set and remove properties, query any set of
40    properties (PROPPATCH/PROPFIND).
41
42 %description -l pl.UTF-8
43 neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
44 Możliwości:
45  - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
46  - niskopziomowy interfejs to obsługi żądań HTTP pozwalający łatwo
47    implementować nowe metody,
48  - stałe połączenia HTTP/1.1 i HTTP/1.0,
49  - autentykacja podstawowa i skrótem RFC-2617 (auth-int, md5-sess...),
50  - obsługa proxy (w tym autentykacja podstawowa i skrótem),
51  - mechanizm obsługi odpowiedzi WebDAV 207 XML,
52  - analiza składniowa XML przy pomocy expat lub libxml,
53  - proste generowanie komunikatów błędów dla odpowiedzi 207,
54  - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
55  - obsługa metadanych WebDAV: ustawianie i usuwanie atrybutów,
56    sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
57
58 %package devel
59 Summary:        Header files for neon
60 Summary(pl.UTF-8):      Pliki nagłówkowe neon
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 %{?with_kerberos5:Requires:     krb5-devel}
64 Requires:       libxml2-devel
65 Requires:       openssl-devel >= 0.9.7c
66
67 %description devel
68 C header files for the neon library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe dla biblioteki neon.
72
73 %package static
74 Summary:        Static libraries for neon
75 Summary(pl.UTF-8):      Biblioteki statyczne neon
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static neon libraries.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki neon.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I macros
91 %{__autoconf}
92 %configure \
93         --with-ssl \
94         --enable-threadsafe-ssl=posix \
95         --enable-shared \
96         %{!?with_static_libs:--enable-static=no} \
97         %{!?with_kerberos5:--without-gssapi} \
98         --with-libxml2
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
110 mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
111
112 mv $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
124 %attr(755,root,root) %{_libdir}/libneon.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libneon.so.27
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/neon-config
130 %attr(755,root,root) %{_libdir}/libneon.so
131 %{_libdir}/libneon.la
132 %{_includedir}/neon
133 %{_pkgconfigdir}/neon.pc
134 %{_mandir}/man1/neon-config.1*
135 %{_mandir}/man3/ne_*.3*
136 %{_mandir}/man3/neon.3*
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libneon.a
142 %endif
This page took 0.059917 seconds and 3 git commands to generate.