]> git.pld-linux.org Git - packages/neon.git/blob - neon.spec
- without not disable, my mistake, testbuild on system with krb
[packages/neon.git] / neon.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  krb             # don't build krb support
5 #
6 Summary:        An HTTP and WebDAV client library
7 Summary(pl):    Biblioteka kliencka HTTP i WebDAV
8 Name:           neon
9 Version:        0.25.5
10 Release:        1.1
11 License:        GPL
12 Group:          Libraries
13 Source0:        http://www.webdav.org/neon/%{name}-%{version}.tar.gz
14 # Source0-md5:  b5fdb71dd407f0a3de0f267d27c9ab17
15 URL:            http://www.webdav.org/neon/
16 BuildRequires:  autoconf >= 2.53
17 BuildRequires:  automake
18 %{?with_krb:BuildRequires:      heimdal-devel >= 0.7}
19 BuildRequires:  libtool
20 BuildRequires:  libxml2-devel
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 neon is an HTTP and WebDAV client library, with a C interface.
27 Featuring:
28  - High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD etc).
29  - Low-level interface to HTTP request handling, to allow implementing
30    new methods easily.
31  - HTTP/1.1 and HTTP/1.0 persistent connections.
32  - RFC2617 basic and digest authentication (including auth-int,
33    md5-sess).
34  - Proxy support (including basic/digest authentication).
35  - Generic WebDAV 207 XML response handling mechanism.
36  - XML parsing using the expat or libxml parsers.
37  - Easy generation of error messages from 207 error responses.
38  - WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
39  - WebDAV metadata support: set and remove properties, query any set of
40    properties (PROPPATCH/PROPFIND).
41
42 %description -l pl
43 neon to biblioteka kliencka HTTP i WebDAV z interfejsem w C.
44 Mo¿liwo¶ci:
45  - wysokopoziomowy interfejs do metod HTTP i WebDAV (PUT, GET, HEAD...),
46  - niskopziomowy interfejs to obs³ugi ¿±dañ HTTP pozwalaj±cy ³atwo
47    implementowaæ nowe metody,
48  - sta³e po³±czenia HTTP/1.1 i HTTP/1.0,
49  - autentykacja podstawowa i skrótem RFC-2617 (auth-int, md5-sess...),
50  - obs³uga proxy (w tym autentykacja podstawowa i skrótem),
51  - mechanizm obs³ugi odpowiedzi WebDAV 207 XML,
52  - analiza sk³adniowa XML przy pomocy expat lub libxml,
53  - proste generowanie komunikatów b³êdów dla odpowiedzi 207,
54  - manipulowanie zasobami WebDAV: MOVE, COPY, DELETE, MKCOL,
55  - obs³uga metadanych WebDAV: ustawianie i usuwanie atrybutów,
56    sprawdzanie dowolnego zbioru atrybutów (PROPPATCH/PROPFIND).
57
58 %package devel
59 Summary:        Header files for neon
60 Summary(pl):    Pliki nag³ówkowe neon
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 %{?with_krb:Requires:   heimdal-devel >= 0.6-5}
64 Requires:       libxml2-devel
65 Requires:       openssl-devel >= 0.9.7c
66
67 %description devel
68 C header files for the neon library.
69
70 %description devel -l pl
71 Pliki nag³ówkowe dla biblioteki neon.
72
73 %package static
74 Summary:        Static libraries for neon
75 Summary(pl):    Biblioteki statyczne neon
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static neon libraries.
81
82 %description static -l pl
83 Statyczne biblioteki neon.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I macros
91 %{__autoconf}
92 %configure \
93         --with-ssl \
94         --enable-shared \
95         %{!?with_static_libs:--enable-static=no} \
96         %{!?with_krb:--without-gssapi} \
97         --with-libxml2
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1,%{_mandir}/man3}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 mv -f doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
109 mv -f doc/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*.txt doc/html/*
120 %attr(755,root,root) %{_libdir}/*.so.*.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_bindir}/neon-config
125 %attr(755,root,root) %{_libdir}/*.so
126 %{_libdir}/*.la
127 %{_includedir}/neon
128 %{_mandir}/man*/*
129 %{_pkgconfigdir}/neon.pc
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/*.a
135 %endif
This page took 0.058917 seconds and 3 git commands to generate.