]> git.pld-linux.org Git - packages/nasm.git/blob - nasm.spec
- rewrited to PLD coding style,
[packages/nasm.git] / nasm.spec
1 Summary:        Nasm is a free assembler for the 80x86 series of microprocessors
2 Name:           nasm
3 Version:        0.98
4 Release:        2
5 Copyright:      GPL
6 URL:            http://www.cryogen.com/nasm/
7 Source:         ftp://sunsite.unc.edu/pub/Linux/devel/lang/assemblers/%{name}-%{version}.tar.bz2
8 Group:          Development
9 BuildRoot:      /tmp/%{name}-%{version}-root
10
11 %description
12 NASM is an 80x86 assembler designed for portability and modularity. It
13 supports a range of object file formats including Linux a.out and ELF,
14 COFF, Microsoft 16-bit OBJ and Win32. It will also output plain binary
15 files. Its syntax is designed to be simple and easy to understand, similar
16 to Intel's but less complex. It supports Pentium, P6 and MMX opcodes, and
17 has macro capability. It includes a disassembler as well. 
18
19 Version 0.97 was entirely a bug fix release, since 0.96 had more bugs than
20 we could shake a large stick at.
21
22 %prep
23 %setup -q
24 cp rdoff/README rdoff/README.rdoff
25
26 %build
27 autoconf
28 LDFLAGS="-s"; export LDFLAGS
29 %configure \
30         --prefix=%{_prefix}
31 make all rdf
32
33 (cd doc; make nasmdoc.texi; makeinfo nasmdoc.texi)
34
35 %install 
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{_bindir},%{_infodir},%{_mandir}/man1}
38 make INSTALLROOT=$RPM_BUILD_ROOT install install_rdf
39
40 install doc/nasm.info* $RPM_BUILD_ROOT%{_infodir}
41 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*,%{_mandir}/man?/*} \
42         Changes Licence Readme Wishlist MODIFIED
43
44 %post
45 /sbin/install-info %{_infodir}/nasm.info.gz /etc/info-dir
46
47 %preun
48 if [ "$1" = "0" ]; then
49         /sbin/install-info --delete %{_infodir}/nasm.info.gz /etc/info-dir
50 fi
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc *gz
58 %attr(755,root,root) %{_bindir}/*
59 %{_infodir}/nasm.info*gz
60 %{_mandir}/man?/*
61
62 %changelog
63 * Fri Jun  4 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
64   [0.98-2]
65 - based on spec from RH contrib,
66 - rewrited to PLD coding style,
67 - added {un}registering info pages for nasm.
This page took 0.064595 seconds and 3 git commands to generate.