]> git.pld-linux.org Git - packages/nagios.git/blob - nagios.spec
- update deps for tests, regen libtool for internal tap
[packages/nagios.git] / nagios.spec
1 # TODO
2 # - /var/log/nagios/archives -> /var/log/archive/nagios
3 #
4 # Conditional build:
5 %bcond_without  gd      # without statusmap and trends, which require gd library
6 %bcond_without  epn     # without Embedded Perl
7 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
8 %bcond_with     tests
9
10 Summary:        Host/service/network monitoring program
11 Summary(pl.UTF-8):      Program do monitorowania serwerów/usług/sieci
12 Summary(pt_BR.UTF-8):   Programa para monitoração de máquinas e serviços
13 Name:           nagios
14 Version:        3.3.1
15 Release:        3
16 License:        GPL v2+
17 Group:          Networking
18 Source0:        http://downloads.sourceforge.net/nagios/%{name}-%{version}.tar.gz
19 # Source0-md5:  c935354ce0d78a63bfabc3055fa77ad5
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}.init
22 Source3:        %{name}.sysconfig
23 Source4:        %{name}-config-20090914.tar.bz2
24 # Source4-md5:  605f1cd28c00db961dad6f529d849f16
25 Source5:        %{name}-lighttpd.conf
26 Source6:        http://www.google.com/mapfiles/shadow50.png
27 # Source6-md5:  eff99f302f21b95a900d321743fce72b
28 Source7:        http://www.google.com/mapfiles/marker.png
29 # Source7-md5:  edefef4bdfc29e1c953694651f05b466
30 Source8:        googlemap.js
31 Patch0:         %{name}-resources.patch
32 Patch1:         %{name}-iconv-in-libc.patch
33 Patch2:         %{name}-webapps.patch
34 Patch3:         %{name}-cgi-http_charset.patch
35 Patch4:         %{name}-cmd-typo.patch
36 Patch5:         config.patch
37 Patch6:         %{name}-googlemap.patch
38 Patch7:         %{name}-doc-usermacros.patch
39 Patch8:         archivelog-timeformat.patch
40 Patch9:         %{name}-html-Makefile.in.patch
41 URL:            http://www.nagios.org/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 BuildRequires:  sed >= 4.0
46 %if %{with gd}
47 BuildRequires:  gd-devel
48 BuildRequires:  libjpeg-devel
49 BuildRequires:  libpng-devel
50 %endif
51 %if %{with tests}
52 BuildRequires:  perl-HTML-Lint
53 BuildRequires:  perl-Test-WWW-Mechanize-CGI
54 %endif
55 Requires(post,preun):   /sbin/chkconfig
56 Requires:       %{name}-common = %{version}-%{release}
57 Requires:       rc-scripts
58 Requires:       sh-utils
59 Suggests:       nagios-notify >= 0.13
60 Suggests:       nagios-plugin-check_load
61 Suggests:       nagios-plugin-check_ping
62 Suggests:       nagios-plugins
63 Provides:       nagios-core
64 Obsoletes:      netsaint
65 Conflicts:      iputils-ping < 1:ss020124
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/%{name}
69 %define         cgidir          %{_libdir}/%{name}/cgi
70 %define         htmldir         %{_prefix}/share/%{name}
71 %define         _localstatedir  /var/lib/%{name}
72 %define         _webapps        /etc/webapps
73 %define         _webapp         %{name}
74
75 %description
76 Nagios is a program that will monitor hosts and services on your
77 network. It has the ability to email or page you when a problem arises
78 and when a problem is resolved. Nagios is written in C and is designed
79 to run under Linux (and some other *NIX variants) as a background
80 process, intermittently running checks on various services that you
81 specify.
82
83 The actual service checks are performed by separate "plugin" programs
84 which return the status of the checks to Nagios. The plugins are
85 available in nagios-plugins packages.
86
87 Nagios is successor to NetSaint.
88
89 %description -l pl.UTF-8
90 Nagios to program, który monitoruje serwery oraz usługi w naszej
91 sieci. Posiada on możliwość wysyłania informacji o wystąpieniu oraz
92 rozwiązaniu problemu. Nagios został napisany w C oraz jest
93 zaprojektowany do pracy pod Linuksem (i niektórymi innymi uniksami)
94 jako proces pracujący w tle i bezustannie wykonujący pewne operacje
95 sprawdzające.
96
97 Właściwe sprawdzanie jest wykonywane przez osobne programy
98 ("wtyczki"), które zwracają informacje o statusie do Nagiosa. Wtyczki
99 są dostępne na stronie w pakietach nagios-plugins.
100
101 Nagios jest następcą NetSainta.
102
103 %description -l pt_BR.UTF-8
104 O Nagios é um programa que monitora máquinas e serviços na sua rede.
105 Ele pode enviar um email ou um aviso de pager para o administrador
106 quando surgir um problema e quando ele for resolvido. Nagios é escrito
107 em C e foi desenvolvido para rodar em plataformas Linux (e algumas
108 variações de *NIX) como um processo em segundo plano, periodicamente
109 executando checagens nos diversos serviços que forem especificados.
110
111 %package common
112 Summary:        Common files needed by both nagios and nrpe
113 Summary(pl.UTF-8):      Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe
114 Group:          Networking
115 Requires(postun):       /usr/sbin/groupdel
116 Requires(postun):       /usr/sbin/userdel
117 Requires(pre):  /bin/id
118 Requires(pre):  /usr/bin/getgid
119 Requires(pre):  /usr/sbin/groupadd
120 Requires(pre):  /usr/sbin/groupmod
121 Requires(pre):  /usr/sbin/useradd
122 Requires(pre):  /usr/sbin/usermod
123 Provides:       group(nagcmd)
124 Provides:       group(nagios)
125 Provides:       user(nagios)
126
127 %description common
128 Common files needed by both nagios and nrpe.
129
130 %description common -l pl.UTF-8
131 Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe.
132
133 %package cgi
134 Summary:        CGI webinterface for Nagios
135 Summary(pl.UTF-8):      Interfejs WWW/CGI dla Nagiosa
136 Group:          Applications/WWW
137 # for dirs... and accessing local logs, nagios config
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       %{name}-imagepaks
140 Requires:       %{name}-theme
141 Requires:       group(http)
142 Requires:       webapps
143 Requires:       webserver
144 Requires:       webserver(access)
145 Requires:       webserver(alias)
146 Requires:       webserver(auth)
147 Requires:       webserver(cgi)
148 Requires:       webserver(indexfile)
149 Suggests:       %{name}-doc
150
151 %description cgi
152 CGI webinterface for Nagios.
153
154 %description cgi -l pl.UTF-8
155 Interfejs CGI dla Nagiosa.
156
157 %package mrtggraphs
158 Summary:        MRTG Graphs: Nagios Statistics
159 Group:          Applications/Networking
160 Requires:       %{name} = %{version}-%{release}
161 Provides:       mrtg-start
162
163 %description mrtggraphs
164 This pacakge graphs several Nagios statistics which can be useful for
165 debugging and trending purposes. The nagiostats binary is used to
166 generate the data.
167
168 %package doc
169 Summary:        HTML Documentation for Nagios
170 Group:          Documentation
171 # does not require base
172
173 %description doc
174 HTML Documentation for Nagios.
175
176 %package theme-classicui
177 Summary:        ClassicUI Nagios theme
178 Group:          Applications/WWW
179 Requires:       %{name}-cgi = %{version}-%{release}
180 Requires:       webserver(php)
181 Provides:       nagios-theme
182 Obsoletes:      nagios-theme
183
184 %description theme-classicui
185 Original theme from Nagios.
186
187 %description theme-classicui -l pl.UTF-8
188 Oryginalny motyw z Nagiosa.
189
190 %package theme-default
191 Summary:        Virtual package to handle Nagios theme migration
192 Group:          Applications/WWW
193 Requires:       nagios-theme
194 Obsoletes:      nagios-theme-default < 3.3.1-1.4
195
196 %description theme-default
197 Virtual package to handle Nagios theme migration
198
199 %package devel
200 Summary:        Include files that Nagios-related applications may compile against
201 Summary(pl.UTF-8):      Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
202 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho necessários para desenvolvimento de aplicativos para o Nagios
203 Group:          Development/Libraries
204 # doesn't require base
205
206 %description devel
207 This package provides include files that Nagios-related applications
208 may compile against.
209
210 %description devel -l pl.UTF-8
211 Ten pakiet dostarcza pliki nagłówkowe, które mogą być wykorzystywane
212 przez aplikacje związane z nagiosem podczas kompilacji.
213
214 %description devel -l pt_BR.UTF-8
215 Este pacote contém arquivos de cabeçalho usados no desenvolvimento de
216 aplicativos para o Nagios.
217
218 %prep
219 %setup -qc -a4
220 mv %{name}/* .
221 %undos cgi/*.c
222 %undos include/*.h
223 %undos base/*
224 %undos p1.pl
225 %patch0 -p0
226 %patch1 -p1
227 %patch2 -p1
228 %patch3 -p1
229 #fixed
230 #%patch4 -p1
231 %patch5 -p1
232 %patch6 -p1
233 %patch7 -p1
234 %patch8 -p1
235 %patch9 -p1
236
237 find -name .cvsignore -o -name .gitignore | xargs rm
238
239 mv nagios-config-*/objects/*.cfg sample-config/template-object
240 mv nagios-config-*/*.cfg sample-config
241
242 # cleanup backups after patching
243 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
244
245 sed -i -e '
246         s,".*/var/rw/%{name}.cmd,"%{_localstatedir}/rw/%{name}.cmd,
247         s,".*/libexec/eventhandlers,"%{_libdir}/%{name}/eventhandlers,
248 ' $(find contrib/eventhandlers -type f)
249
250 %{__sed} -i -e '
251         s,/usr/local/nagios/var/,/var/log/%{name}/,g
252 ' p1.pl
253
254 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE1} > apache.conf
255 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
256
257 # fixup cgi config
258 %{__sed} -i -e '
259         # kill trailing spaces
260         s, \+$,,
261         # use real paths
262         s,/usr/local/%{name}/share,@datadir@,g
263         # we want all authorized users have default access
264         s,=nagiosadmin,=*,g
265 ' sample-config/*.cfg.in
266
267 # fixup paths in doc
268 #%{__sed} -i -e '
269 #       s,/usr/local/%{name}/var/archives/,/var/log/%{name}/archives/,
270 #' html/docs/configmain.html
271
272 #rm t/611cgistatus-hosturgencies.t
273
274 %build
275 cp -f /usr/share/automake/config.sub .
276 %{__aclocal}
277 %{__autoconf}
278 %if %{with tests}
279 cd tap
280 %{__libtoolize}
281 %{__aclocal}
282 %{__autoconf}
283 cd ..
284 %endif
285 %configure \
286         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
287         --bindir=%{_sbindir} \
288         --sbindir=%{cgidir} \
289         --datadir=%{htmldir} \
290         --with-nagios-user=%{name} \
291         --with-nagios-grp=%{name} \
292         --with-command-user=%{name} \
293         --with-command-grp=%{name} \
294         --with-lockfile=%{_localstatedir}/%{name}.pid \
295         --with-checkresult-dir=%{_var}/spool/%{name}/checkresults \
296         --with-ping_command='/bin/ping -n %%s -c %%d' \
297         %{!?with_gd:--disable-statusmap --disable-trends} \
298         %{?with_epn:--enable-embedded-perl --with-perlcache} \
299         %{?with_tests:--enable-libtap} \
300         --enable-event-broker
301
302 %{__make} all
303
304 %if %{with epn}
305 %{__make} -C contrib mini_epn
306 %endif
307
308 %{?with_tests:%{__make} test}
309
310 %install
311 rm -rf $RPM_BUILD_ROOT
312 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
313         $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
314         $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
315         $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
316 %if "%{_lib}" != "lib"
317         $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
318 %endif
319
320 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}
321 cp -p include/*.h       $RPM_BUILD_ROOT%{_includedir}/%{name}
322
323 %{__make} install-unstripped \
324         DESTDIR=$RPM_BUILD_ROOT \
325         INSTALL_OPTS="" \
326         INIT_OPTS="" \
327         COMMAND_OPTS=""
328
329 %if %{with epn}
330 mv $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/%{name}}/p1.pl
331 install -d $RPM_BUILD_ROOT%{_bindir}
332 install -p contrib/mini_epn $RPM_BUILD_ROOT%{_bindir}
333 %endif
334
335 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
336 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
337
338 # install templated configuration files
339 for a in %{name}.cfg resource.cfg commands.cfg contactgroups.cfg contacts.cfg templates.cfg timeperiods.cfg; do
340         cp -p sample-config/$a $RPM_BUILD_ROOT%{_sysconfdir}
341 done
342
343 # webserver files
344 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
345 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
346 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
347 cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
348 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
349 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
350 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
351 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
352 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
353
354 # install event handlers, sample config
355 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
356 cp -a contrib/eventhandlers $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
357 cp -a sample-config $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
358 find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.in' | xargs rm
359
360 # mrtg script
361 install -d $RPM_BUILD_ROOT/etc/mrtg/conf.d
362 cp -a sample-config/mrtg.cfg $RPM_BUILD_ROOT/etc/mrtg/conf.d/%{name}.cfg
363
364 # Object data/cache files
365 for i in {objects.{cache,precache},{retention,status}.dat,%{name}.{tmp,pid}}; do
366         > $RPM_BUILD_ROOT%{_localstatedir}/$i
367 done
368 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.cmd
369
370 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
371 mv $RPM_BUILD_ROOT{%{htmldir}/docs/*,%{_docdir}/%{name}}
372
373 %clean
374 rm -rf $RPM_BUILD_ROOT
375
376 %post
377 for i in %{_localstatedir}/{objects.{cache,precache},{retention,status}.dat}; do
378         [ ! -f $i ] && touch $i
379         chown root:nagios $i
380         chmod 664 $i
381 done
382
383 /sbin/chkconfig --add %{name}
384 %service %{name} restart "Nagios service"
385
386 %preun
387 if [ "$1" = "0" ] ; then
388         %service %{name} stop
389         /sbin/chkconfig --del %{name}
390 fi
391
392 %pre common
393 # rename group netsaint -> nagios
394 if [ "$(getgid netsaint 2>/dev/null)" = "72" ]; then
395         /usr/sbin/groupmod -n nagios netsaint
396 fi
397 # rename group nagios-data -> nagcmd
398 if [ "$(getgid nagios-data 2>/dev/null)" = "147" ]; then
399         /usr/sbin/groupmod -n nagcmd nagios-data
400 fi
401 %groupadd -g 72 nagios
402 %groupadd -g 147 -f nagcmd
403 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
404         /usr/sbin/usermod -d %{_libdir}/%{name} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
405 fi
406 %useradd -u 72 -d %{_libdir}/%{name} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
407
408 %postun common
409 if [ "$1" = "0" ]; then
410         %userremove nagios
411         %groupremove nagios
412         %groupremove nagcmd
413 fi
414
415 %post cgi
416 if [ "$1" = 1 ]; then
417 %banner %{name} -e <<EOF
418 NOTE:
419 You need to add user to %{_webapps}/%{_webapp}/passwd and
420 %{_webapps}/%{_webapp}/group to access Nagios via web.
421
422 EOF
423 fi
424
425 %triggerin cgi -- apache1 < 1.3.37-3, apache1-base
426 %addusertogroup http nagcmd
427 %webapp_register apache %{_webapp}
428
429 %triggerun cgi -- apache1 < 1.3.37-3, apache1-base
430 %webapp_unregister apache %{_webapp}
431
432 %triggerin cgi -- apache < 2.2.0, apache-base
433 %addusertogroup http nagcmd
434 %webapp_register httpd %{_webapp}
435
436 %triggerun cgi -- apache < 2.2.0, apache-base
437 %webapp_unregister httpd %{_webapp}
438
439 %triggerin cgi -- lighttpd
440 %addusertogroup lighttpd nagcmd
441 %webapp_register lighttpd %{_webapp}
442
443 %triggerun cgi -- lighttpd
444 %webapp_unregister lighttpd %{_webapp}
445
446 %triggerpostun -- nagios-cgi < 2.0-0.b3.21
447 chown root:http %{_sysconfdir}/cgi.cfg
448
449 %triggerpostun -- nagios < 3.1.2-4
450 # restore lost files
451 for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.cfg hostextinfo.cfg escalations.cfg checkcommands.cfg misccommands.cfg; do
452         if [ -f %{_sysconfdir}/$a.rpmsave -a ! -f %{_sysconfdir}/$a ]; then
453                 mv -f %{_sysconfdir}/$a{.rpmsave,}
454         fi
455 done
456 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
457
458 %files
459 %defattr(644,root,root,755)
460 %doc Changelog README* UPGRADING INSTALLING LICENSE
461 %attr(750,root,nagios) %dir %{_sysconfdir}/objects
462
463 # leave main nagios config readable for -cgi.
464 %attr(640,root,nagcmd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
465
466 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commands.cfg
467 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contactgroups.cfg
468 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contacts.cfg
469 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/resource.cfg
470 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/templates.cfg
471 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timeperiods.cfg
472
473 %attr(754,root,root) /etc/rc.d/init.d/%{name}
474 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
475
476 %attr(755,root,root) %{_sbindir}/%{name}
477 %attr(755,root,root) %{_sbindir}/nagiostats
478 %dir %{_libdir}/%{name}/brokers
479
480 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}
481 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}/archives
482
483 %attr(770,root,nagcmd) %dir %{_localstatedir}
484 %attr(2770,root,nagcmd) %dir %{_localstatedir}/rw
485 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.cmd
486 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.cache
487 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.precache
488 %attr(664,root,nagios) %ghost %{_localstatedir}/*.dat
489 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
490 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
491
492 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
493
494 %{_examplesdir}/%{name}-%{version}
495
496 # epn
497 %if %{with epn}
498 %attr(755,root,root) %{_libdir}/%{name}/p1.pl
499 %attr(755,root,root) %{_bindir}/mini_epn
500 %endif
501
502 %files common
503 %defattr(644,root,root,755)
504 %attr(750,root,nagcmd) %dir %{_sysconfdir}
505 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
506 %dir %{_libdir}/%{name}
507 %dir %{_libdir}/%{name}/plugins
508 %dir %{_libdir}/%{name}/eventhandlers
509
510 %if "%{_lib}" != "lib"
511 %dir %{_prefix}/lib/%{name}
512 %dir %{_prefix}/lib/%{name}/plugins
513 %dir %{_prefix}/lib/%{name}/eventhandlers
514 %endif
515
516 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
517
518 %files mrtggraphs
519 %defattr(644,root,root,755)
520 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
521
522 %files doc
523 %defattr(644,root,root,755)
524 %{_docdir}/%{name}
525
526 %files cgi
527 %defattr(644,root,root,755)
528 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
529 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
530 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
532 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/cgi.cfg
533 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/passwd
534 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/group
535 %dir %{cgidir}
536 %attr(755,root,root) %{cgidir}/*.cgi
537
538 %dir %{htmldir}
539 %dir %{htmldir}/includes
540 %dir %{htmldir}/images
541 %dir %{htmldir}/stylesheets
542 %{htmldir}/robots.txt
543 %{htmldir}/contexthelp
544 %{htmldir}/media
545 %{htmldir}/ssi
546 %{htmldir}/images/favicon.ico
547 %{htmldir}/images/marker.png
548 %{htmldir}/images/shadow50.png
549
550 %files theme-classicui
551 %defattr(644,root,root,755)
552 %{htmldir}/*.php
553 %{htmldir}/includes/*
554 %{htmldir}/images/*
555 %exclude %{htmldir}/images/favicon.ico
556 %exclude %{htmldir}/images/marker.png
557 %exclude %{htmldir}/images/shadow50.png
558 %{htmldir}/stylesheets/*
559
560 %files theme-default
561 %defattr(644,root,root,755)
562
563 %files devel
564 %defattr(644,root,root,755)
565 %dir %{_includedir}/%{name}
566 %{_includedir}/%{name}/*.h
This page took 0.075457 seconds and 4 git commands to generate.