]> git.pld-linux.org Git - packages/nagios.git/blob - nagios.spec
dca2dfe1812bafb30e0a1dd57a12bd68a4c8846d
[packages/nagios.git] / nagios.spec
1 # TODO
2 # - /var/log/nagios/archives -> /var/log/archive/nagios
3 #
4 # Conditional build:
5 %bcond_without  gd      # without statusmap and trends, which require gd library
6 %bcond_with     epn     # with Embedded Perl
7 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
8 %bcond_with     tests
9
10 Summary:        Host/service/network monitoring program
11 Summary(pl.UTF-8):      Program do monitorowania serwerów/usług/sieci
12 Summary(pt_BR.UTF-8):   Programa para monitoração de máquinas e serviços
13 Name:           nagios
14 Version:        4.0.0
15 Release:        1
16 License:        GPL v2+
17 Group:          Networking
18 Source0:        http://downloads.sourceforge.net/nagios/nagios-4.x/%{name}-%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  bfe64774766e32b6f6130493c52ed7f6
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}.init
22 Source3:        %{name}.sysconfig
23 Source4:        %{name}-config-20090914.tar.bz2
24 # Source4-md5:  605f1cd28c00db961dad6f529d849f16
25 Source5:        %{name}-lighttpd.conf
26 Source6:        http://www.google.com/mapfiles/shadow50.png
27 # Source6-md5:  eff99f302f21b95a900d321743fce72b
28 Source7:        http://www.google.com/mapfiles/marker.png
29 # Source7-md5:  edefef4bdfc29e1c953694651f05b466
30 Source8:        googlemap.js
31 Source9:        %{name}wall.php
32 Source10:       %{name}-httpd.conf
33 Patch0:         %{name}-resources.patch
34 Patch1:         %{name}-iconv-in-libc.patch
35 Patch2:         %{name}-webapps.patch
36 Patch3:         %{name}-cgi-http_charset.patch
37 Patch4:         %{name}-cmd-typo.patch
38 Patch5:         config.patch
39 Patch6:         %{name}-googlemap.patch
40 Patch7:         %{name}-doc-usermacros.patch
41 Patch8:         archivelog-timeformat.patch
42 Patch9:         system-magpierss.patch
43 Patch10:        system-jquery.patch
44 Patch11:        do-not-fetch-rss.patch
45 URL:            http://www.nagios.org/
46 BuildRequires:  autoconf
47 BuildRequires:  automake
48 BuildRequires:  rpmbuild(macros) >= 1.268
49 BuildRequires:  sed >= 4.0
50 %if %{with gd}
51 BuildRequires:  gd-devel
52 BuildRequires:  libjpeg-devel
53 BuildRequires:  libpng-devel
54 %endif
55 %if %{with tests}
56 BuildRequires:  perl-HTML-Lint
57 BuildRequires:  perl-Test-WWW-Mechanize-CGI
58 %endif
59 Requires(post,preun):   /sbin/chkconfig
60 Requires:       %{name}-common = %{version}-%{release}
61 Requires:       rc-scripts >= 0.4.5.5
62 Requires:       sh-utils
63 Suggests:       nagios-notify >= 0.13
64 Suggests:       nagios-plugin-check_load
65 Suggests:       nagios-plugin-check_ping
66 Suggests:       nagios-plugins
67 Provides:       nagios-core
68 Obsoletes:      netsaint
69 Conflicts:      iputils-ping < 1:ss020124
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _sysconfdir     /etc/%{name}
73 %define         cgidir          %{_libdir}/%{name}/cgi
74 %define         htmldir         %{_prefix}/share/%{name}
75 %define         _localstatedir  /var/lib/%{name}
76 %define         _webapps        /etc/webapps
77 %define         _webapp         %{name}
78
79 %description
80 Nagios is a program that will monitor hosts and services on your
81 network. It has the ability to email or page you when a problem arises
82 and when a problem is resolved. Nagios is written in C and is designed
83 to run under Linux (and some other *NIX variants) as a background
84 process, intermittently running checks on various services that you
85 specify.
86
87 The actual service checks are performed by separate "plugin" programs
88 which return the status of the checks to Nagios. The plugins are
89 available in nagios-plugins packages.
90
91 Nagios is successor to NetSaint.
92
93 %description -l pl.UTF-8
94 Nagios to program, który monitoruje serwery oraz usługi w naszej
95 sieci. Posiada on możliwość wysyłania informacji o wystąpieniu oraz
96 rozwiązaniu problemu. Nagios został napisany w C oraz jest
97 zaprojektowany do pracy pod Linuksem (i niektórymi innymi uniksami)
98 jako proces pracujący w tle i bezustannie wykonujący pewne operacje
99 sprawdzające.
100
101 Właściwe sprawdzanie jest wykonywane przez osobne programy
102 ("wtyczki"), które zwracają informacje o statusie do Nagiosa. Wtyczki
103 są dostępne na stronie w pakietach nagios-plugins.
104
105 Nagios jest następcą NetSainta.
106
107 %description -l pt_BR.UTF-8
108 O Nagios é um programa que monitora máquinas e serviços na sua rede.
109 Ele pode enviar um email ou um aviso de pager para o administrador
110 quando surgir um problema e quando ele for resolvido. Nagios é escrito
111 em C e foi desenvolvido para rodar em plataformas Linux (e algumas
112 variações de *NIX) como um processo em segundo plano, periodicamente
113 executando checagens nos diversos serviços que forem especificados.
114
115 %package common
116 Summary:        Common files needed by both nagios and nrpe
117 Summary(pl.UTF-8):      Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe
118 Group:          Networking
119 Requires(postun):       /usr/sbin/groupdel
120 Requires(postun):       /usr/sbin/userdel
121 Requires(pre):  /bin/id
122 Requires(pre):  /usr/bin/getgid
123 Requires(pre):  /usr/sbin/groupadd
124 Requires(pre):  /usr/sbin/groupmod
125 Requires(pre):  /usr/sbin/useradd
126 Requires(pre):  /usr/sbin/usermod
127 Provides:       group(nagcmd)
128 Provides:       group(nagios)
129 Provides:       user(nagios)
130
131 %description common
132 Common files needed by both nagios and nrpe.
133
134 %description common -l pl.UTF-8
135 Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe.
136
137 %package cgi
138 Summary:        CGI webinterface for Nagios
139 Summary(pl.UTF-8):      Interfejs WWW/CGI dla Nagiosa
140 Group:          Applications/WWW
141 # for dirs... and accessing local logs, nagios config
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       %{name}-imagepaks
144 Requires:       %{name}-theme
145 Requires:       group(http)
146 Requires:       jquery
147 Requires:       webapps
148 Requires:       webserver
149 Requires:       webserver(access)
150 Requires:       webserver(alias)
151 Requires:       webserver(auth)
152 Requires:       webserver(cgi)
153 Requires:       webserver(indexfile)
154 Suggests:       %{name}-doc
155 Suggests:       php-magpierss >= 0.72
156 Conflicts:      apache-base < 2.4.0-1
157
158 %description cgi
159 CGI webinterface for Nagios.
160
161 %description cgi -l pl.UTF-8
162 Interfejs CGI dla Nagiosa.
163
164 %package mrtggraphs
165 Summary:        MRTG Graphs: Nagios Statistics
166 Group:          Applications/Networking
167 Requires:       %{name} = %{version}-%{release}
168 Provides:       mrtg-start
169
170 %description mrtggraphs
171 This pacakge graphs several Nagios statistics which can be useful for
172 debugging and trending purposes. The nagiostats binary is used to
173 generate the data.
174
175 %package doc
176 Summary:        HTML Documentation for Nagios
177 Group:          Documentation
178 # does not require base
179
180 %description doc
181 HTML Documentation for Nagios.
182
183 %package theme-classicui
184 Summary:        ClassicUI Nagios theme
185 Group:          Applications/WWW
186 Requires:       %{name}-cgi = %{version}-%{release}
187 Requires:       webserver(php)
188 Provides:       nagios-theme
189 Obsoletes:      nagios-theme
190
191 %description theme-classicui
192 Original theme from Nagios.
193
194 %description theme-classicui -l pl.UTF-8
195 Oryginalny motyw z Nagiosa.
196
197 %package theme-default
198 Summary:        Virtual package to handle Nagios theme migration
199 Group:          Applications/WWW
200 Requires:       nagios-theme
201 Suggests:       nagios-theme-classicui
202 Suggests:       nagios-theme-exfoliation
203 Suggests:       nagios-theme-nuvola
204 Obsoletes:      nagios-theme-default < 3.3.1-1.4
205
206 %description theme-default
207 Virtual package to handle Nagios theme migration
208
209 %package devel
210 Summary:        Include files that Nagios-related applications may compile against
211 Summary(pl.UTF-8):      Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
212 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho necessários para desenvolvimento de aplicativos para o Nagios
213 Group:          Development/Libraries
214 # doesn't require base
215
216 %description devel
217 This package provides include files that Nagios-related applications
218 may compile against.
219
220 %description devel -l pl.UTF-8
221 Ten pakiet dostarcza pliki nagłówkowe, które mogą być wykorzystywane
222 przez aplikacje związane z nagiosem podczas kompilacji.
223
224 %description devel -l pt_BR.UTF-8
225 Este pacote contém arquivos de cabeçalho usados no desenvolvimento de
226 aplicativos para o Nagios.
227
228 %prep
229 %setup -qc -a4
230 mv %{name}/* .
231 %undos cgi/*.c
232 %undos include/*.h
233 %undos base/*
234 %patch0 -p0
235 %patch1 -p1
236 %patch2 -p1
237 %patch3 -p1
238 #fixed
239 #%patch4 -p1
240 %patch5 -p1
241 %patch6 -p1
242 %patch7 -p1
243 %patch8 -p1
244 %patch9 -p1
245 %patch10 -p1
246 %patch11 -p1
247
248 find -name .cvsignore -o -name .gitignore | xargs rm
249
250 mv nagios-config-*/objects/*.cfg sample-config/template-object
251 mv nagios-config-*/*.cfg sample-config
252
253 # cleanup backups after patching
254 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
255
256 sed -i -e '
257         s,".*/var/rw/%{name}.cmd,"%{_localstatedir}/rw/%{name}.cmd,
258         s,".*/libexec/eventhandlers,"%{_libdir}/%{name}/eventhandlers,
259 ' $(find contrib/eventhandlers -type f)
260
261 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE1} > apache.conf
262 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE10} > httpd.conf
263 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
264
265 # fixup cgi config
266 %{__sed} -i -e '
267         # kill trailing spaces
268         s, \+$,,
269         # use real paths
270         s,/usr/local/%{name}/share,@datadir@,g
271         # we want all authorized users have default access
272         s,=nagiosadmin,=*,g
273 ' sample-config/*.cfg.in
274
275 # fixup paths in doc
276 #%{__sed} -i -e '
277 #       s,/usr/local/%{name}/var/archives/,/var/log/%{name}/archives/,
278 #' html/docs/configmain.html
279
280 #rm t/611cgistatus-hosturgencies.t
281
282 %build
283 cp -f /usr/share/automake/config.sub .
284 %{__aclocal}
285 %{__autoconf}
286 %if %{with tests}
287 cd tap
288 %{__libtoolize}
289 %{__aclocal}
290 %{__autoconf}
291 cd ..
292 %endif
293 %configure \
294         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
295         --bindir=%{_sbindir} \
296         --sbindir=%{cgidir} \
297         --datadir=%{htmldir} \
298         --with-nagios-user=%{name} \
299         --with-nagios-grp=%{name} \
300         --with-command-user=%{name} \
301         --with-command-grp=%{name} \
302         --with-lockfile=%{_localstatedir}/%{name}.pid \
303         --with-checkresult-dir=%{_var}/spool/%{name}/checkresults \
304         --with-ping_command='/bin/ping -n %%s -c %%d' \
305         %{!?with_gd:--disable-statusmap --disable-trends} \
306         %{?with_epn:--enable-embedded-perl --with-perlcache} \
307         %{?with_tests:--enable-libtap} \
308         --enable-event-broker
309
310 %{__make} all
311
312 %if %{with epn}
313 %{__make} -C contrib mini_epn
314 %endif
315
316 %{?with_tests:%{__make} test}
317
318 %install
319 rm -rf $RPM_BUILD_ROOT
320 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
321         $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
322         $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
323         $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
324 %if "%{_lib}" != "lib"
325         $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
326 %endif
327
328 %{__make} install-unstripped install-headers \
329         DESTDIR=$RPM_BUILD_ROOT \
330         INSTALL_OPTS="" \
331         INIT_OPTS="" \
332         COMMAND_OPTS=""
333
334 %if %{with epn}
335 install -d $RPM_BUILD_ROOT%{_bindir}
336 install -p contrib/mini_epn $RPM_BUILD_ROOT%{_bindir}
337 %endif
338
339 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
340 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
341
342 # install templated configuration files
343 for a in %{name}.cfg resource.cfg commands.cfg contactgroups.cfg contacts.cfg templates.cfg timeperiods.cfg; do
344         cp -p sample-config/$a $RPM_BUILD_ROOT%{_sysconfdir}
345 done
346
347 # webserver files
348 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
349 cp -p httpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
350 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
351 cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
352 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
353 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
354 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
355 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{htmldir}
356 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
357 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
358
359 # install event handlers, sample config
360 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
361 cp -a contrib/eventhandlers $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
362 cp -a sample-config $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
363 find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.in' | xargs rm
364
365 # mrtg script
366 install -d $RPM_BUILD_ROOT/etc/mrtg/conf.d
367 cp -a sample-config/mrtg.cfg $RPM_BUILD_ROOT/etc/mrtg/conf.d/%{name}.cfg
368
369 # Object data/cache files
370 for i in {objects.{cache,precache},{retention,status}.dat,%{name}.{tmp,pid}}; do
371         > $RPM_BUILD_ROOT%{_localstatedir}/$i
372 done
373 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.cmd
374
375 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
376 mv $RPM_BUILD_ROOT{%{htmldir}/docs/*,%{_docdir}/%{name}}
377
378 %clean
379 rm -rf $RPM_BUILD_ROOT
380
381 %post
382 for i in %{_localstatedir}/{objects.{cache,precache},{retention,status}.dat}; do
383         [ ! -f $i ] && touch $i
384         chown root:nagios $i
385         chmod 664 $i
386 done
387
388 /sbin/chkconfig --add %{name}
389 %service %{name} restart "Nagios service"
390
391 %preun
392 if [ "$1" = "0" ] ; then
393         %service %{name} stop
394         /sbin/chkconfig --del %{name}
395 fi
396
397 %pre common
398 # rename group netsaint -> nagios
399 if [ "$(getgid netsaint 2>/dev/null)" = "72" ]; then
400         /usr/sbin/groupmod -n nagios netsaint
401 fi
402 # rename group nagios-data -> nagcmd
403 if [ "$(getgid nagios-data 2>/dev/null)" = "147" ]; then
404         /usr/sbin/groupmod -n nagcmd nagios-data
405 fi
406 %groupadd -g 72 nagios
407 %groupadd -g 147 -f nagcmd
408 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
409         /usr/sbin/usermod -d %{_libdir}/%{name} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
410 fi
411 %useradd -u 72 -d %{_libdir}/%{name} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
412
413 %postun common
414 if [ "$1" = "0" ]; then
415         %userremove nagios
416         %groupremove nagios
417         %groupremove nagcmd
418 fi
419
420 %post cgi
421 if [ "$1" = 1 ]; then
422 %banner %{name} -e <<EOF
423 NOTE:
424 You need to add user to %{_webapps}/%{_webapp}/passwd and
425 %{_webapps}/%{_webapp}/group to access Nagios via web.
426
427 EOF
428 fi
429
430 %triggerin cgi -- apache1 < 1.3.37-3, apache1-base
431 %addusertogroup http nagcmd
432 %webapp_register apache %{_webapp}
433
434 %triggerun cgi -- apache1 < 1.3.37-3, apache1-base
435 %webapp_unregister apache %{_webapp}
436
437 %triggerin cgi -- apache-base
438 %addusertogroup http nagcmd
439 %webapp_register httpd %{_webapp}
440
441 %triggerun cgi -- apache-base
442 %webapp_unregister httpd %{_webapp}
443
444 %triggerin cgi -- lighttpd
445 %addusertogroup lighttpd nagcmd
446 %webapp_register lighttpd %{_webapp}
447
448 %triggerun cgi -- lighttpd
449 %webapp_unregister lighttpd %{_webapp}
450
451 %triggerpostun -- nagios-cgi < 2.0-0.b3.21
452 chown root:http %{_sysconfdir}/cgi.cfg
453
454 %triggerpostun -- nagios < 3.1.2-4
455 # restore lost files
456 for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.cfg hostextinfo.cfg escalations.cfg checkcommands.cfg misccommands.cfg; do
457         if [ -f %{_sysconfdir}/$a.rpmsave -a ! -f %{_sysconfdir}/$a ]; then
458                 mv -f %{_sysconfdir}/$a{.rpmsave,}
459         fi
460 done
461 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
462
463 %files
464 %defattr(644,root,root,755)
465 %doc Changelog README* UPGRADING INSTALLING LICENSE
466 %attr(750,root,nagios) %dir %{_sysconfdir}/objects
467
468 # leave main nagios config readable for -cgi.
469 %attr(640,root,nagcmd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
470
471 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commands.cfg
472 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contactgroups.cfg
473 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contacts.cfg
474 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/resource.cfg
475 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/templates.cfg
476 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timeperiods.cfg
477
478 %attr(754,root,root) /etc/rc.d/init.d/%{name}
479 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
480
481 %attr(755,root,root) %{_sbindir}/%{name}
482 %attr(755,root,root) %{_sbindir}/nagiostats
483 %dir %{_libdir}/%{name}/brokers
484
485 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}
486 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}/archives
487
488 %attr(770,root,nagcmd) %dir %{_localstatedir}
489 %attr(2770,root,nagcmd) %dir %{_localstatedir}/rw
490 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.cmd
491 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.cache
492 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.precache
493 %attr(664,root,nagios) %ghost %{_localstatedir}/*.dat
494 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
495 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
496
497 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
498
499 %{_examplesdir}/%{name}-%{version}
500
501 # epn
502 %if %{with epn}
503 %attr(755,root,root) %{_bindir}/mini_epn
504 %endif
505
506 %files common
507 %defattr(644,root,root,755)
508 %attr(750,root,nagcmd) %dir %{_sysconfdir}
509 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
510 %dir %{_libdir}/%{name}
511 %dir %{_libdir}/%{name}/plugins
512 %dir %{_libdir}/%{name}/eventhandlers
513
514 %if "%{_lib}" != "lib"
515 %dir %{_prefix}/lib/%{name}
516 %dir %{_prefix}/lib/%{name}/plugins
517 %dir %{_prefix}/lib/%{name}/eventhandlers
518 %endif
519
520 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
521
522 %files mrtggraphs
523 %defattr(644,root,root,755)
524 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
525
526 %files doc
527 %defattr(644,root,root,755)
528 %{_docdir}/%{name}
529
530 %files cgi
531 %defattr(644,root,root,755)
532 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
533 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
534 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
535 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
536 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/cgi.cfg
537 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/passwd
538 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/group
539 %dir %{cgidir}
540 %attr(755,root,root) %{cgidir}/*.cgi
541
542 %dir %{htmldir}
543 %dir %{htmldir}/includes
544 %dir %{htmldir}/images
545 %dir %{htmldir}/stylesheets
546 %{htmldir}/robots.txt
547 %{htmldir}/contexthelp
548 %{htmldir}/media
549 %{htmldir}/ssi
550 %{htmldir}/images/favicon.ico
551 %{htmldir}/images/marker.png
552 %{htmldir}/images/shadow50.png
553 %{htmldir}/nagioswall.php
554
555 %files theme-classicui
556 %defattr(644,root,root,755)
557 %exclude %{htmldir}/nagioswall.php
558 %{htmldir}/*.php
559 %{htmldir}/includes/*
560 %{htmldir}/images/*
561 %exclude %{htmldir}/images/favicon.ico
562 %exclude %{htmldir}/images/marker.png
563 %exclude %{htmldir}/images/shadow50.png
564 %{htmldir}/stylesheets/*
565
566 %files theme-default
567 %defattr(644,root,root,755)
568
569 %files devel
570 %defattr(644,root,root,755)
571 %dir %{_includedir}/%{name}
572 %{_includedir}/%{name}/*.h
This page took 0.051939 seconds and 2 git commands to generate.