]> git.pld-linux.org Git - packages/nagios.git/blob - nagios.spec
- s/-qc/-q/
[packages/nagios.git] / nagios.spec
1 # TODO
2 # - /var/log/nagios/archives -> /var/log/archive/nagios
3 #
4 # Conditional build:
5 %bcond_without  gd      # without statusmap and trends, which require gd library
6 %bcond_without  epn     # without Embedded Perl
7 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
8 %bcond_with     tests
9
10 Summary:        Host/service/network monitoring program
11 Summary(pl.UTF-8):      Program do monitorowania serwerów/usług/sieci
12 Summary(pt_BR.UTF-8):   Programa para monitoração de máquinas e serviços
13 Name:           nagios
14 Version:        3.3.1
15 Release:        5
16 License:        GPL v2+
17 Group:          Networking
18 Source0:        http://downloads.sourceforge.net/nagios/%{name}-%{version}.tar.gz
19 # Source0-md5:  c935354ce0d78a63bfabc3055fa77ad5
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}.init
22 Source3:        %{name}.sysconfig
23 Source4:        %{name}-config-20090914.tar.bz2
24 # Source4-md5:  605f1cd28c00db961dad6f529d849f16
25 Source5:        %{name}-lighttpd.conf
26 Source6:        http://www.google.com/mapfiles/shadow50.png
27 # Source6-md5:  eff99f302f21b95a900d321743fce72b
28 Source7:        http://www.google.com/mapfiles/marker.png
29 # Source7-md5:  edefef4bdfc29e1c953694651f05b466
30 Source8:        googlemap.js
31 Patch0:         %{name}-resources.patch
32 Patch1:         %{name}-iconv-in-libc.patch
33 Patch2:         %{name}-webapps.patch
34 Patch3:         %{name}-cgi-http_charset.patch
35 Patch4:         %{name}-cmd-typo.patch
36 Patch5:         config.patch
37 Patch6:         %{name}-googlemap.patch
38 Patch7:         %{name}-doc-usermacros.patch
39 Patch8:         archivelog-timeformat.patch
40 Patch9:         %{name}-html-Makefile.in.patch
41 URL:            http://www.nagios.org/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 BuildRequires:  sed >= 4.0
46 %if %{with gd}
47 BuildRequires:  gd-devel
48 BuildRequires:  libjpeg-devel
49 BuildRequires:  libpng-devel
50 %endif
51 %if %{with tests}
52 BuildRequires:  perl-HTML-Lint
53 BuildRequires:  perl-Test-WWW-Mechanize-CGI
54 %endif
55 Requires(post,preun):   /sbin/chkconfig
56 Requires:       %{name}-common = %{version}-%{release}
57 Requires:       rc-scripts
58 Requires:       sh-utils
59 Suggests:       nagios-notify >= 0.13
60 Suggests:       nagios-plugin-check_load
61 Suggests:       nagios-plugin-check_ping
62 Suggests:       nagios-plugins
63 Provides:       nagios-core
64 Obsoletes:      netsaint
65 Conflicts:      iputils-ping < 1:ss020124
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/%{name}
69 %define         cgidir          %{_libdir}/%{name}/cgi
70 %define         htmldir         %{_prefix}/share/%{name}
71 %define         _localstatedir  /var/lib/%{name}
72 %define         _webapps        /etc/webapps
73 %define         _webapp         %{name}
74
75 %description
76 Nagios is a program that will monitor hosts and services on your
77 network. It has the ability to email or page you when a problem arises
78 and when a problem is resolved. Nagios is written in C and is designed
79 to run under Linux (and some other *NIX variants) as a background
80 process, intermittently running checks on various services that you
81 specify.
82
83 The actual service checks are performed by separate "plugin" programs
84 which return the status of the checks to Nagios. The plugins are
85 available in nagios-plugins packages.
86
87 Nagios is successor to NetSaint.
88
89 %description -l pl.UTF-8
90 Nagios to program, który monitoruje serwery oraz usługi w naszej
91 sieci. Posiada on możliwość wysyłania informacji o wystąpieniu oraz
92 rozwiązaniu problemu. Nagios został napisany w C oraz jest
93 zaprojektowany do pracy pod Linuksem (i niektórymi innymi uniksami)
94 jako proces pracujący w tle i bezustannie wykonujący pewne operacje
95 sprawdzające.
96
97 Właściwe sprawdzanie jest wykonywane przez osobne programy
98 ("wtyczki"), które zwracają informacje o statusie do Nagiosa. Wtyczki
99 są dostępne na stronie w pakietach nagios-plugins.
100
101 Nagios jest następcą NetSainta.
102
103 %description -l pt_BR.UTF-8
104 O Nagios é um programa que monitora máquinas e serviços na sua rede.
105 Ele pode enviar um email ou um aviso de pager para o administrador
106 quando surgir um problema e quando ele for resolvido. Nagios é escrito
107 em C e foi desenvolvido para rodar em plataformas Linux (e algumas
108 variações de *NIX) como um processo em segundo plano, periodicamente
109 executando checagens nos diversos serviços que forem especificados.
110
111 %package common
112 Summary:        Common files needed by both nagios and nrpe
113 Summary(pl.UTF-8):      Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe
114 Group:          Networking
115 Requires(postun):       /usr/sbin/groupdel
116 Requires(postun):       /usr/sbin/userdel
117 Requires(pre):  /bin/id
118 Requires(pre):  /usr/bin/getgid
119 Requires(pre):  /usr/sbin/groupadd
120 Requires(pre):  /usr/sbin/groupmod
121 Requires(pre):  /usr/sbin/useradd
122 Requires(pre):  /usr/sbin/usermod
123 Provides:       group(nagcmd)
124 Provides:       group(nagios)
125 Provides:       user(nagios)
126
127 %description common
128 Common files needed by both nagios and nrpe.
129
130 %description common -l pl.UTF-8
131 Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe.
132
133 %package cgi
134 Summary:        CGI webinterface for Nagios
135 Summary(pl.UTF-8):      Interfejs WWW/CGI dla Nagiosa
136 Group:          Applications/WWW
137 # for dirs... and accessing local logs, nagios config
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       %{name}-imagepaks
140 Requires:       %{name}-theme
141 Requires:       group(http)
142 Requires:       webapps
143 Requires:       webserver
144 Requires:       webserver(access)
145 Requires:       webserver(alias)
146 Requires:       webserver(auth)
147 Requires:       webserver(cgi)
148 Requires:       webserver(indexfile)
149 Suggests:       %{name}-doc
150
151 %description cgi
152 CGI webinterface for Nagios.
153
154 %description cgi -l pl.UTF-8
155 Interfejs CGI dla Nagiosa.
156
157 %package mrtggraphs
158 Summary:        MRTG Graphs: Nagios Statistics
159 Group:          Applications/Networking
160 Requires:       %{name} = %{version}-%{release}
161 Provides:       mrtg-start
162
163 %description mrtggraphs
164 This pacakge graphs several Nagios statistics which can be useful for
165 debugging and trending purposes. The nagiostats binary is used to
166 generate the data.
167
168 %package doc
169 Summary:        HTML Documentation for Nagios
170 Group:          Documentation
171 # does not require base
172
173 %description doc
174 HTML Documentation for Nagios.
175
176 %package theme-classicui
177 Summary:        ClassicUI Nagios theme
178 Group:          Applications/WWW
179 Requires:       %{name}-cgi = %{version}-%{release}
180 Requires:       webserver(php)
181 Provides:       nagios-theme
182 Obsoletes:      nagios-theme
183
184 %description theme-classicui
185 Original theme from Nagios.
186
187 %description theme-classicui -l pl.UTF-8
188 Oryginalny motyw z Nagiosa.
189
190 %package theme-default
191 Summary:        Virtual package to handle Nagios theme migration
192 Group:          Applications/WWW
193 Requires:       nagios-theme
194 Obsoletes:      nagios-theme-default < 3.3.1-1.4
195
196 %description theme-default
197 Virtual package to handle Nagios theme migration
198
199 %package devel
200 Summary:        Include files that Nagios-related applications may compile against
201 Summary(pl.UTF-8):      Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
202 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho necessários para desenvolvimento de aplicativos para o Nagios
203 Group:          Development/Libraries
204 # doesn't require base
205
206 %description devel
207 This package provides include files that Nagios-related applications
208 may compile against.
209
210 %description devel -l pl.UTF-8
211 Ten pakiet dostarcza pliki nagłówkowe, które mogą być wykorzystywane
212 przez aplikacje związane z nagiosem podczas kompilacji.
213
214 %description devel -l pt_BR.UTF-8
215 Este pacote contém arquivos de cabeçalho usados no desenvolvimento de
216 aplicativos para o Nagios.
217
218 %prep
219 %setup -q -a4 -n %{name}
220 %undos cgi/*.c
221 %undos include/*.h
222 %undos base/*
223 %patch0 -p0
224 %patch1 -p1
225 %patch2 -p1
226 %patch3 -p1
227 #fixed
228 #%patch4 -p1
229 %patch5 -p1
230 %patch6 -p1
231 %patch7 -p1
232 %patch8 -p1
233 %patch9 -p1
234
235 find -name .cvsignore -o -name .gitignore | xargs rm
236
237 mv nagios-config-*/objects/*.cfg sample-config/template-object
238 mv nagios-config-*/*.cfg sample-config
239
240 # cleanup backups after patching
241 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
242
243 sed -i -e '
244         s,".*/var/rw/%{name}.cmd,"%{_localstatedir}/rw/%{name}.cmd,
245         s,".*/libexec/eventhandlers,"%{_libdir}/%{name}/eventhandlers,
246 ' $(find contrib/eventhandlers -type f)
247
248 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE1} > apache.conf
249 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
250
251 # fixup cgi config
252 %{__sed} -i -e '
253         # kill trailing spaces
254         s, \+$,,
255         # use real paths
256         s,/usr/local/%{name}/share,@datadir@,g
257         # we want all authorized users have default access
258         s,=nagiosadmin,=*,g
259 ' sample-config/*.cfg.in
260
261 # fixup paths in doc
262 #%{__sed} -i -e '
263 #       s,/usr/local/%{name}/var/archives/,/var/log/%{name}/archives/,
264 #' html/docs/configmain.html
265
266 #rm t/611cgistatus-hosturgencies.t
267
268 %build
269 cp -f /usr/share/automake/config.sub .
270 %{__aclocal}
271 %{__autoconf}
272 %if %{with tests}
273 cd tap
274 %{__libtoolize}
275 %{__aclocal}
276 %{__autoconf}
277 cd ..
278 %endif
279 %configure \
280         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
281         --bindir=%{_sbindir} \
282         --sbindir=%{cgidir} \
283         --datadir=%{htmldir} \
284         --with-nagios-user=%{name} \
285         --with-nagios-grp=%{name} \
286         --with-command-user=%{name} \
287         --with-command-grp=%{name} \
288         --with-lockfile=%{_localstatedir}/%{name}.pid \
289         --with-checkresult-dir=%{_var}/spool/%{name}/checkresults \
290         --with-ping_command='/bin/ping -n %%s -c %%d' \
291         %{!?with_gd:--disable-statusmap --disable-trends} \
292         %{?with_tests:--enable-libtap} \
293         --enable-event-broker
294
295 %{__make} all
296
297 %{?with_tests:%{__make} test}
298
299 %install
300 rm -rf $RPM_BUILD_ROOT
301 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
302         $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
303         $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
304         $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
305 %if "%{_lib}" != "lib"
306         $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
307 %endif
308
309 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}
310 cp -p include/*.h       $RPM_BUILD_ROOT%{_includedir}/%{name}
311
312 %{__make} install-unstripped \
313         DESTDIR=$RPM_BUILD_ROOT \
314         INSTALL_OPTS="" \
315         INIT_OPTS="" \
316         COMMAND_OPTS=""
317
318 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
319 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
320
321 # install templated configuration files
322 for a in %{name}.cfg resource.cfg commands.cfg contactgroups.cfg contacts.cfg templates.cfg timeperiods.cfg; do
323         cp -p sample-config/$a $RPM_BUILD_ROOT%{_sysconfdir}
324 done
325
326 # webserver files
327 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
328 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
329 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
330 cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
331 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
332 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
333 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
334 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
335 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
336
337 # install event handlers, sample config
338 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
339 cp -a contrib/eventhandlers $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
340 cp -a sample-config $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
341 find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.in' | xargs rm
342
343 # mrtg script
344 install -d $RPM_BUILD_ROOT/etc/mrtg/conf.d
345 cp -a sample-config/mrtg.cfg $RPM_BUILD_ROOT/etc/mrtg/conf.d/%{name}.cfg
346
347 # Object data/cache files
348 for i in {objects.{cache,precache},{retention,status}.dat,%{name}.{tmp,pid}}; do
349         > $RPM_BUILD_ROOT%{_localstatedir}/$i
350 done
351 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.cmd
352
353 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
354 mv $RPM_BUILD_ROOT{%{htmldir}/docs/*,%{_docdir}/%{name}}
355
356 %clean
357 rm -rf $RPM_BUILD_ROOT
358
359 %post
360 for i in %{_localstatedir}/{objects.{cache,precache},{retention,status}.dat}; do
361         [ ! -f $i ] && touch $i
362         chown root:nagios $i
363         chmod 664 $i
364 done
365
366 /sbin/chkconfig --add %{name}
367 %service %{name} restart "Nagios service"
368
369 %preun
370 if [ "$1" = "0" ] ; then
371         %service %{name} stop
372         /sbin/chkconfig --del %{name}
373 fi
374
375 %pre common
376 # rename group netsaint -> nagios
377 if [ "$(getgid netsaint 2>/dev/null)" = "72" ]; then
378         /usr/sbin/groupmod -n nagios netsaint
379 fi
380 # rename group nagios-data -> nagcmd
381 if [ "$(getgid nagios-data 2>/dev/null)" = "147" ]; then
382         /usr/sbin/groupmod -n nagcmd nagios-data
383 fi
384 %groupadd -g 72 nagios
385 %groupadd -g 147 -f nagcmd
386 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
387         /usr/sbin/usermod -d %{_libdir}/%{name} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
388 fi
389 %useradd -u 72 -d %{_libdir}/%{name} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
390
391 %postun common
392 if [ "$1" = "0" ]; then
393         %userremove nagios
394         %groupremove nagios
395         %groupremove nagcmd
396 fi
397
398 %post cgi
399 if [ "$1" = 1 ]; then
400 %banner %{name} -e <<EOF
401 NOTE:
402 You need to add user to %{_webapps}/%{_webapp}/passwd and
403 %{_webapps}/%{_webapp}/group to access Nagios via web.
404
405 EOF
406 fi
407
408 %triggerin cgi -- apache1 < 1.3.37-3, apache1-base
409 %addusertogroup http nagcmd
410 %webapp_register apache %{_webapp}
411
412 %triggerun cgi -- apache1 < 1.3.37-3, apache1-base
413 %webapp_unregister apache %{_webapp}
414
415 %triggerin cgi -- apache < 2.2.0, apache-base
416 %addusertogroup http nagcmd
417 %webapp_register httpd %{_webapp}
418
419 %triggerun cgi -- apache < 2.2.0, apache-base
420 %webapp_unregister httpd %{_webapp}
421
422 %triggerin cgi -- lighttpd
423 %addusertogroup lighttpd nagcmd
424 %webapp_register lighttpd %{_webapp}
425
426 %triggerun cgi -- lighttpd
427 %webapp_unregister lighttpd %{_webapp}
428
429 %triggerpostun -- nagios-cgi < 2.0-0.b3.21
430 chown root:http %{_sysconfdir}/cgi.cfg
431
432 %triggerpostun -- nagios < 3.1.2-4
433 # restore lost files
434 for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.cfg hostextinfo.cfg escalations.cfg checkcommands.cfg misccommands.cfg; do
435         if [ -f %{_sysconfdir}/$a.rpmsave -a ! -f %{_sysconfdir}/$a ]; then
436                 mv -f %{_sysconfdir}/$a{.rpmsave,}
437         fi
438 done
439 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
440
441 %files
442 %defattr(644,root,root,755)
443 %doc Changelog README* UPGRADING INSTALLING LICENSE
444 %attr(750,root,nagios) %dir %{_sysconfdir}/objects
445
446 # leave main nagios config readable for -cgi.
447 %attr(640,root,nagcmd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
448
449 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commands.cfg
450 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contactgroups.cfg
451 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contacts.cfg
452 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/resource.cfg
453 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/templates.cfg
454 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timeperiods.cfg
455
456 %attr(754,root,root) /etc/rc.d/init.d/%{name}
457 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
458
459 %attr(755,root,root) %{_sbindir}/%{name}
460 %attr(755,root,root) %{_sbindir}/nagiostats
461 %dir %{_libdir}/%{name}/brokers
462
463 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}
464 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}/archives
465
466 %attr(770,root,nagcmd) %dir %{_localstatedir}
467 %attr(2770,root,nagcmd) %dir %{_localstatedir}/rw
468 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.cmd
469 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.cache
470 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.precache
471 %attr(664,root,nagios) %ghost %{_localstatedir}/*.dat
472 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
473 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
474
475 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
476
477 %{_examplesdir}/%{name}-%{version}
478
479 %files common
480 %defattr(644,root,root,755)
481 %attr(750,root,nagcmd) %dir %{_sysconfdir}
482 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
483 %dir %{_libdir}/%{name}
484 %dir %{_libdir}/%{name}/plugins
485 %dir %{_libdir}/%{name}/eventhandlers
486
487 %if "%{_lib}" != "lib"
488 %dir %{_prefix}/lib/%{name}
489 %dir %{_prefix}/lib/%{name}/plugins
490 %dir %{_prefix}/lib/%{name}/eventhandlers
491 %endif
492
493 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
494
495 %files mrtggraphs
496 %defattr(644,root,root,755)
497 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
498
499 %files doc
500 %defattr(644,root,root,755)
501 %{_docdir}/%{name}
502
503 %files cgi
504 %defattr(644,root,root,755)
505 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
506 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
507 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
509 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/cgi.cfg
510 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/passwd
511 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/group
512 %dir %{cgidir}
513 %attr(755,root,root) %{cgidir}/*.cgi
514
515 %dir %{htmldir}
516 %dir %{htmldir}/includes
517 %dir %{htmldir}/images
518 %dir %{htmldir}/stylesheets
519 %{htmldir}/robots.txt
520 %{htmldir}/contexthelp
521 %{htmldir}/media
522 %{htmldir}/ssi
523 %{htmldir}/images/favicon.ico
524 %{htmldir}/images/marker.png
525 %{htmldir}/images/shadow50.png
526
527 %files theme-classicui
528 %defattr(644,root,root,755)
529 %{htmldir}/*.php
530 %{htmldir}/includes/*
531 %{htmldir}/images/*
532 %exclude %{htmldir}/images/favicon.ico
533 %exclude %{htmldir}/images/marker.png
534 %exclude %{htmldir}/images/shadow50.png
535 %{htmldir}/stylesheets/*
536
537 %files theme-default
538 %defattr(644,root,root,755)
539
540 %files devel
541 %defattr(644,root,root,755)
542 %dir %{_includedir}/%{name}
543 %{_includedir}/%{name}/*.h
This page took 0.121583 seconds and 3 git commands to generate.