]> git.pld-linux.org Git - packages/nagios.git/blob - nagios.spec
36a603b9808dfaa6d6e3b57290f2308d547c4085
[packages/nagios.git] / nagios.spec
1 # TODO
2 # - /var/log/nagios/archives -> /var/log/archive/nagios
3 #
4 # Conditional build:
5 %bcond_without  gd      # without statusmap and trends, which require gd library
6 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
7 %bcond_with     tests
8
9 Summary:        Open Source host, service and network monitoring program
10 Summary(pl.UTF-8):      Program do monitorowania serwerów/usług/sieci
11 Summary(pt_BR.UTF-8):   Programa para monitoração de máquinas e serviços
12 Name:           nagios
13 Version:        4.0.0
14 Release:        1
15 License:        GPL v2+
16 Group:          Networking
17 Source0:        http://downloads.sourceforge.net/nagios/nagios-4.x/%{name}-%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  bfe64774766e32b6f6130493c52ed7f6
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}.init
21 Source3:        %{name}.sysconfig
22 Source4:        %{name}-config-20090914.tar.bz2
23 # Source4-md5:  605f1cd28c00db961dad6f529d849f16
24 Source5:        %{name}-lighttpd.conf
25 Source6:        http://www.google.com/mapfiles/shadow50.png
26 # Source6-md5:  eff99f302f21b95a900d321743fce72b
27 Source7:        http://www.google.com/mapfiles/marker.png
28 # Source7-md5:  edefef4bdfc29e1c953694651f05b466
29 Source8:        googlemap.js
30 Source9:        %{name}wall.php
31 Source10:       %{name}-httpd.conf
32 Patch0:         %{name}-resources.patch
33 Patch1:         %{name}-iconv-in-libc.patch
34 Patch2:         %{name}-webapps.patch
35 Patch3:         %{name}-cgi-http_charset.patch
36 Patch4:         %{name}-cmd-typo.patch
37 Patch5:         config.patch
38 Patch6:         %{name}-googlemap.patch
39 Patch7:         %{name}-doc-usermacros.patch
40 Patch8:         archivelog-timeformat.patch
41 Patch9:         system-magpierss.patch
42 Patch10:        system-jquery.patch
43 Patch11:        do-not-fetch-rss.patch
44 URL:            http://www.nagios.org/
45 BuildRequires:  autoconf
46 BuildRequires:  automake
47 BuildRequires:  rpmbuild(macros) >= 1.268
48 BuildRequires:  sed >= 4.0
49 %if %{with gd}
50 BuildRequires:  gd-devel
51 BuildRequires:  libjpeg-devel
52 BuildRequires:  libpng-devel
53 %endif
54 %if %{with tests}
55 BuildRequires:  perl-HTML-Lint
56 BuildRequires:  perl-Test-WWW-Mechanize-CGI
57 %endif
58 Requires(post,preun):   /sbin/chkconfig
59 Requires:       %{name}-common = %{version}-%{release}
60 Requires:       rc-scripts >= 0.4.5.5
61 Requires:       sh-utils
62 Suggests:       nagios-notify >= 0.13
63 Suggests:       nagios-plugin-check_load
64 Suggests:       nagios-plugin-check_ping
65 Suggests:       nagios-plugins
66 Provides:       nagios-core
67 Obsoletes:      netsaint
68 Conflicts:      iputils-ping < 1:ss020124
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir     /etc/%{name}
72 %define         cgidir          %{_libdir}/%{name}/cgi
73 %define         htmldir         %{_prefix}/share/%{name}
74 %define         _localstatedir  /var/lib/%{name}
75 %define         _webapps        /etc/webapps
76 %define         _webapp         %{name}
77
78 %description
79 Nagios is a program that will monitor hosts and services on your
80 network. It has the ability to email or page you when a problem arises
81 and when a problem is resolved. Nagios is written in C and is designed
82 to run under Linux (and some other *NIX variants) as a background
83 process, intermittently running checks on various services that you
84 specify.
85
86 The actual service checks are performed by separate "plugin" programs
87 which return the status of the checks to Nagios. The plugins are
88 available in nagios-plugins packages.
89
90 Nagios is successor to NetSaint.
91
92 %description -l pl.UTF-8
93 Nagios to program, który monitoruje serwery oraz usługi w naszej
94 sieci. Posiada on możliwość wysyłania informacji o wystąpieniu oraz
95 rozwiązaniu problemu. Nagios został napisany w C oraz jest
96 zaprojektowany do pracy pod Linuksem (i niektórymi innymi uniksami)
97 jako proces pracujący w tle i bezustannie wykonujący pewne operacje
98 sprawdzające.
99
100 Właściwe sprawdzanie jest wykonywane przez osobne programy
101 ("wtyczki"), które zwracają informacje o statusie do Nagiosa. Wtyczki
102 są dostępne na stronie w pakietach nagios-plugins.
103
104 Nagios jest następcą NetSainta.
105
106 %description -l pt_BR.UTF-8
107 O Nagios é um programa que monitora máquinas e serviços na sua rede.
108 Ele pode enviar um email ou um aviso de pager para o administrador
109 quando surgir um problema e quando ele for resolvido. Nagios é escrito
110 em C e foi desenvolvido para rodar em plataformas Linux (e algumas
111 variações de *NIX) como um processo em segundo plano, periodicamente
112 executando checagens nos diversos serviços que forem especificados.
113
114 %package common
115 Summary:        Common files needed by both nagios and nrpe
116 Summary(pl.UTF-8):      Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe
117 Group:          Networking
118 Requires(postun):       /usr/sbin/groupdel
119 Requires(postun):       /usr/sbin/userdel
120 Requires(pre):  /bin/id
121 Requires(pre):  /usr/bin/getgid
122 Requires(pre):  /usr/sbin/groupadd
123 Requires(pre):  /usr/sbin/groupmod
124 Requires(pre):  /usr/sbin/useradd
125 Requires(pre):  /usr/sbin/usermod
126 Provides:       group(nagcmd)
127 Provides:       group(nagios)
128 Provides:       user(nagios)
129
130 %description common
131 Common files needed by both nagios and nrpe.
132
133 %description common -l pl.UTF-8
134 Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe.
135
136 %package cgi
137 Summary:        CGI webinterface for Nagios
138 Summary(pl.UTF-8):      Interfejs WWW/CGI dla Nagiosa
139 Group:          Applications/WWW
140 # for dirs... and accessing local logs, nagios config
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       %{name}-imagepaks
143 Requires:       %{name}-theme
144 Requires:       group(http)
145 Requires:       jquery
146 Requires:       webapps
147 Requires:       webserver
148 Requires:       webserver(access)
149 Requires:       webserver(alias)
150 Requires:       webserver(auth)
151 Requires:       webserver(cgi)
152 Requires:       webserver(indexfile)
153 Suggests:       %{name}-doc
154 Suggests:       php-magpierss >= 0.72
155 Conflicts:      apache-base < 2.4.0-1
156
157 %description cgi
158 CGI webinterface for Nagios.
159
160 %description cgi -l pl.UTF-8
161 Interfejs CGI dla Nagiosa.
162
163 %package mrtggraphs
164 Summary:        MRTG Graphs: Nagios Statistics
165 Group:          Applications/Networking
166 Requires:       %{name} = %{version}-%{release}
167 Provides:       mrtg-start
168
169 %description mrtggraphs
170 This pacakge graphs several Nagios statistics which can be useful for
171 debugging and trending purposes. The nagiostats binary is used to
172 generate the data.
173
174 %package doc
175 Summary:        HTML Documentation for Nagios
176 Group:          Documentation
177 # does not require base
178
179 %description doc
180 HTML Documentation for Nagios.
181
182 %package theme-classicui
183 Summary:        ClassicUI Nagios theme
184 Group:          Applications/WWW
185 Requires:       %{name}-cgi = %{version}-%{release}
186 Requires:       webserver(php)
187 Provides:       nagios-theme
188 Obsoletes:      nagios-theme
189
190 %description theme-classicui
191 Original theme from Nagios.
192
193 %description theme-classicui -l pl.UTF-8
194 Oryginalny motyw z Nagiosa.
195
196 %package theme-default
197 Summary:        Virtual package to handle Nagios theme migration
198 Group:          Applications/WWW
199 Requires:       nagios-theme
200 Suggests:       nagios-theme-classicui
201 Suggests:       nagios-theme-exfoliation
202 Suggests:       nagios-theme-nuvola
203 Obsoletes:      nagios-theme-default < 3.3.1-1.4
204
205 %description theme-default
206 Virtual package to handle Nagios theme migration
207
208 %package devel
209 Summary:        Include files that Nagios-related applications may compile against
210 Summary(pl.UTF-8):      Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
211 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho necessários para desenvolvimento de aplicativos para o Nagios
212 Group:          Development/Libraries
213 # doesn't require base
214
215 %description devel
216 This package contains the header files, static libraries and
217 development documentation for Nagios. If you are a NEB-module author
218 or wish to write addons for Nagios using Nagios' own API's, you should
219 install this package.
220
221 %description devel -l pl.UTF-8
222 Ten pakiet dostarcza pliki nagłówkowe, które mogą być wykorzystywane
223 przez aplikacje związane z nagiosem podczas kompilacji.
224
225 %description devel -l pt_BR.UTF-8
226 Este pacote contém arquivos de cabeçalho usados no desenvolvimento de
227 aplicativos para o Nagios.
228
229 %prep
230 %setup -qc -a4
231 mv %{name}/* .
232 %undos cgi/*.c
233 %undos include/*.h
234 %undos base/*
235 %patch0 -p0
236 %patch1 -p1
237 %patch2 -p1
238 %patch3 -p1
239 #fixed
240 #%patch4 -p1
241 %patch5 -p1
242 %patch6 -p1
243 %patch7 -p1
244 %patch8 -p1
245 %patch9 -p1
246 %patch10 -p1
247 %patch11 -p1
248
249 find -name .cvsignore -o -name .gitignore | xargs rm
250
251 mv nagios-config-*/objects/*.cfg sample-config/template-object
252 mv nagios-config-*/*.cfg sample-config
253
254 # cleanup backups after patching
255 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
256
257 sed -i -e '
258         s,".*/var/rw/%{name}.cmd,"%{_localstatedir}/rw/%{name}.cmd,
259         s,".*/libexec/eventhandlers,"%{_libdir}/%{name}/eventhandlers,
260 ' $(find contrib/eventhandlers -type f)
261
262 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE1} > apache.conf
263 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE10} > httpd.conf
264 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
265
266 # fixup cgi config
267 %{__sed} -i -e '
268         # kill trailing spaces
269         s, \+$,,
270         # use real paths
271         s,/usr/local/%{name}/share,@datadir@,g
272         # we want all authorized users have default access
273         s,=nagiosadmin,=*,g
274 ' sample-config/*.cfg.in
275
276 # fixup paths in doc
277 #%{__sed} -i -e '
278 #       s,/usr/local/%{name}/var/archives/,/var/log/%{name}/archives/,
279 #' html/docs/configmain.html
280
281 #rm t/611cgistatus-hosturgencies.t
282
283 %build
284 cp -f /usr/share/automake/config.sub .
285 %{__aclocal}
286 %{__autoconf}
287 %if %{with tests}
288 cd tap
289 %{__libtoolize}
290 %{__aclocal}
291 %{__autoconf}
292 cd ..
293 %endif
294 %configure \
295         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
296         --bindir=%{_sbindir} \
297         --sbindir=%{cgidir} \
298         --datadir=%{htmldir} \
299         --with-nagios-user=%{name} \
300         --with-nagios-grp=%{name} \
301         --with-command-user=%{name} \
302         --with-command-grp=%{name} \
303         --with-lockfile=%{_localstatedir}/%{name}.pid \
304         --with-checkresult-dir=%{_var}/spool/%{name}/checkresults \
305         --with-ping_command='/bin/ping -n %%s -c %%d' \
306         %{!?with_gd:--disable-statusmap --disable-trends} \
307         %{?with_tests:--enable-libtap} \
308         --enable-event-broker
309
310 %{__make} all
311
312 %{?with_tests:%{__make} test}
313
314 %install
315 rm -rf $RPM_BUILD_ROOT
316 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
317         $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
318         $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
319         $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
320 %if "%{_lib}" != "lib"
321         $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
322 %endif
323
324 %{__make} install-unstripped install-devel \
325         DESTDIR=$RPM_BUILD_ROOT \
326         INSTALL_OPTS="" \
327         INIT_OPTS="" \
328         COMMAND_OPTS=""
329
330 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
331 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
332
333 # install templated configuration files
334 for a in %{name}.cfg resource.cfg commands.cfg contactgroups.cfg contacts.cfg templates.cfg timeperiods.cfg; do
335         cp -p sample-config/$a $RPM_BUILD_ROOT%{_sysconfdir}
336 done
337
338 # webserver files
339 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
340 cp -p httpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
341 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
342 cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
343 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
344 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
345 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
346 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{htmldir}
347 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
348 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
349
350 # install event handlers, sample config
351 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
352 cp -a contrib/eventhandlers $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
353 cp -a sample-config $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
354 find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.in' | xargs rm
355
356 # mrtg script
357 install -d $RPM_BUILD_ROOT/etc/mrtg/conf.d
358 cp -p sample-config/mrtg.cfg $RPM_BUILD_ROOT/etc/mrtg/conf.d/%{name}.cfg
359
360 # Object data/cache files
361 for i in {objects.{cache,precache},{retention,status}.dat,%{name}.{tmp,pid}}; do
362         > $RPM_BUILD_ROOT%{_localstatedir}/$i
363 done
364 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.cmd
365 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.qh
366
367 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
368 mv $RPM_BUILD_ROOT{%{htmldir}/docs/*,%{_docdir}/%{name}}
369
370 %clean
371 rm -rf $RPM_BUILD_ROOT
372
373 %post
374 for i in %{_localstatedir}/{objects.{cache,precache},{retention,status}.dat}; do
375         [ ! -f $i ] && touch $i
376         chown root:nagios $i
377         chmod 664 $i
378 done
379
380 /sbin/chkconfig --add %{name}
381 %service %{name} restart "Nagios service"
382
383 %preun
384 if [ "$1" = "0" ] ; then
385         %service %{name} stop
386         /sbin/chkconfig --del %{name}
387 fi
388
389 %pre common
390 # rename group netsaint -> nagios
391 if [ "$(getgid netsaint 2>/dev/null)" = "72" ]; then
392         /usr/sbin/groupmod -n nagios netsaint
393 fi
394 # rename group nagios-data -> nagcmd
395 if [ "$(getgid nagios-data 2>/dev/null)" = "147" ]; then
396         /usr/sbin/groupmod -n nagcmd nagios-data
397 fi
398 %groupadd -g 72 nagios
399 %groupadd -g 147 -f nagcmd
400 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
401         /usr/sbin/usermod -d %{_libdir}/%{name} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
402 fi
403 %useradd -u 72 -d %{_libdir}/%{name} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
404
405 %postun common
406 if [ "$1" = "0" ]; then
407         %userremove nagios
408         %groupremove nagios
409         %groupremove nagcmd
410 fi
411
412 %post cgi
413 if [ "$1" = 1 ]; then
414 %banner %{name} -e <<EOF
415 NOTE:
416 You need to add user to %{_webapps}/%{_webapp}/passwd and
417 %{_webapps}/%{_webapp}/group to access Nagios via web.
418
419 EOF
420 fi
421
422 %triggerin cgi -- apache1 < 1.3.37-3, apache1-base
423 %addusertogroup http nagcmd
424 %webapp_register apache %{_webapp}
425
426 %triggerun cgi -- apache1 < 1.3.37-3, apache1-base
427 %webapp_unregister apache %{_webapp}
428
429 %triggerin cgi -- apache-base
430 %addusertogroup http nagcmd
431 %webapp_register httpd %{_webapp}
432
433 %triggerun cgi -- apache-base
434 %webapp_unregister httpd %{_webapp}
435
436 %triggerin cgi -- lighttpd
437 %addusertogroup lighttpd nagcmd
438 %webapp_register lighttpd %{_webapp}
439
440 %triggerun cgi -- lighttpd
441 %webapp_unregister lighttpd %{_webapp}
442
443 %triggerpostun -- nagios-cgi < 2.0-0.b3.21
444 chown root:http %{_sysconfdir}/cgi.cfg
445
446 %triggerpostun -- nagios < 3.1.2-4
447 # restore lost files
448 for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.cfg hostextinfo.cfg escalations.cfg checkcommands.cfg misccommands.cfg; do
449         if [ -f %{_sysconfdir}/$a.rpmsave -a ! -f %{_sysconfdir}/$a ]; then
450                 mv -f %{_sysconfdir}/$a{.rpmsave,}
451         fi
452 done
453 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
454
455 %files
456 %defattr(644,root,root,755)
457 %doc Changelog README* UPGRADING INSTALLING LICENSE
458 %attr(750,root,nagios) %dir %{_sysconfdir}/objects
459
460 # leave main nagios config readable for -cgi.
461 %attr(640,root,nagcmd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
462
463 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commands.cfg
464 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contactgroups.cfg
465 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contacts.cfg
466 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/resource.cfg
467 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/templates.cfg
468 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timeperiods.cfg
469
470 %attr(754,root,root) /etc/rc.d/init.d/%{name}
471 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
472
473 %attr(755,root,root) %{_sbindir}/%{name}
474 %attr(755,root,root) %{_sbindir}/nagiostats
475 %dir %{_libdir}/%{name}/brokers
476
477 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}
478 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}/archives
479
480 %attr(770,root,nagcmd) %dir %{_localstatedir}
481 %attr(2770,root,nagcmd) %dir %{_localstatedir}/rw
482 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.cmd
483 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.qh
484 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.cache
485 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.precache
486 %attr(664,root,nagios) %ghost %{_localstatedir}/*.dat
487 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
488 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
489
490 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
491
492 %{_examplesdir}/%{name}-%{version}
493
494 %files common
495 %defattr(644,root,root,755)
496 %attr(750,root,nagcmd) %dir %{_sysconfdir}
497 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
498 %dir %{_libdir}/%{name}
499 %dir %{_libdir}/%{name}/plugins
500 %dir %{_libdir}/%{name}/eventhandlers
501
502 %if "%{_lib}" != "lib"
503 %dir %{_prefix}/lib/%{name}
504 %dir %{_prefix}/lib/%{name}/plugins
505 %dir %{_prefix}/lib/%{name}/eventhandlers
506 %endif
507
508 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
509
510 %files mrtggraphs
511 %defattr(644,root,root,755)
512 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
513
514 %files doc
515 %defattr(644,root,root,755)
516 %{_docdir}/%{name}
517
518 %files cgi
519 %defattr(644,root,root,755)
520 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
521 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
522 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
523 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
524 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/cgi.cfg
525 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/passwd
526 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/group
527 %dir %{cgidir}
528 %attr(755,root,root) %{cgidir}/*.cgi
529
530 %dir %{htmldir}
531 %dir %{htmldir}/includes
532 %dir %{htmldir}/images
533 %dir %{htmldir}/stylesheets
534 %{htmldir}/robots.txt
535 %{htmldir}/contexthelp
536 %{htmldir}/media
537 %{htmldir}/ssi
538 %{htmldir}/images/favicon.ico
539 %{htmldir}/images/marker.png
540 %{htmldir}/images/shadow50.png
541 %{htmldir}/nagioswall.php
542
543 %files theme-classicui
544 %defattr(644,root,root,755)
545 %exclude %{htmldir}/nagioswall.php
546 %{htmldir}/*.php
547 %{htmldir}/includes/*
548 %{htmldir}/images/*
549 %exclude %{htmldir}/images/favicon.ico
550 %exclude %{htmldir}/images/marker.png
551 %exclude %{htmldir}/images/shadow50.png
552 %{htmldir}/stylesheets/*
553
554 %files theme-default
555 %defattr(644,root,root,755)
556
557 %files devel
558 %defattr(644,root,root,755)
559 %dir %{_includedir}/%{name}
560 %{_includedir}/%{name}/*.h
561 %{_includedir}/%{name}/lib
562 %{_libdir}/libnagios.a
This page took 0.105671 seconds and 2 git commands to generate.