]> git.pld-linux.org Git - packages/nagios-plugin-check_rbl.git/blob - nagios-plugin-check_rbl.spec
- up to 1.3.8; works now (previous version had broken resolving and reported incorrec...
[packages/nagios-plugin-check_rbl.git] / nagios-plugin-check_rbl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         plugin  check_rbl
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Nagios plugin to check if an server is blacklisted in RBL servers
8 Name:           nagios-plugin-%{plugin}
9 Version:        1.3.8
10 Release:        1
11 License:        GPL v3
12 Group:          Networking
13 Source0:        https://github.com/matteocorti/check_rbl/releases/download/v%{version}/%{plugin}-%{version}.tar.gz
14 # Source0-md5:  267eac8db2f27aeb1473025d67855dd0
15 Source1:        %{plugin}.cfg
16 Source2:        %{plugin}.ini
17 URL:            https://github.com/matteocorti/check_rbl/wiki
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  sed >= 4.0
21 %if %{with tests}
22 BuildRequires:  perl-Data-Validate-Domain
23 BuildRequires:  perl-Data-Validate-IP
24 BuildRequires:  perl-Nagios-Plugin >= 0.31
25 BuildRequires:  perl-Net-DNS
26 BuildRequires:  perl-Readonly
27 %endif
28 Requires:       nagios-common
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _sysconfdir     /etc/nagios/plugins
33 %define         plugindir       %{_prefix}/lib/nagios/plugins
34
35 %description
36 Nagios plugin to check if an server is blacklisted in RBL servers.
37
38 %prep
39 %setup -q -n %{plugin}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLVENDORSCRIPT=%{plugindir} \
44         INSTALLDIRS=vendor
45
46 %{__make}
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT%{_sysconfdir}
55 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{plugin}.cfg
56 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{plugin}.ini
57
58 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
59 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/check_rbl/.packlist
60 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/check_rbl.pod
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc AUTHORS Changes NEWS README INSTALL TODO VERSION
68 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{plugin}.cfg
69 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{plugin}.ini
70 %attr(755,root,root) %{plugindir}/%{plugin}
71 %{_mandir}/man1/check_rbl.1*
This page took 0.041215 seconds and 3 git commands to generate.