]> git.pld-linux.org Git - packages/nagios-plugin-check_raid.git/blob - nagios-plugin-check_raid.spec
- new
[packages/nagios-plugin-check_raid.git] / nagios-plugin-check_raid.spec
1 %define         plugin  check_raid
2 Summary:        Nagios plugin to check current server's RAID status
3 Name:           nagios-plugin-%{plugin}
4 Version:        0.1
5 Release:        0.1
6 License:        Unknown
7 Group:          Networking
8 # Source0Download:      https://secure.opsera.com/wsvn/wsvn/opsview/trunk/opsview-core/nagios-plugins/check_raid?op=dl
9 Source0:        %{plugin}
10 Requires:       nagios-core
11 BuildArch:      noarch
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         _sysconfdir     /etc/nagios/plugins
15 %define         plugindir       %{_prefix}/lib/nagios/plugins
16
17 %description
18 This plugin reports the current server's RAID status.
19
20 %prep
21 %setup -qcT
22 cp -p %{SOURCE0} %{plugin}
23
24 cat > nagios.cfg <<'EOF'
25 # Usage:
26 # %{plugin}
27 define command {
28         command_name    %{plugin}
29         command_line    %{plugindir}/%{plugin}
30 }
31 EOF
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{plugindir}}
36 install -p %{plugin} $RPM_BUILD_ROOT%{plugindir}/%{plugin}
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %attr(755,root,root) %{plugindir}/%{plugin}
This page took 0.02876 seconds and 3 git commands to generate.