]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
20460adf20c2e887a5b4e13b7104ef0835bdc764
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl.UTF-8):      Demon i wtyczka zdalnego wywoływania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        4.1.0
5 Release:        1
6 License:        GPL v2
7 Group:          Networking
8 Source0:        https://github.com/NagiosEnterprises/nrpe/releases/download/nrpe-%{version}/nrpe-%{version}.tar.gz
9 # Source0-md5:  ace32f8d41e9b9138ea5d40b8beed274
10 Source1:        nrpe.init
11 Source2:        nrpe-command.cfg
12 Source3:        %{name}.tmpfiles
13 Source4:        commands.cfg
14 Patch0:         %{name}-config.patch
15 Patch1:         nrpe_check_control.patch
16 URL:            https://exchange.nagios.org/directory/Addons/Monitoring-Agents/NRPE--2D-Nagios-Remote-Plugin-Executor/details
17 BuildRequires:  openssl-devel
18 BuildRequires:  openssl-tools
19 BuildRequires:  rpmbuild(macros) >= 1.647
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       nagios-common >= 4.3.3-2
22 Requires:       rc-scripts >= 0.4.1.26
23 Provides:       nagios-core
24 Obsoletes:      netsaint-nrpe
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/nagios
28 %define         _datadir        %{_prefix}/share/%{name}
29 %define         _plugindir      %{_libdir}/nagios/plugins
30 %define         _localstatedir  %{_var}/log/nagios
31 %define         nsport          5666
32
33 %description
34 NPRE (Nagios Remote Plugin Executor) is a system daemon that will
35 execute various Nagios plugins locally on behalf of a remote
36 (monitoring) host that uses the check_nrpe plugin.
37
38 %description -l pl.UTF-8
39 NRPE to dodatek do Nagiosa pozwalający na wywoływanie "lokalnych"
40 wtyczek (takich jak check_disk, check_procs itp.) na zdalnych
41 maszynach. Wtyczka check_nrpe jest wywoływana z poziomu Nagiosa i
42 wysyła żądania uruchomienia wtyczek do demona NRPE działającego na
43 zdalnej maszynie (jako samodzielny demon lub usługa inetd). Obsługuje
44 przekazywanie argumentów poleceń do serwera, a także natywne
45 szyfrowanie SSL/TLS (w trybie anonimowego DH).
46
47 %package -n nagios-plugin-check_nrpe
48 Summary:        check_nrpe plugin for Nagios
49 Summary(pl.UTF-8):      Wtyczka check_nrpe dla Nagiosa
50 Group:          Networking
51 Requires:       nagios-common
52 Provides:       %{name}-plugin = %{version}-%{release}
53 Obsoletes:      nagios-nrpe-plugin < 2.12-6
54
55 %description -n nagios-plugin-check_nrpe
56 The check_nrpe plugin is called from Nagios and makes plugin execution
57 requests to the NRPE daemon running on the remote host. Supports
58 passing command arguments to server, as well as native SSL/TLS
59 encryption (anonymous DH mode).
60
61 %description -n nagios-plugin-check_nrpe -l pl.UTF-8
62 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
63 na innych komputerach za pomocą demona nrpe.
64
65 %prep
66 %setup -q -n nrpe-%{version}
67 %undos contrib/nrpe_check_control.c
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %{__aclocal}
73 %{__autoconf}
74 %configure \
75         --with-nrpe-port=%{nsport} \
76         --with-nrpe-user=nagios \
77         --with-nrpe-group=nagios \
78         --with-piddir=/var/run/nrpe \
79         --enable-ssl \
80         --with-ssl-lib=%{_libdir} \
81         --enable-command-args
82
83 %{__make} all
84
85 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} contrib/nrpe_check_control.c -o contrib/nrpe_check_control
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/{plugins,nrpe.d},%{_libdir}/nagios/plugins,%{_sbindir}} \
90         $RPM_BUILD_ROOT{%{_localstatedir},/var/run/nrpe} \
91         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
92
93 cp -p sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
94 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.d
95 sed -e 's,@plugindir@,%{_plugindir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/plugins/check_nrpe.cfg
96 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
97 install -p src/nrpe $RPM_BUILD_ROOT%{_sbindir}
98 install -p src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
99 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 /sbin/chkconfig --add nrpe
106 %service nrpe restart
107
108 %preun
109 if [ "$1" = "0" ] ; then
110         %service nrpe stop
111         /sbin/chkconfig --del nrpe
112 fi
113
114 %triggerpostun -- %{name} < 2.6-1.1
115 # < 2.15-5
116 # skip *this* trigger on downgrade
117 [ $1 -le 1 ] && exit 0
118
119 # ensure there's include_dir directive
120 if ! grep -q '^include_dir=%{_sysconfdir}/nrpe.d' %{_sysconfdir}/nrpe.cfg; then
121         echo 'include_dir=%{_sysconfdir}/nrpe.d' >> %{_sysconfdir}/nrpe.cfg
122 fi
123
124 # check if need to migrate
125 grep -q '^command\[' %{_sysconfdir}/nrpe.cfg || exit 0
126
127 # move command definitions to separate file
128 mv -f  %{_sysconfdir}/nrpe.d/commands.cfg{,.rpmnew}
129 grep '^command\['  %{_sysconfdir}/nrpe.cfg > %{_sysconfdir}/nrpe.d/commands.cfg
130 cp -f %{_sysconfdir}/nrpe.cfg{,.rpmsave}
131 sed -i -e '/^command\[/d' %{_sysconfdir}/nrpe.cfg
132
133 %service nrpe restart
134
135 # < 2.6-1.1
136 %{__sed} -i -e 's,/var/run/nrpe.pid,/var/run/nrpe/nrpe.pid,' %{_sysconfdir}/nrpe.cfg
137
138 %triggerpostun -n nagios-plugin-check_nrpe -- nagios-plugin-check_nrpe < 2.12-7.1
139 if [ -f %{_sysconfdir}/plugins/nrpe.cfg.rpmsave ]; then
140         cp -f %{_sysconfdir}/plugins/check_nrpe.cfg{,.rpmnew}
141         mv -f %{_sysconfdir}/plugins/{nrpe.cfg.rpmsave,check_nrpe.cfg}
142         sed -i -e 's,-c \$ARG1\$,$ARG1$,' %{_sysconfdir}/plugins/check_nrpe.cfg
143 fi
144
145 %files
146 %defattr(644,root,root,755)
147 %doc CHANGELOG.md LEGAL README* SECURITY.md update-cfg.pl
148 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
149 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.d/commands.cfg
150 %attr(755,root,root) %{_sbindir}/nrpe
151 %attr(754,root,root) /etc/rc.d/init.d/nrpe
152 %dir %attr(775,root,nagios) /var/run/nrpe
153 %{systemdtmpfilesdir}/%{name}.conf
154
155 %files -n nagios-plugin-check_nrpe
156 %defattr(644,root,root,755)
157 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins/check_nrpe.cfg
158 %attr(755,root,root) %{_plugindir}/check_nrpe
This page took 0.103005 seconds and 3 git commands to generate.