]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- package backend locales dir
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 # - bindings:
8 #   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
9 #   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
10 #
11 # Specfile for MythTV
12 #
13 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
14 #  building an rpm by hand on the machine it will be used on, I encourage you
15 #  to use "--with cpu_autodetect" to let mythtv decide for you.
16 #
17 # Conditional build:
18 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
19 %bcond_without  lirc            # lirc support
20 %bcond_without  alsa            # alsa support
21 %bcond_without  oss             # oss support
22 %bcond_without  jack            # jack audio connection kit
23 %bcond_without  pulseaudio      # pulseaudio support
24 %bcond_without  dvb             # DVB support
25 %bcond_without  xrandr          # disable X11 resolution switching
26 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
27 %bcond_without  iptv
28 %bcond_without  firewire        # ieee1394 (NFY)
29 %bcond_without  vdpau           # disable nvidia vdpau support
30 %bcond_without  fftw3           # disable fftw3 support
31 %bcond_with     mmx             # enable MMX
32 %bcond_without  nellymoserdec
33 %bcond_with     vaapi           # enable vaapi
34 %bcond_with     dshowserver     # enable directshow codecs server
35 %bcond_with     perl
36 %bcond_with     php
37 %bcond_without  python
38 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers
39                                 # instead of libvdpau
40
41 # enable mmx automatically on arches having it
42 %ifarch %{ix86} %{x8664}
43 %ifnarch i386 i486 i586 i686
44 %define with_mmx 1
45 %endif
46 %endif
47
48 # dshowserver is exclusive arch for x86 x86_64 only
49 %ifnarch %{ix86} %{x8664}
50 %undefine with_dshowserver
51 %endif
52
53 %include        /usr/lib/rpm/macros.perl
54 Summary:        A personal video recorder (PVR) application
55 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
56 Name:           mythtv
57 Version:        0.26.0
58 Release:        4
59 License:        GPL v2
60 Group:          Applications/Multimedia
61 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
62 # Source0-md5:  f57066bf75e6f14824c494d41639f4f9
63 Source1:        mythbackend.sysconfig
64 Source2:        mythbackend.init
65 Source3:        mythbackend.logrotate
66 Source4:        %{name}.tmpfiles
67 Source5:        pld-mythfrontend.desktop
68 # Source5-md5:  f37a903ac97463683bebacdf29406951
69 Source6:        pld-mythfrontend.png
70 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
71 Source20:       dshowcodecs
72 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
73 Patch0:         %{name}-configure.patch
74 Patch1:         system-zeromq.patch
75 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
76 Patch30:        %{name}-dshowserver-0.22.patch
77 URL:            http://www.mythtv.org/
78 BuildRequires:  Mesa-libGLU-devel
79 BuildRequires:  OpenGL-devel
80 BuildRequires:  Qt3Support-devel
81 BuildRequires:  QtCore-devel
82 BuildRequires:  QtGui-devel
83 BuildRequires:  QtNetwork-devel
84 BuildRequires:  QtOpenGL-devel
85 BuildRequires:  QtScript-devel
86 BuildRequires:  QtSql-devel
87 BuildRequires:  QtWebKit-devel
88 BuildRequires:  QtXml-devel
89 %{?with_alsa:BuildRequires:     alsa-lib-devel}
90 BuildRequires:  ffmpeg-devel
91 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
92 BuildRequires:  freetype-devel >= 1:2.0.0
93 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
94 BuildRequires:  lame-libs-devel
95 %{?with_firewire:BuildRequires: libavc1394-devel}
96 BuildRequires:  libdts-devel
97 %{?with_dvb:BuildRequires:      libdvb-devel}
98 BuildRequires:  libdvdnav-devel
99 %{?with_firewire:BuildRequires: libiec61883-devel}
100 %{?with_firewire:BuildRequires: libraw1394-devel}
101 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
102 BuildRequires:  linux-libc-headers >= 7:2.6.10
103 %{?with_lirc:BuildRequires:     lirc-devel}
104 BuildRequires:  mysql-devel
105 BuildRequires:  perl-devel
106 BuildRequires:  perl-tools-pod
107 %if %{with perl}
108 BuildRequires:  perl-DBI
109 BuildRequires:  perl-DBD-mysql
110 BuildRequires:  perl-HTTP-Message
111 BuildRequires:  perl-libwww
112 BuildRequires:  perl-Net-UPnP-QueryResponse
113 BuildRequires:  perl-Net-UPnP-ControlPoint
114 BuildRequires:  perl-IO-Socket-INET6
115 %endif
116 %if %{with python}
117 BuildRequires:  python-MySQLdb
118 %endif
119 BuildRequires:  pkgconfig
120 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
121 BuildRequires:  python-devel
122 BuildRequires:  qt4-build
123 BuildRequires:  qt4-qmake
124 BuildRequires:  rpm-perlprov >= 4.1-13
125 BuildRequires:  rpm-pythonprov
126 BuildRequires:  rpmbuild(macros) >= 1.228
127 BuildRequires:  sed >= 4.0
128 BuildRequires:  which
129 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
130 BuildRequires:  xorg-lib-libXext-devel
131 BuildRequires:  xorg-lib-libXxf86vm-devel
132 BuildRequires:  zeromq-devel
133 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
134 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
135 # for Perl bindings
136 BuildRequires:  perl-ExtUtils-MakeMaker
137 ExclusiveArch:  %{ix86} %{x8664} ppc
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
141
142 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
143 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
144 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
145 %define         no_install_post_check_so 1
146
147 %description
148 MythTV implements the following PVR features, and more, with a unified
149 graphical interface:
150 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
151 - Video compression using RTjpeg or MPEG-4
152 - Program listing retrieval using XMLTV
153 - Themable, semi-transparent on-screen display
154 - Electronic program guide
155 - Scheduled recording of TV programs
156 - Resolution of conflicts between scheduled recordings
157 - Basic video editing
158
159 %description -l pl.UTF-8
160 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
161 ujednoliconym interfejsem graficznym:
162 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
163   przewijanie "żywej" telewizji
164 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
165 - odczyt listy programów przy użyciu XMLTV
166 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
167 - elektroniczny przewodnik po programie
168 - planowane nagrywanie programów telewizyjnych
169 - rozwiązywanie konfliktów między planowanymi nagraniami
170 - podstawowa edycja obrazu
171
172 %package backend
173 Summary:        Server component of mythtv (a PVR)
174 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
175 Group:          Applications/Multimedia
176 Requires(post,preun):   /sbin/chkconfig
177 Requires(postun):       /usr/sbin/groupdel
178 Requires(postun):       /usr/sbin/userdel
179 Requires(pre):  /bin/id
180 Requires(pre):  /usr/bin/getgid
181 Requires(pre):  /usr/sbin/groupadd
182 Requires(pre):  /usr/sbin/useradd
183 Requires:       libmyth = %{version}-%{release}
184 Requires:       mythtv = %{version}-%{release}
185 Suggests:       mysql
186 Provides:       group(mythtv)
187 Provides:       user(mythtv)
188 Conflicts:      logrotate < 3.8.0
189
190 %description backend
191 MythTV provides a unified graphical interface for recording and
192 viewing television programs. Refer to the mythtv package for more
193 information.
194
195 This package contains only the server software, which provides video
196 and audio capture and encoding services. In order to be useful, it
197 requires a mythtv-frontend installation, either on the same system or
198 one reachable via the network.
199
200 %description backend -l pl.UTF-8
201 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
202 oglądania programów telewizyjnych. Więcej informacji w pakiecie
203 mythtv.
204
205 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
206 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
207 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
208 albo innym osiągalnym w sieci.
209
210 %package frontend
211 Summary:        Client component of mythtv (a PVR)
212 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
213 Group:          Applications/Multimedia
214 Requires:       libmyth = %{version}-%{release}
215 Requires:       mythtv = %{version}-%{release}
216 Requires:       mythtv-themes = %{version}-%{release}
217 Provides:       mythtv-frontend-api = %{myth_api_version}
218
219 %description frontend
220 MythTV provides a unified graphical interface for recording and
221 viewing television programs. Refer to the mythtv package for more
222 information.
223
224 This package contains only the client software, which provides a
225 front-end for playback and configuration. It requires access to a
226 mythtv-backend installation, either on the same system or one
227 reachable via the network.
228
229 %description frontend -l pl.UTF-8
230 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
231 oglądania programów telewizyjnych. Więcej informacji w pakiecie
232 mythtv.
233
234 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
235 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
236 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
237
238 %package setup
239 Summary:        Setup the mythtv backend
240 Summary(pl.UTF-8):      Konfigurator backendu mythtv
241 Group:          Applications/Multimedia
242 Requires:       libmyth = %{version}-%{release}
243
244 %description setup
245 MythTV provides a unified graphical interface for recording and
246 viewing television programs. Refer to the mythtv package for more
247 information.
248
249 This package contains only the setup software for configuring the
250 mythtv backend.
251
252 %description setup -l pl.UTF-8
253 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
254 oglądania programów telewizyjnych. Więcej informacji w pakiecie
255 mythtv.
256
257 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
258
259 %package themes
260 Summary:        Base themes for mythtv's frontend
261 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
262 Group:          Themes
263 Requires:       %{name}-frontend = %{version}-%{release}
264
265 %description themes
266 MythTV provides a unified graphical interface for recording and
267 viewing television programs. Refer to the mythtv package for more
268 information.
269
270 This package contains only the base themes used by the frontend and
271 mythtvsetup.
272
273 %description themes -l pl.UTF-8
274 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
275 oglądania programów telewizyjnych. Więcej informacji w pakiecie
276 mythtv.
277
278 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
279 mythtvsetup.
280
281 %package -n libmyth
282 Summary:        Library providing mythtv support
283 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
284 Group:          Libraries
285 Requires:       QtSql-mysql
286 Requires:       freetype >= 1:2.0.0
287 Requires:       lame
288
289 %description -n libmyth
290 Common library code for MythTV and add-on modules (development) MythTV
291 provides a unified graphical interface for recording and viewing
292 television programs. Refer to the mythtv package for more information.
293
294 %description -n libmyth -l pl.UTF-8
295 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
296 dostarczający ujednolicony interfejs graficzny do nagrywania i
297 oglądania programów telewizyjnych. Więcej informacji w pakiecie
298 mythtv.
299
300 %package -n libmyth-devel
301 Summary:        Development files for libmyth
302 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
303 Group:          Development/Libraries
304 Requires:       libmyth = %{version}-%{release}
305
306 %description -n libmyth-devel
307 This package contains the header files for developing add-ons for
308 mythtv.
309
310 %description -n libmyth-devel -l pl.UTF-8
311 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
312
313 %package -n libmyth-static
314 Summary:        Static libmyth library
315 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
316 Group:          Development/Libraries
317 Requires:       libmyth-devel = %{version}-%{release}
318
319 %description -n libmyth-static
320 Static libmyth library.
321
322 %description -n libmyth-static -l pl.UTF-8
323 Statyczna biblioteka libmyth.
324
325 %package -n perl-MythTV
326 Summary:        MythTV Perl bindings
327 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
328 Group:          Libraries
329
330 %description -n perl-MythTV
331 MythTV Perl bindings.
332
333 %description -n perl-MythTV -l pl.UTF-8
334 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
335
336 %package -n python-MythTV
337 Summary:        MythTV Python bindings
338 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
339 Group:          Libraries
340 Requires:       python-MySQLdb
341
342 %description -n python-MythTV
343 MythTV Python bindings.
344
345 %description -n python-MythTV -l pl.UTF-8
346 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
347
348 %package -n php-MythTV
349 Summary:        MythTV PHP bindings
350 Summary(pl.UTF-8):      Interfejs PHP dla MythTV
351 Group:          Libraries
352
353 %description -n php-MythTV
354 MythTV PHP bindings.
355
356 %description -n php-MythTV -l pl.UTF-8
357 Ten pakiet zawiera moduły PHP do tworzenia dodatków dla mythtv.
358
359 %prep
360
361 %setup -q
362
363 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
364         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
365
366 %patch0  -p1
367 %patch1  -p1
368 %{?with_dshowserver:%patch20 -p1}
369 #%patch30 -p1
370
371 rm -rf database/old # not supported in PLD
372
373 # lib64 fix - enable to update patch
374 %if %{_lib} != "lib" && 0
375 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
376 xargs grep -l /lib . | xargs sed -i -e '
377         s,/''usr/lib/,/%{_libdir}/,g
378         s,/''lib/mythtv,/%{_lib}/mythtv,g
379         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
380 '
381 exit 1
382 %endif
383
384 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
385 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
386 # prevent compiler finding libs from system when they should be looked
387 # from current buildtree.
388 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
389 # so we make QMAKE wrapper which will do sed subst after calling
390 # qmake. this is the wrapper.
391 cat > qmake-wrapper.sh <<'EOF'
392 #!/bin/sh
393 getmakefile() {
394         while [ $# -gt 0 ]; do
395                 case "$1" in
396                 -o)
397                         shift
398                         makefile="$1"
399                         return
400                         ;;
401         esac
402                 shift
403         done
404 }
405
406 qmake-qt4 "$@"
407 getmakefile "$@"
408 if [ "$makefile" ]; then
409         %{__sed} -i -e '
410                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
411                 s;-L$(QTDIR)/%{_lib};;
412         ' $makefile
413 fi
414 EOF
415 chmod +x qmake-wrapper.sh
416
417 # move perl bindings to vendor prefix
418 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
419   bindings/perl/Makefile
420
421 %build
422
423 %if %{with cpu_autodetect}
424 # Make sure we have /proc mounted
425 if [ ! -r /proc/cpuinfo ]; then
426         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
427         exit 1
428 fi
429 %endif
430
431 ./configure \
432         --prefix=%{_prefix} \
433         --libdir=%{_libdir} \
434         --libdir-name=%{_lib} \
435         --mandir=%{_mandir} \
436         --disable-distcc --disable-ccache \
437         --compile-type=%{?debug:debug}%{!?debug:release} \
438         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
439         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
440 %if %{with cpu_autodetect}
441         --enable-proc-opt \
442 %else
443         %ifarch %{ix86}
444                 %ifarch athlon
445                         --arch=athlon \
446                 %else
447                         --cpu=%{_target_cpu} --tune=pentium4 \
448                 %endif
449         %endif
450         %ifarch i386 i486 i586
451         --enable-disable-mmx-for-debugging \
452         %endif
453         %ifarch %{x8664}
454         --arch=x86_64 \
455         %endif
456         %{?with_mmx:--enable-mmx} \
457 %endif
458         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
459         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
460         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
461         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
462         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
463         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
464         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
465         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
466         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
467         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
468         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
469         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
470         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
471         --enable-xv \
472         --enable-x11 \
473
474 #%{_libdir}/qt4/bin/qmake mythtv.pro
475 %{__make}
476
477 %install
478 rm -rf $RPM_BUILD_ROOT
479 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
480                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
481                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
482                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
483                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
484                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
485                 $RPM_BUILD_ROOT%{_pixmapsdir} \
486                 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
487
488 %{__make} install \
489         INSTALL_ROOT=$RPM_BUILD_ROOT
490
491 # Install the files that we added on top of mythtv's own stuff
492 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
493 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
494 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
495 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
496
497 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
498
499 # desktop entries
500 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
501 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
502
503 # Install settings.pro so people can see the build options we used
504 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
505 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
506
507 for p in mythfrontend; do
508         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
509                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
510         done > $p.lang
511 done
512
513 echo "%dir %{_datadir}/mythtv/locales" > mythbackend.lang
514 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/locales/*.xml; do
515         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*/\(.*\).xml\),%%lang(\2) \1,"
516 done >> mythbackend.lang
517
518 # glibc language codes. attempt was made to change it on libmyth side,
519 # but that was just asking for trouble due large coverage of
520 # language.lower() usage.
521 sed -i -e '
522 s,%%lang(en_gb),%%lang(en_GB),
523 s,%%lang(zh_tw),%%lang(zh_TW),
524 s,%%lang(pt_br),%%lang(pt_BR),
525 ' *.lang
526
527 rm -rf mythwelcome mythlcdserver
528 install -d mythwelcome
529 cp -a programs/mythwelcome/README mythwelcome
530 cp -a programs/mythlcdserver/README mythlcdserver
531
532 %clean
533 rm -rf $RPM_BUILD_ROOT
534
535 %pre backend
536 %groupadd -g 149 %{name}
537 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
538 %addusertogroup %{name} video
539 %addusertogroup %{name} audio
540
541 %post backend
542 /sbin/chkconfig --add mythbackend
543
544 %preun backend
545 if [ "$1" = "0" ]; then
546         %service -q mythbackend stop
547         /sbin/chkconfig --del mythbackend
548 fi
549
550 %postun backend
551 if [ "$1" = "0" ]; then
552         %userremove %{name}
553         %groupremove %{name}
554 fi
555
556 %post   -n libmyth -p /sbin/ldconfig
557 %postun -n libmyth -p /sbin/ldconfig
558
559 %post setup
560 if [ "$1" = 1 ]; then
561 %banner -e %{name}-setup <<EOF
562 To grant mysql permissions to mythtv, please run
563 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
564 EOF
565 fi
566
567 %files
568 %defattr(644,root,root,755)
569 %doc README* UPGRADING AUTHORS FAQ
570 %doc docs contrib
571 %doc keys.txt mythwelcome mythlcdserver
572
573 %files backend -f mythbackend.lang
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_bindir}/mythbackend
576 %attr(755,root,root) %{_bindir}/mythcommflag
577 %attr(755,root,root) %{_bindir}/mythfilldatabase
578 %attr(755,root,root) %{_bindir}/mythjobqueue
579 %attr(755,root,root) %{_bindir}/mythlcdserver
580 %attr(755,root,root) %{_bindir}/mythlogserver
581 %attr(755,root,root) %{_bindir}/mythmediaserver
582 %attr(755,root,root) %{_bindir}/mythtranscode
583 %attr(755,root,root) %{_bindir}/mythreplex
584 %attr(755,root,root) %{_bindir}/mythffmpeg
585 %attr(755,root,root) %{_bindir}/mythpreviewgen
586 %attr(755,root,root) %{_bindir}/mythccextractor
587 %attr(755,root,root) %{_bindir}/mythmetadatalookup
588 %attr(755,root,root) %{_bindir}/mythutil
589
590 %attr(775,root,mythtv) %dir /var/lib/mythtv
591 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
592 %attr(775,root,mythtv) %dir /var/cache/mythtv
593 %attr(775,root,mythtv) %dir /var/run/mythtv
594 /usr/lib/tmpfiles.d/%{name}.conf
595 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
598 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
599 %{_datadir}/mythtv/backend-config
600 %{_datadir}/mythtv/html
601
602 %files frontend -f mythfrontend.lang
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_bindir}/mythfrontend
605 %attr(755,root,root) %{_bindir}/mythshutdown
606 %attr(755,root,root) %{_bindir}/mythavtest
607 %attr(755,root,root) %{_bindir}/mythwelcome
608 %dir %{_datadir}/mythtv
609 %dir %{_datadir}/mythtv/themes
610 %{_datadir}/mythtv/internetcontent
611 %if %{without perl}
612 %exclude %{_datadir}/mythtv/internetcontent/nv_perl_libs
613 %endif
614 %{_datadir}/mythtv/metadata
615 %dir %{_libdir}/mythtv
616 %{_datadir}/mythtv/*.xml
617 %dir %{_libdir}/mythtv/filters
618 %dir %{_libdir}/mythtv/plugins
619 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
620 %dir %{_datadir}/mythtv/fonts
621 %{_datadir}/mythtv/fonts/*.ttf
622 %{_datadir}/mythtv/fonts/*.otf
623 %dir %{_datadir}/mythtv/i18n
624 %if %{with dshowserver}
625 %{_datadir}/mythtv/dshowcodecs
626 %endif
627 %{_desktopdir}/*.desktop
628 %{_pixmapsdir}/*.png
629
630 %files setup
631 %defattr(644,root,root,755)
632 %doc database
633 %attr(755,root,root) %{_bindir}/mythtv-setup
634
635 %files themes
636 %defattr(644,root,root,755)
637 %{_datadir}/mythtv/themes/*
638
639 %files -n libmyth
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/lib*.so.*
642 %attr(755,root,root) %{_libdir}/lib*.a
643 %dir %{_datadir}/mythtv
644 %{_datadir}/mythtv/*.pl
645 %{_datadir}/mythtv/hardwareprofile
646
647 %files -n libmyth-devel
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/*.so
650 %{_includedir}/*
651 %{_datadir}/mythtv/build
652
653 %files -n libmyth-static
654 %defattr(644,root,root,755)
655
656 %if %{with perl}
657 %files -n perl-MythTV
658 %defattr(644,root,root,755)
659 %{perl_vendorlib}/MythTV.pm
660 %dir %{perl_vendorlib}/MythTV
661 %{perl_vendorlib}/MythTV/*.pm
662 %dir %{perl_vendorlib}/IO/Socket/INET
663 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
664 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
665 %endif
666
667 %if %{with python}
668 %files -n python-MythTV
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/mythpython
671 %dir %{py_sitescriptdir}/MythTV
672 %{py_sitescriptdir}/MythTV/*
673 %{py_sitescriptdir}/*.egg-info
674 %endif
675
676 %if %{with php}
677 %files -n php-MythTV
678 %defattr(644,root,root,755)
679 %endif
This page took 0.463964 seconds and 3 git commands to generate.