]> git.pld-linux.org Git - packages/mythtv.git/blob - mythtv.spec
- exclude perl scripts that won't work without perl bindings
[packages/mythtv.git] / mythtv.spec
1 # TODO
2 # - bconds: altivec joystick lcd
3 # - lcd? (app-misc/lcdproc)
4 # - alpha, sparc, ppc arches?
5 # - http://outflux.net/software/pkgs/mythtvfs-fuse/
6 # - vaapi support - check for compatible versions of libva?
7 # - bindings:
8 #   WARNING: disabling Python bindings; missing MySQLdb
9 #   WARNING: disabling Perl bindings; missing Net::UPnP::QueryResponse
10 #   WARNING: disabling Perl bindings; missing Net::UPnP::ControlPoint
11 # - dozen of unpackaged files
12 #
13 # Specfile for MythTV
14 #
15 #  MythTV now uses a fairly intelligent cpu-detection script, so if you are
16 #  building an rpm by hand on the machine it will be used on, I encourage you
17 #  to use "--with cpu_autodetect" to let mythtv decide for you.
18 #
19 # Conditional build:
20 %bcond_with     cpu_autodetect  # enable CPU autodetection at compile time (sets "-march", "-mcpu" compile flags really)
21 %bcond_without  lirc            # lirc support
22 %bcond_without  alsa            # alsa support
23 %bcond_without  oss             # oss support
24 %bcond_without  jack            # jack audio connection kit
25 %bcond_without  pulseaudio      # pulseaudio support
26 %bcond_without  dvb             # DVB support
27 %bcond_without  xrandr          # disable X11 resolution switching
28 %bcond_without  ivtv            # ivtv support (PVR-250, PVR-350) NFY
29 %bcond_without  iptv
30 %bcond_without  firewire        # ieee1394 (NFY)
31 %bcond_without  vdpau           # disable nvidia vdpau support
32 %bcond_without  fftw3           # disable fftw3 support
33 %bcond_with     mmx             # enable MMX
34 %bcond_without  nellymoserdec
35 %bcond_with     vaapi           # enable vaapi
36 %bcond_with     dshowserver     # enable directshow codecs server
37 %bcond_with     perl
38 %bcond_with     php
39 %bcond_with     python
40 %bcond_with     nvidia_headers  # build vdpau support with nvidia headers
41                                 # instead of libvdpau
42
43 # enable mmx automatically on arches having it
44 %ifarch %{ix86} %{x8664}
45 %ifnarch i386 i486 i586 i686
46 %define with_mmx 1
47 %endif
48 %endif
49
50 # dshowserver is exclusive arch for x86 x86_64 only
51 %ifnarch %{ix86} %{x8664}
52 %undefine with_dshowserver
53 %endif
54
55 %include        /usr/lib/rpm/macros.perl
56 Summary:        A personal video recorder (PVR) application
57 Summary(pl.UTF-8):      Osobista aplikacja do nagrywania obrazu (PVR)
58 Name:           mythtv
59 Version:        0.26.0
60 Release:        2
61 License:        GPL v2
62 Group:          Applications/Multimedia
63 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
64 # Source0-md5:  f57066bf75e6f14824c494d41639f4f9
65 Source1:        mythbackend.sysconfig
66 Source2:        mythbackend.init
67 Source3:        mythbackend.logrotate
68 Source4:        %{name}.tmpfiles
69 Source5:        pld-mythfrontend.desktop
70 # Source5-md5:  f37a903ac97463683bebacdf29406951
71 Source6:        pld-mythfrontend.png
72 # Source6-md5:  bf76bd1463a022e174e4af976a03e678
73 Source20:       dshowcodecs
74 # Source20-md5: 48327772b9e150f69e1ab8ff44b9a76c
75 Patch0:         %{name}-configure.patch
76 Patch1:         system-zeromq.patch
77 Patch20:        %{name}-compile_fixes_for_qt_4_7.patch
78 Patch30:        %{name}-dshowserver-0.22.patch
79 URL:            http://www.mythtv.org/
80 BuildRequires:  Mesa-libGLU-devel
81 BuildRequires:  OpenGL-devel
82 BuildRequires:  Qt3Support-devel
83 BuildRequires:  QtCore-devel
84 BuildRequires:  QtGui-devel
85 BuildRequires:  QtNetwork-devel
86 BuildRequires:  QtOpenGL-devel
87 BuildRequires:  QtScript-devel
88 BuildRequires:  QtSql-devel
89 BuildRequires:  QtWebKit-devel
90 BuildRequires:  QtXml-devel
91 %{?with_alsa:BuildRequires:     alsa-lib-devel}
92 BuildRequires:  ffmpeg-devel
93 %{?with_fftw3:BuildRequires: fftw3-devel,fftw3-single-devel}
94 BuildRequires:  freetype-devel >= 1:2.0.0
95 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
96 BuildRequires:  lame-libs-devel
97 %{?with_firewire:BuildRequires: libavc1394-devel}
98 BuildRequires:  libdts-devel
99 %{?with_dvb:BuildRequires:      libdvb-devel}
100 BuildRequires:  libdvdnav-devel
101 %{?with_firewire:BuildRequires: libiec61883-devel}
102 %{?with_firewire:BuildRequires: libraw1394-devel}
103 %{!?with_nvidia_headers:%{?with_vdpau:BuildRequires:    libvdpau-devel}}
104 BuildRequires:  linux-libc-headers >= 7:2.6.10
105 %{?with_lirc:BuildRequires:     lirc-devel}
106 BuildRequires:  mysql-devel
107 BuildRequires:  perl-devel
108 BuildRequires:  perl-tools-pod
109 %if %{with perl}
110 BuildRequires:  perl-DBI
111 BuildRequires:  perl-DBD-mysql
112 BuildRequires:  perl-HTTP-Message
113 BuildRequires:  perl-libwww
114 BuildRequires:  perl-Net-UPnP-QueryResponse
115 BuildRequires:  perl-Net-UPnP-ControlPoint
116 BuildRequires:  perl-IO-Socket-INET6
117 %endif
118 BuildRequires:  pkgconfig
119 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
120 BuildRequires:  python-devel
121 BuildRequires:  qt4-build
122 BuildRequires:  qt4-qmake
123 BuildRequires:  rpm-perlprov >= 4.1-13
124 BuildRequires:  rpm-pythonprov
125 BuildRequires:  rpmbuild(macros) >= 1.228
126 BuildRequires:  sed >= 4.0
127 BuildRequires:  which
128 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
129 BuildRequires:  xorg-lib-libXext-devel
130 BuildRequires:  xorg-lib-libXxf86vm-devel
131 BuildRequires:  zeromq-devel
132 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
133 %{!?with_nvidia_headers:BuildConflicts: xorg-driver-video-nvidia-devel}
134 # for Perl bindings
135 BuildRequires:  perl-ExtUtils-MakeMaker
136 ExclusiveArch:  %{ix86} %{x8664} ppc
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 %define myth_api_version %(echo %{version} | cut -d. -f1,2)
140
141 # libmythavdevice.so.52.2.1 missing -l???: sem_init sem_destroy sem_post sem_timedwait
142 # libmythavcodec.so.52.86.1 missing -lpthread: pthread_create pthread_join
143 %define         skip_post_check_so      libmythavdevice.so libmythavcodec.so
144 %define         no_install_post_check_so 1
145
146 %description
147 MythTV implements the following PVR features, and more, with a unified
148 graphical interface:
149 - Basic 'live-tv' functionality. Pause/Fast Forward/Rewind "live" TV.
150 - Video compression using RTjpeg or MPEG-4
151 - Program listing retrieval using XMLTV
152 - Themable, semi-transparent on-screen display
153 - Electronic program guide
154 - Scheduled recording of TV programs
155 - Resolution of conflicts between scheduled recordings
156 - Basic video editing
157
158 %description -l pl.UTF-8
159 MythTV implementuje następujące możliwości PVR, a nawet więcej, wraz z
160 ujednoliconym interfejsem graficznym:
161 - podstawowa funkcjonalność "live-tv"; pauza, szybkie przewijanie,
162   przewijanie "żywej" telewizji
163 - kompresja obrazu przy użyciu RTjpeg lub MPEG-4
164 - odczyt listy programów przy użyciu XMLTV
165 - pseudoprzezroczyste wyświetlanie na obrazie (OSD) z obsługą motywów
166 - elektroniczny przewodnik po programie
167 - planowane nagrywanie programów telewizyjnych
168 - rozwiązywanie konfliktów między planowanymi nagraniami
169 - podstawowa edycja obrazu
170
171 %package backend
172 Summary:        Server component of mythtv (a PVR)
173 Summary(pl.UTF-8):      Część serwerowa mythtv (PVR)
174 Group:          Applications/Multimedia
175 Requires(post,preun):   /sbin/chkconfig
176 Requires(postun):       /usr/sbin/groupdel
177 Requires(postun):       /usr/sbin/userdel
178 Requires(pre):  /bin/id
179 Requires(pre):  /usr/bin/getgid
180 Requires(pre):  /usr/sbin/groupadd
181 Requires(pre):  /usr/sbin/useradd
182 Requires:       libmyth = %{version}-%{release}
183 Requires:       mythtv = %{version}-%{release}
184 Suggests:       mysql
185 Provides:       group(mythtv)
186 Provides:       user(mythtv)
187 Conflicts:      logrotate < 3.8.0
188
189 %description backend
190 MythTV provides a unified graphical interface for recording and
191 viewing television programs. Refer to the mythtv package for more
192 information.
193
194 This package contains only the server software, which provides video
195 and audio capture and encoding services. In order to be useful, it
196 requires a mythtv-frontend installation, either on the same system or
197 one reachable via the network.
198
199 %description backend -l pl.UTF-8
200 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
201 oglądania programów telewizyjnych. Więcej informacji w pakiecie
202 mythtv.
203
204 Ten pakiet zawiera tylko oprogramowanie serwerowe, udostępniające
205 usługi przechwytywania i kodowania obrazu i dźwięku. Aby było
206 przydatne, wymaga instalacji mythtv-frontend - na tym samym systemie,
207 albo innym osiągalnym w sieci.
208
209 %package frontend
210 Summary:        Client component of mythtv (a PVR)
211 Summary(pl.UTF-8):      Część kliencka mythtv (PVR)
212 Group:          Applications/Multimedia
213 Requires:       libmyth = %{version}-%{release}
214 Requires:       mythtv = %{version}-%{release}
215 Requires:       mythtv-themes = %{version}-%{release}
216 Provides:       mythtv-frontend-api = %{myth_api_version}
217
218 %description frontend
219 MythTV provides a unified graphical interface for recording and
220 viewing television programs. Refer to the mythtv package for more
221 information.
222
223 This package contains only the client software, which provides a
224 front-end for playback and configuration. It requires access to a
225 mythtv-backend installation, either on the same system or one
226 reachable via the network.
227
228 %description frontend -l pl.UTF-8
229 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
230 oglądania programów telewizyjnych. Więcej informacji w pakiecie
231 mythtv.
232
233 Ten pakiet zawiera tylko oprogramowanie klienckie, dostarczające
234 frontend do odtwarzania i konfiguracji. Wymaga dostępu do instalacji
235 mythtv-backend - na tym samym systemie, albo innym osiągalnym w sieci.
236
237 %package setup
238 Summary:        Setup the mythtv backend
239 Summary(pl.UTF-8):      Konfigurator backendu mythtv
240 Group:          Applications/Multimedia
241 Requires:       libmyth = %{version}-%{release}
242
243 %description setup
244 MythTV provides a unified graphical interface for recording and
245 viewing television programs. Refer to the mythtv package for more
246 information.
247
248 This package contains only the setup software for configuring the
249 mythtv backend.
250
251 %description setup -l pl.UTF-8
252 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
253 oglądania programów telewizyjnych. Więcej informacji w pakiecie
254 mythtv.
255
256 Ten pakiet zawiera tylko program do konfigurowania backendu mythtv.
257
258 %package themes
259 Summary:        Base themes for mythtv's frontend
260 Summary(pl.UTF-8):      Podstawowe motywy dla frontendu mythtv
261 Group:          Themes
262 Requires:       %{name}-frontend = %{version}-%{release}
263
264 %description themes
265 MythTV provides a unified graphical interface for recording and
266 viewing television programs. Refer to the mythtv package for more
267 information.
268
269 This package contains only the base themes used by the frontend and
270 mythtvsetup.
271
272 %description themes -l pl.UTF-8
273 MythTV dostarcza ujednolicony interfejs graficzny do nagrywania i
274 oglądania programów telewizyjnych. Więcej informacji w pakiecie
275 mythtv.
276
277 Ten pakiet zawiera tylko podstawowe motywy używane przez frontend oraz
278 mythtvsetup.
279
280 %package -n libmyth
281 Summary:        Library providing mythtv support
282 Summary(pl.UTF-8):      Biblioteka udostępniająca obsługę mythtv
283 Group:          Libraries
284 Requires:       QtSql-mysql
285 Requires:       freetype >= 1:2.0.0
286 Requires:       lame
287
288 %description -n libmyth
289 Common library code for MythTV and add-on modules (development) MythTV
290 provides a unified graphical interface for recording and viewing
291 television programs. Refer to the mythtv package for more information.
292
293 %description -n libmyth -l pl.UTF-8
294 Wspólny kod biblioteki dla MythTV i dodatkowych modułów MythTV
295 dostarczający ujednolicony interfejs graficzny do nagrywania i
296 oglądania programów telewizyjnych. Więcej informacji w pakiecie
297 mythtv.
298
299 %package -n libmyth-devel
300 Summary:        Development files for libmyth
301 Summary(pl.UTF-8):      Pliki nagłówkowe libmyth
302 Group:          Development/Libraries
303 Requires:       libmyth = %{version}-%{release}
304
305 %description -n libmyth-devel
306 This package contains the header files for developing add-ons for
307 mythtv.
308
309 %description -n libmyth-devel -l pl.UTF-8
310 Ten pakiet zawiera pliki nagłówkowe do tworzenia dodatków dla mythtv.
311
312 %package -n libmyth-static
313 Summary:        Static libmyth library
314 Summary(pl.UTF-8):      Statyczna biblioteka libmyth
315 Group:          Development/Libraries
316 Requires:       libmyth-devel = %{version}-%{release}
317
318 %description -n libmyth-static
319 Static libmyth library.
320
321 %description -n libmyth-static -l pl.UTF-8
322 Statyczna biblioteka libmyth.
323
324 %package -n perl-MythTV
325 Summary:        MythTV Perl bindings
326 Summary(pl.UTF-8):      Interfejs Perla dla MythTV
327 Group:          Libraries
328
329 %description -n perl-MythTV
330 MythTV Perl bindings.
331
332 %description -n perl-MythTV -l pl.UTF-8
333 Ten pakiet zawiera moduły Perla do tworzenia dodatków dla mythtv.
334
335 %package -n python-MythTV
336 Summary:        MythTV Python bindings
337 Summary(pl.UTF-8):      Interfejs Pythona dla MythTV
338 Group:          Libraries
339 Requires:       python-MySQLdb
340
341 %description -n python-MythTV
342 MythTV Python bindings.
343
344 %description -n python-MythTV -l pl.UTF-8
345 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
346
347 %package -n php-MythTV
348 Summary:        MythTV PHP bindings
349 Summary(pl.UTF-8):      Interfejs PHP dla MythTV
350 Group:          Libraries
351
352 %description -n php-MythTV
353 MythTV PHP bindings.
354
355 %description -n php-MythTV -l pl.UTF-8
356 Ten pakiet zawiera moduły PHP do tworzenia dodatków dla mythtv.
357
358 %prep
359
360 %setup -q
361
362 %{__sed} -i -e 's,/var/log/mythfilldatabase.log,/var/log/mythtv/mythfilldatabase.log,' \
363         programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
364
365 %patch0  -p1
366 %patch1  -p1
367 %{?with_dshowserver:%patch20 -p1}
368 #%patch30 -p1
369
370 rm -rf database/old # not supported in PLD
371
372 # lib64 fix - enable to update patch
373 %if %{_lib} != "lib" && 0
374 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
375 xargs grep -l /lib . | xargs sed -i -e '
376         s,/''usr/lib/,/%{_libdir}/,g
377         s,/''lib/mythtv,/%{_lib}/mythtv,g
378         s,{PREFIX}/lib$,{PREFIX}/%{_lib},g
379 '
380 exit 1
381 %endif
382
383 # Assigning null to QMAKE_LIBDIR_QT will prevent makefiles contain
384 # -L$(QTDIR)/%{_lib} and -Wl,-rpath,$(QTDIR)/%{_lib}. And that will
385 # prevent compiler finding libs from system when they should be looked
386 # from current buildtree.
387 # but that made it link with -lqt which doesn't exist, instead of -lqt-mt
388 # so we make QMAKE wrapper which will do sed subst after calling
389 # qmake. this is the wrapper.
390 cat > qmake-wrapper.sh <<'EOF'
391 #!/bin/sh
392 getmakefile() {
393         while [ $# -gt 0 ]; do
394                 case "$1" in
395                 -o)
396                         shift
397                         makefile="$1"
398                         return
399                         ;;
400         esac
401                 shift
402         done
403 }
404
405 qmake-qt4 "$@"
406 getmakefile "$@"
407 if [ "$makefile" ]; then
408         %{__sed} -i -e '
409                 s;-Wl,-rpath,$(QTDIR)/%{_lib};;
410                 s;-L$(QTDIR)/%{_lib};;
411         ' $makefile
412 fi
413 EOF
414 chmod +x qmake-wrapper.sh
415
416 # move perl bindings to vendor prefix
417 sed -i -e 's#perl Makefile.PL#%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"#' \
418   bindings/perl/Makefile
419
420 %build
421
422 %if %{with cpu_autodetect}
423 # Make sure we have /proc mounted
424 if [ ! -r /proc/cpuinfo ]; then
425         echo "You need to have /proc mounted in order to build with cpu_autodetect!"
426         exit 1
427 fi
428 %endif
429
430 ./configure \
431         --prefix=%{_prefix} \
432         --libdir=%{_libdir} \
433         --libdir-name=%{_lib} \
434         --mandir=%{_mandir} \
435         --disable-distcc --disable-ccache \
436         --compile-type=%{?debug:debug}%{!?debug:release} \
437         --extra-cflags="%{rpmcflags} -fomit-frame-pointer" \
438         --extra-cxxflags="%{rpmcxxflags} -fomit-frame-pointer" \
439 %if %{with cpu_autodetect}
440         --enable-proc-opt \
441 %else
442         %ifarch %{ix86}
443                 %ifarch athlon
444                         --arch=athlon \
445                 %else
446                         --cpu=%{_target_cpu} --tune=pentium4 \
447                 %endif
448         %endif
449         %ifarch i386 i486 i586
450         --enable-disable-mmx-for-debugging \
451         %endif
452         %ifarch %{x8664}
453         --arch=x86_64 \
454         %endif
455         %{?with_mmx:--enable-mmx} \
456 %endif
457         %{?with_dvb:--enable-dvb --dvb-path=%{_includedir}} \
458         --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
459         --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
460         --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
461         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
462         --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
463         --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
464         --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
465         --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
466         --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
467         --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
468         --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
469         --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
470         --enable-xv \
471         --enable-x11 \
472
473 #%{_libdir}/qt4/bin/qmake mythtv.pro
474 %{__make}
475
476 %install
477 rm -rf $RPM_BUILD_ROOT
478 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
479                 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_desktopdir}} \
480                 $RPM_BUILD_ROOT/var/{cache,log,run}/mythtv \
481                 $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
482                 $RPM_BUILD_ROOT%{_libdir}/mythtv \
483                 $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
484                 $RPM_BUILD_ROOT%{_pixmapsdir} \
485                 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
486
487 %{__make} install \
488         INSTALL_ROOT=$RPM_BUILD_ROOT
489
490 # Install the files that we added on top of mythtv's own stuff
491 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mythbackend
492 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
493 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
494 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
495
496 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
497
498 # desktop entries
499 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
500 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
501
502 # Install settings.pro so people can see the build options we used
503 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/build
504 install config.mak settings.pro $RPM_BUILD_ROOT%{_datadir}/mythtv/build
505
506 for p in mythfrontend; do
507         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
508                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
509         done > $p.lang
510 done
511
512 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/locales/*.xml; do
513         echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*/\(.*\).xml\),%%lang(\2) \1,"
514 done > mythbackend.lang
515
516 # glibc language codes. attempt was made to change it on libmyth side,
517 # but that was just asking for trouble due large coverage of
518 # language.lower() usage.
519 sed -i -e '
520 s,%%lang(en_gb),%%lang(en_GB),
521 s,%%lang(zh_tw),%%lang(zh_TW),
522 s,%%lang(pt_br),%%lang(pt_BR),
523 ' *.lang
524
525 rm -rf mythwelcome mythlcdserver
526 install -d mythwelcome
527 cp -a programs/mythwelcome/README mythwelcome
528 cp -a programs/mythlcdserver/README mythlcdserver
529
530 %clean
531 rm -rf $RPM_BUILD_ROOT
532
533 %pre backend
534 %groupadd -g 149 %{name}
535 %useradd -u 149 -d /var/lib/mythtv -g %{name} -c "MythTV User" %{name}
536 %addusertogroup %{name} video
537 %addusertogroup %{name} audio
538
539 %post backend
540 /sbin/chkconfig --add mythbackend
541
542 %preun backend
543 if [ "$1" = "0" ]; then
544         %service -q mythbackend stop
545         /sbin/chkconfig --del mythbackend
546 fi
547
548 %postun backend
549 if [ "$1" = "0" ]; then
550         %userremove %{name}
551         %groupremove %{name}
552 fi
553
554 %post   -n libmyth -p /sbin/ldconfig
555 %postun -n libmyth -p /sbin/ldconfig
556
557 %post setup
558 if [ "$1" = 1 ]; then
559 %banner -e %{name}-setup <<EOF
560 To grant mysql permissions to mythtv, please run
561 zcat %{_docdir}/%{name}-setup-%{version}/database/mc.sql.gz | mysql
562 EOF
563 fi
564
565 %files
566 %defattr(644,root,root,755)
567 %doc README* UPGRADING AUTHORS FAQ
568 %doc docs contrib
569 %doc keys.txt mythwelcome mythlcdserver
570
571 %files backend -f mythbackend.lang
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_bindir}/mythbackend
574 %attr(755,root,root) %{_bindir}/mythcommflag
575 %attr(755,root,root) %{_bindir}/mythfilldatabase
576 %attr(755,root,root) %{_bindir}/mythjobqueue
577 %attr(755,root,root) %{_bindir}/mythlcdserver
578 %attr(755,root,root) %{_bindir}/mythlogserver
579 %attr(755,root,root) %{_bindir}/mythmediaserver
580 %attr(755,root,root) %{_bindir}/mythtranscode
581 %attr(755,root,root) %{_bindir}/mythreplex
582 %attr(755,root,root) %{_bindir}/mythffmpeg
583 %attr(755,root,root) %{_bindir}/mythpreviewgen
584 %attr(755,root,root) %{_bindir}/mythccextractor
585 %attr(755,root,root) %{_bindir}/mythmetadatalookup
586 %attr(755,root,root) %{_bindir}/mythutil
587
588 %attr(775,root,mythtv) %dir /var/lib/mythtv
589 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
590 %attr(775,root,mythtv) %dir /var/cache/mythtv
591 %attr(775,root,mythtv) %dir /var/run/mythtv
592 /usr/lib/tmpfiles.d/%{name}.conf
593 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
595 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
596 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
597 %{_datadir}/mythtv/backend-config
598 %{_datadir}/mythtv/html
599
600 %files frontend -f mythfrontend.lang
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_bindir}/mythfrontend
603 %attr(755,root,root) %{_bindir}/mythshutdown
604 %attr(755,root,root) %{_bindir}/mythavtest
605 %attr(755,root,root) %{_bindir}/mythwelcome
606 %dir %{_datadir}/mythtv
607 %dir %{_datadir}/mythtv/themes
608 %{_datadir}/mythtv/internetcontent
609 %if %{without perl}
610 %exclude %{_datadir}/mythtv/internetcontent/nv_perl_libs
611 %endif
612 %{_datadir}/mythtv/metadata
613 %dir %{_libdir}/mythtv
614 %{_datadir}/mythtv/*.xml
615 %dir %{_libdir}/mythtv/filters
616 %dir %{_libdir}/mythtv/plugins
617 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
618 %dir %{_datadir}/mythtv/fonts
619 %{_datadir}/mythtv/fonts/*.ttf
620 %{_datadir}/mythtv/fonts/*.otf
621 %dir %{_datadir}/mythtv/i18n
622 %if %{with dshowserver}
623 %{_datadir}/mythtv/dshowcodecs
624 %endif
625 %{_desktopdir}/*.desktop
626 %{_pixmapsdir}/*.png
627
628 %files setup
629 %defattr(644,root,root,755)
630 %doc database
631 %attr(755,root,root) %{_bindir}/mythtv-setup
632
633 %files themes
634 %defattr(644,root,root,755)
635 %{_datadir}/mythtv/themes/*
636
637 %files -n libmyth
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/lib*.so.*
640 %attr(755,root,root) %{_libdir}/lib*.a
641 %dir %{_datadir}/mythtv
642 %{_datadir}/mythtv/*.pl
643 %{_datadir}/mythtv/hardwareprofile
644
645 %files -n libmyth-devel
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/*.so
648 %{_includedir}/*
649 %{_datadir}/mythtv/build
650
651 %files -n libmyth-static
652 %defattr(644,root,root,755)
653
654 %if %{with perl}
655 %files -n perl-MythTV
656 %defattr(644,root,root,755)
657 %{perl_vendorlib}/MythTV.pm
658 %dir %{perl_vendorlib}/MythTV
659 %{perl_vendorlib}/MythTV/*.pm
660 %dir %{perl_vendorlib}/IO/Socket/INET
661 %{perl_vendorlib}/IO/Socket/INET/MythTV.pm
662 %exclude %{perl_vendorarch}/auto/MythTV/.packlist
663 %endif
664
665 %if %{with python}
666 %files -n python-MythTV
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/mythpython
669 %dir %{py_sitescriptdir}/MythTV
670 %{py_sitescriptdir}/MythTV/*
671 %{py_sitescriptdir}/*.egg-info
672 %endif
673
674 %if %{with php}
675 %files -n php-MythTV
676 %defattr(644,root,root,755)
677 %endif
This page took 0.075672 seconds and 3 git commands to generate.