]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- mythmusic descriptions
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythmovies      # disable mythmovies plugin
7 %bcond_without  mythdvd         # mythvideo part
8 %bcond_without  mythnetvision   # disable building mythnetvision plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythvideo       # disable building mythgallery plugin
14 %bcond_without  mythweather     # building mythgallery plugin disabled by default
15                                 # it looks unusable "due to msnbc webpage structure change
16 %bcond_without  mythweb         # disable building mythgallery plugin
17 %bcond_without  mythzoneminder  # disable building mythzoneminder plugin
18
19 %if !%{with binary}
20 %undefine       with_mytharchive
21 %undefine       with_mythbrowser
22 %undefine       with_mythmovies
23 %undefine       with_mythdvd
24 %undefine       with_mythnetvision
25 %undefine       with_mythgallery
26 %undefine       with_mythgame
27 %undefine       with_mythmusic
28 %undefine       with_mythnews
29 %undefine       with_mythvideo
30 %undefine       with_mythweather
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34
35 #%define fix     24635
36
37 Summary:        Main MythTV plugins
38 Summary(pl.UTF-8):      Główne wtyczki MythTV
39 Name:           mythplugins
40 Version:        0.23
41 #Release:       fix%{fix}.1
42 Release:        0.1
43 License:        GPL v2
44 Group:          Applications/Multimedia
45 Source0:        ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
46 # Source0-md5:  be44db841f9e03d0d17ab449545b38aa
47 Source1:        mythweb.conf
48 #Patch0: %{name}-lib64.patch
49 #Patch1: %{name}-paths.patch
50 Patch2:         mythweb-chdir.patch
51 Patch20:        %{name}-mytharchive-INT64.patch
52 #Patch21:       mythmusic_fftw3.patch
53 #Patch100:      mythtv-branch.diff
54 URL:            http://www.mythtv.org/
55 %if %{with binary}
56 %if %{with mythgallery} || %{with myhtmusic}
57 BuildRequires:  OpenGL-devel
58 %endif
59 BuildRequires:  Qt3Support-devel
60 BuildRequires:  QtCore-devel
61 BuildRequires:  QtGui-devel
62 BuildRequires:  QtNetwork-devel
63 BuildRequires:  QtOpenGL-devel
64 BuildRequires:  QtSql-devel
65 BuildRequires:  QtWebKit-devel
66 BuildRequires:  QtXml-devel
67 BuildRequires:  SDL-devel
68 BuildRequires:  a52dec-libs-devel
69 BuildRequires:  cdparanoia-III-devel
70 BuildRequires:  faad2-devel >= 2.0-5.2
71 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
72 BuildRequires:  flac-devel >= 1.0.4
73 BuildRequires:  freetype-devel
74 BuildRequires:  libcdaudio-devel >= 0.99.12p2
75 BuildRequires:  libdvdcss-devel >= 1.2.7
76 BuildRequires:  libdvdread-devel >= 0.9.4
77 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
78 BuildRequires:  libfame-devel >= 0.9.0
79 BuildRequires:  libid3tag-devel
80 BuildRequires:  libmad-devel
81 BuildRequires:  libmyth-devel > 0.21
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  libtiff-devel
84 BuildRequires:  libvorbis-devel >= 1:1.0
85 BuildRequires:  mjpegtools-devel >= 1.6.1
86 BuildRequires:  nasm
87 BuildRequires:  patchutils
88 BuildRequires:  qt4-build
89 BuildRequires:  qt4-qmake
90 BuildRequires:  rpm-perlprov >= 4.1-13
91 BuildRequires:  sed >= 4.0
92 %{?with_mythmusic:BuildRequires:        taglib-devel}
93 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xvid-devel >= 1:0.9.1
96 BuildRequires:  zlib-devel
97 %endif
98 %{?with_mytharchive:Requires:   mytharchive}
99 %{?with_mythbrowser:Requires:   mythbrowser}
100 %{?with_mythdvd:Requires:       mythdvd}
101 %{?with_mythnetvision:Requires: mythnetvision}
102 %{?with_mythgallery:Requires:   mythgallery}
103 %{?with_mythgame:Requires:      mythgame}
104 %{?with_mythmysic:Requires:     mythmusic}
105 %{?with_mythnews:Requires:      mythnews}
106 %{?with_mythvideo:Requires:     mythvideo}
107 %{?with_mythweather:Requires:   mythweather}
108 %{?with_mythweb:Requires:       mythweb}
109 ExclusiveArch:  %{ix86} %{x8664} ppc
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
113 %define         _webapps        /etc/webapps
114 %define         _webapp         mythweb
115
116 %description
117 This is a consolidation of all the official MythTV plugins that used
118 to be distributed as separate downloads from mythtv.org.
119
120 %description -l pl.UTF-8
121 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
122 wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
123
124 %package -n mytharchive
125 Summary:        A MythTV module to create and burn DVDs
126 Summary(pl.UTF-8):      Moduł MythTV do tworzenia i wypalania DVD
127 Group:          Applications/Multimedia
128 Requires:       dvdauthor
129 Requires:       mjpegtools
130 Requires:       mythtv-frontend-api = %{myth_api_version}
131 Requires:       python-MySQLdb
132 Requires:       python-PIL
133 Suggests:       dvdrtools-mkisofs
134
135 %description -n mytharchive
136 MythArchive is a MythTV style plugin that uses the Mythburn Script to
137 create and burn DVDs from MythTV recordings, MythVideo files or any
138 video files available on a MythTV system. It can also export
139 recordings to a native archive format that can then be imported back
140 into a MythTV system restoring all the associated metadata.
141
142 %description -n mytharchive -l pl.UTF-8
143 MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
144 i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
145 innych plików z filmami dostępnych w systemie MythTV. Może także
146 eksportować nagrania do natywnego formatu archiwum, który potem można
147 zaimportować z powrotem do systemu MythTV przywracając wszystkie
148 związane z nimi metadane.
149
150 %package -n mythmusic
151 Summary:        The music player add-on module for MythTV
152 Summary(pl.UTF-8):      Moduł odtwarzacza muzyki dla MythTV
153 Group:          Applications/Multimedia
154 BuildRequires:  libvisual-devel
155 Requires:       mythtv-frontend-api = %{myth_api_version}
156
157 %description -n mythmusic
158 Music add-on for MythTV. Support playlists, visualisations, tag editing
159 and plays many popular audio file formats - mp3, flac, wav, ogg etc.
160
161 %description -n mythmusic -l pl.UTF-8
162 Odtwarzacz muzyki dla MythTV. Obsługuje listy odtwarzania, wizualizacje,
163 edycję tagów.
164 Potrafi odtwarzać wiele popularnych formatów audio - mp3, flac, wav, ogg
165 itd.
166
167 %package -n mythvideo
168 Summary:        A generic video player frontend module for MythTV
169 Summary(pl.UTF-8):      Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
170 Group:          Applications/Multimedia
171 Requires:       mplayer
172 Requires:       mythtv-frontend-api = %{myth_api_version}
173
174 %description -n mythvideo
175 A generic video and dvd player frontend module for MythTV.
176
177 %description -n mythvideo -l pl.UTF-8
178 Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
179
180 %package -n mythweather
181 Summary:        A MythTV module that displays a weather forcast
182 Summary(pl.UTF-8):      Moduł MythTV wyświetlający prognozę pogody
183 Group:          Applications/Multimedia
184 Requires:       mythtv-frontend-api = %{myth_api_version}
185
186 %description -n mythweather
187 A MythTV module that displays a weather forcast.
188
189 %description -n mythweather -l pl.UTF-8
190 Moduł MythTV wyświetlający prognozę pogody.
191
192 %package -n mythgallery
193 Summary:        A gallery/slideshow module for MythTV
194 Summary(pl.UTF-8):      Moduł galerii/pokazu slajdów dla MythTV
195 Group:          Applications/Multimedia
196 Requires:       mythtv-frontend-api = %{myth_api_version}
197
198 %description -n mythgallery
199 A gallery/slideshow module for MythTV.
200
201 %description -n mythgallery -l pl.UTF-8
202 Moduł galerii/pokazu slajdów dla MythTV.
203
204 %package -n mythgame
205 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
206 Summary(pl.UTF-8):      Interfejs do gier (xmame, nes, snes, pc) dla MythTV
207 Group:          Applications/Multimedia
208 Requires:       mythtv-frontend-api = %{myth_api_version}
209
210 %description -n mythgame
211 A game frontend (xmame, nes, snes, pc) for MythTV.
212
213 %description -n mythgame -l pl.UTF-8
214 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
215
216 %package -n mythdvd
217 Summary:        A DVD ripper module for MythTV
218 Summary(pl.UTF-8):      Moduł rippujący DVD dla MythTV
219 Group:          Applications/Multimedia
220 Requires:       mythtv-frontend-api = %{myth_api_version}
221 Requires:       mythvideo
222 Requires:       transcode >= 0.6.8
223
224 %description -n mythdvd
225 MythDVD is a MythTV module that allows you to rip DVD's and transcode
226 their video and audio content to other (generally smaller) formats.
227 The playing features are simply myth-style wrappers for your favourite
228 DVD playing software (mplayer, ogle, xine, etc). The transcoding is
229 based on and derived from the excellent transcode package.
230
231 %description -n mythdvd -l pl.UTF-8
232 MythDVD to moduł MythTV umożliwiający rippowanie DVD oraz
233 przekodowywanie obrazu i dźwięku do innych (zwykle mniej zajmujących)
234 formatów. Możliwości odtwarzania to po prostu obudowanie w stylu myth
235 dla ulubionego oprogramowania do odtwarzania DVD (mplayer, ogle, xine
236 itp.). Przekodowywanie jest oparte i wywodzi się ze wspaniałego
237 pakietu transcode.
238
239 %package -n mythnews
240 Summary:        A RSS News Feed plugin for MythTV
241 Summary(pl.UTF-8):      Wtyczka czytnika nowinek RSS dla MythTV
242 Group:          Applications/Multimedia
243 Requires:       mythtv-frontend-api = %{myth_api_version}
244
245 %description -n mythnews
246 A RSS News Feed plugin for MythTV.
247
248 %description -n mythnews -l pl.UTF-8
249 Wtyczka czytnika nowinek RSS dla MythTV.
250
251 %package -n mythbrowser
252 Summary:        A small web browser module for MythTV
253 Summary(pl.UTF-8):      Moduł małej przeglądarki WWW dla MythTV
254 Group:          Applications/Multimedia
255 Requires:       mythtv-frontend-api = %{myth_api_version}
256
257 %description -n mythbrowser
258 MythBrowser is a full fledged web-browser (multiple tabs) to display
259 webpages in full-screen mode. Simple page navigation is possible.
260 Starting with version 0.13 it also has full support for mouse driven
261 navigation (right mouse opens and closes the popup menu).
262
263 MythBrowser also contains a BookmarkManager to manage the website
264 links in a simple mythplugin.
265
266 %description -n mythbrowser -l pl.UTF-8
267 MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
268 zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
269 jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
270 obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
271 menu).
272
273 MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
274 do stron w prostej wtyczce myth.
275
276 %package -n mythweb
277 Summary:        The web interface to MythTV
278 Summary(pl.UTF-8):      Interfejs WWW do MythTV
279 Group:          Applications/Multimedia
280 Requires:       php(mysql)
281 Requires:       php(posix)
282 Requires:       webapps
283 Requires:       webserver(php) >= 4.3
284 #Suggests:      apache(mod_auth)
285 #Suggests:      apache(mod_env)
286
287 %description -n mythweb
288 The web interface to MythTV.
289
290 %description -n mythweb -l pl.UTF-8
291 Interfejs WWW do MythTV.
292
293 %package -n mythnetvision
294 Summary:        Mythtv extension to watch network movie shows
295 Summary(pl.UTF-8):      Dodatek do MythTV do oglądania sieciowych transmisji
296 Group:          Applications/Multimedia
297 Requires:       mythtv-frontend-api = %{myth_api_version}
298 Requires:       mythbrowser
299
300 %description -n mythnetvision
301 Mythtv extension to watch network movie shows (ex. YouTube).
302
303 %description -n mythnetvision -l pl.UTF-8
304 Dodatek do MythTV do oglądania sieciowych transmisji.
305 Na przykład z YouTube.
306
307 %package -n mythmovies
308 Summary:        MythTV cinemas timetable
309 Summary(pl.UTF-8):      Moduł MythTV do repertuaru kinowego
310 Group:          Applications/Multimedia
311 Requires:       mythtv-frontend-api = %{myth_api_version}
312
313 %description -n mythmovies
314 MythTV cinemas timetable.
315
316
317 %description -n mythmovies -l pl.UTF-8
318 Moduł MythTV do repertuaru kinowego.
319
320 %package -n mythzoneminder
321 Summary:        MythTV security TV manager
322 Summary(pl.UTF-8):      Obsługa kamer przemysłowych dla MythTV
323 Group:          Applications/Multimedia
324 Requires:       mythtv-frontend-api = %{myth_api_version}
325
326 %description -n mythzoneminder
327 MythTV security TV manager.
328
329
330 %description -n mythzoneminder -l pl.UTF-8
331 Obsługa kamer przemysłowych dla MythTV.
332
333 %prep
334 %setup -q -n %{name}-%{version}
335 #%if %{_lib} != "lib"
336 #%patch0 -p1
337 #%endif
338 #%patch1 -p1
339 %patch2 -p1
340 %patch20 -p1
341 #%patch21 -p1
342 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
343
344 # make it visible
345 #mv mythweb/data/{.,}htaccess
346
347 # lib64 fix - enable to update patch
348 %if %{_lib} != "lib" && 0
349 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
350 xargs grep -l /lib/ . | xargs sed -i -e '
351         s,/usr/lib/,/%{_lib}/,g
352         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
353 '
354 exit 1
355 %endif
356
357 %build
358 %if %{with binary}
359 export QTDIR="%{_prefix}"
360 # Not gnu configure
361 %configure \
362         --libdir-name=`basename %{_lib}` \
363         --enable-all \
364         %{!?with_mytharchive:--disable-mytharchive} \
365         %{!?with_mythbrowser:--disable-mythbrowser} \
366         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
367         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
368         %{!?with_mythgame:--disable-mythgame} \
369         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
370         %{!?with_mythnews:--disable-mythnews} \
371         %{!?with_mythvideo:--disable-mythvideo} \
372         %{!?with_mythweather:--disable-mythweather} \
373         %{!?with_mythweb:--disable-mythweb} \
374         %{!?with_mythmovies:--disable-mythmovies} \
375         %{!?with_mythnetvision:--disable-mythnetvision} \
376
377 mv mythconfig.mak mythconfig.mak.old
378 cp mythconfig.mak.old mythconfig.mak
379 cat <<'EOF'>> mythconfig.mak
380 QMAKE_CXX=%{__cxx}
381 QMAKE_CC=%{__cc}
382 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
383 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
384 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
385 EOF
386
387 %{__make}
388 %endif
389
390 %install
391 rm -rf $RPM_BUILD_ROOT
392 %if %{with binary}
393 export QTDIR="%{_prefix}"
394 %{__make} install \
395         INSTALL_ROOT=$RPM_BUILD_ROOT
396
397 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythbrowser,mythvideo,pictures}
398 %if %{with mythgame}
399 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
400 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
401 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
402 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
403 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
404 %endif
405 %endif
406
407 %if %{with mythweb}
408 cd mythweb
409 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
410 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
411 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
412 cp -a *.php *.pl classes configuration includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
413 ln -sf /var/cache/mythweb $RPM_BUILD_ROOT%{_datadir}/data
414 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
415 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
416 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
417 cd -
418 %endif
419
420 rm -f $RPM_BUILD_ROOT%{_datadir}/data
421 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
422 for p in mytharchive mythbrowser mythmovies mythdvd mythgallery mythgame mythmusic mythnews mythnetvision mythvideo mythweather mythzoneminder; do
423         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
424                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
425         done > $p.lang
426 done
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
432 %webapp_register apache %{_webapp}
433
434 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
435 %webapp_unregister apache %{_webapp}
436
437 %triggerin -n mythweb -- apache < 2.2.0, apache-base
438 %webapp_register httpd %{_webapp}
439
440 %triggerun -n mythweb -- apache < 2.2.0, apache-base
441 %webapp_unregister httpd %{_webapp}
442
443 %triggerpostun -n mythweb -- mythweb < 0.19
444 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
445         if [ -f /etc/mythweb/$i.rpmsave ]; then
446                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
447                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
448         fi
449 done
450 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
451
452 # migrate from apache-config macros
453 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
454         if [ -d /etc/apache/webapps.d ]; then
455                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
456                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
457         fi
458
459         if [ -d /etc/httpd/webapps.d ]; then
460                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
461                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
462         fi
463         rm -f /etc/mythweb/apache.conf.rpmsave
464 fi
465
466 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
467         rm -f /etc/apache/conf.d/99_mythplugins.conf
468         /usr/sbin/webapp register apache %{_webapp}
469         %service -q apache reload
470 fi
471 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
472         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
473         /usr/sbin/webapp register httpd %{_webapp}
474         %service -q httpd reload
475 fi
476
477 %files
478 %defattr(644,root,root,755)
479
480 %if %{with mytharchive}
481 %files -n mytharchive -f mytharchive.lang
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_bindir}/mytharchivehelper
484 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
485 %{_datadir}/mythtv/archivemenu.xml
486 %{_datadir}/mythtv/archiveutils.xml
487 %{_datadir}/mythtv/themes/default/ma_*.png
488 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
489 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
490 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
491 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
492 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
493 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
494 %{_datadir}/mythtv/mytharchive
495 %endif
496
497 %if %{with mythmusic}
498 %files -n mythmusic -f mythmusic.lang
499 %defattr(644,root,root,755)
500 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
501 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
502 /var/lib/mythmusic
503 %{_datadir}/mythtv/musicmenu.xml
504 %{_datadir}/mythtv/music_settings.xml
505 %{_datadir}/mythtv/themes/default/music-ui.xml
506 %{_datadir}/mythtv/themes/default/mm-titlelines.png
507 %{_datadir}/mythtv/themes/default-wide/music-ui.xml
508 %{_datadir}/mythtv/themes/default-wide/mm-titlelines.png
509 %{_datadir}/mythtv/themes/default/ff_button_off.png
510 %{_datadir}/mythtv/themes/default/ff_button_on.png
511 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
512 %{_datadir}/mythtv/themes/default/miniplayer_background.png
513 %{_datadir}/mythtv/themes/default/mm_*.png
514 %{_datadir}/mythtv/themes/default/music-sel-bg.png
515 %{_datadir}/mythtv/themes/default/next_button_off.png
516 %{_datadir}/mythtv/themes/default/next_button_on.png
517 %{_datadir}/mythtv/themes/default/next_button_pushed.png
518 %{_datadir}/mythtv/themes/default/pause_button_off.png
519 %{_datadir}/mythtv/themes/default/pause_button_on.png
520 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
521 %{_datadir}/mythtv/themes/default/play_button_off.png
522 %{_datadir}/mythtv/themes/default/play_button_on.png
523 %{_datadir}/mythtv/themes/default/play_button_pushed.png
524 %{_datadir}/mythtv/themes/default/prev_button_off.png
525 %{_datadir}/mythtv/themes/default/prev_button_on.png
526 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
527 %{_datadir}/mythtv/themes/default/rew_button_off.png
528 %{_datadir}/mythtv/themes/default/rew_button_on.png
529 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
530 %{_datadir}/mythtv/themes/default/selectionbar.png
531 %{_datadir}/mythtv/themes/default/stop_button_off.png
532 %{_datadir}/mythtv/themes/default/stop_button_on.png
533 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
534 %{_datadir}/mythtv/themes/default/track_info_background.png
535 %{_datadir}/mythtv/themes/default-wide/mm_*.png
536 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
537 %endif
538
539 %if %{with mythvideo}
540 %files -n mythvideo -f mythvideo.lang
541 %defattr(644,root,root,755)
542 %doc mythvideo/README mythvideo/videodb
543 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
544 %{_datadir}/mythtv/themes/default/video-ui.xml
545 %{_datadir}/mythtv/themes/default-wide/video-ui.xml
546 %{_datadir}/mythtv/themes/default/mv_*.png
547 %{_datadir}/mythtv/themes/default-wide/mv_*.png
548 %{_datadir}/mythtv/video_settings.xml
549 %{_datadir}/mythtv/videomenu.xml
550 %dir %{_datadir}/mythtv/mythvideo
551 %dir %{_datadir}/mythtv/mythvideo/scripts
552 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie
553 %dir %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV
554 %dir %{_datadir}/mythtv/mythvideo/scripts/Television
555 %{_datadir}/mythtv/mythvideo/scripts/README
556 %{_datadir}/mythtv/mythvideo/scripts/jamu.README
557 %{_datadir}/mythtv/mythvideo/scripts/jamu-example.conf
558 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.pl
559 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/*.py
560 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Movie/MythTV/*
561 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
562 %attr(644,root,root) %{_datadir}/mythtv/mythvideo/scripts/Television/*
563 /var/lib/mythvideo
564 %endif
565
566 %if %{with mythweather}
567 %files -n mythweather -f mythweather.lang
568 %defattr(644,root,root,755)
569 %doc mythweather/README
570 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
571 %{_datadir}/mythtv/mythweather
572 %{_datadir}/mythtv/weather_settings.xml
573 %{_datadir}/mythtv/themes/default/weather-ui.xml
574 %{_datadir}/mythtv/themes/default-wide/weather-ui.xml
575 %{_datadir}/mythtv/themes/default/cloudy.png
576 %{_datadir}/mythtv/themes/default/fair.png
577 %{_datadir}/mythtv/themes/default/flurries.png
578 %{_datadir}/mythtv/themes/default/fog.png
579 %{_datadir}/mythtv/themes/default/logo.png
580 %{_datadir}/mythtv/themes/default/lshowers.png
581 %{_datadir}/mythtv/themes/default/mcloudy.png
582 %{_datadir}/mythtv/themes/default/mw_*.png
583 %{_datadir}/mythtv/themes/default/mwmain.png
584 %{_datadir}/mythtv/themes/default/pcloudy.png
585 %{_datadir}/mythtv/themes/default/rainsnow.png
586 %{_datadir}/mythtv/themes/default/showers.png
587 %{_datadir}/mythtv/themes/default/snowshow.png
588 %{_datadir}/mythtv/themes/default/sunny.png
589 %{_datadir}/mythtv/themes/default/thunshowers.png
590 %{_datadir}/mythtv/themes/default/unknown.png
591 %{_datadir}/mythtv/themes/default-wide/mw-*.png
592 %endif
593
594 %if %{with mythgallery}
595 %files -n mythgallery -f mythgallery.lang
596 %defattr(644,root,root,755)
597 %doc mythgallery/README
598 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
599 %{_datadir}/mythtv/themes/default/gallery-ui.xml
600 %{_datadir}/mythtv/themes/default-wide/gallery-ui.xml
601 %{_datadir}/mythtv/themes/default/gallery-*.png
602 # FIXME: this is definately stupid path
603 /var/lib/pictures
604 %endif
605
606 %if %{with mythgame}
607 %files -n mythgame -f mythgame.lang
608 %defattr(644,root,root,755)
609 #%doc mythgame/README
610 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
611 %{_datadir}/mythtv/games
612 %{_datadir}/mythtv/game_settings.xml
613 %{_datadir}/mythtv/themes/default/game-ui.xml
614 %{_datadir}/mythtv/themes/default-wide/game-ui.xml
615 %endif
616
617 %if %{with mythdvd}
618 %files -n mythdvd
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/mtd
621 %{_datadir}/mythtv/themes/default/dvd-ui.xml
622 %{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
623 %{_datadir}/mythtv/themes/default/md_*.png
624 %endif
625
626 %if %{with mythnews}
627 %files -n mythnews -f mythnews.lang
628 %defattr(644,root,root,755)
629 %doc mythnews/README mythnews/AUTHORS
630 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
631 %{_datadir}/mythtv/mythnews
632 %{_datadir}/mythtv/themes/default/news-ui.xml
633 # DUPLICATE WITH MYTHFLIX?
634 %{_datadir}/mythtv/themes/default/news-info-bg.png
635 %{_datadir}/mythtv/themes/default/enclosures.png
636 %{_datadir}/mythtv/themes/default/need-download.png
637 %{_datadir}/mythtv/themes/default/podcast.png
638 %{_datadir}/mythtv/themes/default-wide/news-ui.xml
639 %endif
640
641 %if %{with mythbrowser}
642 %files -n mythbrowser -f mythbrowser.lang
643 %defattr(644,root,root,755)
644 %doc mythbrowser/README mythbrowser/AUTHORS
645 #%attr(755,root,root) %{_bindir}/mythbrowser
646 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbrowser.so
647 %{_datadir}/mythtv/themes/default/mb_progress*.png
648 %{_datadir}/mythtv/themes/default/browser-ui.xml
649 %{_datadir}/mythtv/themes/default-wide/browser-ui.xml
650 %endif
651
652 %if %{with mythweb}
653 %files -n mythweb
654 %defattr(644,root,root,755)
655 %doc mythweb/README mythweb/mythweb.conf.lighttpd
656 #%doc mythweb/data/htaccess
657 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
659 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
660 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
661 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
662 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
663 %{_datadir}/mythweb
664 %dir %attr(771,root,http) /var/cache/mythweb
665 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
666 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
667 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
668 %endif
669
670 %if %{with mythnetvision}
671 %files -n mythnetvision -f mythnetvision.lang
672 %defattr(644,root,root,755)
673 %doc mythnetvision/{AUTHORS,ChangeLog,README}
674 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnetvision.so
675 %dir %{_datadir}/mythtv/mythnetvision
676 %{_datadir}/mythtv/netvisionmenu.xml
677 %dir %{_datadir}/mythtv/mythnetvision/scripts
678 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/twit.tv.pl
679 %dir %{_datadir}/mythtv/mythnetvision/icons
680 %dir %{_datadir}/mythtv/mythnetvision/icons/directories
681 %{_datadir}/mythtv/mythnetvision/icons/*.png
682 %{_datadir}/mythtv/mythnetvision/icons/vimeo.jpg
683 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres
684 %{_datadir}/mythtv/mythnetvision/icons/directories/film_genres/*.png
685 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres
686 %{_datadir}/mythtv/mythnetvision/icons/directories/music_genres/*.png
687 %dir %{_datadir}/mythtv/mythnetvision/icons/directories/topics
688 %{_datadir}/mythtv/mythnetvision/icons/directories/topics/*.png
689 %attr(755,root,root) %{_datadir}/mythtv/mythnetvision/scripts/*.py
690 %dir %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs
691 %{_datadir}/mythtv/mythnetvision/scripts/nv_python_libs/*
692 %{_datadir}/mythtv/themes/default-wide/netvision-ui.xml   
693 %{_datadir}/mythtv/themes/default/netvision-ui.xml
694 %endif
695
696 %if %{with mythmovies}
697 %files -n mythmovies
698 %defattr(644,root,root,755)
699 #-f mythmovies.lang
700 %defattr(644,root,root,755)
701 %doc mythmovies/{README,TODO}
702 %attr(755,root,root) %{_bindir}/ignyte
703 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
704 %{_datadir}/mythtv/themes/default/movies-ui.xml
705 %{_datadir}/mythtv/themes/default-wide/movies-ui.xml
706 %{_datadir}/mythtv/i18n/mythmovies_*.qm
707 %endif
708
709 %if %{with mythzoneminder}
710 %files -n mythzoneminder
711 %defattr(644,root,root,755)
712 #-f mythmovies.lang
713 %defattr(644,root,root,755)
714 %doc mythzoneminder/{AUTHORS,README}
715 %attr(755,root,root) %{_bindir}/mythzmserver
716 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
717 %dir %{_datadir}/mythtv/zonemindermenu.xml
718 %{_datadir}/mythtv/themes/default/zoneminder-ui.xml
719 %{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
720 %{_datadir}/mythtv/themes/default/mz_*png
721 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
722 %endif
This page took 0.074208 seconds and 4 git commands to generate.