]> git.pld-linux.org Git - packages/mythplugins.git/blob - mythplugins.spec
- update webapp triggers due apache1 package split
[packages/mythplugins.git] / mythplugins.spec
1 #
2 # Conditional build:
3 %bcond_without  binary          # skip building binary plugins (build only mythweb)
4 %bcond_without  mytharchive     # disable mytharchive plugin
5 %bcond_without  mythbrowser     # disable building mythbrowser plugin
6 %bcond_without  mythcontrols    # disable mythcontrols plugin
7 %bcond_without  mythdvd         # disable building mythgallery plugin
8 %bcond_without  mythflix        # disable building mythflix plugin
9 %bcond_without  mythgallery     # disable building mythgallery plugin
10 %bcond_without  mythgame        # disable building mythgallery plugin
11 %bcond_without  mythmusic       # disable building mythmusic plugin
12 %bcond_without  mythnews        # disable building mythgallery plugin
13 %bcond_without  mythphone       # disable building mythgallery plugin
14 %bcond_without  mythvideo       # disable building mythgallery plugin
15 %bcond_without  mythweather     # disable building mythgallery plugin
16 %bcond_without  mythweb         # disable building mythgallery plugin
17 #
18 %if %{without binary}
19 %undefine       with_mytharchive
20 %undefine       with_mythbrowser
21 %undefine       with_mythcontrols
22 %undefine       with_mythdvd
23 %undefine       with_mythflix
24 %undefine       with_mythgallery
25 %undefine       with_mythgame
26 %undefine       with_mythmusic
27 %undefine       with_mythnews
28 %undefine       with_mythphone
29 %undefine       with_mythvideo
30 %undefine       with_mythweather
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34
35 #define _snap 20060905
36 #define _rev 11046
37 %define _rel 0.3
38 Summary:        Main MythTV plugins
39 Summary(pl):    G³ówne wtyczki MythTV
40 Name:           mythplugins
41 Version:        0.20a
42 Release:        %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
43 License:        GPL v2
44 Group:          Applications/Multimedia
45 Source0:        http://www.mythtv.org/mc/%{name}-%{version}.tar.bz2
46 # Source0-md5:  8a28e3e24a11364e883a43a6e23b3497
47 #Source0:       %{name}-%{_snap}.%{_rev}.tar.bz2
48 Source1:        mythweb.conf
49 Patch0:         %{name}-lib64.patch
50 Patch1:         %{name}-paths.patch
51 Patch2:         mythweb-config.patch
52 Patch100:       mythtv-branch.diff
53 URL:            http://www.mythtv.org/
54 %if %{with binary}
55 %if %{with mythgallery} || %{with myhtmusic}
56 BuildRequires:  OpenGL-devel
57 %endif
58 BuildRequires:  SDL-devel
59 BuildRequires:  XFree86-devel
60 BuildRequires:  a52dec-libs-devel
61 BuildRequires:  cdparanoia-III-devel
62 BuildRequires:  faad2-devel >= 2.0-5.2
63 %{?with_mythmusic:BuildRequires:        fftw-devel >= 2.1.3}
64 BuildRequires:  flac-devel >= 1.0.4
65 BuildRequires:  freetype-devel
66 BuildRequires:  kdelibs-devel
67 BuildRequires:  libcdaudio-devel >= 0.99.12p2
68 BuildRequires:  libdvdcss-devel >= 1.2.7
69 BuildRequires:  libdvdread-devel >= 0.9.4
70 %{?with_mythgallery:BuildRequires:      libexif-devel >= 1:0.6.9}
71 BuildRequires:  libfame-devel >= 0.9.0
72 BuildRequires:  libid3tag-devel
73 BuildRequires:  libmad-devel
74 BuildRequires:  libmyth-devel >= 0.19
75 BuildRequires:  libstdc++-devel
76 BuildRequires:  libtiff-devel
77 BuildRequires:  libvorbis-devel >= 1:1.0
78 BuildRequires:  mjpegtools-devel >= 1.6.1
79 BuildRequires:  nasm
80 BuildRequires:  patchutils
81 BuildRequires:  rpm-perlprov >= 4.1-13
82 BuildRequires:  sed >= 4.0
83 %{?with_mythdvd:BuildRequires:  transcode >= 0.6.8}
84 BuildRequires:  xvid-devel >= 1:0.9.1
85 BuildRequires:  zlib-devel
86 %endif
87 %{?with_mytharchive:Requires:   mytharchive}
88 %{?with_mythbrowser:Requires:   mythbrowser}
89 %{?with_mythdvd:Requires:       mythdvd}
90 %{?with_mythflix:Requires:      mythflix}
91 %{?with_mythgallery:Requires:   mythgallery}
92 %{?with_mythgame:Requires:      mythgame}
93 %{?with_mythmysic:Requires:     mythmusic}
94 %{?with_mythnews:Requires:      mythnews}
95 %{?with_mythphone:Requires:     mythphone}
96 %{?with_mythvideo:Requires:     mythvideo}
97 %{?with_mythweather:Requires:   mythweather}
98 %{?with_mythweb:Requires:       mythweb}
99 ExclusiveArch:  %{ix86} %{x8664} ppc
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
103 %define         _webapps        /etc/webapps
104 %define         _webapp         mythweb
105
106 %description
107 This is a consolidation of all the official MythTV plugins that used
108 to be distributed as separate downloads from mythtv.org.
109
110 %description -l pl
111 Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które by³y
112 wcze¶niej rozpowszechniane jako osobne pakiety na mythtv.org.
113
114 %package -n mytharchive
115 Summary:        A MythTV module to create and burn DVD's
116 Group:          Applications/Multimedia
117 Requires:       mythtv-frontend-api = %{myth_api_version}
118
119 %description -n mytharchive
120 MythArchive is a MythTV style plugin that uses the Mythburn Script to
121 create and burn DVD's from MythTV recordings, MythVideo files or any
122 video files available on a MythTV system. It can also export
123 recordings to a native archive format that can then be imported back
124 into a mythtv system restoring all the associated metadata.
125
126 %package -n mythmusic
127 Summary:        The music player add-on module for MythTV
128 Summary(pl):    Modu³ odtwarzacza muzyki dla MythTV
129 Group:          Applications/Multimedia
130 Requires:       mythtv-frontend-api = %{myth_api_version}
131
132 %description -n mythmusic
133 Music add-on for MythTV.
134
135 %description -n mythmusic -l pl
136 Odtwarzacz muzyki dla MythTV.
137
138 %package -n mythvideo
139 Summary:        A generic video player frontend module for MythTV
140 Summary(pl):    Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV
141 Group:          Applications/Multimedia
142 Requires:       mplayer
143 Requires:       mythtv-frontend-api = %{myth_api_version}
144
145 %description -n mythvideo
146 A generic video player frontend module for MythTV.
147
148 %description -n mythvideo -l pl
149 Modu³ ogólnego interfejsu do odtwarzania obrazu dla MythTV.
150
151 %package -n mythweather
152 Summary:        A MythTV module that displays a weather forcast
153 Summary(pl):    Modu³ MythTV wy¶wietlaj±cy prognozê pogody
154 Group:          Applications/Multimedia
155 Requires:       mythtv-frontend-api = %{myth_api_version}
156
157 %description -n mythweather
158 A MythTV module that displays a weather forcast.
159
160 %description -n mythweather -l pl
161 Modu³ MythTV wy¶wietlaj±cy prognozê pogody.
162
163 %package -n mythgallery
164 Summary:        A gallery/slideshow module for MythTV
165 Summary(pl):    Modu³ galerii/pokazu slajdów dla MythTV
166 Group:          Applications/Multimedia
167 Requires:       mythtv-frontend-api = %{myth_api_version}
168
169 %description -n mythgallery
170 A gallery/slideshow module for MythTV.
171
172 %description -n mythgallery -l pl
173 Modu³ galerii/pokazu slajdów dla MythTV.
174
175 %package -n mythgame
176 Summary:        A game frontend (xmame, nes, snes, pc) for MythTV
177 Summary(pl):    Interfejs do gier (xmame, nes, snes, pc) dla MythTV
178 Group:          Applications/Multimedia
179 Requires:       mythtv-frontend-api = %{myth_api_version}
180
181 %description -n mythgame
182 A game frontend (xmame, nes, snes, pc) for MythTV.
183
184 %description -n mythgame -l pl
185 Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
186
187 %package -n mythdvd
188 Summary:        A DVD player module for MythTV
189 Summary(pl):    Modu³ odtwarzacza DVD dla MythTV
190 Group:          Applications/Multimedia
191 Requires:       mythtv-frontend-api = %{myth_api_version}
192 Requires:       transcode >= 0.6.8
193
194 %description -n mythdvd
195 MythDVD is a MythTV module that allows you to play DVDs on a myth-box
196 and (optionally) rip DVD's and transcode their video and audio content
197 to other (generally smaller) formats. The playing features are simply
198 myth-style wrappers for your favourite DVD playing software (mplayer,
199 ogle, xine, etc). The transcoding is based on and derived from the
200 excellent transcode package.
201
202 %description -n mythdvd -l pl
203 MythDVD to modu³ MythTV umo¿liwiaj±cy odtwarzanie p³yt DVD w MythTV i
204 (opcjonalnie) rippowanie ich oraz przekodowywanie obrazu i d¼wiêku do
205 innych (zwykle mniej zajmuj±cych) formatów. Mo¿liwo¶ci odtwarzania to
206 po prostu obudowanie w stylu myth dla ulubionego oprogramowania do
207 odtwarzania DVD (mplayer, ogle, xine itp.). Przekodowywanie jest
208 oparte i wywodzi siê z wspania³ego pakietu transcode.
209
210 %package -n mythnews
211 Summary:        A RSS News Feed plugin for MythTV
212 Summary(pl):    Wtyczka czytnika nowinek RSS dla MythTV
213 Group:          Applications/Multimedia
214 Requires:       mythtv-frontend-api = %{myth_api_version}
215
216 %description -n mythnews
217 A RSS News Feed plugin for MythTV.
218
219 %description -n mythnews -l pl
220 Wtyczka czytnika nowinek RSS dla MythTV.
221
222 %package -n mythbrowser
223 Summary:        A small web browser module for MythTV
224 Summary(pl):    Modu³ ma³ej przegl±darki WWW dla MythTV
225 Group:          Applications/Multimedia
226 Requires:       mythtv-frontend-api = %{myth_api_version}
227
228 %description -n mythbrowser
229 MythBrowser is a full fledged web-browser (multiple tabs) to display
230 webpages in full-screen mode. Simple page navigation is possible.
231 Starting with version 0.13 it also has full support for mouse driven
232 navigation (right mouse opens and closes the popup menu).
233
234 MythBrowser also contains a BookmarkManager to manage the website
235 links in a simple mythplugin.
236
237 %description -n mythbrowser -l pl
238 MythBrowser to w pe³ni funkcjonalna przegl±darka WWW (z wieloma
239 zak³adkami) wy¶wietlaj±ca strony WWW w trybie pe³noekranowym. Mo¿liwa
240 jest prosta nawigacja po stronie. Pocz±wszy od wersji 0.13 ma pe³n±
241 obs³ugê nawigacji myszk± (prawy przycisk otwiera i zamywa wyskakuj±ce
242 menu).
243
244 MythBrowser zawiera tak¿e BookmarkManagera do zarz±dzania odno¶nikami
245 do stron w prostej wtyczce myth.
246
247 %package -n mythphone
248 Summary:        A video conferencing module for MythTV
249 Summary(pl):    Modu³ wideokonferencji dla MythTV
250 Group:          Applications/Multimedia
251 Requires:       mythtv-frontend-api = %{myth_api_version}
252
253 %description -n mythphone
254 Mythphone is a phone and videophone capability on Myth using the
255 standard SIP protocol. It is compatible with Microsoft XP Messenger
256 and with SIP Service Providers such as Free World Dialup
257 (fwd.pulver.com).
258
259 %description -n mythphone -l pl
260 Mythphone to funkcjonalno¶æ telefonu i wideofonu w Myth przy u¿yciu
261 standardowego protoko³u SIP. Jest kompatybilny z Microsoft XP
262 Messengerem oraz dostawcami us³ug SIP, takimi jak Free World Dialup
263 (fwd.pulver.com).
264
265 %package -n mythweb
266 Summary:        The web interface to MythTV
267 Summary(pl):    Interfejs WWW do MythTV
268 Group:          Applications/Multimedia
269 Requires:       webapps
270 #Suggests:      apache(mod_auth)
271 #Suggests:      apache(mod_env)
272 Requires:       php >= 3:4.3
273 Requires:       php-mysql
274 Requires:       php-posix
275
276 %description -n mythweb
277 The web interface to MythTV.
278
279 %description -n mythweb -l pl
280 Interfejs WWW do MythTV.
281
282 %package -n mythflix
283 Summary:        MythFlix (A NetFlix MythTV)
284 Summary(pl):    MythFlix (NetFlix MythTV)
285 Group:          Applications/Multimedia
286 Requires:       mythtv-frontend-api = %{myth_api_version}
287
288 %description -n mythflix
289 MythFlix is a MythTV plugin for adding movies to your Netflix queue.
290 It currently supports the ability to view your queue and add movies to
291 your queue. The browse feature is based on the Netflix RSS feeds. This
292 plugin is not very mature, which means things might not work right
293 and/or it might break other things.
294
295 %description -n mythflix -l pl
296 MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
297 Aktualnie daje mo¿liwo¶æ ogl±dania kolejki i dodawania do niej filmów.
298 Przegl±danie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
299 jeszcze zbyt dojrza³a, co znaczy, ¿e co¶ mo¿e nie dzia³aæ lub psuæ co¶
300 innego.
301
302 %package -n mythcontrols
303 Summary:        MythTV keybindings editor
304 Summary(pl):    Edytor przypisañ klawiszy MythTV
305 Group:          Applications/Multimedia
306 Requires:       mythtv-frontend-api = %{myth_api_version}
307
308 %description -n mythcontrols
309 This plugin allows you to configure your keybindings on the frontend
310 without having to use mythweb or edit tables by hand.
311
312 %description -n mythcontrols -l pl
313 Ta wtyczka pozwala konfigurowaæ przypisania klawiszy we frontendzie
314 bez konieczno¶ci u¿ywania mythweba ani rêcznego modyfikowania tabel.
315
316 %prep
317 %setup -q %{?_snap:-n %{name}}
318 %if %{_lib} != "lib"
319 #%patch0 -p1
320 %endif
321 %patch1 -p1
322 %patch2 -p1
323 #filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
324
325 # make it visible
326 mv mythweb/{.,}htaccess
327
328 # lib64 fix - enable to update patch
329 %if %{_lib} != "lib" && 0
330 find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
331 xargs grep -l /lib/ . | xargs sed -i -e '
332         s,/usr/lib/,/usr/%{_lib}/,g
333         s,{PREFIX}/lib,{PREFIX}/%{_lib},g
334 '
335 exit 1
336 %endif
337
338 %build
339 %if %{with binary}
340 export QTDIR="%{_prefix}"
341 # Not gnu configure
342 %configure \
343         --libdir-name=%{_lib} \
344         --enable-all \
345         %{!?with_mytharchive:--disable-mytharchive} \
346         %{!?with_mythbrowser:--disable-mythbrowser} \
347         %{!?with_mythdvd:--disable-mythdvd}%{?with_mythdvd:--enable-transcode --enable-vcd} \
348         %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
349         %{!?with_mythgame:--disable-mythgame} \
350         %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
351         %{!?with_mythnews:--disable-mythnews} \
352         %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
353         %{!?with_mythvideo:--disable-mythvideo} \
354         %{!?with_mythweather:--disable-mythweather} \
355         %{!?with_mythweb:--disable-mythweb} \
356         %{!?with_mythcontrols:--disable-mythcontrols} \
357         %{!?with_mythflix:--disable-mythflix} \
358
359 mv mythconfig.mak mythconfig.mak.old
360 cp mythconfig.mak.old mythconfig.mak
361 cat <<'EOF'>> mythconfig.mak
362 QMAKE_CXX=%{__cxx}
363 QMAKE_CC=%{__cc}
364 OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
365 ECFLAGS=%{rpmcflags} -fomit-frame-pointer
366 ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
367 EOF
368
369 %{__make}
370 %endif
371
372 %install
373 rm -rf $RPM_BUILD_ROOT
374
375 %if %{with binary}
376 export QTDIR="%{_prefix}"
377 %{__make} install \
378         INSTALL_ROOT=$RPM_BUILD_ROOT
379
380 install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
381 %if %{with mythgame}
382 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
383 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
384 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
385 install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
386 cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
387 %endif
388 %endif
389
390 %if %{with mythweb}
391 cd mythweb
392 install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
393 install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
394 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
395 cp -a *.php *.pl data includes js modules skins $RPM_BUILD_ROOT%{_datadir}/mythweb
396 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
397 install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
398 touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
399 cd -
400 %endif
401
402 mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
403 rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
404 for p in mytharchive mythbrowser mythcontrols mythdvd mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather; do
405         for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
406                 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
407         done > $p.lang
408 done
409
410 %clean
411 rm -rf $RPM_BUILD_ROOT
412
413 %triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
414 %webapp_register apache %{_webapp}
415
416 %triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
417 %webapp_unregister apache %{_webapp}
418
419 %triggerin -n mythweb -- apache < 2.2.0, apache-base
420 %webapp_register httpd %{_webapp}
421
422 %triggerun -n mythweb -- apache < 2.2.0, apache-base
423 %webapp_unregister httpd %{_webapp}
424
425 %triggerpostun -n mythweb -- mythweb < 0.19
426 for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
427         if [ -f /etc/mythweb/$i.rpmsave ]; then
428                 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
429                 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
430         fi
431 done
432 sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
433
434 # migrate from apache-config macros
435 if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
436         if [ -d /etc/apache/webapps.d ]; then
437                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
438                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
439         fi
440
441         if [ -d /etc/httpd/webapps.d ]; then
442                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
443                 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
444         fi
445         rm -f /etc/mythweb/apache.conf.rpmsave
446 fi
447
448 if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
449         rm -f /etc/apache/conf.d/99_mythplugins.conf
450         /usr/sbin/webapp register apache %{_webapp}
451         %service -q apache reload
452 fi
453 if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
454         rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
455         /usr/sbin/webapp register httpd %{_webapp}
456         %service -q httpd reload
457 fi
458
459 %files
460 %defattr(644,root,root,755)
461
462 %if %{with mytharchive}
463 %files -n mytharchive -f mytharchive.lang
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_bindir}/mytharchivehelper
466 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
467 %{_datadir}/mythtv/archiveformat.xml
468 %{_datadir}/mythtv/archivemenu.xml
469 %{_datadir}/mythtv/archiveselect.xml
470 %{_datadir}/mythtv/themes/default/ma_*.png
471 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
472 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
473 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
474 %{_datadir}/mythtv/mytharchive
475 %endif
476
477 %if %{with mythmusic}
478 %files -n mythmusic -f mythmusic.lang
479 %defattr(644,root,root,755)
480 %doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
481 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
482 /var/lib/mythmusic
483 %{_datadir}/mythtv/musicmenu.xml
484 %{_datadir}/mythtv/music_settings.xml
485 %{_datadir}/mythtv/themes/default/music-ui.xml
486 %{_datadir}/mythtv/themes/default/ff_button_off.png
487 %{_datadir}/mythtv/themes/default/ff_button_on.png
488 %{_datadir}/mythtv/themes/default/ff_button_pushed.png
489 %{_datadir}/mythtv/themes/default/mm_blackhole_border.png
490 %{_datadir}/mythtv/themes/default/mm_blankbutton_off.png
491 %{_datadir}/mythtv/themes/default/mm_blankbutton_on.png
492 %{_datadir}/mythtv/themes/default/mm_blankbutton_pushed.png
493 %{_datadir}/mythtv/themes/default/mm_checked.png
494 %{_datadir}/mythtv/themes/default/mm_checked_high.png
495 %{_datadir}/mythtv/themes/default/mm_down_arrow.png
496 %{_datadir}/mythtv/themes/default/mm_left_arrow.png
497 %{_datadir}/mythtv/themes/default/mm_leftright_off.png
498 %{_datadir}/mythtv/themes/default/mm_leftright_on.png
499 %{_datadir}/mythtv/themes/default/mm_leftright_pushed.png
500 %{_datadir}/mythtv/themes/default/mm_rating.png
501 %{_datadir}/mythtv/themes/default/mm_right_arrow.png
502 %{_datadir}/mythtv/themes/default/mm_unchecked.png
503 %{_datadir}/mythtv/themes/default/mm_unchecked_high.png
504 %{_datadir}/mythtv/themes/default/mm_up_arrow.png
505 %{_datadir}/mythtv/themes/default/mm_volume_background.png
506 %{_datadir}/mythtv/themes/default/mm_volume_tick.png
507 %{_datadir}/mythtv/themes/default/mm_waiting.png
508 %{_datadir}/mythtv/themes/default/music-sel-bg.png
509 %{_datadir}/mythtv/themes/default/next_button_off.png
510 %{_datadir}/mythtv/themes/default/next_button_on.png
511 %{_datadir}/mythtv/themes/default/next_button_pushed.png
512 %{_datadir}/mythtv/themes/default/pause_button_off.png
513 %{_datadir}/mythtv/themes/default/pause_button_on.png
514 %{_datadir}/mythtv/themes/default/pause_button_pushed.png
515 %{_datadir}/mythtv/themes/default/play_button_off.png
516 %{_datadir}/mythtv/themes/default/play_button_on.png
517 %{_datadir}/mythtv/themes/default/play_button_pushed.png
518 %{_datadir}/mythtv/themes/default/prev_button_off.png
519 %{_datadir}/mythtv/themes/default/prev_button_on.png
520 %{_datadir}/mythtv/themes/default/prev_button_pushed.png
521 %{_datadir}/mythtv/themes/default/rew_button_off.png
522 %{_datadir}/mythtv/themes/default/rew_button_on.png
523 %{_datadir}/mythtv/themes/default/rew_button_pushed.png
524 %{_datadir}/mythtv/themes/default/selectionbar.png
525 %{_datadir}/mythtv/themes/default/stop_button_off.png
526 %{_datadir}/mythtv/themes/default/stop_button_on.png
527 %{_datadir}/mythtv/themes/default/stop_button_pushed.png
528 %{_datadir}/mythtv/themes/default/text_button_off.png
529 %{_datadir}/mythtv/themes/default/text_button_on.png
530 %{_datadir}/mythtv/themes/default/text_button_pushed.png
531 %{_datadir}/mythtv/themes/default/track_info_background.png
532 %endif
533
534 %if %{with mythvideo}
535 %files -n mythvideo -f mythvideo.lang
536 %defattr(644,root,root,755)
537 %doc mythvideo/README mythvideo/videodb
538 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
539 %{_datadir}/mythtv/themes/default/video-ui.xml
540 %{_datadir}/mythtv/themes/default/mv-*.png
541 %{_datadir}/mythtv/themes/default/mv_*.png
542 %{_datadir}/mythtv/video_settings.xml
543 %{_datadir}/mythtv/videomenu.xml
544 %dir %{_datadir}/mythtv/mythvideo
545 %dir %{_datadir}/mythtv/mythvideo/scripts
546 %{_datadir}/mythtv/mythvideo/scripts/README
547 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/imdb.pl
548 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/allocine.pl
549 %attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/ofdb.pl
550 /var/lib/mythvideo
551 %endif
552
553 %if %{with mythweather}
554 %files -n mythweather -f mythweather.lang
555 %defattr(644,root,root,755)
556 %doc mythweather/README
557 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
558 %{_datadir}/mythtv/mythweather
559 %{_datadir}/mythtv/themes/default/weather-ui.xml
560 %{_datadir}/mythtv/themes/default/cloudy.png
561 %{_datadir}/mythtv/themes/default/fair.png
562 %{_datadir}/mythtv/themes/default/flurries.png
563 %{_datadir}/mythtv/themes/default/fog.png
564 %{_datadir}/mythtv/themes/default/logo.png
565 %{_datadir}/mythtv/themes/default/lshowers.png
566 %{_datadir}/mythtv/themes/default/mcloudy.png
567 %{_datadir}/mythtv/themes/default/mw-*.png
568 %{_datadir}/mythtv/themes/default/mwmain.png
569 %{_datadir}/mythtv/themes/default/pcloudy.png
570 %{_datadir}/mythtv/themes/default/rainsnow.png
571 %{_datadir}/mythtv/themes/default/showers.png
572 %{_datadir}/mythtv/themes/default/snowshow.png
573 %{_datadir}/mythtv/themes/default/sunny.png
574 %{_datadir}/mythtv/themes/default/thunshowers.png
575 %{_datadir}/mythtv/themes/default/unknown.png
576 %endif
577
578 %if %{with mythgallery}
579 %files -n mythgallery -f mythgallery.lang
580 %defattr(644,root,root,755)
581 %doc mythgallery/README
582 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
583 %{_datadir}/mythtv/themes/default/gallery-ui.xml
584 %{_datadir}/mythtv/themes/default/gallery-*.png
585 # FIXME: this is definately stupid path
586 /var/lib/pictures
587 %endif
588
589 %if %{with mythgame}
590 %files -n mythgame -f mythgame.lang
591 %defattr(644,root,root,755)
592 %doc mythgame/README
593 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
594 %{_datadir}/mythtv/games
595 %{_datadir}/mythtv/game_settings.xml
596 %{_datadir}/mythtv/themes/default/game-ui.xml
597 %endif
598
599 %if %{with mythdvd}
600 %files -n mythdvd -f mythdvd.lang
601 %defattr(644,root,root,755)
602 %doc mythdvd/README mythdvd/AUTHORS
603 %attr(755,root,root) %{_bindir}/mtd
604 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythdvd.so
605 %{_datadir}/mythtv/dvd_settings.xml
606 %{_datadir}/mythtv/dvdmenu.xml
607 %{_datadir}/mythtv/themes/default/dvd-ui.xml
608 %{_datadir}/mythtv/themes/default/md_*.png
609 %endif
610
611 %if %{with mythnews}
612 %files -n mythnews -f mythnews.lang
613 %defattr(644,root,root,755)
614 %doc mythnews/README mythnews/AUTHORS
615 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
616 %{_datadir}/mythtv/mythnews
617 %{_datadir}/mythtv/themes/default/news-ui.xml
618 # DUPLICATE WITH MYTHFLIX?
619 %{_datadir}/mythtv/themes/default/news-info-bg.png
620 %endif
621
622 %if %{with mythbrowser}
623 %files -n mythbrowser -f mythbrowser.lang
624 %defattr(644,root,root,755)
625 %doc mythbrowser/README mythbrowser/AUTHORS
626 %attr(755,root,root) %{_bindir}/mythbrowser
627 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
628 %{_datadir}/mythtv/themes/default/webpage.png
629 %endif
630
631 %if %{with mythphone}
632 %files -n mythphone -f mythphone.lang
633 %defattr(644,root,root,755)
634 %doc mythphone/README mythphone/AUTHORS mythphone/TODO
635 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
636 %{_datadir}/mythtv/themes/default/phone-ui.xml
637 %{_datadir}/mythtv/themes/default/webcam-ui.xml
638 %{_datadir}/mythtv/themes/default/mp_*.png
639 %{_datadir}/mythtv/themes/default/phone.png
640 %endif
641
642 %if %{with mythweb}
643 %files -n mythweb
644 %defattr(644,root,root,755)
645 %doc mythweb/{README,TODO,htaccess}
646 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
647 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
648 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
649 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
650 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
651 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
652 %{_datadir}/mythweb
653 %dir %attr(771,root,http) /var/cache/mythweb
654 %dir %attr(771,root,http) /var/cache/mythweb/image_cache
655 %dir %attr(771,root,http) /var/cache/mythweb/php_sessions
656 %dir %attr(771,root,http) /var/cache/mythweb/tv_icons
657 %endif
658
659 %if %{with mythflix}
660 %files -n mythflix -f mythflix.lang
661 %defattr(644,root,root,755)
662 %doc mythflix/{AUTHORS,ChangeLog,README}
663 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
664 %dir %{_datadir}/mythtv/mythflix
665 %{_datadir}/mythtv/mythflix/netflix-rss.xml
666 %dir %{_datadir}/mythtv/mythflix/scripts
667 %attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
668 %{_datadir}/mythtv/netflix_menu.xml
669 %{_datadir}/mythtv/themes/default/title_netflix.png
670 %{_datadir}/mythtv/themes/default/netflix-ui.xml
671 # DUPLICATE WITH MYTHNEWS?
672 %{_datadir}/mythtv/themes/default/news-info-bg.png
673 %endif
674
675 %if %{with mythcontrols}
676 %files -n mythcontrols -f mythcontrols.lang
677 %defattr(644,root,root,755)
678 %doc mythcontrols/{AUTHORS,README,TODO}
679 %attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
680 %{_datadir}/mythtv/themes/default/controls-ui.xml
681 %{_datadir}/mythtv/themes/default/kb-button-off.png
682 %{_datadir}/mythtv/themes/default/kb-button-on.png
683 %endif
This page took 0.143787 seconds and 4 git commands to generate.