]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
b7158af45b325aa888b09bd4d259eec549ed82e5
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.5.1
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  c6d0efd6e89660857f06103c30fb682e
9 Source1:        %{name}.conf
10 Patch0:         %{name}-zshcompdir.patch
11 Patch1:         %{name}-lua.patch
12 Patch2:         %{name}-wafsyms.patch
13 URL:            http://mpv.io/
14 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
15 BuildRequires:  OpenAL-devel >= 1.13
16 BuildRequires:  OpenGL-devel
17 BuildRequires:  SDL-devel
18 BuildRequires:  alsa-lib-devel
19 BuildRequires:  enca-devel
20 BuildRequires:  ffmpeg-devel >= 2.1.4
21 BuildRequires:  jack-audio-connection-kit-devel
22 BuildRequires:  ladspa-devel
23 BuildRequires:  lcms2-devel >= 2.6
24 BuildRequires:  libass-devel
25 %ifarch i386 i486
26 BuildRequires:  libatomic-devel
27 %endif
28 BuildRequires:  libbluray-devel >= 0.2.1
29 BuildRequires:  libbs2b-devel
30 BuildRequires:  libcaca-devel >= 0.99
31 BuildRequires:  libcdio-paranoia-devel
32 BuildRequires:  libdvdnav-devel >= 4.2.0
33 BuildRequires:  libdvdread-devel >= 4.1.0
34 BuildRequires:  libguess-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libmpg123-devel >= 1.14.0
37 BuildRequires:  libquvi-devel < 0.9.0
38 BuildRequires:  libsmbclient-devel
39 BuildRequires:  libv4l-devel
40 BuildRequires:  libva-devel >= 1.2.0
41 BuildRequires:  libva-glx-devel >= 1.2.0
42 BuildRequires:  libvdpau-devel >= 0.2
43 BuildRequires:  lirc-devel
44 BuildRequires:  lua51-devel
45 BuildRequires:  ncurses-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  portaudio-devel >= 19
48 BuildRequires:  pulseaudio-devel >= 0.9
49 BuildRequires:  rpmbuild(macros) >= 1.336
50 # version dep to handle packaging issue in PLD
51 BuildRequires:  waf >= 1.7.14
52 BuildRequires:  wayland-devel >= 1.3.0
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXScrnSaver-devel
55 BuildRequires:  xorg-lib-libXdamage-devel
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXinerama-devel
58 BuildRequires:  xorg-lib-libXv-devel
59 BuildRequires:  xorg-lib-libXxf86vm-devel
60 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
61 BuildRequires:  xorg-proto-xproto-devel
62 Requires:       OpenGL
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
66
67 %define         zshdir %{_datadir}/zsh/site-functions
68
69 %description
70 Movie player based on MPlayer and mplayer2.
71
72 %package client-libs
73 Summary:        Client library for controlling mpv
74 Group:          Development/Libraries
75
76 %description client-libs
77 Client library for controlling mpv.
78
79 %package client-devel
80 Summary:        Development files for mpv client library
81 Group:          Development/Libraries
82 Requires:       %{name}-client-libs = %{version}-%{release}
83
84 %description client-devel
85 Development files for mpv client library.
86
87 %package -n zsh-completion-mpv
88 Summary:        zsh-completion for mpv
89 Group:          Applications/Shells
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n zsh-completion-mpv
93 zsh-completion for mpv.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %waf configure \
103                 --prefix=%{_prefix} \
104                 --bindir=%{_bindir} \
105                 --confdir=%{_sysconfdir}/mpv \
106                 --libdir=%{_libdir} \
107                 --datadir=%{_datadir} \
108                 --mandir=%{_mandir} \
109                 --disable-debug-build \
110                 --enable-alsa \
111                 --enable-audio-input \
112                 --enable-caca \
113                 --enable-cdda \
114                 --enable-dvb \
115                 --enable-dvbin \
116                 --enable-dvdnav \
117                 --enable-dvdread \
118                 --enable-enca \
119                 --enable-encoding \
120                 --enable-gl-wayland \
121                 --enable-gl-x11 \
122                 --enable-iconv \
123                 --enable-jack \
124                 --enable-joystick \
125                 --enable-jpeg \
126                 --enable-ladspa \
127                 --enable-lcms2 \
128                 --enable-libass \
129                 --enable-libass-osd \
130                 --enable-libavdevice \
131                 --enable-libavfilter \
132                 --enable-libavresample \
133                 --enable-libbluray \
134                 --enable-libbs2b \
135                 --enable-libguess \
136                 --enable-libmpv-shared \
137                 --enable-libpostproc \
138                 --enable-libquvi4 \
139                 --enable-libsmbclient \
140                 --enable-libv4l2 \
141                 --enable-lirc \
142                 --enable-mpg123 \
143                 --enable-openal \
144                 --enable-oss-audio \
145                 --enable-portaudio \
146                 --enable-pulse \
147                 --enable-pvr \
148                 --enable-sdl1 \
149                 --enable-shm \
150                 --enable-terminfo \
151                 --enable-tv \
152                 --enable-tv-v4l2 \
153                 --enable-vaapi \
154                 --enable-vaapi-glx \
155                 --enable-vaapi-hwaccel \
156                 --enable-vaapi-vpp \
157                 --enable-vdpau \
158                 --enable-vdpau-gl-x11 \
159                 --enable-vdpau-hwaccel \
160                 --enable-wayland \
161                 --enable-x11 \
162                 --enable-xext \
163                 --enable-xf86vm \
164                 --enable-xf86xk \
165                 --enable-xinerama \
166                 --enable-xss \
167                 --enable-xv \
168                 --enable-zsh-comp \
169                 --lua=51pld
170
171 %waf build -v
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %waf install --destdir=$RPM_BUILD_ROOT
177
178 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
179 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %dir %{_sysconfdir}/mpv
187 %{_sysconfdir}/mpv/encoding-profiles.conf
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
189 %attr(755,root,root) %{_bindir}/%{name}
190 %{_desktopdir}/mpv.desktop
191 %{_iconsdir}/hicolor/*/apps/mpv.png
192 %{_mandir}/man1/mpv.1*
193
194 %files client-libs
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
198
199 %files client-devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libmpv.so
202 %{_includedir}/mpv
203 %{_pkgconfigdir}/mpv.pc
204
205 %files -n zsh-completion-mpv
206 %defattr(644,root,root,755)
207 %{zshdir}/_mpv
This page took 0.11371 seconds and 3 git commands to generate.