]> git.pld-linux.org Git - packages/mpv.git/blob - mpv.spec
24199d15f4d57c1222d12cf0e7b962a75d219936
[packages/mpv.git] / mpv.spec
1 Summary:        Movie player based on MPlayer and mplayer2
2 Name:           mpv
3 Version:        0.7.0
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        http://github.com/mpv-player/mpv/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
8 # Source0-md5:  ddb900d0f4e086734ccf2a775a15c859
9 Source1:        %{name}.conf
10 Patch0:         %{name}-lua.patch
11 URL:            http://mpv.io/
12 BuildRequires:  Mesa-libwayland-egl-devel >= 9.0.0
13 BuildRequires:  OpenAL-devel >= 1.13
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  alsa-lib-devel
17 BuildRequires:  enca-devel
18 BuildRequires:  ffmpeg-devel >= 2.1.4
19 BuildRequires:  jack-audio-connection-kit-devel
20 BuildRequires:  ladspa-devel
21 BuildRequires:  lcms2-devel >= 2.6
22 BuildRequires:  libass-devel
23 %ifarch i386 i486
24 BuildRequires:  libatomic-devel
25 %endif
26 BuildRequires:  libbluray-devel >= 0.2.1
27 BuildRequires:  libbs2b-devel
28 BuildRequires:  libcaca-devel >= 0.99
29 BuildRequires:  libcdio-paranoia-devel
30 BuildRequires:  libdvdnav-devel >= 4.2.0
31 BuildRequires:  libdvdread-devel >= 4.1.0
32 BuildRequires:  libguess-devel
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libmpg123-devel >= 1.14.0
35 BuildRequires:  libsmbclient-devel
36 BuildRequires:  libv4l-devel
37 BuildRequires:  libva-devel >= 1.2.0
38 BuildRequires:  libva-glx-devel >= 1.2.0
39 BuildRequires:  libvdpau-devel >= 0.2
40 BuildRequires:  lirc-devel
41 BuildRequires:  lua51-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  portaudio-devel >= 19
44 BuildRequires:  pulseaudio-devel >= 0.9
45 BuildRequires:  rpmbuild(macros) >= 1.336
46 # version dep to handle packaging issue in PLD
47 BuildRequires:  waf >= 1.7.14
48 BuildRequires:  wayland-devel >= 1.3.0
49 BuildRequires:  xorg-lib-libX11-devel
50 BuildRequires:  xorg-lib-libXScrnSaver-devel
51 BuildRequires:  xorg-lib-libXdamage-devel
52 BuildRequires:  xorg-lib-libXext-devel
53 BuildRequires:  xorg-lib-libXinerama-devel
54 BuildRequires:  xorg-lib-libXv-devel
55 BuildRequires:  xorg-lib-libXxf86vm-devel
56 BuildRequires:  xorg-lib-libxkbcommon-devel >= 0.3.0
57 BuildRequires:  xorg-proto-xproto-devel
58 Requires:       OpenGL
59 Suggests:       youtube-dl >= 2:20141109
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
63
64 %define         zshdir %{_datadir}/zsh/site-functions
65
66 %description
67 Movie player based on MPlayer and mplayer2.
68
69 %package client-libs
70 Summary:        Client library for controlling mpv
71 Group:          Development/Libraries
72
73 %description client-libs
74 Client library for controlling mpv.
75
76 %package client-devel
77 Summary:        Development files for mpv client library
78 Group:          Development/Libraries
79 Requires:       %{name}-client-libs = %{version}-%{release}
80
81 %description client-devel
82 Development files for mpv client library.
83
84 %package -n zsh-completion-mpv
85 Summary:        zsh-completion for mpv
86 Group:          Applications/Shells
87 Requires:       %{name} = %{version}-%{release}
88
89 %description -n zsh-completion-mpv
90 zsh-completion for mpv.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %waf configure \
98                 --prefix=%{_prefix} \
99                 --bindir=%{_bindir} \
100                 --confdir=%{_sysconfdir}/mpv \
101                 --libdir=%{_libdir} \
102                 --datadir=%{_datadir} \
103                 --mandir=%{_mandir} \
104                 --disable-debug-build \
105                 --enable-alsa \
106                 --enable-audio-input \
107                 --enable-caca \
108                 --enable-cdda \
109                 --enable-dvb \
110                 --enable-dvbin \
111                 --enable-dvdnav \
112                 --enable-dvdread \
113                 --enable-enca \
114                 --enable-encoding \
115                 --enable-gl-wayland \
116                 --enable-gl-x11 \
117                 --enable-iconv \
118                 --enable-jack \
119                 --enable-joystick \
120                 --enable-jpeg \
121                 --enable-ladspa \
122                 --enable-lcms2 \
123                 --enable-libass \
124                 --enable-libass-osd \
125                 --enable-libavdevice \
126                 --enable-libavfilter \
127                 --enable-libavresample \
128                 --enable-libbluray \
129                 --enable-libbs2b \
130                 --enable-libguess \
131                 --enable-libmpv-shared \
132                 --enable-libpostproc \
133                 --enable-libsmbclient \
134                 --enable-libv4l2 \
135                 --enable-lirc \
136                 --enable-mpg123 \
137                 --enable-openal \
138                 --enable-oss-audio \
139                 --enable-portaudio \
140                 --enable-pulse \
141                 --enable-pvr \
142                 --enable-sdl1 \
143                 --enable-shm \
144                 --enable-tv \
145                 --enable-tv-v4l2 \
146                 --enable-vaapi \
147                 --enable-vaapi-glx \
148                 --enable-vaapi-hwaccel \
149                 --enable-vaapi-vpp \
150                 --enable-vdpau \
151                 --enable-vdpau-gl-x11 \
152                 --enable-vdpau-hwaccel \
153                 --enable-wayland \
154                 --enable-x11 \
155                 --enable-xext \
156                 --enable-xinerama \
157                 --enable-xss \
158                 --enable-xv \
159                 --enable-zsh-comp \
160                 --lua=51pld \
161                 --zshdir=%{zshdir}
162
163 %waf build -v
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %waf install --destdir=$RPM_BUILD_ROOT
169
170 install -d $RPM_BUILD_ROOT%{_sysconfdir}/mpv
171 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mpv
172
173 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180 %doc README.md RELEASE_NOTES etc/example.conf etc/input.conf etc/mplayer-input.conf etc/restore-old-bindings.conf
181 %dir %{_sysconfdir}/mpv
182 %{_sysconfdir}/mpv/encoding-profiles.conf
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpv/mpv.conf
184 %attr(755,root,root) %{_bindir}/%{name}
185 %{_desktopdir}/mpv.desktop
186 %{_iconsdir}/hicolor/*/apps/mpv.png
187 %{_mandir}/man1/mpv.1*
188
189 %files client-libs
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libmpv.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libmpv.so.1
193
194 %files client-devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libmpv.so
197 %{_includedir}/mpv
198 %{_pkgconfigdir}/mpv.pc
199
200 %files -n zsh-completion-mpv
201 %defattr(644,root,root,755)
202 %{zshdir}/_mpv
This page took 0.082471 seconds and 3 git commands to generate.