]> git.pld-linux.org Git - packages/mplayer2.git/blob - mplayer2.spec
- builds
[packages/mplayer2.git] / mplayer2.spec
1 #
2
3 %if %{_lib} == "lib64"
4 %define         _suf    64
5 %else
6 %define         _suf    32
7 %endif
8
9 %define         subver  rc2
10 %define         rel     1
11 Summary:        MPlayer - THE Movie Player for UN*X
12 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
13 Summary(es.UTF-8):      Otro reproductor de películas
14 Summary(ko.UTF-8):      리눅스용 미디어플레이어
15 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
16 Summary(pt_BR.UTF-8):   Reprodutor de filmes
17 Name:           mplayer2
18 Version:        2.0
19 Release:        0.%{subver}.%{rel}
20 License:        GPL
21 Group:          Applications/Multimedia
22 Source0:        http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}-%{subver}.tar.xz
23 # Source0-md5:  92793d629181e059384c43972fa9a701
24 URL:            http://www.mplayer2.org/
25 BuildRequires:  OpenAL-devel
26 BuildRequires:  OpenGL-devel
27 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
28 %{?with_aalib:BuildRequires:    aalib-devel}
29 %{?with_alsa:BuildRequires:     alsa-lib-devel}
30 %{?with_arts:BuildRequires:     artsc-devel}
31 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
32 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
33 BuildRequires:  dirac-devel
34 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
35 %{?with_doc:BuildRequires:      docbook-style-xsl}
36 %{?with_dxr3:BuildRequires:     em8300-devel}
37 %{?with_enca:BuildRequires:     enca-devel}
38 %{?with_esd:BuildRequires:      esound-devel}
39 BuildRequires:  faac-devel
40 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
41 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
42 BuildRequires:  freetype-devel >= 2.0.9
43 BuildRequires:  fribidi-devel
44 BuildRequires:  tar >= 1:1.22
45 %{?with_vidix:BuildRequires:    vidix-devel}
46 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
47 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
48 %{?with_gif:BuildRequires:      giflib-devel}
49 %{?with_gui:BuildRequires:      gtk+2-devel}
50 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
51 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
52 BuildRequires:  lame-libs-devel
53 %{?with_caca:BuildRequires:     libcaca-devel}
54 %{?with_libdts:BuildRequires:   libdts-devel}
55 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
56 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
57 %{?with_ggi:BuildRequires:      libggi-devel}
58 BuildRequires:  libjpeg-devel
59 %{?with_mad:BuildRequires:      libmad-devel}
60 BuildRequires:  libmng-devel
61 BuildRequires:  libmpcdec-devel >= 1.2.1
62 BuildRequires:  libpng-devel
63 %{?with_smb:BuildRequires:      libsmbclient-devel}
64 %{?with_theora:BuildRequires:   libtheora-devel}
65 %{?with_vdpau:BuildRequires:    libvdpau-devel}
66 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
67 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
68 BuildRequires:  libxslt-progs
69 %{?with_lirc:BuildRequires:     lirc-devel}
70 %{?with_live:BuildRequires:     live-devel}
71 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
72 %{?with_nas:BuildRequires:      nas-devel}
73 BuildRequires:  ncurses-devel
74 %{?with_amr:BuildRequires:      opencore-amr-devel}
75 BuildRequires:  pkgconfig
76 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
77 BuildRequires:  rpm >= 4.4.9-56
78 BuildRequires:  rpmbuild(macros) >= 1.527
79 BuildRequires:  schroedinger-devel
80 BuildRequires:  speex-devel >= 1.1
81 %{?with_svga:BuildRequires:     svgalib-devel}
82 BuildRequires:  twolame-devel
83 %{?with_xmms:BuildRequires:     xmms-devel}
84 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
85 %ifarch %{ix86} %{x8664}
86 BuildRequires:  yasm
87 %endif
88 BuildRequires:  zlib-devel
89 BuildRequires:  xorg-lib-libX11-devel
90 BuildRequires:  xorg-lib-libXScrnSaver-devel
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXv-devel
94 BuildRequires:  xorg-lib-libXvMC-devel
95 BuildRequires:  xorg-lib-libXxf86dga-devel
96 BuildRequires:  xorg-lib-libXxf86vm-devel
97 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
98 Requires:       OpenGL
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
102 %define         specflags_ia32  -fomit-frame-pointer
103 %if %{with altivec}
104 %define         specflags_ppc   -maltivec
105 %endif
106
107 %description
108 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
109 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
110 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
111 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
112 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
113 optionally with SHM extension, X11 using overlays with the Xvideo
114 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
115 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
116
117 If you want to use win32 codecs install w32codec package.
118
119 %description -l de.UTF-8
120 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
121 Kennzeichnend ist die herausragende Format- und
122 Plattform-Kompatibilität.
123
124 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
125 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
126 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
127 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
128 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
129 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
130 installierte Codecs nicht mit MPlayer kollidieren können.
131
132 %description -l es.UTF-8
133 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
134 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
135 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
136 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
137 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
138 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
139 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
140 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
141 v1.1.7 etc.
142
143 Si quiere usar codecs Win32, instale el paquete w32codec.
144
145 %description -l ko.UTF-8
146 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
147 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
148 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
149 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
150 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
151 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
152 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
153 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
154 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
155
156 %description -l pl.UTF-8
157 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
158 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
159 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
160 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
161 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
162 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
163 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
164
165 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
166
167 %description -l pt_BR.UTF-8
168 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
169 áudio. Diferentes mecanismos de reprodução podem também ser
170 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
171
172 %prep
173 %setup -q -n %{name}
174
175 echo "--prefix=%{_prefix}" >>mplayer_options
176 echo "--enable-runtime-cpudetection" >>mplayer_options
177
178 cat mplayer/etc/example.conf > mplayer/etc/mplayer.conf
179 cat <<'CONFIGADD' >> mplayer/etc/mplayer.conf
180
181 ######################
182 # PLD Linux Defaults #
183 ######################
184 [default]
185
186 # alternate solution for CP1250-encoded subtitles
187 fontconfig = yes
188 subcp = cp1250
189
190 # ...or if you prefer native bitmap fonts shipped with mplayer
191 #fontconfig = no
192 #subcp = iso-8859-1
193
194 # Standard location
195 unrarexec = "%{_bindir}/unrar"
196
197 CONFIGADD
198
199 %build
200 %{__make}
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} 
205
206 %{__make} install DESTDIR=$RPM_BUILD_ROOT
207
208 mv -f $RPM_BUILD_ROOT%{_bindir}/{mplayer,%{name}}
209 # default config files
210 #install mplayer/etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
211
212 # fonts
213 #cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
214 #ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
215
216 #install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
217 #install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %files
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.105349 seconds and 4 git commands to generate.