]> git.pld-linux.org Git - packages/mplayer2.git/blob - mplayer2.spec
- up to 2.0
[packages/mplayer2.git] / mplayer2.spec
1 #
2 %bcond_with     directfb        # with DirectFB video output
3 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
4 %bcond_with     ggi             # with ggi video output
5 %bcond_with     nas             # with NAS audio output
6 %bcond_with     svga            # with svgalib video output
7 %bcond_without  osd             # with osd menu support
8 %bcond_without  altivec         # without altivec support
9 %bcond_without  x264            # without x264 support
10 %bcond_with     xmms            # with XMMS inputplugin support
11 %bcond_without  aalib           # without aalib video output
12 %bcond_without  jack            # without JACKD support
13 %bcond_without  alsa            # without ALSA audio output
14 %bcond_with     arts            # with arts audio output
15 %bcond_without  caca            # without libcaca video output
16 %bcond_without  cdparanoia      # without cdparanoia support
17 %bcond_without  dvdnav          # without dvdnav support
18 %bcond_without  enca            # disable using ENCA charset oracle library
19 %bcond_with     esd             # enable EsounD sound support
20 %bcond_without  faad            # disable FAAD2 (AAC) support
21 %bcond_without  gif             # disable GIF support
22 %bcond_without  gui             # without GTK+ GUI
23 %bcond_without  joystick        # disable joystick support
24 %bcond_without  libdts          # disable libdts support
25 %bcond_without  libdv           # disable libdv en/decoding support
26 %bcond_without  lirc            # without lirc support
27 %bcond_without  live            # without LIVE555 libraries
28 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
29 %bcond_without  mad             # without mad (audio MPEG) support
30 %bcond_without  pulseaudio      # without pulseaudio output
31 %bcond_without  quicktime       # without binary quicktime dll support
32 %bcond_without  real            # without Real* 8/9 codecs support
33 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
34                                 #  in compile time (advertised by mplayer authors as working faster); in this case
35                                 #  mplayer may not work on machine other then where it was compiled
36 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
37 %bcond_without  smb             # disable Samba (SMB) input support
38 %bcond_without  theora          # without theora support
39 %bcond_without  win32           # without win32 codecs support
40 %bcond_without  vdpau           # disable vdpau
41 %bcond_without  vidix           # disable vidix
42 %bcond_without  vorbis          # without Ogg-Vorbis audio support
43 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
44 %bcond_without  xvid            # disable XviD codec
45 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
46 %bcond_without  sdl             # disable SDL
47 %bcond_without  doc             # don't build docs (slow)
48 %bcond_without  amr             # enable Adaptive Multi Rate (AMR) speech codec support
49 %bcond_without  gnomess         # disable controling gnome screensaver
50 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
51 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
52 %bcond_with     on2             # with patches from On2 Flix Engine for Linux
53
54 %bcond_with     nonfree         # non free options of package
55 %bcond_without  va              # VAAPI (Video Acceleration API)
56 %bcond_without  vpx             # VP8, a high-quality video codec
57
58 Summary:        MPlayer - THE Movie Player for UN*X
59 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
60 Summary(es.UTF-8):      Otro reproductor de películas
61 Summary(ko.UTF-8):      리눅스용 미디어플레이어
62 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
63 Summary(pt_BR.UTF-8):   Reprodutor de filmes
64 Name:           mplayer2
65 Version:        2.0
66 Release:        0.1
67 License:        GPL
68 Group:          Applications/Multimedia
69 Source0:        http://ftp.mplayer2.org/pub/release/%{name}-build-%{version}.tar.xz
70 # Source0-md5:  05b93784de995235e2758f182de15f73
71 URL:            http://www.mplayer2.org/
72 BuildRequires:  OpenAL-devel
73 BuildRequires:  OpenGL-devel
74 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
75 %{?with_aalib:BuildRequires:    aalib-devel}
76 %{?with_alsa:BuildRequires:     alsa-lib-devel}
77 %{?with_arts:BuildRequires:     artsc-devel}
78 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
79 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
80 BuildRequires:  dirac-devel
81 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
82 %{?with_doc:BuildRequires:      docbook-style-xsl}
83 %{?with_dxr3:BuildRequires:     em8300-devel}
84 %{?with_enca:BuildRequires:     enca-devel}
85 %{?with_esd:BuildRequires:      esound-devel}
86 BuildRequires:  faac-devel
87 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
88 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
89 BuildRequires:  freetype-devel >= 2.0.9
90 BuildRequires:  fribidi-devel
91 BuildRequires:  tar >= 1:1.22
92 %{?with_vidix:BuildRequires:    vidix-devel}
93 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
94 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
95 %{?with_gif:BuildRequires:      giflib-devel}
96 %{?with_gui:BuildRequires:      gtk+2-devel}
97 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
98 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
99 BuildRequires:  lame-libs-devel
100 %{?with_caca:BuildRequires:     libcaca-devel}
101 %{?with_libdts:BuildRequires:   libdts-devel}
102 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
103 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
104 %{?with_ggi:BuildRequires:      libggi-devel}
105 BuildRequires:  libjpeg-devel
106 %{?with_mad:BuildRequires:      libmad-devel}
107 BuildRequires:  libmng-devel
108 BuildRequires:  libmpcdec-devel >= 1.2.1
109 BuildRequires:  libpng-devel
110 %{?with_smb:BuildRequires:      libsmbclient-devel}
111 %{?with_theora:BuildRequires:   libtheora-devel}
112 %{?with_vdpau:BuildRequires:    libvdpau-devel}
113 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.1}
114 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
115 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20110327}
116 BuildRequires:  libxslt-progs
117 %{?with_lirc:BuildRequires:     lirc-devel}
118 %{?with_live:BuildRequires:     live-devel}
119 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
120 %{?with_nas:BuildRequires:      nas-devel}
121 BuildRequires:  ncurses-devel
122 %{?with_amr:BuildRequires:      opencore-amr-devel}
123 BuildRequires:  pkgconfig
124 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
125 BuildRequires:  rpm >= 4.4.9-56
126 BuildRequires:  rpmbuild(macros) >= 1.527
127 BuildRequires:  schroedinger-devel
128 BuildRequires:  speex-devel >= 1.1
129 %{?with_svga:BuildRequires:     svgalib-devel}
130 BuildRequires:  twolame-devel
131 %{?with_xmms:BuildRequires:     xmms-devel}
132 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
133 %ifarch %{ix86} %{x8664}
134 BuildRequires:  yasm
135 %endif
136 BuildRequires:  zlib-devel
137 BuildRequires:  xorg-lib-libX11-devel
138 BuildRequires:  xorg-lib-libXScrnSaver-devel
139 BuildRequires:  xorg-lib-libXext-devel
140 BuildRequires:  xorg-lib-libXinerama-devel
141 BuildRequires:  xorg-lib-libXv-devel
142 BuildRequires:  xorg-lib-libXvMC-devel
143 BuildRequires:  xorg-lib-libXxf86dga-devel
144 BuildRequires:  xorg-lib-libXxf86vm-devel
145 Requires:       OpenGL
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
149 %define         specflags_ia32  -fomit-frame-pointer
150 %if %{with altivec}
151 %define         specflags_ppc   -maltivec
152 %endif
153
154 %description
155 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
156 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
157 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
158 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
159 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
160 optionally with SHM extension, X11 using overlays with the Xvideo
161 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
162 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
163
164 If you want to use win32 codecs install w32codec package.
165
166 %description -l de.UTF-8
167 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
168 Kennzeichnend ist die herausragende Format- und
169 Plattform-Kompatibilität.
170
171 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
172 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
173 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
174 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
175 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
176 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
177 installierte Codecs nicht mit MPlayer kollidieren können.
178
179 %description -l es.UTF-8
180 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
181 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
182 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
183 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
184 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
185 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
186 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
187 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
188 v1.1.7 etc.
189
190 Si quiere usar codecs Win32, instale el paquete w32codec.
191
192 %description -l ko.UTF-8
193 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
194 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
195 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
196 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
197 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
198 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
199 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
200 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
201 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
202
203 %description -l pl.UTF-8
204 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
205 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
206 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
207 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
208 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
209 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
210 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
211
212 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
213
214 %description -l pt_BR.UTF-8
215 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
216 áudio. Diferentes mecanismos de reprodução podem também ser
217 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
218
219 %prep
220 %setup -q -n %{name}
221
222 # set ffmpeg options:
223 echo "  --arch=%{_target_base_arch}" >>ffmpeg_options
224 echo "  --cc="%{__cc}"" >>ffmpeg_options
225 echo "  --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}"" >>ffmpeg_options
226 echo "  --extra-ldflags="%{rpmcflags} %{rpmldflags}"" >>ffmpeg_options
227 echo "  --disable-debug" >>ffmpeg_options
228 echo "  --disable-optimizations" >>ffmpeg_options
229 echo "  --disable-stripping" >>ffmpeg_options
230 echo "  --enable-avfilter" >>ffmpeg_options
231 echo "  --enable-gpl" >>ffmpeg_options
232 echo "  --enable-version3" >>ffmpeg_options
233 echo "  --enable-libdc1394" >>ffmpeg_options
234 echo "  --enable-libdirac" >>ffmpeg_options
235 #echo " --enable-libfaad" >>ffmpeg_options
236 #echo " --enable-libfaadbin" >>ffmpeg_options
237 # no libgsm-devel
238 #echo " --enable-libgsm" >>ffmpeg_options 
239 echo "  --enable-libmp3lame" >>ffmpeg_options
240 echo "  --enable-libschroedinger" >>ffmpeg_options
241 echo "  --enable-libspeex" >>ffmpeg_options
242 echo "  --enable-libtheora" >>ffmpeg_options
243 echo "  --enable-libvorbis" >>ffmpeg_options
244 echo "  %{?with_vpx:--enable-libvpx}" >>ffmpeg_options
245 # x264 API >= 0.99
246 echo "  --enable-libx264" >>ffmpeg_options
247 echo "  --enable-libxvid" >>ffmpeg_options
248 echo "  --enable-libopencore-amrnb" >>ffmpeg_options
249 echo "  --enable-libopencore-amrwb" >>ffmpeg_options
250 echo "  --enable-libopenjpeg" >>ffmpeg_options
251 echo "  --enable-postproc" >>ffmpeg_options
252 echo "  --enable-pthreads" >>ffmpeg_options
253 echo "  --enable-swscale" >>ffmpeg_options
254 echo "  --enable-vdpau" >>ffmpeg_options
255 echo "  --enable-x11grab" >>ffmpeg_options
256 %ifnarch %{ix86} %{x8664}
257 echo "  --disable-mmx" >>ffmpeg_options
258 %endif
259 #% ifarch i386 i486
260 #echo " --disable-mmx" >>ffmpeg_options
261 #% endif
262 %if %{with nonfree}
263 echo "  --enable-nonfree" >>ffmpeg_options
264 echo "  --enable-libfaac" >>ffmpeg_options
265 %endif
266 echo "  --enable-runtime-cpudetect" >>ffmpeg_options
267
268 # set mplayer options:
269 echo "  --prefix=%{_prefix}" >>mplayer_options
270 echo "  --confdir=%{_sysconfdir}/mplayer" >>mplayer_options
271 echo "  --cc="%{__cc}"" >>mplayer_options
272 echo "  --extra-cflags="$CFLAGS"" >>mplayer_options
273 #echo " --real-ldflags="%{rpmldflags}"" >>mplayer_options
274 echo "  --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}"" >>mplayer_options
275 %if %{with system_ffmpeg}
276 echo "  --disable-libavutil_a" >>mplayer_options
277 echo "  --disable-libavcodec_a" >>mplayer_options
278 echo "  --disable-libavformat_a" >>mplayer_options
279 echo "  --disable-libpostproc_a" >>mplayer_options
280 echo "  --enable-libavutil_so" >>mplayer_options
281 echo "  --enable-libavcodec_so" >>mplayer_options
282 echo "  --enable-libavformat_so" >>mplayer_options
283 echo "  --enable-libpostproc_so" >>mplayer_options
284 %endif
285 %ifnarch %{ix86} %{x8664}
286 echo "  --disable-mmx" >>mplayer_options
287 echo "  --disable-mmxext" >>mplayer_options
288 echo "  --disable-3dnow" >>mplayer_options
289 echo "  --disable-3dnowext" >>mplayer_options
290 echo "  --disable-sse" >>mplayer_options
291 echo "  --disable-sse2" >>mplayer_options
292 echo "  --disable-fastmemcpy" >>mplayer_options
293 %endif
294 echo "  %{__disable ssse3}" >>mplayer_options
295 #echo " %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb}" >>mplayer_options
296 echo "  %{__enable_disable directfb}" >>mplayer_options
297 echo "  %{__disable dxr3}" >>mplayer_options
298 echo "  %{__disable ggi}" >>mplayer_options
299 echo "  %{__disable live}" >>mplayer_options
300 echo "  %{__disable lzo liblzo}" >>mplayer_options
301 echo "  %{__disable nas}" >>mplayer_options
302 echo "  %{__disable svga}" >>mplayer_options
303 echo "  %{__disable aalib aa}" >>mplayer_options
304 echo "  %{__disable jack}" >>mplayer_options
305 echo "  %{__enable_disable alsa}" >>mplayer_options
306 echo "  %{__disable arts}" >>mplayer_options
307 echo "  %{__disable caca}" >>mplayer_options
308 echo "  %{__disable cdparanoia}" >>mplayer_options
309 echo "  %{__disable enca}" >>mplayer_options
310 echo "  %{__disable esd}" >>mplayer_options
311 echo "  %{__disable faad}" >>mplayer_options
312 echo "  %{__disable gif}" >>mplayer_options
313 echo "  %{__enable joystick}" >>mplayer_options
314 echo "  %{__disable libdv}" >>mplayer_options
315 echo "  %{__disable libdts libdca}" >>mplayer_options
316 echo "  %{__enable_disable lirc}" >>mplayer_options
317 echo "  %{__disable mad}" >>mplayer_options
318 echo "  %{__disable pulseaudio pulse}" >>mplayer_options
319 echo "  %{__disable quicktime qtx}" >>mplayer_options
320 echo "  %{__disable real}" >>mplayer_options
321 echo "  %{__enable_disable runtime runtime-cpudetection}" >>mplayer_options
322 echo "  %{__disable select}" >>mplayer_options
323 echo "  %{__disable smb}" >>mplayer_options
324 echo "  %{__disable win32 win32dll}" >>mplayer_options
325 echo "  %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis}" >>mplayer_options
326 echo "  %{__disable_if system_vorbis tremor-internal}" >>mplayer_options
327 echo "  %{__enable osd menu}" >>mplayer_options
328 echo "  %{__disable theora}" >>mplayer_options
329 echo "  %{__disable x264}" >>mplayer_options
330 echo "  %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}}" >>mplayer_options
331 echo "  %{__disable xvid}" >>mplayer_options
332 echo "  %{__disable vidix}" >>mplayer_options
333 echo "  %{__disable vdpau}" >>mplayer_options
334 echo "  %{__disable mencoder}" >>mplayer_options
335 echo "  --enable-dga1" >>mplayer_options
336 echo "  --enable-dga2" >>mplayer_options
337 echo "  %{__enable_disable dvdnav}" >>mplayer_options
338 echo "  --enable-fbdev" >>mplayer_options
339 echo "  --enable-gl" >>mplayer_options
340 echo "  --enable-mga" >>mplayer_options
341 echo "  --enable-radio" >>mplayer_options
342 echo "  --enable-radio-capture" >>mplayer_options
343 echo "  %{__enable_disable sdl}" >>mplayer_options
344 echo "  --enable-tdfxfb" >>mplayer_options
345 echo "  --enable-vm" >>mplayer_options
346 echo "  --enable-x11" >>mplayer_options
347 echo "  --enable-xmga" >>mplayer_options
348 echo "  --enable-xv" >>mplayer_options
349 echo "  --enable-xvmc" >>mplayer_options
350 echo "  --with-xvmclib=XvMCW" >>mplayer_options
351 #echo " --enable-zr" >>mplayer_options
352 echo "  --enable-unrarexec" >>mplayer_options
353 echo "  --enable-dynamic-plugins" >>mplayer_options
354 echo "  --enable-largefiles" >>mplayer_options
355 echo "  --language=all" >>mplayer_options
356 echo "  --codecsdir=%{_libdir}/codecs" >>mplayer_options
357
358 cat mplayer/etc/example.conf > mplayer/etc/mplayer.conf
359 cat <<'CONFIGADD' >> mplayer/etc/mplayer.conf
360
361 ######################
362 # PLD Linux Defaults #
363 ######################
364 [default]
365
366 # alternate solution for CP1250-encoded subtitles
367 fontconfig = yes
368 subcp = cp1250
369
370 # ...or if you prefer native bitmap fonts shipped with mplayer
371 #fontconfig = no
372 #subcp = iso-8859-1
373
374 # Standard location
375 unrarexec = "%{_bindir}/unrar"
376
377 CONFIGADD
378
379 %build
380 %{__make}
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} 
385
386 %{__make} install DESTDIR=$RPM_BUILD_ROOT
387
388 mv -f $RPM_BUILD_ROOT%{_bindir}/{mplayer,%{name}}
389 # default config files
390 #install mplayer/etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
391
392 # fonts
393 #cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
394 #ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
395
396 #install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
397 #install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
398
399 %clean
400 rm -rf $RPM_BUILD_ROOT
401
402 %files
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.079821 seconds and 4 git commands to generate.