]> git.pld-linux.org Git - packages/mpd.git/blob - mpd.spec
- added tmpfiles config for systemd
[packages/mpd.git] / mpd.spec
1 # TODO:
2 # - add logrotate
3 #
4 # Conditional build:
5 %bcond_without  mod             # enable MOD support
6 %bcond_without  pulseaudio      # disable PulseAudio support
7 %bcond_without  audiofile       # Audiofile support (WAV and others)
8
9 Summary:        Music Player Daemon
10 Summary(hu.UTF-8):      Music Player Daemon
11 Summary(pl.UTF-8):      Music Player Daemon - demon odtwarzający muzykę
12 Name:           mpd
13 Version:        0.16.5
14 Release:        3
15 License:        GPL v2+
16 Group:          Applications/Multimedia
17 Source0:        http://downloads.sourceforge.net/musicpd/%{name}-%{version}.tar.bz2
18 # Source0-md5:  f7564cff12035f6a1112cce770655df7
19 Source1:        %{name}.conf
20 Source2:        %{name}.init
21 Source3:        %{name}.sysconfig
22 Source4:        %{name}.tmpfiles
23 URL:            http://www.musicpd.org/
24 BuildRequires:  OpenAL-devel
25 BuildRequires:  alsa-lib-devel >= 0.9.0
26 %{?with_audiofile:BuildRequires:        audiofile-devel >= 0.1.7}
27 BuildRequires:  avahi-glib-devel
28 BuildRequires:  bzip2-devel
29 BuildRequires:  curl-devel
30 BuildRequires:  doxygen
31 BuildRequires:  faad2-devel >= 2.6.1-5
32 BuildRequires:  ffmpeg-devel
33 BuildRequires:  flac-devel >= 1.1.0
34 BuildRequires:  fluidsynth-devel
35 BuildRequires:  game-music-emu-devel
36 BuildRequires:  glib2-devel >= 2.12
37 BuildRequires:  jack-audio-connection-kit-devel >= 0.4
38 BuildRequires:  lame-libs-devel
39 BuildRequires:  libao-devel >= 0.8.3
40 BuildRequires:  libcdio-devel
41 BuildRequires:  libcue-devel
42 BuildRequires:  libid3tag-devel
43 BuildRequires:  libmad-devel
44 %{?with_mod:BuildRequires:      libmikmod-devel >= 3.1.7}
45 BuildRequires:  libmms-devel
46 BuildRequires:  libmodplug-devel
47 BuildRequires:  libmpcdec-devel
48 BuildRequires:  libogg-devel
49 BuildRequires:  libsamplerate-devel >= 0.0.15
50 BuildRequires:  libshout-devel
51 BuildRequires:  libvorbis-devel
52 BuildRequires:  pkgconfig >= 1:0.9.0
53 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
54 BuildRequires:  sqlite3-devel
55 BuildRequires:  twolame-devel
56 BuildRequires:  wavpack-devel
57 BuildRequires:  wildmidi-devel
58 BuildRequires:  xmlto
59 BuildRequires:  zlib-devel
60 BuildRequires:  zziplib-devel
61 Provides:       group(mpd)
62 Provides:       user(mpd)
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Music Player Daemon (MPD) allows remote access for playing music (MP3,
67 Ogg Vorbis, FLAC, AAC, Mod, and wave files) and managing playlists.
68 MPD is designed for integrating a computer into a stereo system that
69 provides control for music playback over a local network. It is also
70 makes a great desktop music player, especially if you are a console
71 junkie, like frontend options, or restart X often.
72
73 %description -l hu.UTF-8
74 Music Player Daemon (MPD)-vel lehetővé válik távoli zenelejátszás
75 (MP3, Ogg Vorbis, FLAC, AAC, Mod és wav fájlok) és lejátszási listák
76 menedzselése. Az MPD a számítógépben egy zenelejátszó, amelyet
77 irányíthatsz helyi hálózaton keresztül. Egyben egy zseniális desktop
78 zenelejátszó is, különösen a konzol-mániásoknak, vagy azoknak, akik
79 sűrűn indítják újra az X-et.
80
81 %description -l pl.UTF-8
82 Music Player Daemon (MPD) pozwala na zdalny dostęp do odtwarzania
83 muzyki (plików MP3, Ogg Vorbis, FLAC, AAC, Mod i wave) oraz
84 zarządzania playlistami. MPD jest zaprojektowany do integrowania
85 komputera w system stereo umożliwiający sterowanie odtwarzaniem muzyki
86 w sieci lokalnej. Służy także za dobry odtwarzacz muzyki dla
87 komputerów biurkowych, zwłaszcza dla miłośników konsoli, różnych opcji
88 frontendów albo często restartujących X.
89
90 %package apidocs
91 Summary:        MPD API documentation
92 Summary(pl.UTF-8):      Dokumentacja API biblioteki API
93 Group:          Documentation
94
95 %description apidocs
96 API and internal documentation for MPD library.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API biblioteki MPD.
100
101 %package doc
102 Summary:        Documentation for Music Player Daemon (MPD)
103 Summary(fr.UTF-8):      Documentation pour Music Player Daemon (MPD)
104 Summary(it.UTF-8):      Documentazione di Music Player Daemon (MPD)
105 Summary(pl.UTF-8):      Podręcznik dla Music Player Daemon (MPD)
106 Group:          Documentation
107
108 %description doc
109 Documentation for Music Player Daemon (MPD).
110
111 %description doc -l fr.UTF-8
112 Documentation pour Music Player Daemon (MPD).
113
114 %description doc -l it.UTF-8
115 Documentazione di Music Player Daemon (MPD).
116
117 %description doc -l pl.UTF-8
118 Dokumentacja do Music Player Daemon (MPD).
119
120 %prep
121 %setup -q
122
123 %build
124 # ac_cv_* hacks to avoid unwanted linking
125 GME_CFLAGS="-I/usr/include/gme" GME_LIBS="-lgme" \
126 %configure \
127         ac_cv_lib_iconv_main=no \
128         ac_cv_lib_nsl_gethostbyname=no \
129         %{!?with_pulseaudio:--disable-pulse} \
130         %{?with_mod:--enable-mikmod} \
131         --disable-sidplay \
132         --enable-alsa \
133         --enable-ao \
134         %{?with_audiofile:--enable-audiofile} \
135         --enable-bzip2 \
136         --enable-cue \
137         --enable-curl \
138         --enable-documentation \
139         --enable-ffmpeg \
140         --enable-fluidsynth \
141         --enable-gme \
142         --enable-httpd-output \
143         --enable-iso9660 \
144         --enable-jack \
145         --enable-lame-encoder \
146         --enable-lastfm \
147         --enable-lsr \
148         --enable-mad \
149         --enable-mms \
150         --enable-modplug \
151         --enable-mvp \
152         --enable-openal \
153         --enable-pipe-output \
154         --enable-recorder-output \
155         --enable-shout \
156         --enable-sqlite \
157         --enable-twolame-encoder \
158         --enable-vorbis-encoder \
159         --enable-wave-encoder \
160         --enable-wavpack \
161         --enable-wildmidi \
162         --enable-zzip \
163         --with-zeroconf=avahi \
164         --without-tremor
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
170         $RPM_BUILD_ROOT{/var/lib/mpd/playlists,/var/log/mpd,/var/run/mpd} \
171         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
172
173 %{__make} install \
174         DESTDIR=$RPM_BUILD_ROOT
175
176 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
177 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mpd
178 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/mpd
179 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
180
181 touch $RPM_BUILD_ROOT/var/lib/mpd/mpd.db
182 touch $RPM_BUILD_ROOT/var/lib/mpd/mpdstate
183 touch $RPM_BUILD_ROOT/var/lib/mpd/sticker.sql
184 touch $RPM_BUILD_ROOT/var/log/mpd/mpd.log
185
186 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mpd
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %pre
192 %groupadd -g 204 mpd
193 %useradd -u 204 -r -d /home/services/mpd -s /bin/false -c "Music Player Daemon (MPD) user" -G audio -g mpd mpd
194
195 %post
196 for f in mpd.log; do
197         if [ ! -f /var/log/%{name}/$f ]; then
198                 touch /var/log/%{name}/$f
199                 chown mpd:mpd /var/log/%{name}/$f
200                 chmod 644 /var/log/%{name}/$f
201         fi
202 done
203 /sbin/chkconfig --add mpd
204
205 %preun
206 if [ "$1" = "0" ]; then
207         %service mpd stop
208         /sbin/chkconfig --del mpd
209 fi
210
211 %postun
212 if [ "$1" = "0" ]; then
213         %userremove mpd
214         %groupremove mpd
215 fi
216
217 %files
218 %defattr(644,root,root,755)
219 %doc AUTHORS NEWS README doc/mpdconf.example UPGRADING
220 %attr(755,root,root) %{_bindir}/*
221 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpd.conf
222 %attr(754,root,root) /etc/rc.d/init.d/mpd
223 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mpd
224 /usr/lib/tmpfiles.d/%{name}.conf
225 %dir %attr(770,root,mpd) /var/lib/%{name}
226 %dir %attr(770,root,mpd) /var/lib/%{name}/playlists
227 %dir %attr(751,root,root) /var/log/%{name}
228 %dir %attr(770,root,mpd) /var/run/%{name}
229 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/mpd.db
230 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/mpdstate
231 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/sticker.sql
232 %attr(644,mpd,mpd) %ghost /var/log/%{name}/mpd.log
233 %{_mandir}/man1/mpd.1*
234 %{_mandir}/man5/mpd.conf.5*
235
236 %files doc
237 %defattr(644,root,root,755)
238 %doc doc/user/*
239
240 %files apidocs
241 %defattr(644,root,root,755)
242 %doc doc/api doc/developer doc/protocol
This page took 0.122661 seconds and 4 git commands to generate.