]> git.pld-linux.org Git - packages/mpd.git/blob - mpd.spec
- add sysconfig (for tuning nice level)
[packages/mpd.git] / mpd.spec
1 # TODO:
2 # - add logrotate
3 #
4 # Conditional build:
5 %bcond_without  mod             # enable MOD support
6 %bcond_without  pulseaudio      # disable PulseAudio support
7
8 Summary:        Music Player Daemon
9 Summary(hu.UTF-8):      Music Player Daemon
10 Summary(pl.UTF-8):      Music Player Daemon - demon odtwarzający muzykę
11 Name:           mpd
12 Version:        0.16.2
13 Release:        2
14 License:        GPL v2+
15 Group:          Applications/Multimedia
16 Source0:        http://downloads.sourceforge.net/musicpd/%{name}-%{version}.tar.bz2
17 # Source0-md5:  dedb75cef8e489f3de5231031876fb77
18 Source1:        %{name}.conf
19 Source2:        %{name}.init
20 Source3:        %{name}.sysconfig
21 URL:            http://www.musicpd.org/
22 BuildRequires:  OpenAL-devel
23 BuildRequires:  alsa-lib-devel >= 0.9.0
24 BuildRequires:  audiofile-devel >= 0.1.7
25 BuildRequires:  avahi-glib-devel
26 BuildRequires:  bzip2-devel
27 BuildRequires:  curl-devel
28 BuildRequires:  doxygen
29 BuildRequires:  faad2-devel >= 2.6.1-5
30 BuildRequires:  ffmpeg-devel
31 BuildRequires:  flac-devel >= 1.1.0
32 BuildRequires:  fluidsynth-devel
33 BuildRequires:  glib2-devel >= 2.12
34 BuildRequires:  jack-audio-connection-kit-devel >= 0.4
35 BuildRequires:  lame-libs-devel
36 BuildRequires:  libao-devel >= 0.8.3
37 BuildRequires:  libcdio-devel
38 BuildRequires:  libcue-devel
39 BuildRequires:  libid3tag-devel
40 BuildRequires:  libmad-devel
41 %{?with_mod:BuildRequires:      libmikmod-devel >= 3.1.7}
42 BuildRequires:  libmms-devel
43 BuildRequires:  libmodplug-devel
44 BuildRequires:  libmpcdec-devel
45 BuildRequires:  libogg-devel
46 BuildRequires:  libsamplerate-devel >= 0.0.15
47 BuildRequires:  libshout-devel
48 BuildRequires:  libvorbis-devel
49 BuildRequires:  pkgconfig >= 1:0.9.0
50 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
51 BuildRequires:  sqlite3-devel
52 BuildRequires:  twolame-devel
53 BuildRequires:  wavpack-devel
54 BuildRequires:  wildmidi-devel
55 BuildRequires:  xmlto
56 BuildRequires:  zlib-devel
57 BuildRequires:  zziplib-devel
58 Provides:       group(mpd)
59 Provides:       user(mpd)
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Music Player Daemon (MPD) allows remote access for playing music (MP3,
64 Ogg Vorbis, FLAC, AAC, Mod, and wave files) and managing playlists.
65 MPD is designed for integrating a computer into a stereo system that
66 provides control for music playback over a local network. It is also
67 makes a great desktop music player, especially if you are a console
68 junkie, like frontend options, or restart X often.
69
70 %description -l hu.UTF-8
71 Music Player Daemon (MPD)-vel lehetővé válik távoli zenelejátszás
72 (MP3, Ogg Vorbis, FLAC, AAC, Mod és wav fájlok) és lejátszási listák
73 menedzselése. Az MPD a számítógépben egy zenelejátszó, amelyet
74 irányíthatsz helyi hálózaton keresztül. Egyben egy zseniális desktop
75 zenelejátszó is, különösen a konzol-mániásoknak, vagy azoknak, akik
76 sűrűn indítják újra az X-et.
77
78 %description -l pl.UTF-8
79 Music Player Daemon (MPD) pozwala na zdalny dostęp do odtwarzania
80 muzyki (plików MP3, Ogg Vorbis, FLAC, AAC, Mod i wave) oraz
81 zarządzania playlistami. MPD jest zaprojektowany do integrowania
82 komputera w system stereo umożliwiający sterowanie odtwarzaniem muzyki
83 w sieci lokalnej. Służy także za dobry odtwarzacz muzyki dla
84 komputerów biurkowych, zwłaszcza dla miłośników konsoli, różnych opcji
85 frontendów albo często restartujących X.
86
87 %prep
88 %setup -q
89
90 %build
91 # ac_cv_* hacks to avoid unwanted linking
92 %configure \
93         ac_cv_lib_iconv_main=no \
94         ac_cv_lib_nsl_gethostbyname=no \
95         %{!?with_pulseaudio:--disable-pulse} \
96         %{?with_mod:--enable-mikmod} \
97         --disable-sidplay \
98         --enable-alsa \
99         --enable-ao \
100         --enable-audiofile \
101         --enable-bzip2 \
102         --enable-cue \
103         --enable-curl \
104         --enable-documentation \
105         --enable-ffmpeg \
106         --enable-fluidsynth \
107         --enable-httpd-output \
108         --enable-iso9660 \
109         --enable-jack \
110         --enable-lame-encoder \
111         --enable-lastfm \
112         --enable-lsr \
113         --enable-mad \
114         --enable-mms \
115         --enable-modplug \
116         --enable-mvp \
117         --enable-openal \
118         --enable-pipe-output \
119         --enable-recorder-output \
120         --enable-shout \
121         --enable-sqlite \
122         --enable-twolame-encoder \
123         --enable-vorbis-encoder \
124         --enable-wave-encoder \
125         --enable-wavpack \
126         --enable-wildmidi \
127         --enable-zzip \
128         --with-zeroconf=avahi \
129         --without-tremor
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
135         $RPM_BUILD_ROOT{/var/lib/mpd/playlists,/var/log/mpd,/var/run/mpd}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
141 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mpd
142 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/mpd
143
144 touch $RPM_BUILD_ROOT/var/lib/mpd/mpd.db
145 touch $RPM_BUILD_ROOT/var/lib/mpd/mpdstate
146 touch $RPM_BUILD_ROOT/var/lib/mpd/sticker.sql
147 touch $RPM_BUILD_ROOT/var/log/mpd/mpd.log
148
149 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mpd
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %pre
155 %groupadd -g 204 mpd
156 %useradd -u 204 -r -d /home/services/mpd -s /bin/false -c "Music Player Daemon (MPD) user" -g audio -G mpd mpd
157
158 %post
159 for f in mpd.log; do
160         if [ ! -f /var/log/%{name}/$f ]; then
161                 touch /var/log/%{name}/$f
162                 chown mpd:mpd /var/log/%{name}/$f
163                 chmod 644 /var/log/%{name}/$f
164         fi
165 done
166 /sbin/chkconfig --add mpd
167
168 %preun
169 if [ "$1" = "0" ]; then
170         %service mpd stop
171         /sbin/chkconfig --del mpd
172 fi
173
174 %postun
175 if [ "$1" = "0" ]; then
176         %userremove mpd
177         %groupremove mpd
178 fi
179
180 %files
181 %defattr(644,root,root,755)
182 %doc AUTHORS NEWS README doc/mpdconf.example UPGRADING doc/api doc/developer doc/protocol doc/user
183 %attr(755,root,root) %{_bindir}/*
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mpd.conf
185 %attr(754,root,root) /etc/rc.d/init.d/mpd
186 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mpd
187 %dir %attr(770,root,mpd) /var/lib/%{name}
188 %dir %attr(770,root,mpd) /var/lib/%{name}/playlists
189 %dir %attr(751,root,root) /var/log/%{name}
190 %dir %attr(770,root,mpd) /var/run/%{name}
191 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/mpd.db
192 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/mpdstate
193 %attr(644,mpd,mpd) %ghost /var/lib/%{name}/sticker.sql
194 %attr(644,mpd,mpd) %ghost /var/log/%{name}/mpd.log
195 %{_mandir}/man1/mpd.1*
196 %{_mandir}/man5/mpd.conf.5*
This page took 0.046847 seconds and 4 git commands to generate.