]> git.pld-linux.org Git - packages/mpatrol.git/blob - mpatrol.spec
- updated to 1.4.8 (bugfixes and porting improvements).
[packages/mpatrol.git] / mpatrol.spec
1 Summary:        A library for controlling and tracing dynamic memory allocations
2 Summary(pl):    Biblioteka do kontroli i ¶ledzenia dynamicznej alokacji pamiêci
3 Name:           mpatrol
4 Version:        1.4.8
5 Release:        1
6 License:        LGPL
7 Group:          Development/Debuggers
8 Group(de):      Entwicklung/Debugger
9 Group(pl):      Programowanie/Odpluskwiacze
10 Source0:        http://www.cbmamiga.demon.co.uk/mpatrol/files/%{name}_%{version}.tar.gz
11 Patch0:         %{name}-info.patch
12 URL:            http://www.cbmamiga.demon.co.uk/mpatrol/index.html
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  texinfo
15 Prereq:         /sbin/ldconfig
16 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 A link library that attempts to diagnose run-time errors that are
20 caused by the wrong use of dynamically allocated memory. Along with
21 providing a comprehensive and configurable log of all dynamic memory
22 operations that occurred during the lifetime of a program, the mpatrol
23 library performs extensive checking to detect any misuse of
24 dynamically allocated memory. All of this functionality can be
25 integrated into existing code through the inclusion of a single header
26 file at compile-time. All logging and tracing output from the mpatrol
27 library is sent to a separate log file in order to keep its
28 diagnostics separate from any that the program being tested might
29 generate. A wide variety of library settings can also be changed at
30 run-time via an environment variable, thus removing the need to
31 recompile or relink in order to change the library's behaviour.
32
33 %description -l pl
34 Biblioteka próbuj±ca zdiagnozowaæ b³êdy dzia³ania programu spowodowane
35 z³ym u¿ywaniem dynamicznie alokowanej pamiêci. Oprócz dawania
36 obszernego i konfigurowalnego loga wszystkich dynamicznych operacji na
37 pamiêci, które wyst±pi³y podczas dzia³ania programu, biblioteka
38 mpatrol stara siê wykryæ wszelkie niew³a¶ciwe u¿ycia dynamicznie
39 przydzielonej pamiêci. Ca³a funkcjonalno¶æ mo¿e byæ zintegrowana z
40 istniej±cym kodem poprzez do³±czenie jednego pliku nag³ówkowego w
41 czasie kompilacji. Ca³e logi i zapis ¶ledzenia z biblioteki mpatrol s±
42 zapisywane do oddzielnego pliku aby oddzieliæ je od wszystkiego
43 innego, co program mo¿e wygenerowaæ. Szeroki zakres ustawieñ
44 biblioteki mo¿e byæ zmieniany bez rekompilacji poprzez ustawianie
45 zmiennych ¶rodowiskowych.
46
47 %prep
48 %setup -q -n mpatrol
49 %patch -p1
50
51 %build
52 (cd build/unix
53  %{__make} libmpatrol.a libmpatrol.so mpatrol mprof mleak \
54         OFLAGS="%{rpmcflags}"
55 )
56 (cd doc; makeinfo mpatrol.texi)
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_infodir}} \
61         $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man{1,3}}
62
63 install build/unix/{mpatrol,mprof,mleak} $RPM_BUILD_ROOT%{_bindir}
64
65 install src/mpatrol.h $RPM_BUILD_ROOT%{_includedir}
66 install build/unix/libmpatrol.{a,so*} $RPM_BUILD_ROOT%{_libdir}
67
68 install doc/mpatrol.info* $RPM_BUILD_ROOT%{_infodir}
69 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
70 install man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
71
72 gzip -9nf README NEWS ChangeLog
73
74 %files
75 %defattr(644,root,root,755)
76 %doc *.gz
77 %attr(755,root,root) %{_bindir}/*
78 %attr(755,root,root) %{_libdir}/*.so*
79 %{_libdir}/*.a
80 %{_includedir}/*
81 %{_infodir}/*
82 %{_mandir}/man[13]/*
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post
88 /sbin/ldconfig
89 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
90
91 %postun
92 /sbin/ldconfig
93 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
This page took 0.055391 seconds and 3 git commands to generate.