]> git.pld-linux.org Git - packages/mpatrol.git/blob - mpatrol.spec
236a1a971a892478833d597484f5ce05df10bca8
[packages/mpatrol.git] / mpatrol.spec
1 Summary:        A library for controlling and tracing dynamic memory allocations
2 Summary(pl):    Biblioteka do kontroli i ¶ledzenia dynamicznej alokacji pamiêcie
3 Name:           mpatrol
4 Version:        1.4.5
5 Release:        1
6 License:        LGPL
7 Group:          Development/Debuggers
8 Group(de):      Entwicklung/Debugger
9 Group(pl):      Programowanie/Odpluskwiacze
10 Source0:        http://www.cbmamiga.demon.co.uk/mpatrol/files/%{name}_%{version}.tar.gz
11 Patch0:         %{name}-info.patch
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  texinfo
14 URL:            http://www.cbmamiga.demon.co.uk/mpatrol/index.html
15 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 A link library that attempts to diagnose run-time errors that are
19 caused by the wrong use of dynamically allocated memory. Along with
20 providing a comprehensive and configurable log of all dynamic memory
21 operations that occurred during the lifetime of a program, the mpatrol
22 library performs extensive checking to detect any misuse of
23 dynamically allocated memory. All of this functionality can be
24 integrated into existing code through the inclusion of a single header
25 file at compile-time. All logging and tracing output from the mpatrol
26 library is sent to a separate log file in order to keep its
27 diagnostics separate from any that the program being tested might
28 generate. A wide variety of library settings can also be changed at
29 run-time via an environment variable, thus removing the need to
30 recompile or relink in order to change the library's behaviour.
31
32 %prep
33 %setup -q -n mpatrol
34 %patch -p1
35
36 %build
37 (cd build/unix
38  %{__make} libmpatrol.a libmpatrol.so mpatrol mprof mleak \
39         OFLAGS="%{rpmcflags}"
40 )
41 (cd doc; makeinfo mpatrol.texi)
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_infodir}} \
46         $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man{1,3}}
47
48 install build/unix/{mpatrol,mprof,mleak} $RPM_BUILD_ROOT%{_bindir}
49
50 install src/mpatrol.h $RPM_BUILD_ROOT%{_includedir}
51 install build/unix/libmpatrol.{a,so*} $RPM_BUILD_ROOT%{_libdir}
52
53 install doc/mpatrol.info* $RPM_BUILD_ROOT%{_infodir}
54 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
55 install man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
56
57 gzip -9nf README NEWS ChangeLog
58
59 %files
60 %defattr(644,root,root,755)
61 %doc *.gz
62 %attr(755,root,root) %{_bindir}/*
63 %{_includedir}/*
64 %{_libdir}/*
65 %{_infodir}/*
66 %{_mandir}/man[13]/*
67
68 %post
69 /sbin/ldconfig
70 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
71
72 %postun
73 /sbin/ldconfig
74 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
This page took 0.077049 seconds and 3 git commands to generate.