]> git.pld-linux.org Git - packages/mozjs68.git/blob - mozjs68.spec
31a8110fb5a5f9e80286f2c712faa04ee0fd372c
[packages/mozjs68.git] / mozjs68.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # tests build
4
5 Summary:        SpiderMonkey 68 - JavaScript implementation
6 Summary(pl.UTF-8):      SpiderMonkey 68 - implementacja języka JavaScript
7 Name:           mozjs68
8 Version:        68.12.0
9 Release:        6
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0:       http://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-%{version}.tar.bz2
13 Source0:        http://ftp.mozilla.org/pub/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
14 # Source0-md5:  80ae7816399f20cc61c9b15495b2341d
15 Patch0:         copy-headers.patch
16 Patch1:         system-virtualenv.patch
17 Patch2:         include-configure-script.patch
18 Patch3:         x32.patch
19 Patch4:         no-rust.patch
20 URL:            https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey
21 BuildRequires:  autoconf2_13 >= 2.13
22 # "TestWrappingOperations.cpp:27:1: error: non-constant condition for static assertion" with -fwrapv on gcc 6 and 7
23 %{?with_tests:BuildRequires:    gcc-c++ >= 6:8}
24 BuildRequires:  libicu-devel >= 59.1
25 BuildRequires:  libstdc++-devel >= 6:4.4
26 BuildRequires:  llvm
27 BuildRequires:  nspr-devel >= 4.19
28 BuildRequires:  perl-base >= 1:5.6
29 BuildRequires:  pkgconfig
30 BuildRequires:  python >= 1:2.5
31 BuildRequires:  python-psutil
32 BuildRequires:  python-virtualenv >= 1.9.1-4
33 BuildRequires:  readline-devel
34 BuildRequires:  rpm-perlprov
35 BuildRequires:  rpmbuild(macros) >= 1.294
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRequires:  zlib-devel >= 1.2.3
39 Requires:       nspr >= 4.19
40 Requires:       zlib >= 1.2.3
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 JavaScript Reference Implementation (codename SpiderMonkey). The
45 package contains JavaScript runtime (compiler, interpreter,
46 decompiler, garbage collector, atom manager, standard classes) and
47 small "shell" program that can be used interactively and with .js
48 files to run scripts.
49
50 %description -l pl.UTF-8
51 Wzorcowa implementacja JavaScriptu (o nazwie kodowej SpiderMonkey).
52 Pakiet zawiera środowisko uruchomieniowe (kompilator, interpreter,
53 dekompilator, odśmiecacz, standardowe klasy) i niewielką powłokę,
54 która może być używana interaktywnie lub z plikami .js do uruchamiania
55 skryptów.
56
57 %package devel
58 Summary:        Header files for JavaScript reference library
59 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki JavaScript
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       libstdc++-devel
63 Requires:       nspr-devel >= 4.19
64
65 %description devel
66 Header files for JavaScript reference library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe do biblioteki JavaScript.
70
71 %prep
72 %setup -q -n firefox-%{version}
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77 %patch4 -p1
78
79 %build
80 export PYTHON="%{__python}"
81 export AUTOCONF="%{_bindir}/autoconf2_13"
82 export SHELL="/bin/sh"
83 cd js/src
84 mkdir -p obj
85 cd obj
86
87 %define configuredir ".."
88 %configure2_13 \
89         --enable-gcgenerational \
90         --disable-jemalloc \
91         --enable-readline \
92         --enable-shared-js \
93         %{!?with_tests:--disable-tests} \
94         --enable-threadsafe \
95         --with-intl-api \
96         --with-system-icu \
97         --with-system-nspr \
98         --with-system-zlib
99
100 %{__make} \
101         HOST_OPTIMIZE_FLAGS= \
102         MODULE_OPTIMIZE_FLAGS= \
103         MOZ_OPTIMIZE_FLAGS="-freorder-blocks" \
104         MOZ_PGO_OPTIMIZE_FLAGS= \
105         MOZILLA_VERSION=%{version}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 cd js/src/obj
111
112 %{__make} -C js/src install \
113     DESTDIR=$RPM_BUILD_ROOT \
114     MOZILLA_VERSION=%{version}
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.ajs
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc js/src/README.html
127 %attr(755,root,root) %{_bindir}/js68
128 %attr(755,root,root) %{_libdir}/libmozjs-68.so
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/js68-config
133 %{_includedir}/mozjs-68
134 %{_pkgconfigdir}/mozjs-68.pc
This page took 0.067114 seconds and 4 git commands to generate.