]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
Cleanup patches
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_with     agent           # with ssh agent forwarding patch
4
5 %define         protobuf_ver    2.6.1
6 Summary:        Mosh mobile shell
7 Summary(pl.UTF-8):      Mosh - przenośna powłoka
8 Name:           mosh
9 Version:        1.4.0
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/Networking
13 Source0:        https://mosh.org/%{name}-%{version}.tar.gz
14 # Source0-md5:  c34a647f8545565d79188acacaea7559
15 Patch0:         https://github.com/keithw/mosh/pull/583.patch
16 # Patch0-md5:   7eb14665ef06072591e5bcd80780c0e4
17 URL:            https://mosh.org/
18 BuildRequires:  autoconf >= 2.61
19 BuildRequires:  automake
20 BuildRequires:  binutils >= 2.20.51.0.2
21 BuildRequires:  libstdc++-devel >= 5:4.0
22 BuildRequires:  libtool
23 BuildRequires:  libutempter-devel
24 BuildRequires:  ncurses-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  patchutils
27 BuildRequires:  perl-base >= 1:5.14
28 BuildRequires:  pkgconfig
29 BuildRequires:  protobuf >= %{protobuf_ver}
30 BuildRequires:  protobuf-devel >= %{protobuf_ver}
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  zlib-devel
34 Requires:       protobuf-libs >= %{protobuf_ver}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # PLD stack protector flags are weaker than upstream, filter them out
38 # https://github.com/keithw/mosh/issues/203
39 %define         _ssp_cflags     %{nil}
40
41 %define         specflags       -Wno-error=non-virtual-dtor
42
43 %description
44 Remote terminal application that allows roaming, supports intermittent
45 connectivity, and provides intelligent local echo and line editing of
46 user keystrokes.
47
48 Mosh is a replacement for SSH. It's more robust and responsive,
49 especially over Wi-Fi, cellular, and long-distance links.
50
51 %description -l pl.UTF-8
52 Zdalna aplikacja terminala, pozwalająca na przemieszczanie,
53 obsługująca przerywaną łączność i zapewniająca inteligentne lokalne
54 echo oraz edycję linii.
55
56 Mosh to zamiennik SSH. Jest potężniejszy i responsywny, w
57 szczególności po połączeniach Wi-Fi, komórkowych i długodystansowych.
58
59 %prep
60 %setup -q
61 %if %{with agent}
62 %patch0 -p1
63 %endif
64 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
65
66 %build
67 %{__libtoolize}
68 %{__aclocal} -I m4
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         --disable-silent-rules \
74         --enable-compile-warnings=error
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog NEWS THANKS
89 %attr(755,root,root) %{_bindir}/%{name}
90 %attr(755,root,root) %{_bindir}/%{name}-client
91 %attr(755,root,root) %{_bindir}/%{name}-server
92 %{_mandir}/man1/%{name}.1*
93 %{_mandir}/man1/%{name}-client.1*
94 %{_mandir}/man1/%{name}-server.1*
This page took 0.114982 seconds and 4 git commands to generate.