]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
- fix gcc epoch
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_without  verbose         # verbose build (V=1)
4
5 %if "%{pld_release}" == "ac"
6 # add suffix, but allow ccache, etc in ~/.rpmmacros
7 %{expand:%%define       __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
8 %{expand:%%define       __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
9 %{expand:%%define       __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
10 %endif
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Mosh mobile shell
14 Name:           mosh
15 Version:        1.2.2
16 Release:        1
17 License:        GPL v3+
18 Group:          X11/Applications
19 Source0:        https://github.com/downloads/keithw/mosh/%{name}-%{version}.tar.gz
20 # Source0-md5:  7ed5b857307685794dcd120afe5bdf52
21 URL:            http://mosh.mit.edu/
22 BuildRequires:  binutils >= 2.20.51.0.2
23 BuildRequires:  libstdc++-devel >= 5:4.0
24 BuildRequires:  libutempter-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  protobuf
27 BuildRequires:  protobuf-devel
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  zlib-devel
31 # gcc4 might be installed, but not current __cc
32 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
33 BuildRequires:  __cc >= 4.0
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Remote terminal application that allows roaming, supports intermittent
39 connectivity, and provides intelligent local echo and line editing of
40 user keystrokes.
41
42 Mosh is a replacement for SSH. It's more robust and responsive,
43 especially over Wi-Fi, cellular, and long-distance links.
44
45 %prep
46 %setup -q
47 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh
48
49 %build
50 %configure \
51         --enable-compile-warnings=error \
52         CPPFLAGS="-I/usr/include/ncurses"
53 %{__make} \
54         %{?with_verbose:V=1}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc AUTHORS ChangeLog NEWS THANKS
67 %attr(755,root,root) %{_bindir}/%{name}
68 %attr(755,root,root) %{_bindir}/%{name}-client
69 %attr(755,root,root) %{_bindir}/%{name}-server
70 %{_mandir}/man1/%{name}.1*
71 %{_mandir}/man1/%{name}-client.1*
72 %{_mandir}/man1/%{name}-server.1*
This page took 0.069581 seconds and 4 git commands to generate.