]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
ae2d65b475a1962444efa4678979014770be3fcb
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_with     agent           # with ssh agent forwarding patch
4
5 %define         protobuf_ver    2.6.1
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Mosh mobile shell
8 Name:           mosh
9 Version:        1.2.6
10 Release:        1
11 License:        GPL v3+
12 Group:          X11/Applications
13 #Source0:       https://github.com/mobile-shell/mosh/releases/download/%{name}-%{version}/mosh-%{version}.tar.gz
14 Source0:        http://mosh.mit.edu/%{name}-%{version}.tar.gz
15 # Source0-md5:  bb4e24795bb135a754558176a981ee9e
16 Patch0:         https://github.com/keithw/mosh/pull/583.patch
17 # Patch0-md5:   7eb14665ef06072591e5bcd80780c0e4
18 URL:            http://mosh.mit.edu/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  binutils >= 2.20.51.0.2
22 BuildRequires:  libstdc++-devel >= 5:4.0
23 BuildRequires:  libtool
24 BuildRequires:  libutempter-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  openssl-devel
27 BuildRequires:  patchutils
28 BuildRequires:  perl-base >= 1:5.14
29 BuildRequires:  pkgconfig
30 BuildRequires:  protobuf >= %{protobuf_ver}
31 BuildRequires:  protobuf-devel >= %{protobuf_ver}
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  zlib-devel
35 Requires:       protobuf-libs >= %{protobuf_ver}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # PLD stack protector flags are weaker than upstream, filter them out
39 # https://github.com/keithw/mosh/issues/203
40 %define         _ssp_cflags     %{nil}
41
42 %define         specflags       -Wno-error=non-virtual-dtor
43
44 %description
45 Remote terminal application that allows roaming, supports intermittent
46 connectivity, and provides intelligent local echo and line editing of
47 user keystrokes.
48
49 Mosh is a replacement for SSH. It's more robust and responsive,
50 especially over Wi-Fi, cellular, and long-distance links.
51
52 %prep
53 %setup -q
54 %if %{with agent}
55 %patch0 -p1
56 %endif
57 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --disable-silent-rules \
67         --enable-compile-warnings=error
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS ChangeLog NEWS THANKS
81 %attr(755,root,root) %{_bindir}/%{name}
82 %attr(755,root,root) %{_bindir}/%{name}-client
83 %attr(755,root,root) %{_bindir}/%{name}-server
84 %{_mandir}/man1/%{name}.1*
85 %{_mandir}/man1/%{name}-client.1*
86 %{_mandir}/man1/%{name}-server.1*
This page took 0.084391 seconds and 3 git commands to generate.