]> git.pld-linux.org Git - packages/mono-tools.git/blob - mono-tools.spec
- adjusted for mono 4.x
[packages/mono-tools.git] / mono-tools.spec
1 #
2 # Conditional build:
3 %bcond_with     gecko           # gecko html renderer
4 #
5 %include        /usr/lib/rpm/macros.mono
6 Summary:        Mono Tools
7 Summary(pl.UTF-8):      Narzędzia do mono
8 Name:           mono-tools
9 Version:        4.2
10 Release:        3
11 License:        GPL v2+
12 Group:          Development/Tools
13 # also available on github
14 #Source0:       https://github.com/mono/mono-tools/archive/%{version}/%{name}-%{version}.tar.gz
15 Source0:        http://download.mono-project.com/sources/mono-tools/%{name}-%{version}.tar.gz
16 # Source0-md5:  d4b7c711ff8295173766c44973c6c10e
17 Patch0:         %{name}-pwd.patch
18 Patch1:         %{name}-configure.patch
19 URL:            http://www.mono-project.com/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  dotnet-gconf-sharp-devel >= 2.16.0
23 %{?with_gecko:BuildRequires:    dotnet-gecko-sharp2-devel >= 0.12}
24 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
25 # gtk-sharp-2.0, glade-sharp-2.0
26 BuildRequires:  dotnet-gtk-sharp2-devel
27 BuildRequires:  dotnet-webkit-sharp-devel >= 0.2-1
28 BuildRequires:  gettext-tools
29 BuildRequires:  glib2-devel >= 2.0
30 BuildRequires:  libgdiplus
31 BuildRequires:  mono-compat-links
32 BuildRequires:  mono-csharp
33 BuildRequires:  mono-devel >= 4.0
34 BuildRequires:  mono-monodoc >= 3.2.5-2
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.730
37 BuildRequires:  rpmbuild(monoautodeps)
38 BuildRequires:  sed >= 4.0
39 Requires:       hicolor-icon-theme
40 Requires:       mono >= 2.10
41 Requires:       mono-tools-html-renderer
42 Obsoletes:      mono-tools-gtkhtml
43 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 ia64 mips ppc ppc64 s390x sparc sparcv9 sparc64
44 ExcludeArch:    i386
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # provided in private directory
48 %define         _noautoreq_mono Gendarme.Framework Gendarme.Rules.Performance
49
50 %description
51 Mono Tools is a collection of development and testing programs and
52 utilities for use with Mono.
53
54 %description -l pl.UTF-8
55 Mono Tools jest kolekcją rozwojowych i testowych programów oraz
56 narzędzi do użycia z Mono.
57
58 %package gecko
59 Summary:        Gecko based monodoc HTML renderer
60 Summary(pl.UTF-8):      Oparty na gecko wyświetlacz HTML-a dla monodoc
61 Group:          Development/Tools
62 Requires:       %{name} = %{version}-%{release}
63 Provides:       mono-tools-html-renderer
64
65 %description gecko
66 Gecko based monodoc HTML renderer.
67
68 %description gecko -l pl.UTF-8
69 Oparty na gecko wyświetlacz HTML-a dla monodoc.
70
71 %package webkit
72 Summary:        WebKit based monodoc HTML renderer
73 Summary(pl.UTF-8):      Oparty na WebKit wyświetlacz HTML-a dla monodoc
74 Group:          Development/Tools
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       mono-tools-html-renderer
77
78 %description webkit
79 WebKit based monodoc HTML renderer.
80
81 %description webkit -l pl.UTF-8
82 Oparty na WebKit wyświetlacz HTML-a dla monodoc.
83
84 %package monowebbrowser
85 Summary:        Mono.WebBrowser based monodoc HTML renderer
86 Summary(pl.UTF-8):      Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc
87 Group:          Development/Tools
88 Requires:       %{name} = %{version}-%{release}
89 Provides:       mono-tools-html-renderer
90
91 %description monowebbrowser
92 Mono.WebBrowser based monodoc HTML renderer.
93
94 %description monowebbrowser -l pl.UTF-8
95 Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc.
96
97 %package gendarme
98 Summary:        A tool to find problems in .NET applications and libraries
99 Summary(pl.UTF-8):      Narzędzie znajdujące problemy w aplikacjach i bibliotekach .NET
100 Group:          Development/Tools
101 Requires:       monodoc >= 2.10
102
103 %description gendarme
104 Gendarme is a extensible rule-based tool to find problems in .NET
105 applications and libraries. Gendarme inspects programs and libraries
106 that contain code in ECMA CIL format (Mono and .NET) and looks for
107 common problems with the code, problems that compiler do not typically
108 check or have not historically checked.
109
110 %description gendarme -l pl.UTF-8
111 Gendarme to rozszerzalne narzędzie oparte o regułki, znajdujące
112 problemy w aplikacjach i bibliotekach .NET. Gendarme przeprowadza
113 inspekcję programów i bibliotek w formacie ECMA CIL (Mono i .NET)
114 szukając typowych problemów, których często kompilator nie sprawdza,
115 lub tych które nie były kiedyś sprawdzane.
116
117 %package gui-compare
118 Summary:        Compares API changes between different assemblies
119 Summary(pl.UTF-8):      Porównuje zmiany API między różnymi assembly
120 Group:          Development/Tools
121
122 %description gui-compare
123 Compares API changes between different assemblies.
124
125 %description gui-compare -l pl.UTF-8
126 Porównuje zmiany API między różnymi assembly.
127
128 %package mprof-decoder
129 Summary:        Console decoder for the logging profiler output files
130 Summary(pl.UTF-8):      Konsolowy dekoder dla plików tworzonych przez logujący profiler
131 Group:          Development/Tools
132
133 %description mprof-decoder
134 Decodes the contents of a logging profiler output file and prints the
135 data on standard output.
136
137 %description mprof-decoder -l pl.UTF-8
138 Dekoduje zawartość pliku wynikowego profilera logującego i wypisuje
139 dane na standardowe wyjście.
140
141 %package mprof-heap-viewer
142 Summary:        GUI viewer for the logging profiler heap snapshots
143 Summary(pl.UTF-8):      Narzędzie do oglądania migawek sterty profilera logującego
144 Group:          Development/Tools
145
146 %description mprof-heap-viewer
147 This program decodes the contents of a logging profiler output file
148 and locates all the heap snapshots inside it. The user can then select
149 each individual snapshot and decide to load it in memory and explore
150 its contents.
151
152 %description mprof-heap-viewer -l pl.UTF-8
153 Ten program dekoduje plik wynikowy profilera logującego i lokalizuje
154 wszystkie znajdujące się w nim migawki sterty. Umożliwia wybranie
155 dowolnej migawki i załadowanie jej do pamięci w celu obejrzenia
156 zawartości.
157
158 %prep
159 %setup -q
160 %patch0 -p1
161 %patch1 -p1
162
163 # as expected by ilcontrast script
164 %{__sed} -i -e 's,\$(libdir)/ilcontrast,$(prefix)/lib/ilcontrast,' ilcontrast/Makefile.am
165
166 # mono-2.8+ path for gasnview.exe
167 %{__sed} -i -e 's,mono/1.0,mono/4.5,' asn1view/gtk/Makefile.am
168
169 %build
170 %{__glib_gettextize}
171 %{__aclocal}
172 %{__autoconf}
173 %{__automake}
174 %configure
175 %{__make} -j1
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT \
182         pkgconfigdir=%{_pkgconfigdir} \
183         pkglibdir=%{_prefix}/lib/mono-tools
184
185 # debug
186 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/mono-tools/{Mono.Profiler.Widgets.dll,emveepee.exe}.mdb
187
188 %find_lang %{name}
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post
194 %update_icon_cache hicolor
195
196 %postun
197 %update_icon_cache hicolor
198
199 %files -f %{name}.lang
200 %defattr(644,root,root,755)
201 %doc AUTHORS ChangeLog README
202 %attr(755,root,root) %{_bindir}/create-native-map
203 %attr(755,root,root) %{_bindir}/emveepee
204 %attr(755,root,root) %{_bindir}/gasnview
205 %attr(755,root,root) %{_bindir}/gsharp
206 %attr(755,root,root) %{_bindir}/ilcontrast
207 %attr(755,root,root) %{_bindir}/minvoke
208 %attr(755,root,root) %{_bindir}/monodoc
209 %attr(755,root,root) %{_bindir}/mperfmon
210 %dir %{_prefix}/lib/gsharp
211 %attr(755,root,root) %{_prefix}/lib/gsharp/gsharp.exe
212 %{_prefix}/lib/gsharp/gsharp.exe.config
213 %attr(755,root,root) %{_prefix}/lib/mono/4.5/gasnview.exe
214 %{_prefix}/lib/create-native-map
215 %dir %{_prefix}/lib/ilcontrast
216 %attr(755,root,root) %{_prefix}/lib/ilcontrast/ilcontrast.exe
217 %dir %{_prefix}/lib/minvoke
218 %attr(755,root,root) %{_prefix}/lib/minvoke/minvoke.exe
219 %dir %{_prefix}/lib/mperfmon
220 %{_prefix}/lib/mperfmon/config
221 %attr(755,root,root) %{_prefix}/lib/mperfmon/mperfmon.exe
222 %dir %{_prefix}/lib/mono-tools
223 %{_prefix}/lib/mono-tools/Mono.Profiler.Widgets.dll
224 %attr(755,root,root) %{_prefix}/lib/mono-tools/emveepee.exe
225 %attr(755,root,root) %{_prefix}/lib/monodoc/browser.exe
226 %{_prefix}/lib/monodoc/web
227 %{_desktopdir}/gsharp.desktop
228 %{_desktopdir}/ilcontrast.desktop
229 %{_desktopdir}/monodoc.desktop
230 %{_pixmapsdir}/ilcontrast.png
231 %{_pixmapsdir}/monodoc.png
232 %{_iconsdir}/hicolor/*x*/apps/monodoc.png
233 %{_pkgconfigdir}/create-native-map.pc
234 %{_mandir}/man1/create-native-map.1*
235 %{_mandir}/man1/mperfmon.1*
236
237 %if %{with gecko}
238 %files gecko
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_bindir}/ilcontrast
241 %{_prefix}/lib/ilcontrast
242 %{_prefix}/lib/monodoc/GeckoHtmlRender.dll
243 %{_desktopdir}/ilcontrast.desktop
244 %{_pixmapsdir}/ilcontrast.png
245 %endif
246
247 %files webkit
248 %defattr(644,root,root,755)
249 %{_prefix}/lib/monodoc/WebKitHtmlRender.dll
250
251 %files monowebbrowser
252 %defattr(644,root,root,755)
253 %{_prefix}/lib/monodoc/MonoWebBrowserHtmlRender.dll
254
255 %files gendarme
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_bindir}/gd2i
258 %attr(755,root,root) %{_bindir}/gendarme
259 %attr(755,root,root) %{_bindir}/gendarme-wizard
260 %{_prefix}/lib/gendarme
261 %{_prefix}/lib/monodoc/sources/Gendarme*
262 %{_prefix}/lib/monodoc/sources/gendarme*
263 %{_desktopdir}/gendarme-wizard.desktop
264 %{_pkgconfigdir}/gendarme-framework.pc
265 %{_pixmapsdir}/gendarme.svg
266 %{_mandir}/man1/gd2i.1*
267 %{_mandir}/man1/gendarme.1*
268 %{_mandir}/man5/gendarme.5*
269
270 %files gui-compare
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_bindir}/gui-compare
273 %{_prefix}/lib/gui-compare
274
275 %files mprof-decoder
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_bindir}/mprof-decoder
278 %{_prefix}/lib/mono-tools/mprof-decoder-library.*
279 %{_prefix}/lib/mono-tools/mprof-decoder.*
280 %{_mandir}/man1/mprof-decoder.1*
281
282 %files mprof-heap-viewer
283 %defattr(644,root,root,755)
284 %attr(755,root,root) %{_bindir}/mprof-heap-viewer
285 %{_prefix}/lib/mono-tools/mprof-heap-snapshot-explorer.*
286 %{_prefix}/lib/mono-tools/mprof-heap-viewer.*
287 %{_mandir}/man1/mprof-heap-viewer.1*
This page took 0.080761 seconds and 3 git commands to generate.