]> git.pld-linux.org Git - packages/mlkit.git/blob - mlkit.spec
- first revision
[packages/mlkit.git] / mlkit.spec
1 Summary:        A Standard ML native compiler
2 Summary(pl):    Kompilator Standard ML do kodu maszynowego x86
3 Name:           mlkit
4 Version:        4.0.0
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.it.edu/research/mlkit/download/%{name}-%{version}.tgz
9 URL:            http://www.it.edu/research/mlkit
10 BuildRequires:  smlnj = 110.0.7
11 Requires:       %{name}-common = %{version}
12 ExclusiveArch:  %{ix86}
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 # don't strip heap images
16 %define         no_install_post_strip 1
17
18 %description 
19 The ML Kit (henceforth refered to as the Kit) is a compiler for the
20 programming language Standard ML. The Kit covers all of Standard ML,
21 as defined in the 1997 edition of the Definition of Standard ML and
22 supports most of the Standard ML Basis Library. The Kit uses a region
23 based memory management scheme in which allocation and de-allocation
24 primitives are added to the program at compile time. The Kit also
25 makes it possible to combine the region based memory management scheme
26 with traditional reference tracing garbage collection. The largest program
27 compiled with the Kit is the Kit itself (around 80.000 lines of SML,
28 plus the Basis Library).
29
30 This package provides version of compiler which generates effective x86
31 machine code.
32
33 %description -l pl
34 ML Kit jest kompilatorem dla jêzyka programowania Standard ML. ML Kit
35 obejmuje kompletny standard SML 97 i wspiera wiêkszo¶æ standardowej
36 biblioteki SML (Standard ML Basis Library). ML Kit u¿ywa schematu
37 zarz±dzania pamiêci± bazuj±cego na regionach, w którym operacje alokacji
38 i dealokacji s± dodawane do programu w trakcie kompilacji. ML Kit umo¿liwia
39 tak¿e ³±czenie zarz±dzania pamiêci± opartego na regionach ze standardowym
40 od¶miecaniem ze zliczaniem referencji. Najwiêkszym programem skompilowanym
41 przez ML Kit jest on sam (oko³o 80000 linii SML plus biblioteka standardowa).
42
43 Pakiet tez zawiera wersjê kompilatora generuj±c± efektywny kod dla maszyn
44 x86.
45
46 %package kam
47 Summary:        A Standard ML bytecode compiler
48 Summary(pl):    Kompilator Standard ML do przenosnego kodu bajtowego
49 Group:          Development/Languages
50 Requires:       %{name}-common = %{version}
51
52 %description kam 
53 The ML Kit (henceforth refered to as the Kit) is a compiler for the
54 programming language Standard ML. The Kit covers all of Standard ML,
55 as defined in the 1997 edition of the Definition of Standard ML and
56 supports most of the Standard ML Basis Library. The Kit uses a region
57 based memory management scheme in which allocation and de-allocation
58 primitives are added to the program at compile time. The Kit also
59 makes it possible to combine the region based memory management scheme
60 with traditional reference tracing garbage collection. The largest program
61 compiled with the Kit is the Kit itself (around 80.000 lines of SML,
62 plus the Basis Library).
63
64 This package provides version of compiler which generates portable bytecode
65 that can be interpreted by an abstract machine.
66
67 %description kam -l pl
68 ML Kit jest kompilatorem dla jêzyka programowania Standard ML. ML Kit
69 obejmuje kompletny standard SML 97 i wspiera wiêkszo¶æ standardowej
70 biblioteki SML (Standard ML Basis Library). ML Kit u¿ywa schematu
71 zarz±dzania pamiêci± bazuj±cego na regionach, w którym operacje alokacji
72 i dealokacji s± dodawane do programu w trakcie kompilacji. ML Kit umo¿liwia
73 tak¿e ³±czenie zarz±dzania pamiêci± opartego na regionach ze standardowym
74 od¶miecaniem ze zliczaniem referencji. Najwiêkszym programem skompilowanym
75 przez ML Kit jest on sam (oko³o 80000 linii SML plus biblioteka standardowa).
76
77 Pakiet tez zawiera wersjê kompilatora generuj±c± przeno¶ny kod bajtowy który
78 mo¿e byæ interpretowany przez maszynê wirtualn±
79
80 %package common
81 Summary:        Common files for ML Kit bytecode and native compilers
82 Summary(pl):    Pliki wspólne dla kompilatora natywnego i kodu bajtowego ML Kit
83 Group:          Development/Languages
84
85 %description common
86 Common files for ML Kit bytecode and native compilers.
87 Install mlkit or mlkit-kam packages for full ML Kit system.
88
89 %description common -l pl
90 Pliki wspólne dla kompilatora natywnego i kodu bajtowego ML Kit.
91 Zainstaluj pakiety mlkit lub mlkit-kam dla pe³nego systemu ML Kit.
92
93 %prep
94 %setup -q
95
96 %build
97 %{__make} mlkit
98 %{__make} mlkit_kam
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT{%{_libdir}/mlkit/bin,%{_bindir},%{_examplesdir}}
104 install bin/{runtimeSystem*.o,kam} $RPM_BUILD_ROOT%{_libdir}/mlkit/bin
105 install bin/mlkit{,_kam}.x86-linux $RPM_BUILD_ROOT%{_libdir}/mlkit/bin
106 install bin/rp2ps $RPM_BUILD_ROOT%{_bindir}
107 cp -a basislib ml-yacc-lib $RPM_BUILD_ROOT%{_libdir}/mlkit
108 cp -a kitdemo $RPM_BUILD_ROOT%{_examplesdir}/mlkit-%{version}
109 (cd $RPM_BUILD_ROOT && ln -sf %{_bindir}/rp2ps .%{_libdir}/mlkit/bin/rp2ps)
110
111 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/mlkit
112 #!/bin/sh
113 %{_prefix}/lib/mlkit/bin/mlkit.x86-linux %{_libdir}/mlkit $*
114 EOF
115 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/mlkit_kam
116 #!/bin/sh
117 %{_prefix}/lib/mlkit/bin/mlkit_kam.x86-linux %{_libdir}/mlkit $*
118 EOF
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/rp2ps
126 %attr(755,root,root) %{_bindir}/mlkit
127 %attr(755,root,root) %{_libdir}/mlkit/bin/mlkit.x86-linux
128 %attr(755,root,root) %{_libdir}/mlkit/bin/rp2ps
129 %{_libdir}/mlkit/bin/runtimeSystem*.o
130
131 %files kam
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/mlkit_kam
134 %attr(755,root,root) %{_libdir}/mlkit/bin/kam
135 %attr(755,root,root) %{_libdir}/mlkit/bin/mlkit_kam.x86-linux
136
137 %files common
138 %defattr(644,root,root,755)
139 %doc README NEWS doc/manual/mlkit.pdf
140 %{_libdir}/mlkit/ml-yacc-lib
141 %{_libdir}/mlkit/basislib
142 %{_examplesdir}/mlkit-%{version}
This page took 0.07058 seconds and 4 git commands to generate.