]> git.pld-linux.org Git - packages/mlkit.git/blob - mlkit.spec
- updated to 4.1.1
[packages/mlkit.git] / mlkit.spec
1 Summary:        A Standard ML native compiler
2 Summary(pl):    Kompilator Standard ML do kodu maszynowego x86
3 Name:           mlkit
4 Version:        4.1.1
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.it.edu/research/mlkit/dist/%{name}-%{version}.tgz
9 Patch0:         %{name}-OPT.patch
10 URL:            http://www.it.edu/research/mlkit
11 BuildRequires:  smlnj = 110.0.7
12 Requires:       %{name}-common = %{version}
13 ExclusiveArch:  %{ix86}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # don't strip heap images
17 %define         no_install_post_strip 1
18
19 %description 
20 The ML Kit (henceforth refered to as the Kit) is a compiler for the
21 programming language Standard ML. The Kit covers all of Standard ML,
22 as defined in the 1997 edition of the Definition of Standard ML and
23 supports most of the Standard ML Basis Library. The Kit uses a region
24 based memory management scheme in which allocation and de-allocation
25 primitives are added to the program at compile time. The Kit also
26 makes it possible to combine the region based memory management scheme
27 with traditional reference tracing garbage collection. The largest program
28 compiled with the Kit is the Kit itself (around 80.000 lines of SML,
29 plus the Basis Library).
30
31 This package provides version of compiler which generates effective x86
32 machine code.
33
34 %description -l pl
35 ML Kit jest kompilatorem dla jêzyka programowania Standard ML. ML Kit
36 obejmuje kompletny standard SML 97 i wspiera wiêkszo¶æ standardowej
37 biblioteki SML (Standard ML Basis Library). ML Kit u¿ywa schematu
38 zarz±dzania pamiêci± bazuj±cego na regionach, w którym operacje alokacji
39 i dealokacji s± dodawane do programu w trakcie kompilacji. ML Kit umo¿liwia
40 tak¿e ³±czenie zarz±dzania pamiêci± opartego na regionach ze standardowym
41 od¶miecaniem ze zliczaniem referencji. Najwiêkszym programem skompilowanym
42 przez ML Kit jest on sam (oko³o 80000 linii SML plus biblioteka standardowa).
43
44 Pakiet tez zawiera wersjê kompilatora generuj±c± efektywny kod dla maszyn
45 x86.
46
47 %package kam
48 Summary:        A Standard ML bytecode compiler
49 Summary(pl):    Kompilator Standard ML do przenosnego kodu bajtowego
50 Group:          Development/Languages
51 Requires:       %{name}-common = %{version}
52
53 %description kam 
54 The ML Kit (henceforth refered to as the Kit) is a compiler for the
55 programming language Standard ML. The Kit covers all of Standard ML,
56 as defined in the 1997 edition of the Definition of Standard ML and
57 supports most of the Standard ML Basis Library. The Kit uses a region
58 based memory management scheme in which allocation and de-allocation
59 primitives are added to the program at compile time. The Kit also
60 makes it possible to combine the region based memory management scheme
61 with traditional reference tracing garbage collection. The largest program
62 compiled with the Kit is the Kit itself (around 80.000 lines of SML,
63 plus the Basis Library).
64
65 This package provides version of compiler which generates portable bytecode
66 that can be interpreted by an abstract machine.
67
68 %description kam -l pl
69 ML Kit jest kompilatorem dla jêzyka programowania Standard ML. ML Kit
70 obejmuje kompletny standard SML 97 i wspiera wiêkszo¶æ standardowej
71 biblioteki SML (Standard ML Basis Library). ML Kit u¿ywa schematu
72 zarz±dzania pamiêci± bazuj±cego na regionach, w którym operacje alokacji
73 i dealokacji s± dodawane do programu w trakcie kompilacji. ML Kit umo¿liwia
74 tak¿e ³±czenie zarz±dzania pamiêci± opartego na regionach ze standardowym
75 od¶miecaniem ze zliczaniem referencji. Najwiêkszym programem skompilowanym
76 przez ML Kit jest on sam (oko³o 80000 linii SML plus biblioteka standardowa).
77
78 Pakiet tez zawiera wersjê kompilatora generuj±c± przeno¶ny kod bajtowy który
79 mo¿e byæ interpretowany przez maszynê wirtualn±
80
81 %package common
82 Summary:        Common files for ML Kit bytecode and native compilers
83 Summary(pl):    Pliki wspólne dla kompilatora natywnego i kodu bajtowego ML Kit
84 Group:          Development/Languages
85
86 %description common
87 Common files for ML Kit bytecode and native compilers.
88 Install mlkit or mlkit-kam packages for full ML Kit system.
89
90 %description common -l pl
91 Pliki wspólne dla kompilatora natywnego i kodu bajtowego ML Kit.
92 Zainstaluj pakiety mlkit lub mlkit-kam dla pe³nego systemu ML Kit.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__make} mlkit \
100         OPT="%{optflags}"
101 %{__make} mlkit_kam \
102         OPT="%{optflags}"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 install -d $RPM_BUILD_ROOT{%{_libdir}/mlkit/bin,%{_bindir},%{_examplesdir}}
108 install bin/{runtimeSystem*.a,kam} $RPM_BUILD_ROOT%{_libdir}/mlkit/bin
109 install bin/mlkit{,_kam}.x86-linux $RPM_BUILD_ROOT%{_libdir}/mlkit/bin
110 install bin/rp2ps $RPM_BUILD_ROOT%{_bindir}
111 cp -a basislib ml-yacc-lib $RPM_BUILD_ROOT%{_libdir}/mlkit
112 cp -a kitdemo $RPM_BUILD_ROOT%{_examplesdir}/mlkit-%{version}
113 (cd $RPM_BUILD_ROOT && ln -sf %{_bindir}/rp2ps .%{_libdir}/mlkit/bin/rp2ps)
114
115 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/mlkit
116 #!/bin/sh
117 %{_prefix}/lib/mlkit/bin/mlkit.x86-linux %{_libdir}/mlkit $*
118 EOF
119 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/mlkit_kam
120 #!/bin/sh
121 %{_prefix}/lib/mlkit/bin/mlkit_kam.x86-linux %{_libdir}/mlkit $*
122 EOF
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/rp2ps
130 %attr(755,root,root) %{_bindir}/mlkit
131 %attr(755,root,root) %{_libdir}/mlkit/bin/mlkit.x86-linux
132 %attr(755,root,root) %{_libdir}/mlkit/bin/rp2ps
133 %{_libdir}/mlkit/bin/runtimeSystem*.a
134
135 %files kam
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/mlkit_kam
138 %attr(755,root,root) %{_libdir}/mlkit/bin/kam
139 %attr(755,root,root) %{_libdir}/mlkit/bin/mlkit_kam.x86-linux
140
141 %files common
142 %defattr(644,root,root,755)
143 %doc README NEWS doc/manual/mlkit.pdf
144 %{_libdir}/mlkit/ml-yacc-lib
145 %{_libdir}/mlkit/basislib
146 %{_examplesdir}/mlkit-%{version}
This page took 0.084929 seconds and 4 git commands to generate.