]> git.pld-linux.org Git - packages/mlkit.git/blob - mlkit.spec
- cosmetics
[packages/mlkit.git] / mlkit.spec
1 Summary:        A Standard ML native compiler
2 Summary(pl):    Kompilator Standard ML do kodu maszynowego x86
3 Name:           mlkit
4 Version:        4.1.1
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.it.edu/research/mlkit/dist/%{name}-%{version}.tgz
9 # Source0-md5:  fc76e18d0e2201bea92344f6e1e1e5cd
10 Patch0:         %{name}-OPT.patch
11 URL:            http://www.it.edu/research/mlkit/
12 BuildRequires:  smlnj = 110.0.7
13 Requires:       %{name}-common = %{version}
14 ExclusiveArch:  %{ix86}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # don't strip heap images
18 %define         no_install_post_strip 1
19
20 %description
21 The ML Kit (henceforth refered to as the Kit) is a compiler for the
22 programming language Standard ML. The Kit covers all of Standard ML,
23 as defined in the 1997 edition of the Definition of Standard ML and
24 supports most of the Standard ML Basis Library. The Kit uses a region
25 based memory management scheme in which allocation and de-allocation
26 primitives are added to the program at compile time. The Kit also
27 makes it possible to combine the region based memory management scheme
28 with traditional reference tracing garbage collection. The largest program
29 compiled with the Kit is the Kit itself (around 80.000 lines of SML,
30 plus the Basis Library).
31
32 This package provides version of compiler which generates effective x86
33 machine code.
34
35 %description -l pl
36 ML Kit jest kompilatorem dla jêzyka programowania Standard ML. ML Kit
37 obejmuje kompletny standard SML 97 i wspiera wiêkszo¶æ standardowej
38 biblioteki SML (Standard ML Basis Library). ML Kit u¿ywa schematu
39 zarz±dzania pamiêci± bazuj±cego na regionach, w którym operacje alokacji
40 i dealokacji s± dodawane do programu w trakcie kompilacji. ML Kit umo¿liwia
41 tak¿e ³±czenie zarz±dzania pamiêci± opartego na regionach ze standardowym
42 od¶miecaniem ze zliczaniem referencji. Najwiêkszym programem skompilowanym
43 przez ML Kit jest on sam (oko³o 80000 linii SML plus biblioteka standardowa).
44
45 Pakiet tez zawiera wersjê kompilatora generuj±c± efektywny kod dla maszyn
46 x86.
47
48 %package kam
49 Summary:        A Standard ML bytecode compiler
50 Summary(pl):    Kompilator Standard ML do przenosnego kodu bajtowego
51 Group:          Development/Languages
52 Requires:       %{name}-common = %{version}
53
54 %description kam
55 The ML Kit (henceforth refered to as the Kit) is a compiler for the
56 programming language Standard ML. The Kit covers all of Standard ML,
57 as defined in the 1997 edition of the Definition of Standard ML and
58 supports most of the Standard ML Basis Library. The Kit uses a region
59 based memory management scheme in which allocation and de-allocation
60 primitives are added to the program at compile time. The Kit also
61 makes it possible to combine the region based memory management scheme
62 with traditional reference tracing garbage collection. The largest program
63 compiled with the Kit is the Kit itself (around 80.000 lines of SML,
64 plus the Basis Library).
65
66 This package provides version of compiler which generates portable bytecode
67 that can be interpreted by an abstract machine.
68
69 %description kam -l pl
70 ML Kit jest kompilatorem dla jêzyka programowania Standard ML. ML Kit
71 obejmuje kompletny standard SML 97 i wspiera wiêkszo¶æ standardowej
72 biblioteki SML (Standard ML Basis Library). ML Kit u¿ywa schematu
73 zarz±dzania pamiêci± bazuj±cego na regionach, w którym operacje alokacji
74 i dealokacji s± dodawane do programu w trakcie kompilacji. ML Kit umo¿liwia
75 tak¿e ³±czenie zarz±dzania pamiêci± opartego na regionach ze standardowym
76 od¶miecaniem ze zliczaniem referencji. Najwiêkszym programem skompilowanym
77 przez ML Kit jest on sam (oko³o 80000 linii SML plus biblioteka standardowa).
78
79 Pakiet tez zawiera wersjê kompilatora generuj±c± przeno¶ny kod bajtowy który
80 mo¿e byæ interpretowany przez maszynê wirtualn±
81
82 %package common
83 Summary:        Common files for ML Kit bytecode and native compilers
84 Summary(pl):    Pliki wspólne dla kompilatora natywnego i kodu bajtowego ML Kit
85 Group:          Development/Languages
86
87 %description common
88 Common files for ML Kit bytecode and native compilers.
89 Install mlkit or mlkit-kam packages for full ML Kit system.
90
91 %description common -l pl
92 Pliki wspólne dla kompilatora natywnego i kodu bajtowego ML Kit.
93 Zainstaluj pakiety mlkit lub mlkit-kam dla pe³nego systemu ML Kit.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__make} mlkit \
101         OPT="%{rpmcflags}"
102 %{__make} mlkit_kam \
103         OPT="%{rpmcflags}"
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT{%{_libdir}/mlkit/bin,%{_bindir},%{_examplesdir}}
109 install bin/{runtimeSystem*.a,kam} $RPM_BUILD_ROOT%{_libdir}/mlkit/bin
110 install bin/mlkit{,_kam}.x86-linux $RPM_BUILD_ROOT%{_libdir}/mlkit/bin
111 install bin/rp2ps $RPM_BUILD_ROOT%{_bindir}
112 cp -a basislib ml-yacc-lib $RPM_BUILD_ROOT%{_libdir}/mlkit
113 cp -a kitdemo $RPM_BUILD_ROOT%{_examplesdir}/mlkit-%{version}
114 (cd $RPM_BUILD_ROOT && ln -sf %{_bindir}/rp2ps .%{_libdir}/mlkit/bin/rp2ps)
115
116 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/mlkit
117 #!/bin/sh
118 %{_prefix}/lib/mlkit/bin/mlkit.x86-linux %{_libdir}/mlkit $*
119 EOF
120 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/mlkit_kam
121 #!/bin/sh
122 %{_prefix}/lib/mlkit/bin/mlkit_kam.x86-linux %{_libdir}/mlkit $*
123 EOF
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/rp2ps
131 %attr(755,root,root) %{_bindir}/mlkit
132 %attr(755,root,root) %{_libdir}/mlkit/bin/mlkit.x86-linux
133 %attr(755,root,root) %{_libdir}/mlkit/bin/rp2ps
134 %{_libdir}/mlkit/bin/runtimeSystem*.a
135
136 %files kam
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/mlkit_kam
139 %attr(755,root,root) %{_libdir}/mlkit/bin/kam
140 %attr(755,root,root) %{_libdir}/mlkit/bin/mlkit_kam.x86-linux
141
142 %files common
143 %defattr(644,root,root,755)
144 %doc README NEWS doc/manual/mlkit.pdf
145 %{_libdir}/mlkit/ml-yacc-lib
146 %{_libdir}/mlkit/basislib
147 %{_examplesdir}/mlkit-%{version}
This page took 0.102722 seconds and 4 git commands to generate.