]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- release 5: fix %install_post bug (duplicated REEADME files in %doc).
[packages/ming.git] / ming.spec
1
2 %include        /usr/lib/rpm/macros.perl
3 %include        /usr/lib/rpm/macros.python
4
5 Summary:        Ming - an SWF output library
6 Summary(pl):    Ming - biblioteka do produkcji plików SWF
7 Name:           ming
8 Version:        0.2a
9 Release:        5
10 License:        LGPL
11 Vendor:         Opaque Industries
12 Group:          Libraries
13 Source0:        http://www.opaque.net/ming/%{name}-%{version}.tgz
14 Patch0:         %{name}-dynamic-exts.patch
15 Patch1:         %{name}-soname.patch
16 Patch2:         %{name}-python.patch
17 URL:            http://www.opaque.net/ming/
18 BuildRequires:  python-devel
19 BuildRequires:  zlib-devel
20 BuildRequires:  rpm-perlprov >= 4.0.2-24
21 BuildRequires:  rpm-pythonprov
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         phpextdir       %(php-config --extension-dir)
25
26 %description
27 Ming is a C library for generating SWF ("Flash") format movies, plus a
28 set of wrappers for using the library from c++ and popular scripting
29 languages like PHP, Python, and Ruby.
30
31 %description -l pl
32 Ming jest bibliotek± w C do generowania animacji w formacie SWF
33 ("Flash") wraz z zestawem wrapperów do u¿ywania jej z C++ i
34 popularnymi jêzykami skryptowymi, takimi jak PHP, Python i Ruby.
35
36 %package devel
37 Summary:        Ming development files
38 Summary(pl):    Pliki dla programistów Ming
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}
41
42 %description devel
43 Header files for ming library (C and C++).
44
45 %description devel -l pl
46 Pliki nag³ówkowe dla biblioteki ming (do C i C++).
47
48 %package -n perl-ming
49 Summary:        Ming perl module
50 Summary(pl):    Modu³ perla Ming
51 Group:          Development/Languages/Perl
52 Requires:       %{name} = %{version}
53 Obsoletes:      ming-perl
54
55 %description -n perl-ming
56 Ming perl module - perl wrapper for Ming library.
57
58 %description -n perl-ming -l pl
59 Modu³ perla Ming - perlowy wrapper do biblioteki Ming.
60
61 %package -n python-ming
62 Summary:        Ming Python module
63 Summary(pl):    Modu³ biblioteki Ming dla jêzyka Python
64 Group:          Development/Languages/Perl
65 Requires:       %{name} = %{version}
66
67 %description -n python-ming
68 Ming Python module.
69
70 %description -n python-ming -l pl
71 Modu³ biblioteki Ming dla jêzyka Python.
72
73 %package utils
74 Summary:        Ming utilities
75 Summary(pl):    Narzêdzia Ming
76 Group:          Applications/File
77
78 %description utils
79 Ming utilities:
80 - listswf - swf format disassembler
81 - listfdb - show contents of fdb font file
82 - makefdb - rip fdb font definition files out of a generator template
83   file
84 - swftophp - attempt to make a php/ming script out of an swf file
85
86 %description utils -l pl
87 Narzêdzia Ming:
88 - listswf - disasembler plików swf
89 - listfdb - pokazuje zawarto¶æ plików fontów fdb
90 - makefdb - wyci±ga pliki definicji fontów fdb z pliku generatora
91 - swftophp - próbuje zrobiæ skrypt php/ming z pliku swf
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98
99 mv 0f rb_ext/README README.rb_ext
100
101 %build
102 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags}"
103
104 #%{__make} -C java_ext
105
106 (cd perl_ext
107 perl ./Makefile.PL
108 %{__make} OPTIMIZE="%{rpmcflags}"
109 )
110
111 %{__make} -C py_ext PYINCDIR=%{py_incdir}
112 #%{__make} -C rb_ext
113
114 (cd util
115 %{__make} CC="%{__cc} %{rpmcflags}" \
116         listswf listaction swftophp makefdb
117 %{__cc} %{rpmcflags} -o listfdb listfdb.c
118 )
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_bindir},%{py_sitedir}}
123
124 %{__make} PREFIX=$RPM_BUILD_ROOT%{_prefix} install
125
126 %{__make} -C perl_ext install DESTDIR=$RPM_BUILD_ROOT
127
128 %{__make} -C py_ext install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         PYLIBDIR=$RPM_BUILD_ROOT%{py_libdir}
131 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
132 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
133
134 install util/{listswf,listaction,listfdb,makefdb,swftophp} $RPM_BUILD_ROOT%{_bindir}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc CHANGES CREDITS README TODO README.rb_ext
145 %attr(755,root,root) %{_libdir}/libming.so.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libming.so
150 %{_includedir}/ming.h
151 %{_includedir}/mingpp.h
152
153 %files -n perl-ming
154 %defattr(644,root,root,755)
155 %doc perl_ext/{README,TODO}
156 %{perl_sitearch}/SWF.pm
157 %{perl_sitearch}/SWF
158 %dir %{perl_sitearch}/auto/SWF
159 %{perl_sitearch}/auto/SWF/SWF.bs
160 %attr(755,root,root) %{perl_sitearch}/auto/SWF/SWF.so
161 %{_mandir}/man3/SWF*
162
163 %files -n python-ming
164 %defattr(644,root,root,755)
165 %doc py_ext/{README,TODO}
166 %attr(755,root,root) %{py_sitedir}/*.so
167 %{py_sitedir}/*.py[co]
168
169 %files utils
170 %defattr(644,root,root,755)
171 %doc util/{README,TODO}
172 %attr(755,root,root) %{_bindir}/*
This page took 0.034975 seconds and 3 git commands to generate.