]> git.pld-linux.org Git - packages/microcode-data-intel.git/blob - microcode-data-intel.spec
c665dab2bad9ed8596ba70ca5cdd28c20a38df86
[packages/microcode-data-intel.git] / microcode-data-intel.spec
1 # TODO
2 # - do not package intel-microcode2ucode and make package noarch, tool doesn't seem to be used runtime
3 Summary:        Microcode definitions for Intel processors
4 Summary(pl.UTF-8):      Definicje mikrokodu dla procesorów Intela
5 Name:           microcode-data-intel
6 Version:        20170707
7 Release:        1
8 License:        INTEL SOFTWARE LICENSE AGREEMENT
9 Group:          Base
10 # http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
11 Source0:        http://downloadmirror.intel.com/26925/eng/microcode-%{version}.tgz
12 # Source0-md5:  fe4bcb12e4600629a81fb65208c34248
13 # Tool for splitting Intel's microcode file. From Fedora
14 Source1:        intel-microcode2ucode.c
15 Provides:       microcode-data
16 ExclusiveArch:  i686 pentium2 pentium3 pentium4 %{x8664} x32
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The microcode data file for Linux contains the latest microcode
21 definitions for all Intel processors.
22
23 %description -l pl.UTF-8
24 Te pliki danych mikrokodu dla Linuksa zawierają najnowsze definicje
25 mikrokodu dla procesorów Intela.
26
27 %prep
28 %setup -q -c
29
30 %build
31 if ! grep -q 0x00000000 microcode.dat; then
32         echo >&2 microcode.dat contains giberrish
33         exit 1
34 fi
35
36 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
37 ./intel-microcode2ucode microcode.dat > /dev/null || exit 1
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_sbindir},/lib/firmware}
42
43 install intel-microcode2ucode $RPM_BUILD_ROOT%{_sbindir}
44 mv intel-ucode $RPM_BUILD_ROOT/lib/firmware
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %attr(755,root,root) %{_sbindir}/intel-microcode2ucode
52 /lib/firmware/intel-ucode
This page took 0.76466 seconds and 3 git commands to generate.