]> git.pld-linux.org Git - packages/megacmd.git/blob - megacmd.spec
Remove no longer needed cppcheck hack
[packages/megacmd.git] / megacmd.spec
1 #
2 # Conditional build:
3 %bcond_without  ffmpeg                  # build with ffmpeg for thumbnails and previews
4 %bcond_without  freeimage               # build with freeimage to manage thumbnails/previews
5 %bcond_without  fuse                    # build megafuse
6 %bcond_without  libmediainfo    # build with libmediainfo for media file attributes
7
8 Summary:        Command Line Interactive and Scriptable Application to access MEGA
9 Name:           megacmd
10 Version:        1.2.0
11 Release:        1
12 # https://github.com/meganz/MEGAcmd/commit/b366c77370c277223be123e05e5ef15fafbce185#r31261647
13 License:        BSD 2-Clause "Simplified" License
14 Group:          Applications
15 Source0:        https://github.com/meganz/MEGAcmd/archive/%{version}_Linux/%{name}-%{version}.tar.gz
16 # Source0-md5:  879d5d2b70508736eff30db420b12cd1
17 Source1:        https://github.com/meganz/sdk/archive/de4ff325d/mega-sdk-v3.5.3-1921-gde4ff325d.tar.gz
18 # Source1-md5:  8fcb952d8909d3d5deb1c82072d41afe
19 URL:            https://mega.nz/
20 %{?with_freeimage:BuildRequires:        FreeImage-devel}
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  c-ares-devel
24 BuildRequires:  cryptopp-devel
25 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
26 %{?with_fuse:BuildRequires:     libfuse-devel}
27 %{?with_mediainfo:BuildRequires:        libmediainfo-devel}
28 BuildRequires:  libraw-devel
29 BuildRequires:  libsodium-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtool
32 BuildRequires:  libuv-devel
33 BuildRequires:  openssl-devel
34 BuildRequires:  pcre-cxx-devel
35 BuildRequires:  pcre-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  readline-devel
38 BuildRequires:  sqlite3-devel
39 BuildRequires:  zlib-devel
40 Requires:       %{name}-libs = %{version}-%{release}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 MEGAcmd provides non UI access to MEGA services. It intends to offer
45 all the functionality with your MEGA account via commands. It features
46 synchronization and backup of local folders into your MEGA account.
47
48 %package libs
49 Summary:        Shared libmega library
50 Group:          Libraries
51 Requires:       %{name}-libs = %{version}-%{release}
52
53 %description libs
54 Shared libmega library.
55
56 %package devel
57 Summary:        Header files for %{name} library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
59 Group:          Development/Libraries
60 Requires:       %{name}-libs = %{version}-%{release}
61
62 %description devel
63 Header files for %{name} library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki %{name}.
67
68 %package fuse
69 Summary:        megafuse
70 Group:          Libraries
71
72 %description fuse
73 megafuse.
74
75 %prep
76 %setup -q -n MEGAcmd-%{version}_Linux -a1
77 mv sdk-*/* sdk
78
79 %build
80 autoreconf -vif
81 %configure \
82         %{__with_without ffmpeg} \
83         %{__with_without freeimage} \
84         %{__with_without fuse} \
85         %{__with_without libmediainfo} \
86         --disable-silent-rules
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmega.la
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   libs -p /sbin/ldconfig
100 %postun libs -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README.md LICENSE
105 /etc/bash_completion.d/megacmd_completion.sh
106 %attr(755,root,root) %{_bindir}/mega-attr
107 %attr(755,root,root) %{_bindir}/mega-backup
108 %attr(755,root,root) %{_bindir}/mega-cancel
109 %attr(755,root,root) %{_bindir}/mega-cat
110 %attr(755,root,root) %{_bindir}/mega-cd
111 %attr(755,root,root) %{_bindir}/mega-cmd
112 %attr(755,root,root) %{_bindir}/mega-cmd-server
113 %attr(755,root,root) %{_bindir}/mega-confirm
114 %attr(755,root,root) %{_bindir}/mega-confirmcancel
115 %attr(755,root,root) %{_bindir}/mega-cp
116 %attr(755,root,root) %{_bindir}/mega-debug
117 %attr(755,root,root) %{_bindir}/mega-deleteversions
118 %attr(755,root,root) %{_bindir}/mega-df
119 %attr(755,root,root) %{_bindir}/mega-du
120 %attr(755,root,root) %{_bindir}/mega-errorcode
121 %attr(755,root,root) %{_bindir}/mega-exclude
122 %attr(755,root,root) %{_bindir}/mega-exec
123 %attr(755,root,root) %{_bindir}/mega-export
124 %attr(755,root,root) %{_bindir}/mega-find
125 %attr(755,root,root) %{_bindir}/mega-ftp
126 %attr(755,root,root) %{_bindir}/mega-get
127 %attr(755,root,root) %{_bindir}/mega-graphics
128 %attr(755,root,root) %{_bindir}/mega-help
129 %attr(755,root,root) %{_bindir}/mega-https
130 %attr(755,root,root) %{_bindir}/mega-import
131 %attr(755,root,root) %{_bindir}/mega-invite
132 %attr(755,root,root) %{_bindir}/mega-ipc
133 %attr(755,root,root) %{_bindir}/mega-killsession
134 %attr(755,root,root) %{_bindir}/mega-lcd
135 %attr(755,root,root) %{_bindir}/mega-log
136 %attr(755,root,root) %{_bindir}/mega-login
137 %attr(755,root,root) %{_bindir}/mega-logout
138 %attr(755,root,root) %{_bindir}/mega-lpwd
139 %attr(755,root,root) %{_bindir}/mega-ls
140 %attr(755,root,root) %{_bindir}/mega-mediainfo
141 %attr(755,root,root) %{_bindir}/mega-mkdir
142 %attr(755,root,root) %{_bindir}/mega-mount
143 %attr(755,root,root) %{_bindir}/mega-mv
144 %attr(755,root,root) %{_bindir}/mega-passwd
145 %attr(755,root,root) %{_bindir}/mega-permissions
146 %attr(755,root,root) %{_bindir}/mega-preview
147 %attr(755,root,root) %{_bindir}/mega-proxy
148 %attr(755,root,root) %{_bindir}/mega-put
149 %attr(755,root,root) %{_bindir}/mega-pwd
150 %attr(755,root,root) %{_bindir}/mega-quit
151 %attr(755,root,root) %{_bindir}/mega-reload
152 %attr(755,root,root) %{_bindir}/mega-rm
153 %attr(755,root,root) %{_bindir}/mega-session
154 %attr(755,root,root) %{_bindir}/mega-share
155 %attr(755,root,root) %{_bindir}/mega-showpcr
156 %attr(755,root,root) %{_bindir}/mega-signup
157 %attr(755,root,root) %{_bindir}/mega-speedlimit
158 %attr(755,root,root) %{_bindir}/mega-sync
159 %attr(755,root,root) %{_bindir}/mega-thumbnail
160 %attr(755,root,root) %{_bindir}/mega-transfers
161 %attr(755,root,root) %{_bindir}/mega-tree
162 %attr(755,root,root) %{_bindir}/mega-userattr
163 %attr(755,root,root) %{_bindir}/mega-users
164 %attr(755,root,root) %{_bindir}/mega-version
165 %attr(755,root,root) %{_bindir}/mega-webdav
166 %attr(755,root,root) %{_bindir}/mega-whoami
167 %attr(755,root,root) %{_bindir}/megacli
168 %attr(755,root,root) %{_bindir}/megasimplesync
169
170 %if %{with fuse}
171 %files fuse
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/megafuse
174 %endif
175
176 %files libs
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libmega.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libmega.so.30609
180
181 %files devel
182 %defattr(644,root,root,755)
183 %{_includedir}/mega
184 %{_includedir}/mega.h
185 %{_includedir}/megaapi.h
186 %{_includedir}/megaapi_impl.h
187 %{_libdir}/libmega.so
188 %{_pkgconfigdir}/libmega.pc
This page took 0.064036 seconds and 3 git commands to generate.