]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
- speex epoch
[packages/mediastreamer.git] / mediastreamer.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl          # X11+OpenGL rendering support
4 %bcond_with     pcap            # audio playing from PCAP files
5 %bcond_without  pulseaudio      # PulseAudio support
6 #
7 Summary:        Audio/Video real-time streaming
8 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
9 Name:           mediastreamer
10 Version:        2.10.0
11 Release:        2
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/mediastreamer/%{name}-%{version}.tar.gz
15 # Source0-md5:  5a4e7545e212068534b56fdf41c961e9
16 Patch0:         %{name}-imagedir.patch
17 URL:            http://www.linphone.org/eng/documentation/dev/mediastreamer2.html
18 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  alsa-lib-devel
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  doxygen
24 # libavcodec >= 51.0.0, libswscale >= 0.7.0
25 BuildRequires:  ffmpeg-devel
26 BuildRequires:  gettext-tools
27 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
28 BuildRequires:  jack-audio-connection-kit-devel
29 BuildRequires:  intltool >= 0.40
30 BuildRequires:  libgsm-devel
31 %{?with_pcap:BuildRequires:     libpcap-devel}
32 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
33 BuildRequires:  libtool >= 2:2
34 BuildRequires:  libupnp-devel >= 1.6
35 BuildRequires:  libupnp-devel < 1.7
36 BuildRequires:  libv4l-devel
37 BuildRequires:  libvpx-devel >= 0.9.6
38 BuildRequires:  opus-devel >= 0.9.0
39 BuildRequires:  ortp-devel >= 0.23.0
40 BuildRequires:  pkgconfig
41 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  spandsp-devel >= 0.0.6
44 BuildRequires:  speex-devel >= 1:1.2-beta3
45 BuildRequires:  speexdsp-devel >= 1.2-beta3
46 BuildRequires:  xorg-lib-libX11-devel
47 BuildRequires:  xorg-lib-libXv-devel
48 BuildRequires:  xxd
49 %{?with_opengl:Requires:        glew >= 1.5}
50 Requires:       libtheora >= 1.0-0.alpha7
51 Requires:       libupnp >= 1.6
52 Requires:       libvpx >= 0.9.6
53 Requires:       opus >= 0.9.0
54 Requires:       ortp >= 0.23.0
55 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
56 Requires:       spandsp >= 0.0.6
57 Requires:       speex >= 1:1.2-beta3
58 Requires:       speexdsp >= 1.2-beta3
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Mediastreamer2 is a GPL licensed library to make audio and video
63 real-time streaming and processing. Written in pure C, it is based
64 upon the oRTP library.
65
66 %description -l pl.UTF-8
67 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
68 przesyłania i przetwarzania strumieni audio/video w czasie
69 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
70
71 %package devel
72 Summary:        Header files and development documentation for mediastreamer library
73 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 %{?with_opengl:Requires:        OpenGL-devel}
77 Requires:       alsa-lib-devel
78 Requires:       ffmpeg-devel
79 %{?with_opengl:Requires:        glew-devel >= 1.5}
80 Requires:       libtheora-devel >= 1.0-0.alpha7
81 Requires:       libupnp-devel >= 1.6
82 Requires:       libupnp-devel < 1.7
83 Requires:       libv4l-devel
84 Requires:       libvpx-devel >= 0.9.6
85 Requires:       opus-devel >= 0.9.0
86 Requires:       ortp-devel >= 0.23.0
87 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
88 Requires:       spandsp-devel >= 0.0.6
89 Requires:       speex-devel >= 1:1.2-beta3
90 Requires:       speexdsp-devel >= 1.2-beta3
91 Requires:       xorg-lib-libX11-devel
92 Requires:       xorg-lib-libXv-devel
93
94 %description devel
95 Header files and development documentation for mediastreamer library.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer.
99
100 %package static
101 Summary:        Static mediastreamer library
102 Summary(pl.UTF-8):      Statyczna biblioteka mediastreamer
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static mediastreamer library.
108
109 %description static -l pl.UTF-8
110 Statyczna biblioteka mediastreamer.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %configure \
123         --enable-external-ortp \
124         %{!?with_opengl:--disable-glx} \
125         %{?with_pcap:--enable-pcap} \
126         %{?with_pulseaudio:--enable-pulseaudio} \
127         --disable-silent-rules \
128         --enable-static
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 # for external plugins
139 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
140
141 # Remove duplicated documentation
142 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README
155 %attr(755,root,root) %{_bindir}/mediastream
156 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
157 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.3
159 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.3
161 %dir %{_libdir}/mediastreamer
162 %dir %{_libdir}/mediastreamer/plugins
163 %{_pixmapsdir}/%{name}
164
165 %files devel
166 %defattr(644,root,root,755)
167 %doc help/doc/html
168 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so
169 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so
170 %{_libdir}/libmediastreamer_base.la
171 %{_libdir}/libmediastreamer_voip.la
172 %{_includedir}/mediastreamer2
173 %{_pkgconfigdir}/mediastreamer.pc
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libmediastreamer_base.a
178 %{_libdir}/libmediastreamer_voip.a
This page took 0.095455 seconds and 4 git commands to generate.